• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Warning: ultrasn0w May Break GPS on Baseband 6.15.00


    The Dev-Team is warning about a potential issue with ultrasn0w for iOS 4.2.1 on iPhones with the 06.15.00 baseband. An increasing number of users with that version of the baseband software are reportedly losing GPS functionality when they unlock their device. The blog post says they are looking for the root cause but haven't found it yet, and notes that it's not a problem for all or even most users with that baseband. Still, to be on the safe side, they're suggesting people should just not expect GPS to work if they want to unlock iPhones with the 06.15.00 baseband using ultrasn0w:

    Update #5: Unlockers have been reporting mixed results about GPS functionality at 06.15.00. Until we can track down what differentiates those who retain GPS vs. those who lose it, be conservative and assume youíll lose GPS at 06.15.00. As we work on finding the cause (and possibly a fix), please report your personal findings in our comments section. (Update: early indications are that while 06.15.00 is capable of GPS, it will require some further hacks. But please still be conservative and assume you will lose GPS at 06.15, in case the hacks donít work).
    Source: Dev-Team Blog
    This article was originally published in forum thread: Warning: ultrasn0w May Break GPS on Baseband 6.15.00 started by Paul Daniel Ash View original post
    Comments 175 Comments
    1. ItsLGA's Avatar
      ItsLGA -
      Yes, people i have updated to ipad baseband in 4.1 and it has broken my baseband. I'd like to know if there will exist any solution?, thanks a lot, and sory for my english. PD: I did not know that it would break my gps when i did it ):. If I knew that, i wouldn't do it.
    1. ninthchamber99's Avatar
      ninthchamber99 -
      Ok, so I have a question that I hope is not a stupid one. So, I have a
      3GS running 4.0, baseband 5.11.07. My question is how do you upgrade your baseband, not that I want to, I just want to make sure that I don't upgrade the baseband by accident. I skipped upgrading and JB'ing at 4.1 since I didn't see the point at that time, but now that 4.2.1 is out I want to upgrade and JB the current FW once an untethered JB is released. Plus, I am waiting for the untethered so I can upgrade my iPad as well.

      Edit: As of right now, I have no need to unlock, just JB. But I was thinking about leaving ATT at some point so any info about JBing and unlocking regards to my question would be great.
    1. walktovanish's Avatar
      walktovanish -
      I have a 3G on 4.1 bb 6.15 and GPS and calls work great. Mine was hacktivated and still gets much better battery life than before. So far, no problems with 6.15 at all.
    1. 97vrsix's Avatar
      97vrsix -
      How about we do something constructive! Instead of people ********, and crying over the fact that they can't read, don't want to read, or skipped over reading what can happen. Or the fact people are crying over GPS not working, and looking for a fix!

      1. No fix, stop crying, learn to read post, before you jump!
      2. Making calls, is a way higher priority then GPS! Period!
      3. Once again, IPhone users 3G and 3GS! This update may keep your phone at a different Baseband! For life!
      4. Let's keep to important fact in these topics! Please, go make a post for crying, some place else! Or people like Ipieret 2nd page, please learn how to include what in gods green earth your talking about! You make no sence!
      5. Let's set up some help for people! Rather then going over and over what we know, or should know by reading the tools we USE before we USE THEM!

      People, please leave what your phone is! Size, Baseband you were on, and moved to! What IOS you are on, and using!

      Like, does this unlock still work on 4.1? With a 3GS? Better yet, post up your exact configuration! Maybe we the people can find a pattern!

      Currently, I'm on 4.1, with 5.14, ultrasnow 1.2. Just as a test, I installed just to see if it would still kill my GPS! So far, so good! I'll be making my custom IOS later, to obtain base 6! But, I'll stay at 4.1, if I can!

      I will post results, asap!

      Please, keep on topic, stop your ********! Learn how to ask a question, or leave all details about your question, so it can be answered!

      For the last time!
      YES, this update may cause you to lose everything! And may cause you to lose you GPS!
      NO, currently no fix! This is why I want to see if it is IOS dependent, or Baseband dependent.

      Sincerely! With all respect!
    1. VIRUSCELL's Avatar
      VIRUSCELL -
      The one that asked how does the baseband update well its easy just dont update to a higher fw(firmware)
      But if u want to update to 06.15 you need to use redsn0w beta 6
    1. Jay316's Avatar
      Jay316 -
      I've just had an email from SpiritJB telling that the iPhone 4 unlock is out for 4.2.1. Can anyone confirm this?
    1. BenderRodriguez's Avatar
      BenderRodriguez -
      Quote Originally Posted by Jay316 View Post
      I've just had an email from SpiritJB telling that the iPhone 4 unlock is out for 4.2.1. Can anyone confirm this?
      Not me, I'm guessing 4.3 will have 6.16 baseband
    1. athleticswimmer's Avatar
      athleticswimmer -
      good thing I dont have to worry about all dis! Im gettin a android in April and i cant wait! unless the iphone shows up in tmobile phones...then yea ill worry bout this
    1. ninthchamber99's Avatar
      ninthchamber99 -
      Just for clarity.....if/when I upgrade my FW from 4.0 with BB 5.11.07 on a 3GS to the latest FW 4.2.1, it will change my BB right?

      And sorry in advance if my question is one that has been already addressed but I have been out of the JBreaking game for awhile and I feel like I am re-learning everything again!!
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by ninthchamber99 View Post
      Just for clarity.....if/when I upgrade my FW from 4.0 with BB 5.11.07 on a 3GS to the latest FW 4.2.1, it will change my BB right?

      And sorry in advance if my question is one that has been already addressed but I have been out of the JBreaking game for awhile and I feel like I am re-learning everything again!!
      Yes it would change to 5.15.04 which is not unlockable
    1. ninthchamber99's Avatar
      ninthchamber99 -
      Cool. That is what I thought but since I will not be unlocking for a while longer, I will be good to upgrade when the untethered JB is released.

      Thanks again x98car (even though you are a Lakers fan, LOL!!)
    1. Simon's Avatar
      Simon -
      We cant all be perfect
    1. crazy4dss's Avatar
      crazy4dss -
      Quote Originally Posted by ipirate View Post
      I am having a problem not receiving calls. I can give out calls but cannot receive. What i noticed is that once you do not type in internet under cellular data (APN) you can then received calls, but as you type in internet, that's it i cannot receive any calls. This feild is a must, so as you can get access to the internet.This is a iphone 3Gs 32Gig please help!!!!!!
      What carrier are you on? If it's T-Mobile call them they will gladly help with alternate apn settings..... Good Luck
    1. 97vrsix's Avatar
      97vrsix -
      1.People not getting signal, try APN settings! 2.And a network resets before you do this!

      3. Then after all that is done, pull the sim, and re install.
      So steps in order! 2, then 1, then 3.... As listed above.

      Sent from my iPhone using ModMyi
    1. Hellorobert's Avatar
      Hellorobert -
      I am using 4.2.1 os, on 3GS 16gb. I used the redsnow9.6b5 with the ios4.2.1(8C148A)restore.

      Everything works great!

      Even Cydia and all the repo's.

      Very satisfied now!
    1. comthre3's Avatar
      comthre3 -
      I can confirm this issue, upgraded/updated bb on my 3GS, 4.1 no more gps :/ old bootrom
    1. VIRUSCELL's Avatar
      VIRUSCELL -
      Well i think maybe it happens just to the old bootrooms
      EDIT:with what beta redsn0w did u use it
    1. iForm's Avatar
      iForm -
      (using iPhone 3Gs iOS 4.1) i confirm have no GPS work after upgrade to bb 06.15.00. tomtom said "Poor GPS Reception" but the compass is work.

      i need downgrade to iOS 3.1.2 for testing GPS, but sydia have not saved 3.1.2 shsh, only 4.1 (i don't now why)
      i have saved all 3.1.2 rootfs, any solution de get shsh from it ?


      Thanks.

      -------------------------------
      (if the devs were announced this GPS dysfunction before, I would certainly not do this update.)
    1. Simon's Avatar
      Simon -
      You can only get SHSH when Apple is still signing that firmware. So you could only have saved 3.1.2 SHSH when 3.1.2 was the current firmware.
    1. d_animality's Avatar
      d_animality -
      Hey..so any news about untethered JB??is the rumour about 4.2 coming out mid december true??n so im wondering..is it still possible to update to future FW normally if we already did flash the BB as in now??