• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Pod2g Updates Blog With A5 Jailbreak FAQ Explaining Why it is Not Currently Possible



    A4 iDevice users have been enjoying the labor of love that is the iOS 5.0.1 untethered jailbreak for over a week now. However, A5 device owners (iPhone 4S and iPad 2) still live in a jailbreakless world, and apparently many have expressed their displeasure to pod2g.

    This displeasure resulted in pod2g posting the following FAQ on his blog this morning. It explains, in brief, why an A5 jailbreak is currently not possible.

    How could pod2g have an untethered 4S and dev teams still haven't released tools to achieve this at home ?

    The exploit I used to inject the untethering files to the 4S relies on having a developer account, and can't be released publicly.
    It's the same reason why @MuscleNerd has an iPad 2 tethered jailbreak but couldn't distribute it.

    So, we need to find a distributable exploit to remount the system partition read/write and to set Corona files at the correct places.

    Why A4 version of Corona was easier to release ?

    Because a tethered jailbreak is a good way to install Corona!

    Why don't you do a tethered jailbreak then ?

    A tethered jailbreak also relies on an exploitable vulnerability that we still haven't found yet !

    pod2g, release this stuff quick, [your insult here], I've waited enough now.
    While an A5 jailbreak will likely happen at some point in the future, don't expect it anytime soon. The fact that an untethered A4 iOS 5 jailbreak exists has no influence on the timeliness of the untethered A5 jailbreak's release. Patience is a virtue. A largely ignored one, but still a virtue.

    Source: pod2g

    *Thanks BSP (first tipster) and the many others who blew up our inbox with this tip this morning*
    This article was originally published in forum thread: pod2g Updates Blog With A5 Jailbreak FAQ Explaing Why it is Not Currently Possible started by Phillip Swanson View original post
    Comments 178 Comments
    1. vduub's Avatar
      vduub -
      U know people stuff happens. Yes pod2g said in a week however has anyone who dared to comment ever tried to alter and change files or inject a program with a exploit in order to gain access. As for many of you who comment I can bet u all 99% of u haven't let alone even be able to understand the language in which this all takes place. I have a idea if u all are such in a rush, pick up a book. Read, learn a fraction of how to, if u can retain any actual info and apply it and do it yourself.

      Keep up the good work pod2g, and the rest of the developers who help and work together to bring us all these advances in technology
    1. Adrianvert's Avatar
      Adrianvert -
      What is wrong with all these people being abusive to someone who is doing something for everyone largely for free? I have no facts but i wouldn't be surprised if pod2g and others could sod all this and move onto something else thats got more money in it in a heartbeat and have more free time to themselves, and are only giving you moaning bunch of m*rons the jailbreak because they enjoy making it for the people that ARE respectful. Stop moaning and be grateful that someone is putting so much time into something that no one else can even get their heads around! You're lucky!

      Quote Originally Posted by RyoSaeba View Post
      Maybe I'm not understanding everything here but the iPad 2 uses A5 correct? And that has a untethered jailbreak for 4.3.3 right (because I'm using it right now)?

      So I'm assuming that the hardware is exploitable but somehow iOS5 has closed most holes to exploit that?

      What sounded to me in this article is the A5 jailbreak is just not possible without using a developer account [on all iOS versions].
      it only means that the holes in iOS 4.3.3 have all been plugged and its a struggle to find new ones based on the A5 chip and the IOS combined

      Quote Originally Posted by lukinrats View Post
      based on what you said you know the answer to your own question, as it is clearly stated there is no *hole* for the iOS 5.0.1
    1. z28kid's Avatar
      z28kid -
      I know what it's like trying to make everyone happy.. just cant do it. People want everything now, other are patient.. though the number of impatient people is greater than the number of patient ones.

      Keep at it guys, you will find a way.. you always do
    1. Cruzzer08's Avatar
      Cruzzer08 -
      All I got to say is IN YOUR FACE 4S OWNERS!!! Whos phone is better now??
      Thanks pod2g for all the hard work!
    1. jayune's Avatar
      jayune -
      Man I love this guy, nomaly it's "we have something...here a VERRY short video...now piss off" cough....cough...musclenerd. I understand all the secrecy but it's nice to get off the throne and givel the people some updates. That being said looks like my pessimism paid off. My iPad 2 is on 4.3.3 and I was debating if I should update and loose the jailbreak....good thing I didn't.
    1. GUNNY29's Avatar
      GUNNY29 -
      My phone is still better lol I'm happy with my iPhone 4s jailbroken or not same with my ipad2 I didnt spend nearly 1000 on devices just to jailbreak
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by GUNNY29 View Post
      I might of interpreted it wrong but I think he was explaining why jb developers such as himself muscle nerd have jailbroken a5 devices but there is not a public one. I still think his hopefully next week statement still stands
      How can I retweet this on ModMyI!!!
      Thank you for being one of the few that gets it!
    1. Moonie M33's Avatar
      Moonie M33 -
      While I understand the many months of development @pod2g has gone through in order to bring his corona untether to the community, I feel like this revelation is all the cannon fodder people need to really start laying into him with the hate. If he knew that that the untethered A5 jailbreak required a developers account, why not let us know via the blog he created in order to keep us updated on his work in the first place? Also why did he post a couple of days ago on twitter that we could see a release in a week or so? Was this to shut people up? Im sorry but it really doesnt work like that and it seems his good intentions are going to back fire. It really is a shame there are so many douche bags on the internet that hound talent such as this with the spoilt brat approach, but I still think pod2g went about the situation the wrong way.
    1. Netherscourge's Avatar
      Netherscourge -
      The iPad 2 (A5 device) was jailbroken using a PDF exploit on the Jailbreakme.com website. That PDF exploit didn't require any sort of 3rd party injection or hardware workaround. It was a 100% Safari browser/PDF exploit. That PDF exploit was patched by Apple and is no longer available as a jailbreaking method if you updated your device beyond iOS 4.3.3

      The current jailbreak method for A4 devices simply does not work on A5 devices. This is due to a different hardware configuration.

      However, it is possible to jailbreak A5 devices via Developer Account access. The only "trick" now is to figure out how to convert that to a Public Account access for all of us.

      It's not impossible. It's just a matter of finding an exploit for the injection method.

      The only cause for alarm is that since pod2g release the A4 jailbreak publicly, Apple now knows what they need to patch to prevent future jailbreaks for both A4 and A5 devices.

      If you're on a iOS 5.0.1 device now, you're safe because the current Jailbreak being developed is for iOS 5.0.1

      However, if your running a 4.3.3 Jailbroken A5 device (aka the iPad 2 via the Jailbreakme.com exploit) then you have a decision to make.

      ----------Decision 1: Stay jailbroken on 4.3.3 and hope Apple doesn't release 5.0.2 anytime soon. Because if they do, it will be impossible for you to upgrade to 5.0.1 to Jailbreak your A5 device whenever the jailbreak IS released.

      ----------Decision 2: Upgrade to iOS 5.0.1 now, and give up your current iOS 4.3.3 jailbreak on your iPad 2. The risk is obvious here. It's possible iOS 5.0.1 may never get jailbroken and you may lose you jailbreak forever (unlikely, but could be a long time before you can get your jailbreak apps back again).


      That's what people are wrestling with right now.



      If you're on an iPhone 4S, you have no option but to upgrade to 5.0.1 because nobody is working on a iOS 5.0.0 jailbreak anyway.


      However, it's very important to NOT UPGRADE PAST 5.0.1 on any device right now. Stay at 5.0.1 or lower if you're overly catious.

      DO NOT UPGRADE TO 5.0.2 or higher if Apple releases a new iOS update.
    1. thazsar's Avatar
      thazsar -
      Quote Originally Posted by Netherscourge View Post
      The iPad 2 (A5 device) was jailbroken using a PDF exploit on the Jailbreakme.com website. That PDF exploit didn't require any sort of 3rd party injection or hardware workaround. It was a 100% Safari browser/PDF exploit. That PDF exploit was patched by Apple and is no longer available as a jailbreaking method if you updated your device beyond iOS 4.3.3

      The current jailbreak method for A4 devices simply does not work on A5 devices. This is due to a different hardware configuration.

      However, it is possible to jailbreak A5 devices via Developer Account access. The only "trick" now is to figure out how to convert that to a Public Account access for all of us.

      It's not impossible. It's just a matter of finding an exploit for the injection method.

      The only cause for alarm is that since pod2g release the A4 jailbreak publicly, Apple now knows what they need to patch to prevent future jailbreaks for both A4 and A5 devices.

      If you're on a iOS 5.0.1 device now, you're safe because the current Jailbreak being developed is for iOS 5.0.1

      However, if your running a 4.3.3 Jailbroken A5 device (aka the iPad 2 via the Jailbreakme.com exploit) then you have a decision to make.

      ----------Decision 1: Stay jailbroken on 4.3.3 and hope Apple doesn't release 5.0.2 anytime soon. Because if they do, it will be impossible for you to upgrade to 5.0.1 to Jailbreak your A5 device whenever the jailbreak IS released.

      ----------Decision 2: Upgrade to iOS 5.0.1 now, and give up your current iOS 4.3.3 jailbreak on your iPad 2. The risk is obvious here. It's possible iOS 5.0.1 may never get jailbroken and you may lose you jailbreak forever (unlikely, but could be a long time before you can get your jailbreak apps back again).


      That's what people are wrestling with right now.



      If you're on an iPhone 4S, you have no option but to upgrade to 5.0.1 because nobody is working on a iOS 5.0.0 jailbreak anyway.


      However, it's very important to NOT UPGRADE PAST 5.0.1 on any device right now. Stay at 5.0.1 or lower if you're overly catious.

      DO NOT UPGRADE TO 5.0.2 or higher if Apple releases a new iOS update.
      Nice breakdown! Thanx!
    1. ricroc911's Avatar
      ricroc911 -
      What a tosser, tells us to update to 5.0.1 then release's that, what an idiot, but i bet he's enjoying all those donations we have sent him!!!
    1. dazdaman80's Avatar
      dazdaman80 -
      Quote Originally Posted by T76 View Post
      this is crap
      Your an idiot !. Two comments and both have been ******** about it !. I hope pod2g reads these comments and says, "f*** you !, it will take even longer now !
    1. GUNNY29's Avatar
      GUNNY29 -
      Your the idiot you obviously aren't capable of producing a public jailbreak yourself and the donations are for devices that he doesn't own and for the time he puts into finding an exploit come back when you have the brain capacity to even think about starting to learn what he knows
    1. wolverinemarky's Avatar
      wolverinemarky -
      Quote Originally Posted by Simon View Post
      I wonder why he previously posted "in a week" then? Sad news. Understandable. But sad.
      I'm hoping hes just mad and saying that so we get off his back, because i do remember seeing the story where they were saying he was saying within a week also. While I really dont need a JB would be nice to have SBSettings and Bitesms this is the downfall of buying a new phone near launch day it always takes a while to JB it.

      keep up the good work i will wait patiently
    1. jailer's Avatar
      jailer -
      I would like to just say that I think pod2g is an absolute genius. Anyone that can do what he does, is absolutely amazing to me. I am in complete awe of these guys. Not only because of the skill they possess, but how unselfish they are. These guys are willing to do a tremendous amount of work, which they obviously don't get paid for, and then give it away for free! I have a great idea. If anyone is upset with pod2g, why don't you go ahead and release a jb for the 4S. If you cannot do that, and if you are not paying pod2g or any of the other guys, the big dollars they deserve, then SHUT YOUR MOUTH. Anyone that would insult pod2g or the other devs, for not having or releasing a jb, is a complete and utter useless piece of garbage. There is no room on this or any other site for you. I have spent thousands of dollars giving donations, buying all sorts of stuff from Cydia, and have never complained about anything. I was very excited when pod2g seemed to be close, but when I found out that it might not happen, I said, "that sucks," and that's it. Don't bite the hand that feeds you. I think pod2g and all the devs should charge $25 for a jailbreak. These guys need to get paid, and I would be more than willing to pay that. I am in awe of all the guys that have the ability to do this stuff. I patiently wait and hope for a jb of the 4S, and if it doesn't happen, then oh well. Keep up the good work guys. You are very appreciated.
    1. Fallguy's Avatar
      Fallguy -
      IMO what will happen is the further we get into the year , the more likely this untethered JB wont be released because they will say " were waiting for the ipad 3 to come out before its release" . I only say that because it seems to have happened in the past. So be patient , and wait like the rest of us did for the ipad 2 JB last year.
      Oh and the 4s users are losers now. Ha
    1. GUNNY29's Avatar
      GUNNY29 -
      ^^^^^+1000

      To jailers post
    1. Hedrush's Avatar
      Hedrush -
      To all the whiners. No where does it say it won't be released soon. Pod2g is just explaining where he is up to so far with his jb process. The whiners don't deserve a jb imo.
    1. jayune's Avatar
      jayune -
      Quote Originally Posted by Netherscourge View Post

      However, if your running a 4.3.3 Jailbroken A5 device (aka the iPad 2 via the Jailbreakme.com exploit) then you have a decision to make.

      ----------Decision 1: Stay jailbroken on 4.3.3 and hope Apple doesn't release 5.0.2 anytime soon. Because if they do, it will be impossible for you to upgrade to 5.0.1 to Jailbreak your A5 device whenever the jailbreak IS released.

      ----------Decision 2: Upgrade to iOS 5.0.1 now, and give up your current iOS 4.3.3 jailbreak on your iPad 2. The risk is obvious here. It's possible iOS 5.0.1 may never get jailbroken and you may lose you jailbreak forever (unlikely, but could be a long time before you can get your jailbreak apps back again).


      That's what people are wrestling with right now.


      uh....what about the shsh blobs
    1. GUNNY29's Avatar
      GUNNY29 -
      Shsh blobs aren't able to be used on a5 devices just yet keep saving them tho the dev is working hard to make it happen