• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • TinyUmbrella Updated to Work With iOS 5.0.1 (Build 9A406) for iPhone 4S

    TinyUmbrella is an SHSH solution for iOS.

    TinyUmbrella, the tool that we've used to save our SHSH blobs since the days of Christopher Columbus, has been updated to work with the second release of iOS 5.0.1 for the iPhone 4S (Build 9A406) which was released in order to fix the iPhone 4S not detecting the SIM card. Right now, using TinyUmbrella to save your SHSH blobs is a good idea, especially with the news that we reported on today with pod2g confirming that it could be just a week until we see the iPhone 4S jailbreak.

    While at this point in time, there is currently no way to replay cached blobs to to restore 5.0.1 once Apple stops signing it with the iPhone 4S or iPad 2, we assure you that it's a good idea to save them anyway just in case of any future inventions that might allow us to use it for something special. There is currently no bootrom exploit for the A5 processor which means that iPhone 4S and iPad 2 users cannot use tools like iFaith to create custom firmwares are restore to them. This is one reason that we recommend that you update to iOS 5.0.1 as soon as possible to lock your hands on the untethered jailbreak before Apple releases iOS 5.1.

    Hopefully soon in the future, hackers will find a way to use these SHSH blobs and APtickets for these newer A5 devices to restore the firmware like new - a luxury that only older iDevice users have right now. The download links for the updated TinyUmbrella (5.10.04) can be found below:

    TinyUmbrella for Mac OS X
    TinyUmbrella for Windows

    Sources: TinyUmbrella
    This article was originally published in forum thread: TinyUmbrella Updated to Work With iOS 5.0.1 (Build 9A406) for iPhone 4S started by Anthony Bouchard View original post
    Comments 89 Comments
    1. mikerlx's Avatar
      mikerlx -
      Build ur custom 5.0.1 and save it just in case and I highly recommend tiny umbrella
    1. A3gOwner's Avatar
      A3gOwner -
      Does it save APtickets as well? I haven't looked into it, guess I'm being lazy. If it does a bootrom exploit would still be needed for pwned dfu to restore to the stitched (signed) ipsw. It's a step forward at least.
    1. 2k1's Avatar
      2k1 -
      i faith is the one that save ya ap tickets
    1. csglinux's Avatar
      csglinux -
      Quote Originally Posted by xfsasx View Post
      I have a question, if I'm at 5.0.1 and something happens and I need to restore they're no ways of making sure I'm gonna stay at 5.0.1

      The possibilities of jailbroken apps incompatibility may cause a crash and therefore may warrant a restore, so if 5.1 is released and a problem occurs there is no way to do a factory restore is there? Like android for example...
      Correct. There is currently no way to restore A5 devices. (Outside of Apple's signing window.)
    1. Senyaichiya's Avatar
      Senyaichiya -
      I haven't used my jailbreak brain in a while so a few stupid questions to make sure I'm correct.

      Should I save the IPSW and upgrade or can have the IPSW and upgrade when the jailbreak comes out?

      I like old firmware I'm weird like that.
    1. A3gOwner's Avatar
      A3gOwner -
      Quote Originally Posted by 2k1dakotaman View Post
      i faith is the one that save ya ap tickets
      TU does now too for iPhone 4 and older devices. I'm asking about for the 4s. APtickets in TU were integrated right after ifaith was released (5.0.1 and higher).
    1. ZeRo-cOoL's Avatar
      ZeRo-cOoL -
      Any guide on how to save ipad 2 shsh on windows??? the app doesn't seems to be detecting my ipad 2. thanks in advanced
      ---------------------
      Edit: Got it working! thanks
    1. honeydew's Avatar
      honeydew -
      So I guess there is no need to worry about new baseband???
    1. A3gOwner's Avatar
      A3gOwner -
      Quote Originally Posted by honeydew View Post
      So I guess there is no need to worry about new baseband???
      Baseband unlocks have been off the table for awhile (soft unlocks that is). Look at the newest bb that has a soft unlock out its been over a year. Hard unlocks (ie Gevey) might be updated for future basebands. I personally wouldn't worry about it much if your not on AT&T. The other carriers will unlock on their own terms so before you sell it have sprint/Verizon or whoever unlock.
    1. honeydew's Avatar
      honeydew -
      oopse, I forgot to mention that I was worrying about the baseband in regards of 4s,

      h never mind, I know what you mean, but first time when I red your comment, thought it was only about all other iPhones except 4s

      my bad
    1. A3gOwner's Avatar
      A3gOwner -
      Well that basically holds true to all versions as of now. Everyone focused on 4s everything else gets put on back burner. This is a 4s thread too btw.
    1. myiphone3gs4055's Avatar
      myiphone3gs4055 -
      Quote Originally Posted by 2k1dakotaman View Post
      upgrade is your best bet
      What about if I want to unlock my 4s.Do I need to upgrade too ?

      Quote Originally Posted by A3gOwner View Post
      Baseband unlocks have been off the table for awhile (soft unlocks that is). Look at the newest bb that has a soft unlock out its been over a year. Hard unlocks (ie Gevey) might be updated for future basebands. I personally wouldn't worry about it much if your not on AT&T. The other carriers will unlock on their own terms so before you sell it have sprint/Verizon or whoever unlock.
      Should I upgrade my 4s to 5.0.1 to get the unlock too because Im kind of confusing when p0sixninja said that everyone should upgrade to 5.0.1 except unlocker. Did he mean except who want to unlock 4s?????
    1. A3gOwner's Avatar
      A3gOwner -
      Quote Originally Posted by myiphone3gs4055 View Post
      What about if I want to unlock my 4s.Do I need to upgrade too ?



      Should I upgrade my 4s to 5.0.1 to get the unlock too because Im kind of confusing when p0sixninja said that everyone should upgrade to 5.0.1 except unlocker. Did he mean except who want to unlock 4s?????
      Why do you need to unlock a 4s? Why not just buy a factory unlocked from apple if you need it that bad? He was probably referring to older devices.
    1. GunHo198's Avatar
      GunHo198 -
      So what he's basically saying is.... All of us who has an iPhone 4S that wants a jailbreak, should make sure we upgrade the Firmware to 5.0.1 and save our SHSH files with the new TinyUmbrella just in case someone developed an app that would help us downgrade back to 5.0.1 if they had too because they were at some point in the Intergalactic Space time continuum forced to upgrade there firmware to 5.1 because of some unforeseen software crash....

      Am I correct???
    1. A3gOwner's Avatar
      A3gOwner -
      Yes.
    1. metaserph's Avatar
      metaserph -
      You are correct GunHo. Just make sure of wearing the tin foil hat while doing it.
    1. myiphone3gs4055's Avatar
      myiphone3gs4055 -
      The reason I need to unlock my 4s is because I go back to my country which is Vietnam every year or two ( not often ) and dont want to spent 800 buck
    1. Anthony Bouchard's Avatar
      Anthony Bouchard -
      Quote Originally Posted by A3gOwner View Post
      Does it save APtickets as well? I haven't looked into it, guess I'm being lazy. If it does a bootrom exploit would still be needed for pwned dfu to restore to the stitched (signed) ipsw. It's a step forward at least.
      Yes TinyUmbrella saves APtickets - not sure about A5 devices though.
    1. A3gOwner's Avatar
      A3gOwner -
      Quote Originally Posted by Anthony Bouchard View Post
      Yes TinyUmbrella saves APtickets - not sure about A5 devices though.
      I knew it did for older devices. I'm asking about the 4s, since this is a 4s thread.
    1. Anthony Bouchard's Avatar
      Anthony Bouchard -
      Quote Originally Posted by A3gOwner View Post
      I knew it did for older devices. I'm asking about the 4s, since this is a 4s thread.
      Probably. I would just do it anyway and wait for updates on the information.