• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Redsn0w Updated to Version 0.9.10b3

    Here's to another great redsn0w update!

    We all know by now that the redsn0w 0.9.10 series is the version capable of providing us with an untethered jailbreak (compliments of pod2g) for our iOS 5.0.1 non-A5 devices. It's one of the two methods of gaining the untethered ability – the other being the Corona untether package. Since redsn0w 0.9.10b2 was released yesterday fixing the 'launchctl' problem that caused many dependent applications not to work; IntelliScreenX and OpenSSH to name a couple, many people used it to fix the problem and were plagued with a new problem. The problem was that after running redsn0w over the already untethered jailbreak achieved by redsn0w 0.9.10b1, all of the tweaks installed on the device would disappear causing many to either reinstall all of them or restore the device and rejailbreak. Of course, this was a huge inconvenience with all of the repositories being slow and unresponsive.

    To fix the issue, the iPhone-Dev team has released a new version of redsn0w dubbed redsn0w 0.9.10b3 which can be used to safely run redsn0w over the existing untethered jailbreak without removing all of your tweaks and causing a MobileSubstrate glitch. This morning, you will notice that there is a MobileSubstrate update in Cydia. The glitch from yesterday could be fixed easily by simply reinstalling MobileSubstrate after running the redsn0w overlay, but it seems impractical to have to do that. The new redsn0w will keep you from needing to that.

    The iPhone-Dev team posted this on their blog to summarize the updated redsn0w:
    Update #3: The b3 version of redsn0w fixes a problem where re-running redsn0w over an existing jailbreak would cause MobileSubstrate-based apps to stop running until MS was installed again. Now you can re-run the redsn0w jailbreak step without worrying about that (but still remember to de-select the “Install Cydia” option if it’s already installed).

    TIP: If auto-detection fails and redsn0w tells you no identifying data was found, you can always pre-select the appropriate 5.0.1 IPSW using “Extras->Select IPSW”.
    If you are still having repository errors when reloading, keep in mind that this isn't a jailbreak problem or a Cydia problem, the host servers are simply being overloaded by the volume of people who are jailbreaking and installing things from the repositories. This means that you won't find a jailbreak fix for it and that even tethered jailbreak users are having the problem because they work off of the same repositories as you are. The only fix for it is to wait until traffic dies down a little - I was able to get full successful reloads yesterday which means traffic is easing up.

    This version of redsn0w has been dubbed safe for running over your current jailbreak. Once again jailbreakers rejoice at Apple being Pwned on their brand new operating system. Keep in mind that this jailbreak does not support the iPhone 4S or the iPad 2 yet - but soon, it will. When using this version of redsn0w to jailbreak over your existing jailbreak, deselect, "Install Cydia" first when performing the jailbreak.

    Here are the redsn0w 0.9.10b3 download links:
    redsn0w 0.9.10b3 for Mac
    redsn0w 0.9.10b3 for Windows

    Sources: Dev-Team Blog
    This article was originally published in forum thread: Redsn0w Updated to Version 0.9.10b3 started by Anthony Bouchard View original post
    Comments 165 Comments
    1. moveandstore's Avatar
      moveandstore -
      I had JB'd with the b2 update. Everything worked fine until I used PKGBackup to reinstall my apps and tweaks. My phone kept going into Safe Mode, until I removed Backgrounder. Then everything worked fine until when I used respring on SB Settings, it going into a long looping respring, and would not come out of it. (I had to hold the power and center button at the same time for 10 seconds to come out of it. So I had to uninstall and reinstall SB Settings. Now everything seems fine. I did not reinstall Backgrounder though. All my other apps and tweaks works fine.
    1. snarkster's Avatar
      snarkster -
      I just upgraded from 5.0.0 with semi-tether to 5.0.1 untethered with redsn0w b3. Everything went fine except my battery life got MUCH MUCH worse than it already was. I pulled my phone from the charger at 6pm yesterday with a 100% charge and woke up this morning at 9am with 11% remaining. There was no activity at all overnight. This sucks. Any suggestions? I already have many of the location services turned off including the infamous "setting time zone"... crap now I'm down to 5% in less than another hour of inactivity!!!
    1. teej1410's Avatar
      teej1410 -
      Quote Originally Posted by moveandstore View Post
      I had JB'd with the b2 update. Everything worked fine until I used PKGBackup to reinstall my apps and tweaks. My phone kept going into Safe Mode, until I removed Backgrounder. Then everything worked fine until when I used respring on SB Settings, it going into a long looping respring, and would not come out of it. (I had to hold the power and center button at the same time for 10 seconds to come out of it. So I had to uninstall and reinstall SB Settings. Now everything seems fine. I did not reinstall Backgrounder though. All my other apps and tweaks works fine.
      So it would be safe to say that backgrounder isn't iOS 5 compatible?
    1. A3gOwner's Avatar
      A3gOwner -
      Quote Originally Posted by snarkster View Post
      I just upgraded from 5.0.0 with semi-tether to 5.0.1 untethered with redsn0w b3. Everything went fine except my battery life got MUCH MUCH worse than it already was. I pulled my phone from the charger at 6pm yesterday with a 100% charge and woke up this morning at 9am with 11% remaining. There was no activity at all overnight. This sucks. Any suggestions? I already have many of the location services turned off including the infamous "setting time zone"... crap now I'm down to 5% in less than another hour of inactivity!!!
      When you restored to 5.0.1 did you set your phone up as new or from a backup? If from a backup restore again and set up as new. Pkgbackup really causes more issues than anything. Your better off to reinstall your tweaks one by one and find the package causing the issue your having that way.
    1. VerizonIphone4_help's Avatar
      VerizonIphone4_help -
      Quote Originally Posted by VerizonIphone4_help View Post
      I have a cydia problem I jailbroke with v 9.10.b1 then fresh restored to apple fireware then broke with v 9.10.b2 same issue, just did a fresh restore to apple firmware 5.0.1 and broke again using v 9.10.b3.

      I still have the same problem, a blank Cydia home page, blank package pages (no description or anything, just the background) and only THREE packages in cydia when it i first open it. I CAN download and use tweaks successfully but these problems I just can't work with.

      can anyone please help?!

      here's the picture of the three packages that cydia has when i open it. there is usually about a dozen which i think help cydia run.

      Attachment 558944

      here's my cydia home page:

      Attachment 558945
      Fixed my own problem

      sweet moses don't ever use the restore for your iphone BEFORE you jailbreak. All i had to do to get cydia working right is fresh restore, then set up as a new iphone (not in itunes just in the iphone), then jailbreak - THEN and only THEN restore using your backup on itunes.
    1. Plotkin35's Avatar
      Plotkin35 -
      Quote Originally Posted by goofball2k View Post
      I don't have this problem with Iphone 4 and 5.0.1. Running jb'ed after using b1, then b2 over top, then b3 over top again.
      I went from stock 5.0.1 and only JB with the b3 Red Snow.
    1. Lunky's Avatar
      Lunky -
      First of all, my thanks again to all the volunteers who contributed to this untethered jailbreak effort.

      I have two questions.

      I updated with the first two Redsnow versions, but not the third. I have updated corona and other items from Cydia.

      Is there a reason to use the latest Redsnow update? I fear I might break something that seems to be (largely) working.

      The only item not current working quite properly is....big surprise...iBooks.

      I tried ibooksfix and ibooksfix2; but neither seemed to work properly for me.

      What does work in a non-optimal way is to move ibook files usinig iFile to a different directory. But then one can't easily import books into iBooks using iTunes.

      So I am wondering if an official fix for iBooks is coming.

      Thanks again.
    1. esizzle777's Avatar
      esizzle777 -
      My answer/decline/end buttons are clear i can only see the words, anyone got any ideas???
    1. metaserph's Avatar
      metaserph -
      @Lunky. I posted how mine got working iBooks. Run redsn0w b3 on top of the one you have. Reboot. Open Cydia, upgrade MobileSubstrate. Respring. Reboot.(Yes, first respring, THEN reboot right after). Then install a fresh copy of iBooks. Reboot. Then open iBooks, see if it works. This is how it worked for me.
    1. Lunky's Avatar
      Lunky -
      metaserph;

      Perhaps it was because I was already up to date with mobile substrate and corona....but I can not get the latest version of redsnow to run properly. Errors are being registered (tried twice). The phone does reboot as jailbroken.

      Needless to say, I tried your ideas out. But ibooks remain unhappy with its current state of affairs, even after following your procedures. But of course it is fair to point out that the latest jailbreak could not be viewed as fully successful (even though the device is in fact jailbroken).
    1. metaserph's Avatar
      metaserph -
      Sorry to hear that it didn't work. I'd try delete iBooks, respring. Reboot. Then re-install iBooks, reboot. Then launch iBooks. Hope an update to the fix shows up, but mine is working. Odd.
    1. shortysos7's Avatar
      shortysos7 -
      how do you uncheck install cydia? I cant seem to find where to uncheck it lol
    1. metaserph's Avatar
      metaserph -
      Shorty, select jailbreak and after it starts the jailbreak it will come to that section, you uncheck it.
    1. PoEtikly's Avatar
      PoEtikly -
      Quote Originally Posted by metaserph View Post
      Sorry to hear that it didn't work. I'd try delete iBooks, respring. Reboot. Then re-install iBooks, reboot. Then launch iBooks. Hope an update to the fix shows up, but mine is working. Odd.
      iBooksfix 2 worked for me but then you're obviously stuck with the ugly iOS stock iBooks icon. It doesn't change with your theme anymore because it moves it to a different directory. Btw, how has all the server traffic gotten? Is it much better? Is BigBoss running good?
    1. metaserph's Avatar
      metaserph -
      Repos are running fine for me, of course the once in a while glitch. On my end, iBooks is themed.
    1. PoEtikly's Avatar
      PoEtikly -
      Quote Originally Posted by metaserph View Post
      Repos are running fine for me, of course the once in a while glitch. On my end, iBooks is themed.
      See when I jb using b1 BigBoss wouldn't work at all but 25 min after I restored, Rejb with 0.9.9d9d tethered and then used corona and all my repos worked perfectly. So you think if I restore again and jb with b3 untethered my iBooks should work?
    1. DamenZZ's Avatar
      DamenZZ -
      I updated essentials in Cydia ...i think the update was red snow or ultra snow a few others?? Now my phone is stuck on apple logo with wheel....what happened? ughhhh

      TIA
    1. metaserph's Avatar
      metaserph -
      Poe, that's a gamble you know? I'm sharing how that worked for me, it's up to you to decide to give it a whirl. If it wouldn't undo a lot of work and time you put to get it where it is, I would try if iBooks is a big deal right now. That was my case and that's how it worked for me. Just saying...
    1. david_77598modmy's Avatar
      david_77598modmy -
      Hi Some One Out There !!! I have 2 iPhone4-32Gb iOS 5.0.1 Baseband 04.11.08. and 1 Baseband 04.10.01. and 1 iPhone3Gs-16Gb
      Baseband 05.16.05.. Before Jailbreak every things work fine, But affter i jailbreak some of the items not working,like ibook and newstand not worked at all,it not 1 phone but this 3 phones they all the same problems !!! i don't know what to do ???
      Some One Please Help Me !!!
    1. PoEtikly's Avatar
      PoEtikly -
      Quote Originally Posted by david_77598modmy View Post
      Hi Some One Out There !!! I have 2 iPhone4-32Gb iOS 5.0.1 Baseband 04.11.08. and 1 Baseband 04.10.01. and 1 iPhone3Gs-16Gb
      Baseband 05.16.05.. Before Jailbreak every things work fine, But affter i jailbreak some of the items not working,like ibook and newstand not worked at all,it not 1 phone but this 3 phones they all the same problems !!! i don't know what to do ???
      Some One Please Help Me !!!
      First, relax Chief. If you haven't noticed A LOT of people are having the iBooks issue. I can't tell where to get but google what repo you can iBooksfix 2 from. That worked for me for iBooks. It doesn't seem to be working for everyone though. About newstand......I don't know what to tell you, I never use it, don't have the issue, and I haven't heard of it but if you go to the forums and search it somebody might have a fix. You have to realize that this untethered exploit took a long time and I'm sure as difficult as it was there are a lot of links to be worked out. Look, redsn0w is already on b3 and that was after about 3 days of a release. The devs I'm sure are working on making the exploit as stable as they can but Apple has made it much harder so it's going to take more time. Relax. Remember, it could worse. You could have NO jailbreak.

      Quote Originally Posted by metaserph View Post
      Poe, that's a gamble you know? I'm sharing how that worked for me, it's up to you to decide to give it a whirl. If it wouldn't undo a lot of work and time you put to get it where it is, I would try if iBooks is a big deal right now. That was my case and that's how it worked for me. Just saying...
      Thanks metaserph. Yes I do have a lot of time on getting my phone setup. I'm untethering my fiances i4 tomorrow and I'll see if it fixes her iBooks before I go and do all that.

      I just thought about something. I hope they get animate to work for this jailbreak. I installed animate fix for 4.x and it actually works but after it boots then you get these really weird graphics lines for a bit. And the boot logo is extremely laggy.