• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Redsn0w Updated to Version 0.9.10b2

    Today, the iPhone-Dev team has rolled out an update to the iOS 5.0.1-untethering redsn0w 0.9.10 that was released yesterday for non-A5 devices only. As you may recall the untether could have been achieved one of three ways - 1. Installing the Corona untether package from Cydia while already being on a tethered jailbreak on iOS 5.0.1; 2. Running the updated redsn0w 0.9.10 over the tethered jailbreak that you had on iOS 5.0.1; 3. Completely updating/restoring your iDevice to iOS 5.0.1 and doing a fresh jailbreak using redsn0w 0.9.10.

    As we reported yesterday, Saurik tweeted that he released two consecutive updates to the Corona untether package in Cydia in order to keep Corona from breaking the 'launchctl' dependency for numerous applications. All Corona untether users and redsn0w 0.9.10 jailbreakers included were advised to download and install the new Corona update to fix the launchctl problem that had occurred.

    Since the Corona untether package was fixed yesterday, providing light for tweaks and applications that depended on launchctl including applications like IntelliScreenX and OpenSSH, the iPhone-Dev team found it necessary to update redsn0w to version 0.9.10b2 which would fix that issue for redsn0w users too. This way, redsn0w users would have no reason to install the Corona package to fix the launchctl problem.

    If you jailbroke iOS 5.0.1 yesterday using redsn0w 0.9.10b1, then we recommend that you do a jailbreak over it today with the new redsn0w 0.9.10b2 so that that launchctl problem can be addressed. If you installed the Corona untether package after reading our article about it yesterday to fix the problem, you can uninstall it after you jailbreak over your existing jailbreak with the new redsn0w. When you do so, just make sure that you don't re-select the Install Cydia option and that you power down the device before going into DFU mode. If you're using Windows, run redsn0w 0.9.10b2 with administrator privileges. Here is the iPhone-Dev team's complete update description via their blog:

    Quote Originally Posted by Dev-Team Blog
    Update #2: The b2 version of redsn0w includes the launchctl-related fix by planetbeing as mentioned by saurik here and here. As usual, you can just re-run redsn0w in jailbreak mode over your existing 5.0.1 jailbreak (even a PwnageTool one), making sure to de-select "Install Cydia" if you do. Always be sure to do a controlled "slide to power off" shutdown of your device before running redsn0w.
    redsn0w 0.9.10b2 download links:
    redsn0w 0.9.10b2 for Mac
    redsn0w 0.9.10b2 for Windows

    Sources: Dev-Team Blog
    This article was originally published in forum thread: redsn0w Updated to Version 0.9.10b2 started by Anthony Bouchard View original post
    Comments 152 Comments
    1. Mg48's Avatar
      Mg48 -
      Darn it I just ran redsnow last night. Luckily it was so easy I will do it again today!
    1. KraXik's Avatar
      KraXik -
      I used Redsn0w yesterday but had no problems with IntelliscreenX?! Confused much.
    1. lol.darkrai's Avatar
      lol.darkrai -
      iBooks is broken once again on jailbroken iOS 5
    1. vantheman169's Avatar
      vantheman169 -
      Yes iBooks has been broke for me too since the first time i ran redsn0w for the untethered JB. WTF is anyone working on this issue?
    1. tangus999's Avatar
      tangus999 -
      dont update to cydia 1.1.3 if you have a ipad 2 running 4.3.3
      it broke LTOS of things for me! i think the problem isn't corona but with cydia 1.1.3.
      but i don't now nothing
      reupdateing my i4 now though hopefully i can get that to work better:/
    1. jtanner's Avatar
      jtanner -
      I'm going to go with the "if it aint broke, don't fix it" idea... or at least I should have in hindsight.

      I like to have things neat, so, I re jailbroke using redsnow 0.9.10.b2... the moment It rebooted something wasn't right... NONE of my MS extensions were active. Toggling them in SBSettings made no difference. It was like every package had been disabled. I tried respringing and rebooting but no luck. I then removed Corona as mentioned above (it says to remove AFTER reapplying the JB)... and BOOM I'm now in a constant respring loop!!

      FFS I spent hours updating and sorting my phone out last night... and now just I gotta restore it AGAIN ...

      Sigh :: I'd recommend, that if you installed Corona to fix launchctl (even with Redsn0w JB) that you STAY AS YOU ARE!!
    1. rlowride's Avatar
      rlowride -
      Now I'm scurred and confused..
      I ran redsn0w last night.... Fresh...
      Did corona anyway.... Phone seems to be fine...
      What to do...
    1. teej1410's Avatar
      teej1410 -
      Quote Originally Posted by vantheman169 View Post
      Yes iBooks has been broke for me too since the first time i ran redsn0w for the untethered JB. WTF is anyone working on this issue?
      I know how to fix it. Go to Barnes and noble or the library and get the book you like there. No problems of books crashing there. Lol
    1. SkyMuffin's Avatar
      SkyMuffin -
      Quote Originally Posted by KraXik View Post
      I used Redsn0w yesterday but had no problems with IntelliscreenX?! Confused much.
      It only caused problems if you upgraded from a tethered to untethered with redsnow or the corona package. Not if you started vanilla and went straight to untethered.
    1. loudest_silence1's Avatar
      loudest_silence1 -
      Quote Originally Posted by vantheman169 View Post
      Yes iBooks has been broke for me too since the first time i ran redsn0w for the untethered JB. WTF is anyone working on this issue?
      Simple. Same fix as before.
      1. Uninstall iBooks.
      2. Reinstall iBooks but DON'T launch it.
      3. Install iBooksFix2 and respring.

      Good to go.
    1. DoWoRkSoN's Avatar
      DoWoRkSoN -
      Quote Originally Posted by lol.darkrai View Post
      iBooks is broken once again on jailbroken iOS 5
      I just noticed that myself.
    1. xxscaxx's Avatar
      xxscaxx -
      i'm also having issues with this redsnow update. Many of my jailbreak tweaks are not working. meh, should have left it.

      they show up in cydia and are installed, just not in my settings or just don't work.
    1. EJB1188's Avatar
      EJB1188 -
      Quote Originally Posted by jtanner View Post
      I'm going to go with the "if it aint broke, don't fix it" idea... or at least I should have in hindsight.

      I like to have things neat, so, I re jailbroke using redsnow 0.9.10.b2... the moment It rebooted something wasn't right... NONE of my MS extensions were active. Toggling them in SBSettings made no difference. It was like every package had been disabled. I tried respringing and rebooting but no luck. I then removed Corona as mentioned above (it says to remove AFTER reapplying the JB)... and BOOM I'm now in a constant respring loop!!

      FFS I spent hours updating and sorting my phone out last night... and now just I gotta restore it AGAIN ...

      Sigh :: I'd recommend, that if you installed Corona to fix launchctl (even with Redsn0w JB) that you STAY AS YOU ARE!!

      I second that.
      All my stuff is broken after being jailbroken with redsnow 0.9.10.b1 + Corona then using redsnow 0.9.10.b2 without installing Cydia.
    1. cjuni's Avatar
      cjuni -
      I too spent hrs on this last night but will try it again now & post any updated's. As my cydia was not working correctly last night/this morning.

      Thanks Again
    1. thuwun's Avatar
      thuwun -
      Quote Originally Posted by jtanner View Post
      I'm going to go with the "if it aint broke, don't fix it" idea... or at least I should have in hindsight.

      I like to have things neat, so, I re jailbroke using redsnow 0.9.10.b2... the moment It rebooted something wasn't right... NONE of my MS extensions were active. Toggling them in SBSettings made no difference. It was like every package had been disabled. I tried respringing and rebooting but no luck. I then removed Corona as mentioned above (it says to remove AFTER reapplying the JB)... and BOOM I'm now in a constant respring loop!!

      FFS I spent hours updating and sorting my phone out last night... and now just I gotta restore it AGAIN ...

      Sigh :: I'd recommend, that if you installed Corona to fix launchctl (even with Redsn0w JB) that you STAY AS YOU ARE!!
      Yes there is def still something wrong with the jailbreak, or some incompatible tweaks, but my springboard now looks like it is in a permanent safe mode, and most if not all my tweaks are disabled. and none of the tweaks on in the settings app anymore they have all been pushed to the springboard and are not functioning. I really don't want to restore my phone all over again so I am continuing to try and rejailbreak w redsn0w 0.9.10b2 hoping it will eventually go back to normal... or until someone figures out what is going wrong.

      AGAIN: If there is nothing wrong w your phone as is. DO NOT JAILBREAK over the beta1... it may actually break your jailbreak! I will post screenshots later.

      OK HERE IS THE FIX
      if your are jail breaking over the jailbreak, and phone appears broken!

      CONFIRMED

      Just go into Cydia
      Manage
      Packages
      Mobile Substrate
      Modify
      Reinstall
      Respring
      & Reboot (Strongly suggested)
      And all is back to normal.... hope this helps for anyone who Jailbreak over Jailbreak!

      S/O to:
      WTFX
      chritty
      oneduality
      EJB1188

      This is what the community is all about!

      Moderators you might want to add this as a NOTE / WARNING
    1. DoWoRkSoN's Avatar
      DoWoRkSoN -
      Quote Originally Posted by loudest_silence1 View Post
      Simple. Same fix as before.
      1. Uninstall iBooks.
      2. Reinstall iBooks but DON'T launch it.
      3. Install iBooksFix2 and respring.

      Good to go.
      Oh thanks....I'll try that now!
    1. jtanner's Avatar
      jtanner -
      So that looks to be 3 so far that just got "done over" lol ... perhaps a "proceed with caution" should be added to the article just in case.
    1. KraXik's Avatar
      KraXik -
      Quote Originally Posted by SkyMuffin View Post
      It only caused problems if you upgraded from a tethered to untethered with redsnow or the corona package. Not if you started vanilla and went straight to untethered.
      Thanks man! I did start fresh which explains!
    1. chritty's Avatar
      chritty -
      same only apps working no tweaks/themes even after re installation and respring
    1. jtanner's Avatar
      jtanner -
      Quote Originally Posted by thuwun View Post
      Yes there is def still something wrong with the jailbreak, or some incompatible tweaks, but my springboard now looks like it is in a permanent safe mode, and most if not all my tweaks are disabled. and none of the tweaks on in the settings app anymore they have all been pushed to the springboard and are not functioning. I really don't want to restore my phone all over again so I am continuing to try and rejailbreak w redsn0w 0.9.10b2 hoping it will eventually go back to normal... or until someone figures out what is going wrong.

      AGAIN: If there is nothing wrong w your phone as is. DO NOT JAILBREAK over the beta1... it may actually break your jailbreak! I will post screenshots later.
      I fear it's too late my friend... the damage is done! (You are numero 4 to the **** list )

      I've just restored... I'm gonna install my IntelliScreenX and see if it works as expected (to see if the launchctl prob is at least fixed correctly)

      Do'h