• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iFaith 1.4.1 Released

    iFaith is the amazing application that pioneered iOS 5 downgrading.

    In case you aren't familiar with iFaith, it's a Windows application made by iH8sn0w that dumps your SHSH blobs and APtickets locally so that you can make custom signed restorable firmwares. iFaith was the first application that allowed you to make a signed '.ipsw' file for iOS 5. If you like what you're hearing so far, you might be interested in hearing that iH8sn0w just Tweeted on Twitter that he has released an updated iFaith 1.4.1.



    The update resolves some problems that arose in iFaith 1.4 including a rare issue that could cause DFU mode not to be detected. Another thing that was fixed was compatibility with the new 8GB iPhone 4 models which gave a lot of people headaches while using iFaith 1.4 last time. Also resolved was an issue with the iPhone 3GS that would cause an error number (21) when restoring using an iFaith signed firmware. Last but not least, some iOS detection problems were addressed making sure that iFaith would not have any problems detecting the firmware you were using. The Apple TV's new iOS 4.4.4 (9A406a) firmware is also supported now. You can read the whole list of release notes from this link.

    If you're one of the people that listened to MuscleNerd when he said you can use Tiny Umbrella to save your SHSH blobs with APtickets instead of iFaith you will be happy to hear that iFaith 1.4.1 is now able to accept the SHSH blob files that you save with Tiny Umbrella. We recommend that you simply use the SHSH blobs and APtickets that iFaith saves simply for the best compatibility experience, however it works either way. If you don't want to use iFaith at all, you can use redsn0w 0.9.9b9d to stitch your iOS 5.0 or iOS 5.0.1 APtickets from Tiny Umbrella into a custom firmware. So that option is a fork in the road for you to choose.

    Since iFaith 1.4.1 is a Windows-only application, it won't be for everyone. The Tiny Umbrella and redsn0w method is multi-platform. If you plan to use iFaith 1.4.1 anyways, you can download it from this link. I have used it already, and it appears to be a stable release. If you had any problems with iFaith 1.4, then try this version out and it should work correctly. If not, then report the bugs to iH8sn0w so that he can work on them. This release does not work with any A5 devices yet and will continue to not work with them until a bootrom exploit is discovered as iH8sn0w warns.

    With an untethered jailbreak for iOS 5.0.1 just on the horizon for A4 and A5 devices, it would be a good idea for anyone who has an A4 device to save their signed iOS 5.0.1 firmware as soon as possible so that you will have some insurance in case something goes wrong. The signed '.ipsw' file for iOS 5.0.1 can be used to downgrade back to a fresh copy of iOS 5.0.1 even when Apple stops signing it. You simply need to put your iDevice into Pwned DFU mode to restore using the signed firmware.

    Sources: iH8sn0w
    This article was originally published in forum thread: iFaith 1.4.1 Released started by Anthony Bouchard View original post
    Comments 26 Comments
    1. Anthony Bouchard's Avatar
      Anthony Bouchard -
      Quote Originally Posted by iphonerookie View Post
      So does this support 4S yet or not?
      So I'm guessing you didn't read it?

    1. iphonerookie's Avatar
      iphonerookie -
      Thanks
    1. iYeow's Avatar
      iYeow -
      Quote Originally Posted by iphonerookie View Post
      So does this support 4S yet or not?
      No, it does not support 4s and ipad 2
    1. golf4life80's Avatar
      golf4life80 -
      Does TU or iFaith allow you to save the APTicket if you are not on 5.0.1 yet, like SHSH? I'm on 4.x. Do you actually have to be on 5.0.1 to save the APTicket?
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by golf4life80 View Post
      Does TU or iFaith allow you to save the APTicket if you are not on 5.0.1 yet, like SHSH? I'm on 4.x. Do you actually have to be on 5.0.1 to save the APTicket?
      Yes tiny umbrella can save them regardless of what firmware you are on. iFaith no, you have to be on that firmware to save them.
    1. uwishu's Avatar
      uwishu -
      I get the Oversized APTicket :0 warning too. This was using the shsh with APTicket saved by TinyUmbrella and iFaith to create the custom IPSW.

      Does anyone know if the resulting IPSW will work when I later try to restore with it?