• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Redsn0w 0.9.9b9d Released!

    Redsn0w 0.9.9b9b has been released in full.

    Article has been updated with download links for redsn0w 0.9.9b9d.

    Yeah, the jailbreak is still tethered right now.

    Redsn0w has been updated with a whole truckload of new things added to it and it is the same user interface that we know and love. According to the Dev-Team Blog, redsn0w version 0.9.9b9 has been officially released followed by an update to fix a bug dubbed redsn0w 0.9.9b9b.

    What's new in Redsn0w 0.9.9b9?

    First and foremost, Redsn0w 0.9.9b9 has been updated to work with the iOS 5.0.1 firmware whereas it didn't before – you needed to point Redsn0w to iOS 5.0 in order to boot tethered and jailbreak the device. Now you can use the iOS 5.0.1 firmware instead. On top of that, iBooks has been fixed for iOS 5.0 and iOs 5.0.1. This means that you will now be able to download iBooks and read/delete/by books on your jailbroken iDevice without getting the configuration error which Apple purposely built into it to defer jailbreakers. Sn0wbreeze offered a fix for iBooks a while back; now redsn0w does too.

    Any iPhone 3GS old-bootrom owners can now make custom firmwares without stitching any SHSH blobs at all. In addition to that, there will be an ultrasn0w update for iOS 5.0.1 on Cydia today with the same baseband requirements as the previous ultrasn0w. Also, Windows users can now make custom '.ipsw' files that have no baseband updates whereas only Mac OS X users could do that before. We can now also use redsn0w to jailbreak the new 8GB iPhone 4 models which we have seen arising at Sprint, AT&T, and Verizon in preparation for sales of the iPhone 4S.

    Aside from the iPhone, the iPad 2 (GSM only) now has gained support in iOS 4 firmware SHSH blob stitching. It will not work with iOS 5 yet and it will not work with the iPhone 4S at all because no bootrom exploits have been found to make that possible. Another thing to note is that the top of the redsn0w window will now tell you if you have the newest version or if there is an update available to download. The Dev-Team also notes on their blog that this version of redsn0w does not support iOS 5.1 beta because the beta is not compatible with Cydia and other jailbreak applications. They also warn the newer iPhone 3GS owners can not use iPad basebands. The complete description below:

    Quote Originally Posted by Dev-Team Blog
    Update #17: The holiday season is almost here (Happy Holidays!) so we realize everyone is busy (especially @pod2g!). And even though we always recommend that jailbreakers stay where they are until a new untethered JB comes out, that’s not always possible. So we’ve updated redsn0w for those who may have found themselves at iOS 5.0.1, and added some other useful features too:
    • native support for 5.0.1 (no need to point redsn0w at 5.0 IPSW or use command-line args). Support automatically extends to all of redsn0w’s various functions: “Jailbreak”, “Just boot”, “Fetch blobs”, “Stitch blobs”, “Recovery Fix”
    • iBooks fixed in 5.0 and 5.0.1. This is a targeted fix that doesn’t remove entire sandbox mechanism. 5.x users already using redsn0w “Just Boot” can just use the new version without redoing entire jailbreak again
    • 3GS old-bootrom owners can now create custom IPSWs without blobs
    • ultrasn0w compatability update (i.e. same baseband requirements) for 5.0.1 will be available on Cydia Monday
    • support for newer 8GB iPhone4 (which until now had problems with “Fetch blobs”). Thanks to JKjeepnJeff for loaning us one of these newer i4 units for testing!
    • allows Windows users (not just OS X users) to use the “Custom” button to create IPSWs without baseband update. (Update: please wait for 0.9.9b9b for this!)
    • accommodates APTickets in 5.x (until next Apple countermove). APTickets are crypto-verified before submitting to Cydia, just like the main blobs. Cydia server support for sending back the APTickets is upcoming. For now, use stitched IPSWs for 5.x. Due to APTickets, stitched 5.x IPSWs now require user to start in “Pwned DFU” mode
    • Support added for stitching 4.x blobs to iPad2-GSM IPSWs. Similar to notcom’s TinyCFW but doesn’t require lots of RAM or a TSS-assisted restore. Won’t work for iPad2 5.x blobs (or iPhone4S at all) until a bootrom-level exploit is out
    • top line now shows whether (and where) a redsn0w update is available, or if the version being run is the latest. Uses DNS TXT record to alleviate any concerns about snooping
    • no 5.1 beta support at this time (major apps like Cydia are not yet compatible)
    • pod2g has been doing a great job porting his 5.x untether…check his blog for updates!
    • Owners of newer 3GS iPhones must not flash the iPad baseband. The iPad baseband will not work on 3GS iPhones built later than 2011 week 35. You have a week 35 or later device if your serial # starts with xx135.

    What's new in Redsn0w 0.9.9b9b?

    Quote Originally Posted by Dev-Team Blog
    Update #17b: Version 0.9.9b9b enables the “Custom” button for Windows users, and make the 3GS week 35 warning a more explicit part of the process.
    What's new in Redsn0w 0.9.9b9b(2)?

    This update is for Windows users only.

    Quote Originally Posted by Dev-Team Blog
    Update #17c: For those Windows users encountering launch errors due to the self-update check, please use this version instead for now.
    This redsn0w update is huge. It fixes a ton of issues, adds a lot more support, and even supports the newer firmware so that you can delete the old firmware and free up some hard disk drive space. It definitely makes a difference for us solid state drive users who are buckled down to low memory sizes. The interface of redsn0w still looks the same and you will continue to be able to find everything right where it was before – no major changes have been applied to the interface. If you have a device jailbroken on iOS 5.0.1 using the iOS 5.0 firmware to jailbreak and boot tethered, you can run this version of redsn0w over it to get the iBooks fix and things of that nature (simply boot tethered, you don't need to rejailbreak). I have done it myself this morning.

    Download Links:
    Mac OS X: Redsn0w 0.9.9b9b
    Windows: Redsn0w 0.9.9b9b(2)


    EDIT: Article has been edited for conciseness.

    Are you excited to use the new Redsn0w? Share in the comments.

    Sources: Dev-Team Blog
    This article was originally published in forum thread: Redsn0w 0.9.9b9b Released! started by Anthony Bouchard View original post
    Comments 35 Comments
    1. Neilsen's Avatar
      Neilsen -
      Quote Originally Posted by mindblown View Post
      hmm 5.0 or 5.0.1 with newbootrom?
      you need to manually point redsn0w to 5.0 or 5.0.1 FW vice versa:
      Goto Extras/Select IPSW/Open Stock 5.0 or 5.0.1 Firmware, then jailbreak.
      That's all

      "No Identifying data fetched" error occurs when apple servers are down or you just have bad internet connection, so the steps i told you is kinda like an alternative
      I tired doing that but now it says Unexpected error what to do?
    1. linkisbest's Avatar
      linkisbest -
      FINALLY! Ultrasn0w update! WOHOO!
    1. PoEtikly's Avatar
      PoEtikly -
      The links to download are dead btw.

      Quote Originally Posted by PoEtikly View Post
      The links to download are dead btw.
      Yeah everywhere I try to download from it says "PAGE NOT FOUND"! What's up?
    1. celeron's Avatar
      celeron -
      I cant check the links right now, im on my ipod but a quick google search should bring a few download links
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by PoEtikly View Post
      The links to download are dead btw.



      Yeah everywhere I try to download from it says "PAGE NOT FOUND"! What's up?

      Try here: https://sites.google.com/a/iphone-dev.com/files/home/
    1. PoEtikly's Avatar
      PoEtikly -
      Quote Originally Posted by Simon View Post
      Ok now that worked. I googles it and went to 7 different sites that have that link and I kept getting the same message. But This one worked. I thought it was 0.9.9b9b not 9b9d??? It's showing it as 0.9.9b9d, is that right?
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by PoEtikly View Post
      Ok now that worked. I googles it and went to 7 different sites that have that link and I kept getting the same message. But This one worked. I thought it was 0.9.9b9b not 9b9d??? It's showing it as 0.9.9b9d, is that right?
      Looks like MN updated 3 hours ago. That site is the home of the dev team files.
    1. NakedFaerie's Avatar
      NakedFaerie -
      You asked if I'm excited for this redsn0w?
      Not at all. Its not an unteathered so WHO would be excited for this?
      I thought this was the unteathered until I read the story then realised its nothing new. Its still tethered so not what we are after.

      If you want to use 501 with jb then use sn0wbreeze as thats been available since 501 first came out so this redsn0w is really late to the party.

      They have already updated it 4 times since it was released. 9d is out now so update your first post.
    1. blueaviator's Avatar
      blueaviator -
      i don't know what's going on:

      - jailbreaked using latest ...9d redsnow version
      - iphone boots itself without need to use Redsnow's "Just Boot" option
      - Cydia icon is blank... When I try to launch it, nothing happens...
      - iOS 5.0.1 by the way...

      Anyone...help...???

      Thanks!
    1. samuel17's Avatar
      samuel17 -
      Quote Originally Posted by blueaviator View Post
      i don't know what's going on:

      - jailbreaked using latest ...9d redsnow version
      - iphone boots itself without need to use Redsnow's "Just Boot" option
      - Cydia icon is blank... When I try to launch it, nothing happens...
      - iOS 5.0.1 by the way...

      Anyone...help...???

      Thanks!
      Did you try the "Just Boot" option? It is required on a tethered JB for cydia and JB apps to work.

      Quote Originally Posted by Tario70 View Post
      Samuel, this is incorrect. I'm on an old-bootrom 3GS. I should be completely untethered. Key word, SHOULD.

      The mail.app is just broken for some reason & I can only hope MuscleNerd received my emails & will read them. I tried tweeting him too, but still nothing. I know he's busy, but after 3 installations of custom firmware I'm definitely burnt out today. I just got 4.3.3 back installed & have a usable phone now. (Don't get me wrong, I appreciate all he & the dev team do!)

      Based on other discussions from other sites, it seems like MobileSubstrate is the cause. The minute it is installed, the phone will not reboot.

      However, this does not explain why the mail.app crashes at all. That is completely unrelated to mobilesubstrate.
      Sorry Tario, i dont know JB on iphones that well, i know the 3GS old bootrom was rumored to work fine and be untethered, but im an ipod touch user, so i thought id just throw the idea out there
    1. celeron's Avatar
      celeron -
      Quote Originally Posted by blueaviator View Post
      i don't know what's going on:

      - jailbreaked using latest ...9d redsnow version
      - iphone boots itself without need to use Redsnow's "Just Boot" option
      - Cydia icon is blank... When I try to launch it, nothing happens...
      - iOS 5.0.1 by the way...

      Anyone...help...???

      Thanks!
      Turn off iphone and boot tether with redsnow
    1. blueaviator's Avatar
      blueaviator -
      Thanks @celeron and @samuel17

      Effectively, I had to switch off iPhone and use "Just Boot" option to activate Cydia

      But, when launching Cydia, lot's of packages were not downloaded and/or installed... Several errors saying that the packages are "old"...

      Couldn't make several of my packages work...

      So, just "Restored" my iPhone to non-jailbreak state... Can't be hassled with those errors all the time...

      Appreciate your help anyway!

      I guess I will wait for the untethered option...

      Merry Christmas to all

      blueaviator
    1. samuel17's Avatar
      samuel17 -
      Quote Originally Posted by blueaviator View Post
      Thanks @celeron and @samuel17

      Effectively, I had to switch off iPhone and use "Just Boot" option to activate Cydia

      But, when launching Cydia, lot's of packages were not downloaded and/or installed... Several errors saying that the packages are "old"...

      Couldn't make several of my packages work...

      So, just "Restored" my iPhone to non-jailbreak state... Can't be hassled with those errors all the time...

      Appreciate your help anyway!

      I guess I will wait for the untethered option...

      Merry Christmas to all

      blueaviator
      Not sure if its of use now since you already went away from the JB, but i had gotten that a time or 2 from cydia after i upgraded and JB to 5.0.1 but it stopped happening after a few times. Possibly because it doesnt recognize the new iOS right away? not real sure. I myself cant wait for an untether though, i need to get back into the bootlogo making game, i cant do that tethered! :P Well i cant test them myself at least haha Merry Christmas to you too and to all!
    1. Houtsy's Avatar
      Houtsy -
      Quote Originally Posted by Simon View Post
      Thanks for the new link!!!
    1. Anthony Bouchard's Avatar
      Anthony Bouchard -
      Updating redsn0w links now. They were dead because I linked redsn0w 0.9.9b9b and later that night they released redsn0w 0.9.9b9d.