• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Untethered Jailbreak Code Finished for All A4 Devices on iOS 5.0.1

    Everyone in the jailbreak community is eagerly anticipating the release of an untethered jailbreak for iOS devices on iOS 5 (confirmed to work with iOS 5.0.1 as well). Therefore, everyone has their eyes on @pod2g right now who is the iOS hacker currently showing significant progress with the jailbreak.

    The hacker previously released a video demonstrating a working untethered jailbreak on a third generation iPod Touch running the latest iOS software. He then recently confirmed it to work on the iPhone 4 as well. In a string of posts found on his blog, he continues to inform the community of his progress, which consists of several devices being added to the list.

    Pod2g noted that he has completed the code for his jailbreak for the iPad (first generation), the iPod Touch 4G, the iPhone 4, the iPhone 3GS, the iPhone 3G and the Apple TV 2G. The next step will be proceeding with testing on these devices over the next few days. Once he is done testing the exploit used in the iOS devices hes developed the code for, his jailbreak will be nearly complete for all A4 devices.

    The news is quite exciting for the jailbreak community as a whole but not quite for everyone. There hasnt been any new information regarding whether the jailbreak will be compatible with A5 devices such as the iPad 2 and the iPhone 4S. Wed recommend continuing to be patient and showing support while waiting for further developments. As always, you can stay tuned by checking back on the site and/or following us on Twitter (@ModMyi) for any developments with the jailbreak.

    Source: pod2g (blog)
    This article was originally published in forum thread: Untethered Jailbreak Code Finished for All A4 Devices on iOS 5.0.1 started by Akshay Masand View original post
    Comments 79 Comments
    1. superouse's Avatar
      superouse -
      Quote Originally Posted by TheDirtyDiddler View Post
      By the time we get a jailbreak for the A5s there will be new devices out with A6 chips. This is my single biggest regret about buying a 4S.
      Make a jailbreak yourself then.Stop moaning
    1. TheOrioles33's Avatar
      TheOrioles33 -
      Am I going to have to trade my 4S for my wifes 4 so I can jailbreak?
    1. Cucumbijuana's Avatar
      Cucumbijuana -
      I have a question though. When the untethered jailbreak comes out, can we run it over our current tethered jailbreak or do we need a fresh stock firmware to do it?
    1. SepticTank's Avatar
      SepticTank -
      Giving credit to the hard work and efforts.

      Thanks,

      Jon
    1. exNavy's Avatar
      exNavy -
      Should pod2g create a tool on his own to release will it be mac, windows or both???
    1. -JailbreakeR-'s Avatar
      -JailbreakeR- -
      Quote Originally Posted by Cucumbijuana View Post
      I have a question though. When the untethered jailbreak comes out, can we run it over our current tethered jailbreak or do we need a fresh stock firmware to do it?
      Your best bet is to do a fresh restore and start over. In the past it's been ok to run one over the other but from what I'm reading a restore gonna be needed for this one.
    1. Silverado1987's Avatar
      Silverado1987 -
      That's great. Cept I own a 4s :/
    1. puissance000's Avatar
      puissance000 -
      That just made my day! Just a couple more days!
    1. Striknine's Avatar
      Striknine -
      Why spend so munch time and effort on an old device. Why not try to get past the A5 for all future iOS releases. The iPad 2 was released close to a year ago and we've only seen one jailbreak since then. I'm not complaining as I'm happy to have that one jailbreak but so many people have the new iPhone and latest iPad that is doesn't make sense to me why they would work on a jailbreak for an older device. The iPhone 4 was released over a year and a half ago. In apples world that's old.
    1. Bailey4427's Avatar
      Bailey4427 -
      Maybe the JB team is waiting for 5.1 to drop before releasing this JB. That wouldn't be such a bad idea.
    1. Donnutt's Avatar
      Donnutt -
      I'm so glad I didn't buy the 4S. The iOS 5 tweaks are amazing! I'm semi-tethered, so I'm not sure I will be re-jailbreaking. Never know though...
    1. vantheman169's Avatar
      vantheman169 -
      Great job @Pod2g! Now on to the real deal, the iPad 2 and iPhone 4S. Tethered or untethered, bring it! my 4S is naked.
    1. -JailbreakeR-'s Avatar
      -JailbreakeR- -
      Quote Originally Posted by Striknine View Post
      Why spend so munch time and effort on an old device. Why not try to get past the A5 for all future iOS releases. The iPad 2 was released close to a year ago and we've only seen one jailbreak since then. I'm not complaining as I'm happy to have that one jailbreak but so many people have the new iPhone and latest iPad that is doesn't make sense to me why they would work on a jailbreak for an older device. The iPhone 4 was released over a year and a half ago. In apples world that's old.
      It's a numbers game just like everything else. The number of "older" devices greatly outnumbers the number of new a5 products. It's people's own fault for buying a phone that is so new and expecting a jailbreak right away (if at all). The iPad 2 is a perfect example one jailbreak and so long on the market, that should have been a clue as to what's instore for the 4s aswell. It may never be jail broke without the use of apple code, of that's the case the dev won't release it. Just look at comex first iPad jailbreak, it was done but not without violating laws by distributing it. So when people whine "I want a jb for 4s/ipad2" it's your own fault for purchasing the device. I have 3 4s's right now (selling 2 on eBay currently) and I'd still rather use my jb 4 than a stock 4s. The speed difference isn't that noticeable.
    1. DnBKiD521's Avatar
      DnBKiD521 -
      To my understanding there is a jb that will work with the 4S. It's just a matter of finding an exploit in the bootrom (since the A5 devices aren't susceptible to limera1n) to actually get the jailbreak into the device. In theory, @pod2g's jailbreak will stick into A5 devices running 5.0 or 5.0.1. It's just a matter now of getting the kernel into the actual device. Just hang on guys. It's gonna come
    1. FireSpyder's Avatar
      FireSpyder -
      Quote Originally Posted by Striknine View Post
      Why spend so munch time and effort on an old device. Why not try to get past the A5 for all future iOS releases. The iPad 2 was released close to a year ago and we've only seen one jailbreak since then. I'm not complaining as I'm happy to have that one jailbreak but so many people have the new iPhone and latest iPad that is doesn't make sense to me why they would work on a jailbreak for an older device. The iPhone 4 was released over a year and a half ago. In apples world that's old.
      There are a lot more A4 devices out there than A5. These debs are also working on JB for their own devices. Pod2g owns an iPod Touch 4g. Relatively few people and on A5 devices compared to A4.

      I just hope the JB comes out before apple pushes out 5.1 and stops signing 5.0.1. I'm overseas now using an unlocked iPhone 4 on 4.3.3 to tether my iPad 2. I think I need to do the upgrade and unlock in one go if I want to keep everything running smoothly.
    1. Breezy215's Avatar
      Breezy215 -
      It's beginning to look a lot like Christmas! Pod2g, you are the Santa Claus of Jailbreakers! (but I'm not sitting on your lap... lol)
    1. iamsalim's Avatar
      iamsalim -
      is there a working unlock for 5.0.1? for iPhone 4 with 1.59.00 baseband?
    1. mexchorizo's Avatar
      mexchorizo -
      TheOrioles33 - Today, 07:56 AM
      Am I going to have to trade my 4S for my wifes 4 so I can jailbreak?


      I did....

      Quote Originally Posted by TheOrioles33 View Post
      Am I going to have to trade my 4S for my wifes 4 so I can jailbreak?

      I did ...
    1. WeeDuck's Avatar
      WeeDuck -
      5.1 should be out in January so I can't see the untether being out before then. If it is then there's a good chance apple could patch it in 5.1
    1. mikerlx's Avatar
      mikerlx -
      I will be sitting by my Christmas Tree with my Egg Nog MacBook and iPhone 4 ready to do the untethered jailbreak!