• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • ultrasn0w 1.2 Out - Unlocks "Stuck" iPhone 3G/3GS


    The DevTeam has released ultrasn0w 1.2 - with a clever feature for those of you who've had an iPhone 3G or 3G[S] with a baseband later than 05.13.04.

    It turns out that the very first iPad firmware 3.2.2 has baseband version 06.15.00 still vulnerable to AT+XAPP. The iPad baseband is built for the exact same baseband chip as the iPhone3G/3GS — they’re fully compatible!
    For many iPhone 3G and iPhone 3G[S] users, you've been stuck at baseband 05.14 or 05.15 and unable to unlock because there is no carrier unlock available for those basebands on those phones. The Dev Team found the iPad baseband is actually a *higher* version number, but it STILL VULNERABLE to the ultrasn0w unlock exploit, as well as being FULLY COMPATIBLE with the iPhone 3G and 3G[S].

    Meaning?

    If - AND ONLY IF - you've got either of those devices (3G/3G[S]) and NEED an unlock but can't because your baseband is 05.14 or 05.15... you can now upgrade your baseband to the iPad one (06.15) and use ultrasn0w to unlock. This should NOT be done unless you absolutely need to. Here's the full warning posted by the Dev Team as to why:

    WARNING — YOU DO THIS AT YOUR OWN RISK! PLEASE UNDERSTAND THE CONSEQUENCES OF UPDATING TO 06.15.
    • There is no way to come back down from 06.15, and there’s no hiding the baseband version from Apple. You’ll be voiding your warranty in a very obvious way.[/B]
    • If some future baseband comes out with a critical fix, you won’t be able to update to it if it remains down in the 05.xx sequence (then again, you wouldn’t update to it if you wanted to keep your unlock anyway).
    • Starting with FW 4.2.1 if you have 06.15 on your iPhone you won’t ever be able to restore to stock firmware (it will fail). You’ll need to only restore to custom IPSWs (then again, if you’re unlocker you should already be doing that).
    Certainly don’t update to 06.15 if you don’t need to! Only do this if you need the unlock and you’re stuck on 05.14 or 05.15, and you’re willing to assume the above risks.
    We'll have a full guide up asap, but they include basic instructions in their blog post detailing how to do so using redsn0w 0.9.6beta5 or Pwnage Tool 4.1.3 Unlock Edition.

    This does NOT unlock the iPhone 4 yet. The Dev Team gave this info:

    The i4 unlock is taking more effort though, and no further concrete info is available about that yet.
    There's a lot of info in that post, so read up, but basically - stuck 3G and 3G[S] users can finally breathe a sigh of relief.
    This article was originally published in forum thread: ultrasn0w 1.2 Out - Unlocks "Stuck" iPhone 3G/3GS started by Kyle Matthews View original post
    Comments 118 Comments
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by nawarekko View Post
      now i am really confused !!
      i can't understand !!
      OMG /// ... dude i have iphone 3g on ios 3.1.2 but bb 05.14
      so what to do now step by step ?

      do i have to update the fmware to 4.2.1 ?
      or i can simply restore to 4.1 and jailbreak then unlock ?

      2nd question ?: how do i unlock it ? i tried the new ultrasn0w and it seems it's not working ! i dunno why ! i mean i tried it on my 3g ios 3.2.1 !
      so can u please clear the ideas for me ? thanks

      and can you please also add the links to direct download to the snowbreeze and ultrasn0w!? and what ever tool we may need ? thanks
      Follow this guide: iClarified - iPhone - How to Jailbreak and Unlock Your iPhone 3G Using RedSn0w (Windows) [4.2.1]
    1. pritesh23's Avatar
      pritesh23 -
      Quote Originally Posted by firedog341 View Post

      No, redsnow only works on what FW is currently on your phone. In order to go to 4.2.1, you have to have 4.2.1 on your phone already. You need a custom FW to update to 4.2.1 and preserve your BB. Windows, snowbreeze = 4.1 & OSX, pwnage = 4.2.1 for now. There might be a pwnage for windows release to go up to 4.2.1
      So I can only preserve my BB 5.13.04 if I use pwnage to go to 4.2.1? Snowbreeze will not allow me to go to 4.2.1 with 5.13.04?
    1. firedog341's Avatar
      firedog341 -
      Quote Originally Posted by nawarekko View Post
      now i am really confused !!
      i can't understand !!
      OMG /// ... dude i have iphone 3g on ios 3.1.2 but bb 05.14
      so what to do now step by step ?

      do i have to update the fmware to 4.2.1 ?
      or i can simply restore to 4.1 and jailbreak then unlock ?

      2nd question ?: how do i unlock it ? i tried the new ultrasn0w and it seems it's not working ! i dunno why ! i mean i tried it on my 3g ios 3.2.1 !
      so can u please clear the ideas for me ? thanks

      and can you please also add the links to direct download to the snowbreeze and ultrasn0w!? and what ever tool we may need ? thanks
      Your BB 5.14 is not currently unlockable. You or someone probably update the FW to stock 4.1 and then tried to downgrade it because the BB couldn't be unlocked. Trouble is, BB doesn't downgrade.

      So, you have 2 choices. Upgrade to stock 4.1 because your BB is already stock and then follow the Dev team instructions for Redsnow using the 6.15 BB upgrade. Or upgrade to stock 4.2.1 and then follow Dev team instructions for Redsnow using the 6.15 BB upgrade.

      Either way, the only "current" unlock for your BB is the 6.15 upgrade no matter what FW you run.

      Quote Originally Posted by pritesh23 View Post
      So I can only preserve my BB 5.13.04 if I use pwnage to go to 4.2.1? Snowbreeze will not allow me to go to 4.2.1 with 5.13.04?
      You got it. Current release of Snowbreeze is for 4.1. Current Pwnage for OSX is 4.2.1. Both for Windows might be released in the future for 4.2.1
    1. Poseidon79's Avatar
      Poseidon79 -
      Apple could truly screw everyone if they decide not to update the stock baseband on these (3G/3GS) phones past 6.15. In order to perma-void everyone's warranty they could just stick to 5.XX forever. This would also essentially make the phone unsellable because you would never be able to restore back to stock.

      Very risky business
    1. vindutch's Avatar
      vindutch -
      This is off topic. But i have an iphone 4 firmware 4.1. It is jailbroken with limera1n and unlocked with ultrasn0w on baseband 1.59.00. My facetime doesn't work and i have tried everything i can think to get it back. Any suggestions? Thanks
    1. Flatbeats's Avatar
      Flatbeats -
      I know im not the only one confused about the BB. where does 6.xx come from?

      Im on a 3G, did an official upgrade to 4.2.1 and im still on 5.14 BB, then a day later did a restore to scratch on official 4.2.1 and Im still on 5.14 BB
      yesterday ran redsnow jailbreak and all is good,
    1. mosesjade's Avatar
      mosesjade -
      Ive sucessfully unlocked my phone... Thanks
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by Flatbeats View Post
      I know im not the only one confused about the BB. where does 6.xx come from?

      Im on a 3G, did an official upgrade to 4.2.1 and im still on 5.14 BB, then a day later did a restore to scratch on official 4.2.1 and Im still on 5.14 BB
      yesterday ran redsnow jailbreak and all is good,
      It came from the iPad 3G baseband from 3.2.2 firmware.
    1. k1653d's Avatar
      k1653d -
      3gs old bootroom jb with limerain on 4.1. Used the new redsnow to update BB only to unlock. BB was successfully updated to 06.15.00. Installed ultrasnow and no service.


      I would recommend waiting for a few days to get the kinks out.
    1. GrandMstrBud's Avatar
      GrandMstrBud -
      I hope they release an unlock for the iPhone 4 soon.
    1. nawarekko's Avatar
      nawarekko -
      Awesome .. now i am stuck on this window . as shown in the screen fetching ipad baseband .. for more than one hour now

      help
    1. Simon's Avatar
      Simon -
      Stop the process and try again. The downloading of the ipad baseband may have stalled.
    1. adrockn's Avatar
      adrockn -
      I have a jailbroken/unlocked iPhone 3g running 3.1.3 with baseband 05.12.01.
      I would like to upgrade to 4.2/4.2.1 and keep my jailbreak, unlock and baseband. Can someone please point me in the right direction?

      Thank you.
    1. StealthBravo's Avatar
      StealthBravo -
      Quote Originally Posted by Poseidon79 View Post
      Apple could truly screw everyone if they decide not to update the stock baseband on these (3G/3GS) phones past 6.15. In order to perma-void everyone's warranty they could just stick to 5.XX forever. This would also essentially make the phone unsellable because you would never be able to restore back to stock.

      Very risky business
      I bet their close to not updating it anymore anyways. I would only do this unlock if you have to. If you can stay on a lower firmware with older ultrasn0w, do it.
    1. locobans's Avatar
      locobans -
      Hello,

      Thanks for the information... I'm wondering if these guys are actually going to keep trying to work in order to unlock BB 05.14.... I'm willing to wait if that's the case

      Thanks,
    1. Flatbeats's Avatar
      Flatbeats -
      Quote Originally Posted by adrockn View Post
      I have a jailbroken/unlocked iPhone 3g running 3.1.3 with baseband 05.12.01.
      I would like to upgrade to 4.2/4.2.1 and keep my jailbreak, unlock and baseband. Can someone please point me in the right direction?

      Thank you.
      go to the dev team blog, explains it all there
    1. EskimoRuler's Avatar
      EskimoRuler -
      I've always been grateful I never needed to unlock
    1. babes's Avatar
      babes -
      Ok I need help. I downloaded redsn0w but it wants me to browse for my firmware. when i hit browse my firmware does not come up in itunes. Where can I get that. I have 3gs 5.14.02. I have downloaded the ipad firmware to my computer just dont know how to get it on my phone. I had already jb with limera1n and have the latest ultrasn0w on my phone.
      Thank you so much
    1. Taranis17's Avatar
      Taranis17 -
      Quote Originally Posted by babes View Post
      Ok I need help. I downloaded redsn0w but it wants me to browse for my firmware. when i hit browse my firmware does not come up in itunes. Where can I get that. I have 3gs 5.14.02. I have downloaded the ipad firmware to my computer just dont know how to get it on my phone. I had already jb with limera1n and have the latest ultrasn0w on my phone.
      Thank you so much
      1. Firmware links (latest versions): NO LINKS EDIT
      2. You don't need the ipad firmware if you're on Windows using redsn0w. Redsn0w will download the ipad baseband from Apple.

      For Win 7 users: Right-click redsn0w, select compatibility> xp for sp2/sp3 and run as administrator checkbox. If you don't do this, redsn0w will hang on updating ram disk. Fix it, reboot phone, start over.

      If you have the latest ultrasn0w, are you already unlocked?
    1. toytbo88's Avatar
      toytbo88 -
      Quote Originally Posted by jjr3211 View Post
      I am courious dose mms work when you upgrade to 4.2.1 and update your baseband to 6.15.
      I had gotten mms to work on 3 different iPhones on older basebands with the same exact settings, how ever when I upraded my sisters 3G baseband and I put all the mms settings she was able to send a picture to me but she couldn't receive it it gave her a message about the mms being too large or a higher resolution but on my other 2 sisters 3G and 3GS they received them ... So I guess it partially works.