• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • ultrasn0w 1.2 Out - Unlocks "Stuck" iPhone 3G/3GS


    The DevTeam has released ultrasn0w 1.2 - with a clever feature for those of you who've had an iPhone 3G or 3G[S] with a baseband later than 05.13.04.

    It turns out that the very first iPad firmware 3.2.2 has baseband version 06.15.00 still vulnerable to AT+XAPP. The iPad baseband is built for the exact same baseband chip as the iPhone3G/3GS — they’re fully compatible!
    For many iPhone 3G and iPhone 3G[S] users, you've been stuck at baseband 05.14 or 05.15 and unable to unlock because there is no carrier unlock available for those basebands on those phones. The Dev Team found the iPad baseband is actually a *higher* version number, but it STILL VULNERABLE to the ultrasn0w unlock exploit, as well as being FULLY COMPATIBLE with the iPhone 3G and 3G[S].

    Meaning?

    If - AND ONLY IF - you've got either of those devices (3G/3G[S]) and NEED an unlock but can't because your baseband is 05.14 or 05.15... you can now upgrade your baseband to the iPad one (06.15) and use ultrasn0w to unlock. This should NOT be done unless you absolutely need to. Here's the full warning posted by the Dev Team as to why:

    WARNING — YOU DO THIS AT YOUR OWN RISK! PLEASE UNDERSTAND THE CONSEQUENCES OF UPDATING TO 06.15.
    • There is no way to come back down from 06.15, and there’s no hiding the baseband version from Apple. You’ll be voiding your warranty in a very obvious way.[/B]
    • If some future baseband comes out with a critical fix, you won’t be able to update to it if it remains down in the 05.xx sequence (then again, you wouldn’t update to it if you wanted to keep your unlock anyway).
    • Starting with FW 4.2.1 if you have 06.15 on your iPhone you won’t ever be able to restore to stock firmware (it will fail). You’ll need to only restore to custom IPSWs (then again, if you’re unlocker you should already be doing that).
    Certainly don’t update to 06.15 if you don’t need to! Only do this if you need the unlock and you’re stuck on 05.14 or 05.15, and you’re willing to assume the above risks.
    We'll have a full guide up asap, but they include basic instructions in their blog post detailing how to do so using redsn0w 0.9.6beta5 or Pwnage Tool 4.1.3 Unlock Edition.

    This does NOT unlock the iPhone 4 yet. The Dev Team gave this info:

    The i4 unlock is taking more effort though, and no further concrete info is available about that yet.
    There's a lot of info in that post, so read up, but basically - stuck 3G and 3G[S] users can finally breathe a sigh of relief.
    This article was originally published in forum thread: ultrasn0w 1.2 Out - Unlocks "Stuck" iPhone 3G/3GS started by Kyle Matthews View original post
    Comments 118 Comments
    1. C1KK's Avatar
      C1KK -
      This new unlock sounds real risky since you have to update your baseband all the way to 06.15.00.

      I'm still on 3.1.3 since I haven't found any good ios4 themes yet, I was hoping to be able to upgrade to 4.2.1 this weekend, since I'm starting to get bored and a lot of new apps I want require atleast 4.0

      So there's no way to upgrade while keeping your same baseband? I thought there was before?

      Just incase anyone can answer this, I'm on iPhone 3GS old bootrom w/ baseband 05.13.04
    1. chrodriguezmarydown's Avatar
      chrodriguezmarydown -
      You will need to update to a custom made firmware using a program such as pwnag tool or snowbreeze. Make sure to click the options hacktivate phone and to NOT update baseband to keep your unlock

      I recommend going to 4.1. Most 4.2/4.2.x jailbreaks are tethered as of now
    1. toytbo88's Avatar
      toytbo88 -
      Yup what the above poster said
    1. Rob2G's Avatar
      Rob2G -
      C1KK,
      From what I have gathered unlockers cant update to 4.2.1 without the iPad baseband. If you have shshs for 4.1 you can use pwnage to update to 4.1 with out upgrading the baseband.
    1. grumpytreto's Avatar
      grumpytreto -
      I saw in another post that there is no option to enter settings for mms on BB 6.15, and to be on firmware 4.2 you have to be on BB 6.15, is this correct?
    1. C1KK's Avatar
      C1KK -
      Well after reading the dev team blog I saw this:

      "If you have an old-bootrom 3GS and are already unlockable but want to get to 4.2.1, please wait til we release an “unofficial” bundle for you. Read no further."

      So for those in the same situation as me, it might be better wait a little while instead of having to upgrade your baseband to 06.15.00

      It might be good for this to be made more clear before everybody starts thinking they need to upgrade there baseband to be unlocked on 4.2.1
    1. ev_ol's Avatar
      ev_ol -
      I just upgraded my mothers 3G to 4.2.1 so I could use the 6.15 baseband and unlock. That all worked out great, but my question is wasn't 4.2 suppose to offer speed improvements to the 3G? It still seems incredibly slow.
    1. florevil's Avatar
      florevil -
      Guys i have an iphone 3G 4.1 and the unlock didn't work for me why ?
    1. d_animality's Avatar
      d_animality -
      Im still waiting for the most stable jb and unlocks..updating BB too risky for me..im stil on 3.1.3 3Gs new bootrom..my best bet is to see how others are doing with these jb n unlock so far..
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by florevil View Post
      Guys i have an iphone 3G 4.1 and the unlock didn't work for me why ?
      Did you update your baseband using this new method?
    1. tapansheth's Avatar
      tapansheth -
      yahoooo... thnx iphone dev team. I am back with my iphone 3gs but still stuck with iphone4 but thnx thnx thnx a lot my iphone 3gs is working now

      thank you very much all
    1. coolguy742's Avatar
      coolguy742 -
      pretty neat, it's kinda funny that this was here the entire time and no one noticed it!
    1. athleticswimmer's Avatar
      athleticswimmer -
      if only I had an iphone(4)....im still waiting for a clean untethered jailbreak for the ipad, no way im going tethered!! not in a million years.
    1. jjr3211's Avatar
      jjr3211 -
      I am courious dose mms work when you upgrade to 4.2.1 and update your baseband to 6.15.
    1. nyrajputz's Avatar
      nyrajputz -
      i have a iPhone 3G with 4.1 fw. Limerain jb. is this the safest way to unlock my phone?
    1. pritesh23's Avatar
      pritesh23 -
      I'm currently on an unlocked 3g with 4.0 FW and 5.13.04 BB. It looks like I don't need to do the 6.15 BB with the ipad FW. Can I just use the 4.2.1 3g FW and use redsn0w and then ultrasn0w?
    1. Rcooley617's Avatar
      Rcooley617 -
      wait I'm confused is 4.2.1 is out?...& do we even have an official jailbreak & unlock for 4.2?...Please guide me in the right direction, its been awhile
    1. pritesh23's Avatar
      pritesh23 -
      4.2 is 4.2.1 Same thing.
    1. firedog341's Avatar
      firedog341 -
      Quote Originally Posted by d_animality View Post
      Im still waiting for the most stable jb and unlocks..updating BB too risky for me..im stil on 3.1.3 3Gs new bootrom..my best bet is to see how others are doing with these jb n unlock so far..
      Looks like you are on Windows, just use Snowbreez to cook up a custom FW for 4.1. Won't update your BB, preserves your unlock and you get updated FW.

      Quote Originally Posted by nyrajputz View Post
      i have a iPhone 3G with 4.1 fw. Limerain jb. is this the safest way to unlock my phone?
      Might not be the "safest" but it's the only way right now because BB 5.14.02 & 5.15.04 aren't unlocked. They might be in the future, but for now, the upgrade is the only available unlock for those locked on those BB.

      Quote Originally Posted by pritesh23 View Post
      I'm currently on an unlocked 3g with 4.0 FW and 5.13.04 BB. It looks like I don't need to do the 6.15 BB with the ipad FW. Can I just use the 4.2.1 3g FW and use redsn0w and then ultrasn0w?
      No, redsnow only works on what FW is currently on your phone. In order to go to 4.2.1, you have to have 4.2.1 on your phone already. You need a custom FW to update to 4.2.1 and preserve your BB. Windows, snowbreeze = 4.1 & OSX, pwnage = 4.2.1 for now. There might be a pwnage for windows release to go up to 4.2.1
    1. nawarekko's Avatar
      nawarekko -
      now i am really confused !!
      i can't understand !!
      OMG /// ... dude i have iphone 3g on ios 3.1.2 but bb 05.14
      so what to do now step by step ?

      do i have to update the fmware to 4.2.1 ?
      or i can simply restore to 4.1 and jailbreak then unlock ?

      2nd question ?: how do i unlock it ? i tried the new ultrasn0w and it seems it's not working ! i dunno why ! i mean i tried it on my 3g ios 3.2.1 !
      so can u please clear the ideas for me ? thanks

      and can you please also add the links to direct download to the snowbreeze and ultrasn0w!? and what ever tool we may need ? thanks