• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • ultrasn0w 1.2 Out - Unlocks "Stuck" iPhone 3G/3GS


    The DevTeam has released ultrasn0w 1.2 - with a clever feature for those of you who've had an iPhone 3G or 3G[S] with a baseband later than 05.13.04.

    It turns out that the very first iPad firmware 3.2.2 has baseband version 06.15.00 still vulnerable to AT+XAPP. The iPad baseband is built for the exact same baseband chip as the iPhone3G/3GS — they’re fully compatible!
    For many iPhone 3G and iPhone 3G[S] users, you've been stuck at baseband 05.14 or 05.15 and unable to unlock because there is no carrier unlock available for those basebands on those phones. The Dev Team found the iPad baseband is actually a *higher* version number, but it STILL VULNERABLE to the ultrasn0w unlock exploit, as well as being FULLY COMPATIBLE with the iPhone 3G and 3G[S].

    Meaning?

    If - AND ONLY IF - you've got either of those devices (3G/3G[S]) and NEED an unlock but can't because your baseband is 05.14 or 05.15... you can now upgrade your baseband to the iPad one (06.15) and use ultrasn0w to unlock. This should NOT be done unless you absolutely need to. Here's the full warning posted by the Dev Team as to why:

    WARNING — YOU DO THIS AT YOUR OWN RISK! PLEASE UNDERSTAND THE CONSEQUENCES OF UPDATING TO 06.15.
    • There is no way to come back down from 06.15, and there’s no hiding the baseband version from Apple. You’ll be voiding your warranty in a very obvious way.[/B]
    • If some future baseband comes out with a critical fix, you won’t be able to update to it if it remains down in the 05.xx sequence (then again, you wouldn’t update to it if you wanted to keep your unlock anyway).
    • Starting with FW 4.2.1 if you have 06.15 on your iPhone you won’t ever be able to restore to stock firmware (it will fail). You’ll need to only restore to custom IPSWs (then again, if you’re unlocker you should already be doing that).
    Certainly don’t update to 06.15 if you don’t need to! Only do this if you need the unlock and you’re stuck on 05.14 or 05.15, and you’re willing to assume the above risks.
    We'll have a full guide up asap, but they include basic instructions in their blog post detailing how to do so using redsn0w 0.9.6beta5 or Pwnage Tool 4.1.3 Unlock Edition.

    This does NOT unlock the iPhone 4 yet. The Dev Team gave this info:

    The i4 unlock is taking more effort though, and no further concrete info is available about that yet.
    There's a lot of info in that post, so read up, but basically - stuck 3G and 3G[S] users can finally breathe a sigh of relief.
    This article was originally published in forum thread: ultrasn0w 1.2 Out - Unlocks "Stuck" iPhone 3G/3GS started by Kyle Matthews View original post
    Comments 118 Comments
    1. Pops29's Avatar
      Pops29 -
      Hi I have a iphone 3GS I download redsnow and try to unlock it as per Iclarified tutorials, but since get stucked in the apple logo I tried to do it with Ipad Baseband option in Redsnow and the same (still in the apple logo when finishes), now I tried to restore it with 4.2.1 and I have a error 105 so now I cant either restore, what I should do? do I need to download the ipad 3.2.2 and restore it with this?

      Please help.

      Tks
    1. vindutch's Avatar
      vindutch -
      Quote Originally Posted by Pops29 View Post
      Hi I have a iphone 3GS I download redsnow and try to unlock it as per Iclarified tutorials, but since get stucked in the apple logo I tried to do it with Ipad Baseband option in Redsnow and the same (still in the apple logo when finishes), now I tried to restore it with 4.2.1 and I have a error 105 so now I cant either restore, what I should do? do I need to download the ipad 3.2.2 and restore it with this?

      Please help.

      Tks
      Did you try tiny umbrella to kick it out of recovery? I try everything when my phone gets stuck. I ran limera1n once just to get it in recovery and used tiny umbrella to kick it out just to get my phone back to normal. But don' t quote me on this. Desperate times call for desperate measures!
    1. locobans's Avatar
      locobans -
      Quote Originally Posted by vindutch View Post
      Did you try tiny umbrella to kick it out of recovery? I try everything when my phone gets stuck. I ran limera1n once just to get it in recovery and used tiny umbrella to kick it out just to get my phone back to normal. But don' t quote me on this. Desperate times call for desperate measures!
      Sounds like me
    1. Pops29's Avatar
      Pops29 -
      I did it again and now is working, but I dont have the cydia and try to do it in limera and ultrasnow and cant install cydia and my phone is still locked. The other things happening is now I have version 4.1 with baseband (modem firmware) 06.15.00, what should I do?
    1. locobans's Avatar
      locobans -
      Quote Originally Posted by Pops29 View Post
      I did it again and now is working, but I dont have the cydia and try to do it in limera and ultrasnow and cant install cydia and my phone is still locked. The other things happening is now I have version 4.1 with baseband (modem firmware) 06.15.00, what should I do?
      Try running redsnow again and pick option "Insall Cydia"
    1. rreynoso7's Avatar
      rreynoso7 -
      I have a 3gs with 4.1 and i just upgrade the baseband from 6.04 to 6.15 so i could unlock my phone installing ultrasnow.

      So it worked, but only for a minute or two, when i turn it on i get a signal but it desapears after some minutes and i get no service.

      Does anyone knows why?

      Thanks for your help
    1. Stray's Avatar
      Stray -
      I did it and it worked!!!!!!!!!!! Hahahahaha
    1. romeo_herman's Avatar
      romeo_herman -
      Quote Originally Posted by rreynoso7 View Post
      I have a 3gs with 4.1 and i just upgrade the baseband from 6.04 to 6.15 so i could unlock my phone installing ultrasnow.

      So it worked, but only for a minute or two, when i turn it on i get a signal but it desapears after some minutes and i get no service.

      Does anyone knows why?

      Thanks for your help
      Please go out side and find signal...
    1. Stray's Avatar
      Stray -
      Quote Originally Posted by romeo_herman View Post
      Please go out side and find signal...
      I lol'ed at this reply
    1. babes's Avatar
      babes -
      I am soo excited I unlocked my 3gs on 4.1 firmware 5.14.02 It is now on tmobile!!!!Thanks DEV team
    1. toytbo88's Avatar
      toytbo88 -
      Quote Originally Posted by babes View Post
      I am soo excited I unlocked my 3gs on 4.1 firmware 5.14.02 It is now on tmobile!!!!Thanks DEV team
      There's no way you could of unlocked 5.14.02 as it's not supported .... You sure you didn't update the baseband ???
    1. sotexcustomz's Avatar
      sotexcustomz -
      Quote Originally Posted by toytbo88 View Post
      There's no way you could of unlocked 5.14.02 as it's not supported .... You sure you didn't update the baseband ???
      anyone try ultrasn0w 1.2 on 5.14 bb yet?
    1. rreynoso7's Avatar
      rreynoso7 -
      Quote Originally Posted by romeo_herman View Post
      Please go out side and find signal...:
      Why are you wasting my time, if you dont have anything helpful please dont answer.
      I have another iphone and i have perfect reception
    1. Poseidon79's Avatar
      Poseidon79 -
      Quote Originally Posted by rreynoso7 View Post
      Why are you wasting my time, if you dont have anything helpful please dont answer.
      I have another iphone and i have perfect reception
      Try turning off 3G.. Try doing a reset network settings.


      Sent from my iPhone using ModMyi
    1. toytbo88's Avatar
      toytbo88 -
      Quote Originally Posted by sotexcustomz View Post
      anyone try ultrasn0w 1.2 on 5.14 bb yet?
      I tried and it didn't work I had to upgrade the baseband, no choice.
    1. Deviatorz's Avatar
      Deviatorz -
      I don't know much about programming but here's what I am wondering. If the ipad 6.15.00 baseband has the same exploit found in the 5.14.02 and the 3GS one as well, why don't they just include it in ultrasn0w? I mean if the exploit is essentially the same, it shouldn't take them long to make an unlock for the 3G/3GS baseband with the same exploit all included in ultrasn0w? Just my theory.
    1. towut2000's Avatar
      towut2000 -
      Does this mean that my iPhone will have a PERMANENT THETHERED JAILBREAK? Instead of having an untethered one which really bother me a lot as if my iPhone runs out of battery or restarting it, I will need to connect to the computer to re-jailbreak again?
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by Deviatorz View Post
      I don't know much about programming but here's what I am wondering. If the ipad 6.15.00 baseband has the same exploit found in the 5.14.02 and the 3GS one as well, why don't they just include it in ultrasn0w? I mean if the exploit is essentially the same, it shouldn't take them long to make an unlock for the 3G/3GS baseband with the same exploit all included in ultrasn0w? Just my theory.
      The exploit is not in 5.14.02. That is why you have to update the baseband to the iPad one.

      Quote Originally Posted by towut2000 View Post
      Does this mean that my iPhone will have a PERMANENT THETHERED JAILBREAK? Instead of having an untethered one which really bother me a lot as if my iPhone runs out of battery or restarting it, I will need to connect to the computer to re-jailbreak again?
      The dev team is working on making it untethered now.
    1. babes's Avatar
      babes -
      Yes I did update the baseband. I am just excited it worked!
    1. nacatus51's Avatar
      nacatus51 -
      So let me get this straight.. I'm using iphone 3G iOs 4.1 with baseband 05.14.02. Does this mean that i have to upgrade to 06.15 in order to unlock my iphone?