• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • MyWi Released! Turn your iPhone into a Wifi hotspot!



    Create a WiFi HotSpot with a press of a finger! Wherever you are - you can connect your laptop or other mobile device to your iPhone easily!

    Features:
    - Create WiFi Hotspot to connect mutiple laptops or mobile devices to share your iPhone's internet connection
    - 40 bit and 104 bit WEP Security to prevent others from accessing your WiFi HotSpot
    - Ability to enable USB and Bluetooth Tethering on your iPhone as well
    - Broadcasts the Network Name (SSID) - no need to fuss with creating an adhoc network on your laptop
    - Uses less battery and much faster then PdaNet due to native routing
    - Shows up and down bandwith usage


    NOTE: MyWi does not support the iPhone 2G. Please see your carrier contract for eligibility and/or additional fees.
    I played around with this all afternoon, and it seems to work great. A nice addition to this app is that you don't have to have tethering enabled from a custom ipcc either, you can enable tethering from MyWi. I had three laptops connected to my phone earlier this afternoon and they all were able to cruise the net quite nicely. MyWi sells for $9.99 and is a great application to have on your iPhone. There is a free 10 day trial available also


    cash edit: you can get it via rockyourphone



    Enjoy!
    This article was originally published in forum thread: MyWi Released! Turn your iPhone into a Wifi hotspot! started by StealthBravo View original post
    Comments 447 Comments
    1. MikePA's Avatar
      MikePA -
      r u using WEP?
    1. chakraj's Avatar
      chakraj -
      Guys I think it would help everybody concerned if when you say it works or does not you include, your firmware, your phone model, your jailbreak method. Thanks
    1. dserensits's Avatar
      dserensits -
      I installed mywi and it will not connect to the internet. I had previously used the internet tethering hack. Does anyone have mywi working who had previously installed the tethering hack. Can I remove the tethering hack short of doing a complete restore? Thanks for any help
    1. sbd's Avatar
      sbd -
      Quote Originally Posted by fabi121 View Post
      Hello,
      im on version 0.94.5.
      I can surf the internet for about a minute.
      then the connection breaks up and my iphone goes into the safe mode!I also reinstalled rockapp an mywi.

      programms that coud interfere with myfi:
      sbsettings
      winterboard

      Does anybody know what i should do?
      Has SBSettings been fixed since it had major issues not too long ago? It messed up quite a few users phones to the point of re-installing the iphone os. I know when I had sbsettings installed, I did get the safemode thing quite a bit.
    1. reanimationxp's Avatar
      reanimationxp -
      Quote Originally Posted by kraziebone View Post
      Can anyone tell me how and why this application keeps booting me into safe mode? I love the application but after a few minutes it will give me the "safe mode" screen.
      Happens to me too.
      16GB iPhone 3G, JB with PwnageTool 3.0 fw.
      Running SBSettings, Winterboard, 5-column SB and 5-icon Dock

      No problems with Springboard at all prior to using MyWi.

      Quote Originally Posted by sbd View Post
      Has SBSettings been fixed since it had major issues not too long ago? It messed up quite a few users phones to the point of re-installing the iphone os. I know when I had sbsettings installed, I did get the safemode thing quite a bit.
      SBSettings has been updated upwards of 4 times since the 3.0 release, and before using MyWi, has been extremely stable for me and hasn't crashed the phone once, even while I've been using Winterboard and other modifications like 5-column and 5-icon SB. I think this is definitely MyWi.
    1. skeels's Avatar
      skeels -
      Anyone having disconnect issues or not being able to turn on MyWi: Please send your syslog in an email to Rock Your Phone - Support ( ahht rockyourphone.com). We'll be able to identify and resolve your issue very quickly.

      How to get a syslog easily: Using the Rock Your Phone Desktop client and your iPhone attached via USB - Right/alt click on your phone - and choose View iPhone System log. Then turn on MyWi - wait for an issue to occur, and copy and paste the log into an email.
    1. s4mb4's Avatar
      s4mb4 -
      my Palm Pre already does this for free ;-)
      i still love my iPhone though.
    1. Mista Brothason's Avatar
      Mista Brothason -
      @psuskeels

      Could you tell us PSP and DS users why it's not compatible with those devices yet?
    1. an0nym0u5's Avatar
      an0nym0u5 -
      Quote Originally Posted by StealthBravo View Post
      Sweet, now to load this on a bunch of iphones and sell wifi hotspot passes around town

      lmao
      You do know that in the US companies would actually do that and people would actually pay, right?
    1. skeels's Avatar
      skeels -
      Mista: This creates an adhoc network (IBSS/infrastructure). Maybe you can google and see if there's anyway to get the PSP/DS to connect to that kind of device (others have said no - but who knows - maybe's theres a hack for that)
    1. GrayDog's Avatar
      GrayDog -
      There has just been another update released, .95.1, and no offense to the developer as it seems he is trying to fix the issues, but it is still not working properly. With the previous update, I was able to get a device connected, even though it only lasted a minute, but with the latest I am back to square one and cannot connect any device at all (have tried 3 different laptops).
      3G 3.0 redsn0w.
    1. TheOrioles33's Avatar
      TheOrioles33 -
      Quote Originally Posted by s4mb4 View Post
      my Palm Pre already does this for free ;-)
      i still love my iPhone though.
      The Pre can turn itself into a wireless access point or do you mean just tether?
    1. GrayDog's Avatar
      GrayDog -
      It seems after removing any wireless networks in range of my phone (Forget Network) and then powering off my phone, the app is now working. I have been online for approximately 4 minutes now. Hopefully it lasts...

      15 minutes and still going strong...

      Still going, I even put the phone in my pocket, went a few offices away for about 30 minutes, came back and it is still connected. Well Done.
    1. msgeek's Avatar
      msgeek -
      Quote Originally Posted by €hR!$ View Post
      Same. But at least you get 700kbps. I get to 4 and it stops.

      Already deleted the app. Would be cool to have a wi-fi hotspot, but I guess I'll live with just USB tethering.
      The new MyWi update fixed the issue, I have been on, using wifi and USB for over 45 minutes on my tMobile iphone 8-D.
      This is great!
    1. RareProjectz's Avatar
      RareProjectz -
      [QUOTE=GrayDog;4805971]It seems after removing any wireless networks in range of my phone (Forget Network) and then powering off my phone, the app is now working. I have been online for approximately 4 minutes now. Hopefully it lasts...

      Still having problems, how did you do the forget network thing, please help!
    1. iphoneuser2008's Avatar
      iphoneuser2008 -
      POSSIBLE FIX FOR ALL 3GS USERS - TRY AT YOU OWN RISK. (it worked 100% for me)

      PHONE MODEL: I own a iPhone 3GS, jailbroken with Redsn0w 0.8. I only selected Cydia when I jailbroke my phone using Redsn0w. I DID NOT install ICY. (Just FYI)

      BACKGROUND: Hello, I was having all the problems everyone has been listing on this thread. ie: MyWi cuts off after a minute or so , just not working consistently, not showing tethering blue mode, etc.

      WHAT I WAS TRYING TO DO TO FIX IT, BUT STILL FAILED TO CORRECT IT: I was deleting and reinstalling the two Rock programs apps via Cydia a few times, along with the MyWi app. I believe that these deletions and reinstallations caused a hidden corruption / error to remain on my iPhone 3GS. So when I would reinstalled the two Rock programs and the MyWi again, the apps would appear to install correctly, but would just not work correctly. (ie: same connection problems etc.) Again, I believe this was due to me uninstalling and reinstalling them via Cydia, which I did a few times. So I believe it caused a corruption to remain somehow, thus preventing all subsequent installs to also not work. (my opinion)

      MY FINAL SOLUTION THAT WORKED 100%: I did a complete backup of my iphone 3GS, then I did a complete fresh restore and rejailbreak. For my backup process I used the latest itunes & the latest Aptbackup. The Aptbackup program restored all my Cydia apps, as well as installing fresh copies of the two "Rock Your Phone" programs on my iPhone. I then opened the Rock program and it prompted me to upgrade the two rock programs, I had on my phone, to the latest versions. I did this upgrade first. Then within the Rock iPhone app, I installed the MyWi application. So MyWi was now freshly installed on my newly restored and jailbroken 3GS phone.

      I then made sure BOTH my 3G data was turned on and my Wi-fi was ALSO turned on first. Then I turned on the MyWi program by pressing the turn on blue button. The Mywi app then began to load, BUT this time the app WORKED 100%, like it should have originally. I experienced no issues. I ran some more test runs by turning off the MyWi app then opening other Cydia apps, respringing, then going back into the mywi app and turning it on again. It still continued to work flawlessly 100%.

      WHAT YOU SHOULD BE SEEING EACH TIME YOU TURN ON THE MyWi APP, TO KNOW IF IT IS WORKING CORRECTLY: Remember to have 3G and Wi-fi BOTH turned on. When I pressed the MyWi "turn on" blue button, it would load and show the spinning loading wheel rotating. It may take "up to" 60 seconds to connect so just let it keep loading and don't mess with it at all. Once loaded, I then ALWAYS got the blue colored “tethering on” at the top of the iphone screen. It also showed the upload and download megabytes parts on the screen as well. The data megabytes section WILL show as increasing as you use the program online. So this is what you should see each and every time to know if it is correctly working. If you turn on the MyWi app and the blue colored "tethering on" does not come on at the top of your iphone screen, then the app is not working correctly. Even if the MyWi blue turn on switch is showing as "on", but you are NOT ALSO seeing the blue colored "tethering on" at the top of your screen, then the app is NOT working correctly. This is how you will know if the program is working correctly right from the beginning.

      SOME FINAL THOUGHTS: The decision to do a wholesale restore of my iphone was no small consideration. I view a total restore as a time consuming process and a last option that I dread. But my decision was based on the fact that the potential benefits of getting this program to work correctly was to great to let a full restore deter me. I took a leap of faith and it worked for me. I am saying this cause I am not trying to convince you to do this, this is just what worked for me. If you install this app on a freshly restored and jailbroken phone, it seems to resolve all the issues. Take it for what its worth.

      So now I have my 2nd Generation iPod Touch and my laptop all connected to my 3GS's Wifi hotspot via MyWi. Freakin Awesome!!!!!

      If you should decide to try out this method,,please let me know how it worked for you!!
    1. Channan's Avatar
      Channan -
      I tried connecting my friend's iPhone to mine and it finally worked! Only did it for about a minute though, but that's better than it used to work. It was still working when I disconnected it so I guess it's working now.

      I'll definitely buy this app when the trial period is up.
    1. blazingangel1986's Avatar
      blazingangel1986 -
      now this is definitely really col
    1. wipeoutxxl's Avatar
      wipeoutxxl -
      Per your instructions: WHAT YOU SHOULD BE SEEING EACH TIME YOU TURN ON THE MyWi APP, TO KNOW IF IT IS WORKING CORRECTLY: Remember to have 3G and Wi-fi BOTH turned on. When I pressed the MyWi "turn on" blue button, it would load and show the spinning loading wheel rotating. It may take "up to" 60 seconds to connect so just let it keep loading and don't mess with it at all. Once loaded, I then ALWAYS got the blue colored “tethering on” at the top of the iphone screen. It also showed the upload and download megabytes parts on the screen as well. The data megabytes section WILL show as increasing as you use the program online. So this is what you should see each and every time to know if it is correctly working. If you turn on the MyWi app and the blue colored "tethering on" does not come on at the top of your iphone screen, then the app is not working correctly. Even if the MyWi blue turn on switch is showing as "on", but you are NOT ALSO seeing the blue colored "tethering on" at the top of your screen, then the app is NOT working correctly. This is how you will know if the program is working correctly right from the beginning.~~~

      I just installed this on my 3GS and it's not working - When I hit Wi-Fi tethering the "spinning wheel" is turned on the whole time and does not connect to anything. Do you have any additional documentation on how this works or step by step instructions on how to get it to work? Thanks!
    1. Channan's Avatar
      Channan -
      Quote Originally Posted by €hR!$ View Post
      I tried connecting my friend's iPhone to mine and it finally worked! Only did it for about a minute though, but that's better than it used to work. It was still working when I disconnected it so I guess it's working now.

      I'll definitely buy this app when the trial period is up.
      Update: Yep. Works perfect now! Used the connection on two computers and two different iPhones with it.