• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Report: iOS 5 Will Be Incompatible with iPhone 3GS



    The editorial chief at a credible and popular Russian mobile phone blog is getting a lot of attention today for a telling revelation he made via Twitter. The announcement has since taken the tech blogosphere by storm, despite the lack of confirmation from Apple that the information presented is correct.

    Mobile-Review's editor-in-chief Eldar Murtazin turned to Twitter to share that which he learned from his sources in the know: "Just one comment. Apple iPhone 3Gs wont be upgradable to iOS 5.x. iPhone 4 will."

    If correct, the forthcoming iOS 5 - which may be unveiled as soon as June 6th when WWDC gets underway - will not be compatible with the second-to last iPhone model, the iPhone 3GS. Given that millions of these particular models are still in use around the world, this information - if accurate - could come as a devastating bit of news.

    To be sure, Murtazin is far from an Apple-related gossip king. But he generally gets his information from reliable sources familiar with the broader mobile phone industry. And while all reports must be taken with a grain of salt until confirmed by Apple, it's easy to see how Murtazin's report may be correct. Given the supposedly elaborate nature of the next major iOS upgrade, the iPhone 3GS and all earlier models will likely be incapable of powering such a powerful new operating system.

    Source: Mobile-Review, Twitter
    This article was originally published in forum thread: Report: iOS 5 Will Be Incompatible with iPhone 3GS started by Michael Essany View original post
    Comments 68 Comments
    1. Petrit H's Avatar
      Petrit H -
      Apple sucks, get an old nokia 3310 and enjoy nokia tune
    1. Taranis17's Avatar
      Taranis17 -
      Now there's a shocker.

      Apple's IOS is slowly turning into bloatware. 4.3.x slowed my iPhone 4 down to unacceptable levels, introducing hitching in the animations for the first time since I got the phone the day it was released. 4.3.1, 4.3.2 and 4.3.3 all did it, jailbroken or not. Three times now I've upgraded to the latest firmware, only to be disappointed and move back to 4.2.1. Looks like that's the sweet spot for OIS on the iPhone 4 - at least for me. I won't give up performance for features in IOS, and I'm sure as hell not plunking down another $200-$600 on a new phone so I can have the horsepower to run their bloated crap. What is so hard about adding features to IOS while keeping performance at or better-than previous IOS levels? You know the iPhone 4 will run it, IF it's coded right.
    1. Eagleye's Avatar
      Eagleye -
      That is devastating news... guess I'll have to play their game and get the "iPhone 4S," "iPhone 5," "Magic iPhone," or whatever they choose to call it when it comes out. Really hope it is a re-design and not just a super iPhone 4.
    1. tomybomby's Avatar
      tomybomby -
      This sucks for 3gs owners who cares (lol) but this makes perfect business sense. Besides, there are far too many fanboys anyway, so I'm sure they'd either upgrade to the iphone4 now or wait for the iphone 4s/5 either way.
    1. unison999's Avatar
      unison999 -
      Quote Originally Posted by Taranis17 View Post
      Now there's a shocker.

      Apple's IOS is slowly turning into bloatware. 4.3.x slowed my iPhone 4 down to unacceptable levels, introducing hitching in the animations for the first time since I got the phone the day it was released. 4.3.1, 4.3.2 and 4.3.3 all did it, jailbroken or not. Three times now I've upgraded to the latest firmware, only to be disappointed and move back to 4.2.1. Looks like that's the sweet spot for OIS on the iPhone 4 - at least for me. I won't give up performance for features in IOS, and I'm sure as hell not plunking down another $200-$600 on a new phone so I can have the horsepower to run their bloated crap. What is so hard about adding features to IOS while keeping performance at or better-than previous IOS levels? You know the iPhone 4 will run it, IF it's coded right.
      It has always been Apple's practice to introduce iOS that would tax the current version so people will want to get the new one when it comes out, yet we do not know or use any of the "improvements" for all I know it just installed "lagging program". If that does not get you to change to new phone, 2 years later after introduction they stop support for the hardware to make you upgrade. I am getting sick of Apple taking a portion of my income every freaking year, so my next phone would not be made by Apple or any other smart phone actually. Just an ordinary phone where I do not waste money on data service, no need for a fancy phone when it spends most of its life in my pocket.
    1. kraziebone's Avatar
      kraziebone -
      Quote Originally Posted by exNavy View Post
      Makes perfect business sense to me. You don't make money when you continue to provide new firmware to old iphones.
      That's not true. If I know that a business is likely to abandon a product after a short period of time, I am very unlikely to purchase products from that vendor. It is in Apples interest to keep their products supported for as long as possible. The iPhone 3GS is currently still on sale. In my opinion it's not in Apples best interest to abandon a product after only weeks of selling it, even if it does boost revenue in the temporarily.
    1. feidhlim1986's Avatar
      feidhlim1986 -
      Typical Apple. And they'll continue to sell the 3GS right up until the day iOS 5 hits. I wouldn't be half as annoyed if they just stopped selling the 3GS ~6 months before iOS5 hits.

      God forbid they optimize iOS. Instead they'll just bloat it up and require the fastest iPhones to run it.

      I'm waiting for the day that new versions of OS X will only run on the latest Macs.

      Absolutely HATE the new look of MMi
    1. ZapersOnline's Avatar
      ZapersOnline -
      Quote Originally Posted by confucious View Post
      Based on that theory you are presumably still running MS Dos?
      Hahaha nice 1 :P and im new to this modmyi forum