• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Report: iOS 5 Will Be Incompatible with iPhone 3GS



    The editorial chief at a credible and popular Russian mobile phone blog is getting a lot of attention today for a telling revelation he made via Twitter. The announcement has since taken the tech blogosphere by storm, despite the lack of confirmation from Apple that the information presented is correct.

    Mobile-Review's editor-in-chief Eldar Murtazin turned to Twitter to share that which he learned from his sources in the know: "Just one comment. Apple iPhone 3Gs wont be upgradable to iOS 5.x. iPhone 4 will."

    If correct, the forthcoming iOS 5 - which may be unveiled as soon as June 6th when WWDC gets underway - will not be compatible with the second-to last iPhone model, the iPhone 3GS. Given that millions of these particular models are still in use around the world, this information - if accurate - could come as a devastating bit of news.

    To be sure, Murtazin is far from an Apple-related gossip king. But he generally gets his information from reliable sources familiar with the broader mobile phone industry. And while all reports must be taken with a grain of salt until confirmed by Apple, it's easy to see how Murtazin's report may be correct. Given the supposedly elaborate nature of the next major iOS upgrade, the iPhone 3GS and all earlier models will likely be incapable of powering such a powerful new operating system.

    Source: Mobile-Review, Twitter
    This article was originally published in forum thread: Report: iOS 5 Will Be Incompatible with iPhone 3GS started by Michael Essany View original post
    Comments 68 Comments
    1. Cowboy's Avatar
      Cowboy -
      Quote Originally Posted by ODB25 View Post
      Where's the mobile app to this site I miss it.
      Wrong thread bud
      Stay on topic
    1. Wesss's Avatar
      Wesss -
      The 3GS has the same amount of RAM the ipt4g has, so that woudn't be a problem.
    1. waroftyr's Avatar
      waroftyr -
      I dont see this being true for a few reasons, the first being that the obvious that the 3gs still is very well capable of handling more than what they give it already, this is obvious if you have jailbroken and opened up some of the features only in the 4 right now. The second is that the 3gs is still being sold currently right now, and as far as we know right now will continue to be until the 5/4s comes out, the fact is once they made the 2g obsolete it was past the last date that a warranty could have been on a 2g. if they sell the 3gs they will at least continue to support it for another year past the last day they sold it. i think them cutting off the 3g was a fluke because we all know how brutal it was to try to use a 3g after 4.0 and no matter how hard they tried just couldnt get it to run correctly. its not like they didnt try though. in the end continuing to support the 3g till 4.2.1 was a pr nightmare in itself.

      to sell someone a 3gs and then a month or so later say that you arent going to support it anymore would be another huge pr nightmare for them. think about as soon as you buy a phone having to go through all your apps start becoming incompatible...apple would loose too much money over that.

      everyone keep in mind this is an article based purely on speculation, so asking if your ipod will still be supported or anything like that is not worth asking till facts actually come out.
    1. Orby's Avatar
      Orby -
      Quote Originally Posted by waroftyr View Post
      I dont see this being true for a few reasons, the first being that the obvious that the 3gs still is very well capable of handling more than what they give it already, this is obvious if you have jailbroken and opened up some of the features only in the 4 right now. The second is that the 3gs is still being sold currently right now, and as far as we know right now will continue to be until the 5/4s comes out, the fact is once they made the 2g obsolete it was past the last date that a warranty could have been on a 2g. if they sell the 3gs they will at least continue to support it for another year past the last day they sold it. i think them cutting off the 3g was a fluke because we all know how brutal it was to try to use a 3g after 4.0 and no matter how hard they tried just couldnt get it to run correctly. its not like they didnt try though. in the end continuing to support the 3g till 4.2.1 was a pr nightmare in itself.

      to sell someone a 3gs and then a month or so later say that you arent going to support it anymore would be another huge pr nightmare for them. think about as soon as you buy a phone having to go through all your apps start becoming incompatible...apple would loose too much money over that.

      everyone keep in mind this is an article based purely on speculation, so asking if your ipod will still be supported or anything like that is not worth asking till facts actually come out.
      If Apple doesn't support the S5L8920-22 (iPhone 3GS/iPT3G) in iOS 5... it'll be an ugly PR move, but it does make some sense from a developer's standpoint.

      Assuming all apps supported on a particular OS have to support all devices on that firmware, there would be three levels of screen resolution (320x480, 640x960, 1024x768), four application processors (likely not as significant an issue), three GPUs, etc.

      If they go S5L8930 and newer only, suddenly, there's only two screen resolutions (Retina and iPad), two very powerful GPUs, dual-cameras (except the iPad 1), accelerometers, gyroscopes, magnetometers (in all except the Wi-Fi iPads)...

      It'd make developer's lives much easier, allow for much more powerful-feature type apps, and of course, it'd be insane to ignore the "planned obsolescence" factor, especially when dealing with a hardware-centric company like Apple.

      PS: By this time last year, we were already on iOS 4.0b3 or b4 for a June 21st release (Gold Master came out shortly after WWDC). WWDC starts in two weeks from yesterday; and there's no developer beta testing going on for new firmware (that I'm aware of). We may not get a new major release in the early summer this year.
    1. waroftyr's Avatar
      waroftyr -
      Quote Originally Posted by orbyorb View Post
      If Apple doesn't support the S5L8920-22 (iPhone 3GS/iPT3G) in iOS 5... it'll be an ugly PR move, but it does make some sense from a developer's standpoint.

      Assuming all apps supported on a particular OS have to support all devices on that firmware, there would be three levels of screen resolution (320x480, 640x960, 1024x768), four application processors (likely not as significant an issue), three GPUs, etc.

      If they go S5L8930 and newer only, suddenly, there's only two screen resolutions (Retina and iPad), two very powerful GPUs, dual-cameras (except the iPad 1), accelerometers, gyroscopes, magnetometers (in all except the Wi-Fi iPads)...

      It'd make developer's lives much easier, allow for much more powerful-feature type apps, and of course, it'd be insane to ignore the "planned obsolescence" factor, especially when dealing with a hardware-centric company like Apple.

      PS: By this time last year, we were already on iOS 4.0b3 or b4 for a June 21st release (Gold Master came out shortly after WWDC). WWDC starts in two weeks from yesterday; and there's no developer beta testing going on for new firmware (that I'm aware of). We may not get a new major release in the early summer this year.
      make a good point there. but in that same respect they are already making apps in three resolutions currently. through this entire time they have had apps that werent very backwards compatible to other phones (i remember when i first bought my 3gs and could use the compass in the yelp app and no one else could). so its not like its an unheard of practice with os updates. and from apples perspective lets say you got that yelp app on the 3gs when it first came out, and you watched your friends use the compass but you couldnt, it would make you want to update more instead of using the dumb downed version.

      your right though for a few reasons, in the long run it helps apple push developers to make apps that take advantage of the hardware.

      i have to agree with you on the 5.0 betas though, this time the last two years i was running a very unstable phone lol. its interesting to see that they havent released anything yet, makes that september date seem more realistic. on the other hand we might finally see something big they wanted to hide till wwdc is the reason why. (mostly my hopes being high on that one, crossing my fingers for a complete overhaul of the ui)
    1. Stray's Avatar
      Stray -
      I LOVE how they still continue to sell the 3gs and people who buy it will be left with iOS 4
    1. alexevo's Avatar
      alexevo -
      I don't think many of you are considering that they don't have to provide firmware updates to be able to honor warranty issues. I.e. they will always have a supply of refurbished 3GS phones to swap out in the case of a warranty issue and they will all probably have 4.3.2 or 4.3.3 and nothing higher. They could technically be able to honor the warranty on a 3GS 3 or 4 years after it came out. It has been out 2 years so far and they will likely discontinue it when the iP54S comes out so they really only have until September 2012 that they'll need to honor warranty issues through of which they have plenty of phones to swap out. After that, which I'm sure some of you might not have known, the rest of the stock gets wholesaled and they end up on eBay and Craigslist as "Brand new in box 3GS!" listings. They have professionals that figure out all of this stuff so believe me, if they say they are not going to support the 3GS or below as far as iOS5 then they won't have to because your equipment will not need the iOS5 update to fix anything since they'll just swap it out for a new phone for you.

      Also to those of you that claim there will be this PR nightmare. what PR nightmare are you referring to? the one where Apple says, "due to the problems experienced with certain users installing firmware 4.0 on their 3G that caused performance to deteriorate we will only be releasing iOS5 for the devices that will not negatively impact performance by installing it." At that point they will become the responsible people that didn't force an update on unsuspecting customers only to cripple their phones.
    1. Orby's Avatar
      Orby -
      Quote Originally Posted by alexevo View Post
      Also to those of you that claim there will be this PR nightmare. what PR nightmare are you referring to? the one where Apple says, "due to the problems experienced with certain users installing firmware 4.0 on their 3G that caused performance to deteriorate we will only be releasing iOS5 for the devices that will not negatively impact performance by installing it." At that point they will become the responsible people that didn't force an update on unsuspecting customers only to cripple their phones.
      No argument on warranty coverage, but in regards to not forcing firmware upgrades, Apple already does that on all their current iOS devices--my friend, the SHSH system, would like to introduce itself.

      Though, from Apple's perspective, what would be the worse situation to deal with: angry customers who just bought a new 3GS (as in last week new) and are (hypothetically) now being outright told they can't use the new features, or half-baking iOS 5 for the 3GS vis--vis the 3G and iOS 4? The only way they don't cause some frustration in my opinion is to make a solid iOS 5 for the 3GS... but that'd be the most immediately expensive and least long-term profitable solution (not to mention likely the most difficult).
    1. KBI2113's Avatar
      KBI2113 -
      Quote Originally Posted by kingbijan View Post
      2.
      i wouldn't "Thanks" this post, just like all of your recent posts, Michael. Your posts have been from desperation not a good story. You jump on whatever you can even if it's as HORRIBLE and PROBABLY UNTRUE as this.
      If ANYTHING the 3G will be incompatible.
      Please, I'm not one to hate just PLEASE stop posting useless ish.
      Just..... Stop.

      I'm still running on 4.2.1 and my phone is doing just fine. Although I've been wanting to upgrade it, just need time to do it. If it's true, it's true. If not.... well... it's not.
    1. alukado's Avatar
      alukado -
      Looking forward the update of ios 5. More priorities.....
    1. Jurrassikk's Avatar
      Jurrassikk -
      ummmm duh.... from this point the will be dropping the oldest with each successive iOS update, well, according to their track record. Don't be surprised if/when the 4 is dropped for iOS 6.
    1. iYeow's Avatar
      iYeow -
      Quote Originally Posted by whereswaldo View Post
      We can't say we didn't see this coming. I guess it will be incompatible with iPT3 also
      I would think so too
    1. thetoothfairy's Avatar
      thetoothfairy -
      Update or not... I am tired of waiting to see if we are going to get a new iPhone or not.... I wouldn't have the 3Gs if Apple would have had the white iPhone 4 when it was supposed to be released!
    1. NakedFaerie's Avatar
      NakedFaerie -
      Wow, they just killed off the 3G with 4.3 firmware and it looks like they are about to kill off the 3GS with 5 firmware.

      Looks like they don't want to be that popular anymore if they keep in killing off their previous models.
      So, if I got a HTC instead of my iPhone 2G it'll still be supported but the iPhones next 2 models after that have already been discontinued?

      Not the right way to do business crApple...


      About ModMyI v3
      I'm using OPERA browser and the button to submit has no label (no name), just a little blue button. I guessed it was the submit button so I clicked it and it worked.

      Also the "Thanks" button is huge. It's about 3 times the size of the "Quote" button next to it.
      And, there is no "Thanks" button for the original first post.
      And when you do click the "Thanks" button it does nothing but changes into a select. The cursor turns up in the box and the word "Thanks" disappear.

      And when you do post it goes back to the first page, not to your post like it use to.

      Good news, when you edit a post all the buttons are right. correct size with labels.
    1. javiert30's Avatar
      javiert30 -
      It's getting closer to us iPhone 4 users, when iPhone 6 or whatever is going to bee released after the next one, they are going to forget about us too.
    1. ShredNasty's Avatar
      ShredNasty -
      Whah. Whaaaaah. Apple won't keep supporting my 2+ year old phone! Apple should hold back all innovation until I can afford to get it. Whahhhh. In other news, I'm pretty pissed my VCR won't play Blurays. Greedy Sony. Always after muh cash.....
    1. confucious's Avatar
      confucious -
      Are people surprised at this?

      I would have been far more surprised if it had been. My son's 3Gs should turn up today - now I just have to sell his iPod touch and HTC to pay for it....
    1. reprazent1's Avatar
      reprazent1 -
      Even if you could run iOS5 properly on a 3gs, Apple wouldn't want to support old hardware: they want you to update and buy the newest model each year.
    1. klouud's Avatar
      klouud -
      Could really care less about my 3GS. What I am now worried about is that Apple may be biting off more than they can chew in terms of resources required to run iOS5 and the i4/i5's ability to run it properly. I would rather have a bare bones OS and more power at my disposal.

      Anyone?
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by klouud View Post
      Could really care less about my 3GS. What I am now worried about is that Apple may be biting off more than they can chew in terms of resources required to run iOS5 and the i4/i5's ability to run it properly. I would rather have a bare bones OS and more power at my disposal.

      Anyone?
      Based on that theory you are presumably still running MS Dos?