• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Report: iOS 5 Will Be Incompatible with iPhone 3GS



    The editorial chief at a credible and popular Russian mobile phone blog is getting a lot of attention today for a telling revelation he made via Twitter. The announcement has since taken the tech blogosphere by storm, despite the lack of confirmation from Apple that the information presented is correct.

    Mobile-Review's editor-in-chief Eldar Murtazin turned to Twitter to share that which he learned from his sources in the know: "Just one comment. Apple iPhone 3Gs wont be upgradable to iOS 5.x. iPhone 4 will."

    If correct, the forthcoming iOS 5 - which may be unveiled as soon as June 6th when WWDC gets underway - will not be compatible with the second-to last iPhone model, the iPhone 3GS. Given that millions of these particular models are still in use around the world, this information - if accurate - could come as a devastating bit of news.

    To be sure, Murtazin is far from an Apple-related gossip king. But he generally gets his information from reliable sources familiar with the broader mobile phone industry. And while all reports must be taken with a grain of salt until confirmed by Apple, it's easy to see how Murtazin's report may be correct. Given the supposedly elaborate nature of the next major iOS upgrade, the iPhone 3GS and all earlier models will likely be incapable of powering such a powerful new operating system.

    Source: Mobile-Review, Twitter
    This article was originally published in forum thread: Report: iOS 5 Will Be Incompatible with iPhone 3GS started by Michael Essany View original post
    Comments 68 Comments
    1. alexevo's Avatar
      alexevo -
      A. This is what Apple should have done with iOS4 with regards to the iPhone 3G.

      B. This was going to happen eventually as software gets more resource hungry and older hardware becomes less able to handle it.

      C. At least newbie jailbreakers can't accidentally update now.
    1. Ven0M0D's Avatar
      Ven0M0D -
      the ipod 4 will be able to upgrade correct?
    1. brianjw's Avatar
      brianjw -
      I personally think Apple's process about this needs to change. With more competitors such as Android appearing, they NEED to. Apple should provide firmware updates for older devices as well. Just charge the older devices money to upgrade to that firmware. Sure, older devices might not be able to handle some of the new features, so let them update and provide the features that WILL work, leave out the ones that won't. Android provides continuous updates to pretty much all their old devices as far as I know and even still, they have the power to upgrade their firmware by other means even if it wasn't supplied to them via a OTA update.

      That's just my opinion, but I don't think Apple can continue its same path much longer without losing business. And this by the way, is coming from a person who owns an iMac, iPhone 4, the previous iPhone 3GS, the iPod Touch 2G. So I am a fanboy, with some criticizations.
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by Ven0M0D View Post
      the ipod 4 will be able to upgrade correct?
      Yes
    1. i.Annie's Avatar
      i.Annie -
      Well that was quick. I thought the 3GS had at least another year's worth of updates before this happened.

      Clearly Apple is aiming to eliminate any use of devices that came before iPhone 4, so that people will upgrade to the 4 or the next iPhone of this year.
    1. steve-z17's Avatar
      steve-z17 -
      Meh, just another rumor for now..
    1. moon#pie's Avatar
      moon#pie -
      Quote Originally Posted by Stryker1 View Post
      A good example of Apple screwing over its people AGAIN!!

      Stryker1
      And other cell companies are even worse about it. Some android phones never see it past 2.1, even though the HW can support newer.

      Quote Originally Posted by brianjw View Post
      I personally think Apple's process about this needs to change. With more competitors such as Android appearing, they NEED to. Apple should provide firmware updates for older devices as well. Just charge the older devices money to upgrade to that firmware. Sure, older devices might not be able to handle some of the new features, so let them update and provide the features that WILL work, leave out the ones that won't. Android provides continuous updates to pretty much all their old devices as far as I know and even still, they have the power to upgrade their firmware by other means even if it wasn't supplied to them via a OTA update.

      That's just my opinion, but I don't think Apple can continue its same path much longer without losing business. And this by the way, is coming from a person who owns an iMac, iPhone 4, the previous iPhone 3GS, the iPod Touch 2G. So I am a fanboy, with some criticizations.
      Most android phones are running 6-12 month old FW when newer is available. Android is far worse than apple in this aspect.
    1. Kupe's Avatar
      Kupe -
      ...this could come as a devastating bit of news.
      Devastating? Geez...that might be a bit of hyperbole.

      "Bummer" maybe. "Disappointing" perhaps. But "devastating"? It's an iOS folks. We'll live.

      Kupe
    1. unison999's Avatar
      unison999 -
      uhhhh not news.
      Apple always stop support a device after about 2 years after its introduction, just to obsolete the older devices so people buy new ones.
      I can guarantee that my next phone will not be an iPhone.
    1. Hardcoredrummer1996's Avatar
      Hardcoredrummer1996 -
      Quote Originally Posted by jmaderosk8r View Post
      It makes no sense because ATT is still marketing the 3gs. Lately ive seen the 3gs commercial more that the iphone 4. But like mentioned above apple likes the green and really wouldnt care of 3gs owners getting mad. But i would rather have a jaibroken 3gs with 4.2.1 than a 3gs 5.x.x that will make my phone laggier like the ios4 did to the 3g.
      Yeah, but thats a perfect example on how Apple is greedy and try to get money off of us by making us have garbage. I mean at least Android trys to make EVERY ANDROID PHONE EQUAL!
      -__- im seriously starting to think I should switch to Android...
    1. Simon's Avatar
      Simon -
      Quote Originally Posted by Hardcoredrummer1996 View Post
      I mean at least Android trys to make EVERY ANDROID PHONE EQUAL!
      -__- im seriously starting to think I should switch to Android...
      Afaik devices that run android can vary greatly about which version of android is on them. And that is not even including honeycomb which is not available to many android tablets that are not that old at all (samsung galaxy tab for eg)
    1. Hardcoredrummer1996's Avatar
      Hardcoredrummer1996 -
      Better be compatible because then I'm probably switching to android...
    1. blkcadi's Avatar
      blkcadi -
      This would really suck for 3Gs owners.
    1. Spamcan's Avatar
      Spamcan -
      As a 3Gs owner I'm glad they're cutting off support at the proper time rather then forcing us to go through the agony 3G users had to last year with iOS 4.
    1. whereswaldo's Avatar
      whereswaldo -
      We can't say we didn't see this coming. I guess it will be incompatible with iPT3 also
    1. technolust109's Avatar
      technolust109 -
      thats just bull **** how 3gs cant upgrade to ios5 D:
    1. Cowboy's Avatar
      Cowboy -
      Yeah sucks for all the 3gs owners but it is a 2 year old phone and in this day and age its way old technology
    1. Cer0's Avatar
      Cer0 -
      Not surprised at this myself. Kinda was expecting it. The A4 can handle more than older chips and maybe iOS5 will be having some big power hungry upgrades.
    1. santaf's Avatar
      santaf -
      obviously this would happen every year they take off compatibility with the phone 2 years past it makes it so people have to buy iphones again wether it be the previous model or the new one they come out with.
    1. Muff!nMan's Avatar
      Muff!nMan -
      thats strange... the 3gs isnt even that old