• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Independence 1.2.4 is out (OSX)


    Basically and updated version of the last twp with a lot of bugfixes.

    Download Independence 1.2.4

    If you used Independence 1.2.2 you'll need the springboard patcher

    Download

    and also if you used 1.2.2 you'll need the 300mbkiller

    Download

    thanks jecastros
    This article was originally published in forum thread: Independence 1.2.4 is out (OSX) started by Cody Overcash View original post
    Comments 51 Comments
    1. knowtheobscure's Avatar
      knowtheobscure -
      Quote Originally Posted by adriankeith View Post
      sorry but I just want to comment on how this has got to be the greatest graphic for iPhone related programs ever.
      Its freakin tight!
    1. adit555's Avatar
      adit555 -
      Hello Cash,
      Great post !! Just wanted to confirm some newbie questions. I have 2 iPhones with me.
      1) Unlocked version 1.0.2 with iUnlock method I suppose
      2) brand new virgin iPhone with V1.1.1

      NEW Virgin iPhone V1.1.1 = Do I just start of with iNdependence 1.2.4 and then run anysim 1.1 ?? Or will I have to downgrade the baseband V1.1.1 and then run independence 1.2.4 and then anysim 1.1 ??

      unlocked V1.0.2 = how do I go about it ? or do I wait for the devteam to come up with a virginizer ??

      Much appreciated, warmest regards,
      Adit.
    1. pz59's Avatar
      pz59 -
      I used ifuntastic with the old firmware 101 and then i did a normal update to 111. how do i go about using Independence and do i have to downgrade?
    1. ntmf@mac.com's Avatar
      Sorry but you can leave the SIM Card in the phone - I did the whole upgrade from hacked 102 to hacked 111 with IPSF and left the SIM in:

      And it works perfect!

      Quote Originally Posted by dalton voss View Post
      I just intentionally bricked mine to 1.1.1, downgraded, unlocked, and upgraded. Most instruction sets don't tell you about removing your SIM card for pretty much everything but the activation step, so I had to do a couple of things over again.

      Here is a great link (its for IPSF but it will get you on downgraded 1.0.2 and let you use independence to prep for 1.1.1):

      http://www.freeouriphones.com/MacTutorial.html

      Keep in mind the bit about needing a SIM card inserted for the activation bit (at least, I did).
    1. glimer4's Avatar
      glimer4 -
      Dear all, i need some directions to upgrade to 1.1.1, i have iphone version 1.0.2 (1C28), firmware 03.14.08_G and it is unlocked. What is the safest and the best way to upgrade it. please somebody show me the way. Thanks
    1. jetnor's Avatar
      jetnor -
      very nice thing is independence. thanx
    1. at182's Avatar
      at182 -
      Quote Originally Posted by iPhoneWriter View Post
      Not sure what 'image' you're thinking of refreshing, as iNdependence is an actual application you'd run on your Mac. Do you mean to 'make' your own build?

      Either way, here's the wiki for iNdependence.

      Hope this helps.
      I meant is I'm tossing up whether it is necessary to use 1.2.4 to upgrade my phone again or can I just apply the fixes that were include in 1.2.4 myself?

      thanks
    1. rottdog's Avatar
      rottdog -
      hmmm ok since i'm new to a mac and just got my first one the other day , i have a rather newb question , i've been thru all these steps and everything on windows to no avail , how the fluck to i stop itunes from opening everytime i plug in my damn phone , it's closed for sure but it still opens whenever i plug the damn thing in which is making this update process more of a pain than it should be
    1. bobim45's Avatar
      bobim45 -
      This is best logo i ever seen, triumph!! Best regard
    1. redeldog1's Avatar
      redeldog1 -
      thanks for the universal version
    1. pcuserforever's Avatar
      pcuserforever -
      I'M READY TO TAKE THE PLUNGE AS A NOOB!

      a couple of questions:
      1. not intrested in unlocking, i can use the new version of independece to jailbreak only?
      2. i have 1.1.1 recently upgraded, never unlocked, never jailbroken before is it ok to proceed?
      3. if i use independence on my friend's mac, will i be able to mod and install new software from my pc after the jailbreak, or am i locked to mac after using independence?

      any response is greatly appreciated.

      THANK YOU DEV TEAM FOR ALL THE WORK!!!

      ever see the apple 1984 big brother commercial? can you say role reversal?
    1. efesusceo's Avatar
      efesusceo -
      all this talk about downgrading, 102, 111, etc. has me all confused.

      i have a hacked v1.0.2, not unlocked. should i upgrade to 1.1.1 , then downgrade, and do all the cooky steps to get my phone back to it's hacked state? or, is there a way to facilitate the process since i'm still in 1.0.2? thanks.
    1. TheYoshi's Avatar
      TheYoshi -
      Quote Originally Posted by waynema View Post
      trust me.. you are not the only one..
      without SFTP I cant even use terminal to install app tapp installer...
      so i can never use open ssh + BSD in 1.1.1

      I've tried removing known_hosts file
      and using another static ip

      still shows:
      ssh: connect to host 192.168.x.xx port 22: Connection refused
      I have answered this exact issue countless times now. You CAN install installer.app without sftp and quite easily using SCP which so far works fine with every SSH daemon I have run across for iPhone. http://www.modmyi.com/forums/showthread.php?t=9667 That explains it in exact detail. Just pick up from where I start my instructions and stop referring you to dev team instructions. READ IT THROUGH once first... then you'll understand what you're doing before you start doing it.
    1. Mulanzo's Avatar
      Mulanzo -
      hahaha....im downloading this based on the logo alone...that has me in tears lol
    1. iBwizzle's Avatar
      iBwizzle -
      iHave windows, can you pretty please make one for the millions of poor PC users?

      -sent from my iPhone
    1. EatingPie's Avatar
      EatingPie -
      Quote Originally Posted by 360boi View Post
      i also did all the intrustions correctly but whenever i try to install an the installar app via independence i keep getting this error: "Couldn't connect to SSH server. Ensure IP address is correct, phone is connected to a network, and SSH is installed correctly."

      can sum1 please help?
      Did you set up passwordless ssh access on your iPhone?

      I had the same error, and FINALLY realized Independence expected a password prompt, which it never got. To fix this ssh into your iphone, and execute the following:

      mv ~/.ssh ~/.ssh-save

      There's another possibility, but unlikely...

      Your iPhone has an IP that conflicts with one already in your "~/.ssh/known_hosts" file. Fire up the Terminal, ssh into your iPhone, and see if you get any warnings. I didn't see this happen, but I'm just throwing it out as a possibility.

      Quote Originally Posted by pcuserforever View Post
      I'M READY TO TAKE THE PLUNGE AS A NOOB!

      a couple of questions:
      1. not intrested in unlocking, i can use the new version of independece to jailbreak only?
      Jailbreak, is the only thing Independence does.* It will not unlock your iPhone. So you're set.

      *Yes, I know Independence also adds ssh, apps, ringtones, etc. if you want to, but that was too complicated to say.

      2. i have 1.1.1 recently upgraded, never unlocked, never jailbroken before is it ok to proceed?
      With all applicable caveats, yes it should be.

      3. if i use independence on my friend's mac, will i be able to mod and install new software from my pc after the jailbreak, or am i locked to mac after using independence?
      Once you're jailbroken, you can install ssh. From there, you can scp or sftp (I think) stuff to your heart's content. Even if it is from (ugh) Windows.

      -Pie
    1. billchase2's Avatar
      billchase2 -
      i'm currently biting the bullet and am upgrading in hopes to jailbreak using independence! wish me luck!
    1. afinite17's Avatar
      afinite17 -
      I have 1.1.1 and iTunes 7.4, it says it works with these, but when I click to perform the jailbreak, it says error: I have to downgrade to 1.0.2 then special upgrade to 1.1.1? Help? lol.
    1. billchase2's Avatar
      billchase2 -
      Quote Originally Posted by afinite17 View Post
      I have 1.1.1 and iTunes 7.4, it says it works with these, but when I click to perform the jailbreak, it says error: I have to downgrade to 1.0.2 then special upgrade to 1.1.1? Help? lol.
      open the help file in independence. from there, they have a step-by-step guide on how to downgrade and re-upgrade so that it can be jailbreaked.

      ugh, somewhere in the upgrading process... it lost all of my settings. so now i have to go through and redo all of my favorites and everything. i even lost my text messages... :-\ oh well i guess.

      ouch........ even lost all of my special iphone-only bookmarks and notes. not very happy...
    1. Arianiv's Avatar
      Arianiv -
      this app would be cool if you didn't have to downgrade to 1.02, and lose your stuff via restore... hopefully a 1.11 jailbreak comes about. At least apple will release an SDK if not. For now I am gonna live without the cool 3rd party apps, constantly re configuring my phone and worry about bricking at the next update sorta takes away from the "convenience-time-saving" aspect of a pda-phone-internet appliance