• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • 1.1.1 Baseband Downgrade Achieved!
    cash edit: All you OSX guys out there I have written a nice guide for you, it takes a little time but i tried to be as detailed as possible.
    Click here for the Downgrade from 1.1.1 to 1.0.2 complete guide including baseband via osx


    Revan has made the windows guide click here

    All right! If any of you have "bricked" iPhones from upgrading unlocked iPhone's to 1.1.1, you are now able to downgrade without paying a dime!

    The guys over at RDGaccess.com have put together a guide on how to do it, here it is:

    "UNBRICKING 1.1.1 UPGRADE

    How To

    0. Download firmware 1.0.2 from apple: http://appldnld.apple.com.edgesuite....8_Restore.ipsw

    1. rename it to iPhone1,1_1.0.2_1C28_Restore.zip and unpack.

    2. extract the ramdisk file from it by typing

    dd if=694-5259-38.dmg of=ramdisk.dmg bs=512 skip=4

    3. mount the ramdisk by doubleclicking it (on mac). On windows use some HFS tools to peek inside it or get the files from someone who extracted it already.

    4. Put your phone into DFU mode and do option-restore in iTunes. This will reflash everything to 1.0.2. You will get an error at the end because it couldnt reflash the baseband. You will end up with a yellow triangle.

    5. Quit iTunes, launch iNdependence and quit it again, relaunch iTunes. Press the power button on the phone for 3-4 seconds. After like 10 seconds you end up on the activation screen.

    6. Complete the Downgrade by Jailbreaking / Activating, Installing SSh on to the phone etc. There are tons of wiki's about that so I won't repeat. (probably also true for step 4,5)

    7. Extract the baseband firmware and EEPROM files of 3.14 from the ramdisk of firmware 1.0.2. The files are named ICE03.14.08_G.eep and ICE03.14.08_G.fls and are located under /usr/local/standalone/firmware.

    8. Get the Secpack of baseband firmware 4.0. Its at the bottom of this post.

    9. Download ieraser2 from http://www.fink.org/ieraser/ or from Geohot's blog.

    10. Install all the tools on to the phone (i use the location /usr/local/bin)needed to get ssh access to the 1.0.2 firmware phone and upload ieraser2, the secpack, the firmware 3.14's FLS and EEP file and anySIM 1.0.2.

    11. ssh to the phone. Stop CommCenter? by typing:

    launchctl remove com.apple.CommCenter?

    12. run bbupdater -v. it will tell you you run version 4.01 of the baseband.

    (bbupdater is a tool by apple which is also on the ramdisk)

    13. run ieraser2. This will WIPE your baseband, given a file "secpack" is in the same directory and this is a version 4 secpack.

    14. run " bbupdater -v " again. it will not find any firmware now. 15. run " bbupdater -e ICE03.14.08_G.eep -f ICE03.14.08_G.fls " 16. run " bbupdater -v " it will tell you you run version 3.14 At this point in time you will still have a IMEI number starting with 004999... and its not of use yet. So still bricked but at least downgraded to version 3.14.

    17. run anySIM Version 1.0.2 (note that older versions might not be good here as 1.0.2 has a lot of fixes for this kind of stuff).

    Now you have a unlocked 3.14 baseband with IMEI being your original one! Congratulations you now fully recovered from your update 1.1.1 and are back to 1.0.2.

    If you want to return to virgin state again you can stop the commcenter again and repeat " bbupdater -e ICE03.14.08_G.eep -f ICE03.14.08_G.fls " again to reflash the "locked" version of the baseband.
    "

    RDGaccess

    All files needed are here
    This article was originally published in forum thread: 1.1.1 Baseband Downgrade Achieved! started by Kyle Matthews View original post
    Comments 178 Comments
    1. Cody Overcash's Avatar
      Cody Overcash -
      alright osx baseband downgrade guide coming up just from me to you(all)
    1. meatwagon's Avatar
      meatwagon -
      Quote Originally Posted by poetic_folly View Post
      All right! If any of you have "bricked" iPhones from upgrading unlocked iPhone's to 1.1.1, you are now able to downgrade without paying a dime!

      2. extract the ramdisk file from it by typing

      dd if=694-5259-38.dmg of=ramdisk.dmg bs=512 skip=4


      I tried that in terminal

      XXXXXXXXXX-computer:~/Desktop/iphone baseband XXXXXX$ dd if=694-5259-38.dmg
      dd: 694-5259-38.dmg: No such file or directory


      my 694 dmg isnt -38 but -5 and i got the file from the hyper link.. any suggestions!??!
    1. fantheplaya's Avatar
      fantheplaya -
      any windows guide in the works yet?
    1. Kyle Matthews's Avatar
      Kyle Matthews -
      Quote Originally Posted by Digitol View Post
      (insert troll noise here)


      :P
      Hey look through that guys past posts. Looks like he doesn't post much useful stuff.

      Quote Originally Posted by fantheplaya View Post
      any windows guide in the works yet?
      Not yet... its in the works.
    1. Mirza513's Avatar
      Mirza513 -
      IT WORKED!
      unbricked my iphone wooot i can call again!
      btw, i did this on windows
    1. liontos's Avatar
      liontos -
      Quote Originally Posted by Mirza513 View Post
      IT WORKED!
      unbricked my iphone wooot i can call again!
      btw, i did this on windows
      How did you

      2. extract the ramdisk file from it by typing

      dd if=694-5259-38.dmg of=ramdisk.dmg bs=512 skip=4

      in windows?

      Thanks
    1. MimoG3's Avatar
      MimoG3 -
      Hey guys here is the secpack, http://rapidshare.com/files/61914114...40113.bin.html found it on this website http://code.google.com/p/iphone-elit...radingBaseband
    1. Mirza513's Avatar
      Mirza513 -
      Quote Originally Posted by liontos View Post
      How did you

      2. extract the ramdisk file from it by typing

      dd if=694-5259-38.dmg of=ramdisk.dmg bs=512 skip=4

      in windows?

      Thanks
      i didnt, i used the files that PF provided
      i did change the secpack.bin to just secpack
    1. SquareGravy's Avatar
      SquareGravy -
      Will this work on an unlocked 1.0.2 phone never updated to 1.1.1?
    1. wawawa11's Avatar
      wawawa11 -
      will this work on brand new iphone with 1.1.1 out of the box?
    1. SquareGravy's Avatar
      SquareGravy -
      Quote Originally Posted by wawawa11 View Post
      will this work on brand new iphone with 1.1.1 out of the box?
      Why would you want to use this? Your phone is fine. Jailbreak it and wait for the free unlock to come out.
    1. EZ2ENVY's Avatar
      EZ2ENVY -
      So cash when will you be posting that guide for the baseband?
    1. meatwagon's Avatar
      meatwagon -
      i cant get com.apple.CommCenter? to stop
      launchctl remove error: No such process


      cash, any word on your tutorial?????
    1. ddochi11's Avatar
      ddochi11 -
      I bought an iPhone that was originally unlocked (i don't know which method was used...), then it was upgraded.

      I have downgraded to 1.0.2, and everything is working except the phone functions.
      I also unknowingly tried to unlock the phone with one of the free simunlock services, but obviously it didn't work.

      However, I have read that I should not attempt to downgrade BB if I have modified the BB with some of the unlock programs.

      My modem firmware is 04.01.13_G. It seems this is what it's supposed to be.
      How do i know if my BB is messed around with?
      And can I still downgrade BB?

      Thanks in advance
    1. EZ2ENVY's Avatar
      EZ2ENVY -
      Do you think an easy step by step program like simfree will come out and you dont have to do all this stuff? just click and go? would make it alot easier, faster, hassel free, and error free
    1. hat's Avatar
      hat -
      i have already unlocked my phone with anysim my phone is running on 1.0.2 my phone is working fine i am able to call if i do this process my phoen will get bricked pls help me as i dont want to mess up by doing this and lose what i have

      thanks
    1. EZ2ENVY's Avatar
      EZ2ENVY -
      i also have an unlocked iphone 1.02 that works and used anysim,

      I want ppls opinion, do you think i should update the phone and use these new 1.1.1 jailbreakers and unlockers?

      Or should i just keep it the way it is? and if i decide to do this, do i have to restore it to the 1.02 from the downloaded link or since 1.02 is on my phone already unlocked by anysim, can i just start this proceedure

      PLEASE ANY HELP WOULD BE AWESOME
    1. noar's Avatar
      noar -
      Quote Originally Posted by poetic_folly View Post
      Better instructions coming soon by cash. This was the quick guide which was from the original author. Cash is rewriting as we speak. You type that in Terminal.
      WHERE I TYPE THAT?

      AND WHERE I DOWNLOAD firmware 4.0

      THANKS
    1. Mirza513's Avatar
      Mirza513 -
      Okay here is a quick guide with what I did to "unbrick" my iPhone

      Follow this guide to downgrade your iPhone firmware back to 1.0.2 (but still having BB firmware at 4.01)
      http://modmyi.com/wiki/index.php/Dow...firmware_1.0.2

      After you have finished that guide, you should be looking at your Springboard.

      STEP 1
      1 - Connect your iPhone to iBrickr
      2 - Go to applications and follow the instructions (it should ask you to restart phone twice)
      3 - After you finished that, browse the applications and install - BSD SubSystem, Mobile Terminal, and anySIM 1.0.2
      (if the Mobile Terminal is acting weird and it's not letting you type in commands. Delete BSDsubsystem and install it again.)

      STEP 2
      1 - After that, download the files that Poetic_folly provided here
      2 - Extract the files and rename secpack.bin to just secpack
      4 - Now upload the following files to /usr/bin using iBrickr. (ieraser, secpack, ICE03.14.08_G.eep and ICE03.14.08_G.fls, bbupdater)

      STEP 3
      0 - Tap the Terminal icon and enter the following commands
      1 - launchctl remove com.apple.CommCenter
      2 - cd /usr/bin
      3 - chmod +x bbupdater
      4 - ./bbupdater -v (the v stands for versions I guess. This will show you which BB version you have)
      5 - chmod +x ieraser
      6 - ./ieraser (Wait for it to finish)
      7 - ./bbupdater -f *.fls -e *.eep (Wait for it to finish)
      8 - ./bbupdater -v (Now check if you have BB version 3.14. If not then something did not go right. Try again)
      9 - Tap the anySIM icon and let it do it's thing (Make sure the auto lock thing is set to never)

      -Restart your phone and you should not get the "Incorrect SIM" error anymore
      -You should also have the correct BB version now along with the correct IMEI number


      I wrote this from memory, I hope its accurate and for the record, I don't know much about the unlock process or what its doing. I just followed the instructions from the first post

      All credit goes to the people who made this possible!

      Good Luck Guys!!
    1. cyber_bilal's Avatar
      cyber_bilal -
      Quote Originally Posted by cash7c3 View Post
      alright osx baseband downgrade guide coming up just from me to you(all)
      can we have a windows guide too??