• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Dev Team 1.1.1 Jailbreak
    cash edit: Read our Jailbreaking 1.1.1 on OSX Guide HERE
    Windows Guide HERE

    The Dev Team has now announced a 1.1.1 jailbreak method which allows for:
    • Downgrading to 1.0.2 (if necessary)
    • Preparing the iPhone for a jailbroken update
    • Performing a software update, leaving you with a jailbroken v1.1.1
    • Forcing v1.1.1 to mount read-write so you can access it
    • Installing SSH and BSD world
    • Activating with a Non-ATT SIM
    • Patching SpringBoard to allow third-party applications
    • Clean-up
    This does NOT allow you to unlock a 1.1.1 iPhone, and WILL NOT WORK ON AN UNLOCKED IPHONE. Again, if you have unlocked your iPhone, DO NOT DO THIS.

    Download here.
    This article was originally published in forum thread: Dev Team 1.1.1 Jailbreak started by Kyle Matthews View original post
    Comments 617 Comments
    1. mikef's Avatar
      mikef -
      theres got to be a simple way to do all this????? im not even gonna get started with all this code ****, and screw my 1.0.2! ill wait for a week and see the devs come out with a easier way!! theres gotta be an easier way! RIGHT?

      i guess im just a weekend hacker!! hahahahah
    1. kndhadley's Avatar
      kndhadley -
      Ok I have a 1 week old unaltered iphone with 1.1.1 I have an att acount and only want to add third party apps change icons and sounds ect. Is this the program I could use? (real question)
      I followed steps up till it says go into iphone. when I pryed it apart a few peices sprung out hit my eye. after returning from the hospital I discovered my 3 yr old son was shooting that little disc thing out of his soft disc shooter gun into the wall. after crazy gluing the disk thing back together and putting most parts back in the iphone (I only had to use very little masking tape to keep it shut) I started
      to redock the iphone and relized that the glue from my hand had securly attached the iphone to my hand in an upside down position. Now as I sat trying to think of what do do next my battery died. Would it be safe to chare the iphone upside down still attached to my hand? Would it be safer to stand on my head to turn the iphone rightside up and now after all this will my iphone be UNLOCKED? (sorry I was bored and everyone is getting so serious I had to lighten the mood) PS the first question is for real I am a newbie and all these post confussed me.
    1. LaZARuZ's Avatar
      LaZARuZ -
      i cant get ssh to work i get error conection. I did everything like 100+ times and im still up i give up till sameone find a way to fix this...
    1. JedixJarf's Avatar
      JedixJarf -
      Quote Originally Posted by LaZARuZ View Post
      i cant get ssh to work i get error conection. I did everything like 100+ times and im still up i give up till sameone find a way to fix this...
      Did you try to connect as SCP?
    1. rianbattle's Avatar
      rianbattle -
      urgh.

      ok, so, after poking through all the pages in this thread i've yet to see anyone mention this problem, if i missed it then i'm sorry. i've never upgraded to 1.1.1 before today and never unlocked my phone in any way, only jailbroken(jailbreaked...whatever).

      i went through all the steps and everything, and did the putjailbreak command through iphuc-jailbreak.exe, restarted the phone, and did the getfile for the fstab, and looked inside it to be sure it said "rw" instead of "ro" for the root directory. so, i have read write access to the root directory. i went on to install the new sshify-windows.bat file and had to do the putfile through iphoneinterface.exe to put the last file on the phone. when i launched iphoneinterface it said i'm not jailbroken, but still let me put in commands and i did the putfile and it gave me a fileref of 1 so i know it put it there. the prompt says "r_command" and lets me type commands on a new line. when i try doing an ls it shows all the directories in the root directory with an l_ prefix, and it shows the iTunes_Control folder.

      this is the second time i've tried this. the first time was from 1.0.2 and it did this. so i downgraded to 1.0.2 from 1.1.1 and tried again and got the same results.

      anyone else encounter this? it appears i have read write access but am not able to install ssh properly.
    1. s2kpdx's Avatar
      s2kpdx -
      Quote Originally Posted by rianbattle View Post
      urgh.

      ok, so, after poking through all the pages in this thread i've yet to see anyone mention this problem, if i missed it then i'm sorry. i've never upgraded to 1.1.1 before today and never unlocked my phone in any way, only jailbroken(jailbreaked...whatever).

      i went through all the steps and everything, and did the putjailbreak command through iphuc-jailbreak.exe, restarted the phone, and did the getfile for the fstab, and looked inside it to be sure it said "rw" instead of "ro" for the root directory. so, i have read write access to the root directory. i went on to install the new sshify-windows.bat file and had to do the putfile through iphoneinterface.exe to put the last file on the phone. when i launched iphoneinterface it said i'm not jailbroken, but still let me put in commands and i did the putfile and it gave me a fileref of 1 so i know it put it there. the prompt says "r_command" and lets me type commands on a new line. when i try doing an ls it shows all the directories in the root directory with an l_ prefix, and it shows the iTunes_Control folder.

      this is the second time i've tried this. the first time was from 1.0.2 and it did this. so i downgraded to 1.0.2 from 1.1.1 and tried again and got the same results.

      anyone else encounter this? it appears i have read write access but am not able to install ssh properly.
      I had issues installing SSH as well, are you on windows or mac?? I finally gave up on windows and used independence on my mac at home to install SSH, worked like a charm after that....
    1. rianbattle's Avatar
      rianbattle -
      i knew i forgot to mention something, i'm on a pc running windows xp. i don't have a mac to turn to, unfortunately. the files are there, i can see them. it just won't let me connect using winSCP for some reason. i have the correct IP address, my iphone is connected to wi-fi, and i'm connecting using the new password and with SCP as the setting.
    1. rkisling's Avatar
      rkisling -
      I tried this process; ran Trip1Prepz once; but ran into an error later in the process. After re-downgrading to 1.0.2, when I connect to Itunes, it only gives me a restore option; how can I reset my var/root/media settings. The only files I currently show are


      var/root/Library
      var/root/media

      and in

      var/root/media I only show

      /DCIM
      /iTunes_Control


      I don't have a media.old folder in this directory

      I couldn't find anything on how to reset the file structure to allow me to get the upgrade / download 1.1.1 option in Itunes. I did a full downgrade to 1.0.2 and that seems to be running fine. BSD and SSH are running.

      Thanks
    1. Eurisko's Avatar
      Eurisko -
      Quote Originally Posted by poetic_folly View Post
      if you have unlocked your iPhone, DO NOT DO THIS.
      So..... big question. What do we do if our phone IS unlocked? Are we SOL for the foreseeable future?
    1. Cody Overcash's Avatar
      Cody Overcash -
      Quote Originally Posted by Eurisko View Post
      So..... big question. What do we do if our phone IS unlocked? Are we SOL for the foreseeable future?
      you wait
    1. daniel_emt's Avatar
      daniel_emt -
      Anyone else have trouble gettng Trip1prepz to install via installer? It downloands, unpacks, but hangs up everytime on install. Any ideas?
      Also, I just downgraded from 1.1.1 to 1.0.2 a couple of days ago and remodded, should i restore my 1.0.2 before i start all this or just do it with 1.0.2 mods. Hope that makes sense.
    1. anigamersk's Avatar
      anigamersk -
      I had the same problem with trip1prepz hanging up. I believe that all the themes and everything you install (through installer or whatever you use) goes into the media folder (at least from what I saw when I looked into the folder) so there's alot of files. All I did was leave it running for about 20 minutes or so then when I came back to the phone it installed fine.
    1. Spamdumpster's Avatar
      Spamdumpster -
      Quote Originally Posted by rianbattle View Post
      urgh.

      ok, so, after poking through all the pages in this thread i've yet to see anyone mention this problem, if i missed it then i'm sorry. i've never upgraded to 1.1.1 before today and never unlocked my phone in any way, only jailbroken(jailbreaked...whatever).

      i went through all the steps and everything, and did the putjailbreak command through iphuc-jailbreak.exe, restarted the phone, and did the getfile for the fstab, and looked inside it to be sure it said "rw" instead of "ro" for the root directory. so, i have read write access to the root directory. i went on to install the new sshify-windows.bat file and had to do the putfile through iphoneinterface.exe to put the last file on the phone. when i launched iphoneinterface it said i'm not jailbroken, but still let me put in commands and i did the putfile and it gave me a fileref of 1 so i know it put it there. the prompt says "r_command" and lets me type commands on a new line. when i try doing an ls it shows all the directories in the root directory with an l_ prefix, and it shows the iTunes_Control folder.

      this is the second time i've tried this. the first time was from 1.0.2 and it did this. so i downgraded to 1.0.2 from 1.1.1 and tried again and got the same results.

      anyone else encounter this? it appears i have read write access but am not able to install ssh properly.

      Your experience is exactly the same as mine. I've been up to 1.1.1 twice and back to 1.02 for my third time. I don't have time to try again right now.
    1. taylorireton's Avatar
      taylorireton -
      same, i installed the tripz on my phone and hangs up on anout 20 percent i let it run for about 30 min and gave up and restored the phone, tried it again in the morning and doing the samething...errr it fills up my disk space, and i cant seen to find where that file is so i can delete it with out restoring it to 1.0.2 again.
    1. s2kpdx's Avatar
      s2kpdx -
      Maybe you guys having issues with downloading tripz should try it the alternate "manual" way???

      It downloaded just fine for me though....
    1. rianbattle's Avatar
      rianbattle -
      it seems the same thing is happening either way, as i did do it "manually" because i didn't feel like downloading the tripz program. i already had ssh and it isn't terribly difficult to type a couple lines into winscp as the directions say.

      i did notice something though. after getting past the step of typing the putjailbreak command and rebooting the phone and checking the fstab file, i went on to install ssh. after running the sshify program for 1.1.1, i noticed that doing an ls on the root directory makes iTunesControl show up, as well as a couple other files(.plist files, i think). i wish i had taken a screenshot of them but i already restored back down the 1.0.2 for the third time today. i will probably give it another shot later, but it seems my problem lies in installing ssh.
    1. daniel_emt's Avatar
      daniel_emt -
      DONE, And I am a total newb. You guys freakin rock, the guides are fantastic.
      thanks guys.
    1. extenet's Avatar
      extenet -
      Ok, so I'm running everything smoothly until I get to where I have to ssh. . .
      i type in ssh -l root iphone ip (and yes I type in my iphones wireless ip address), but then it says connection failed or conection block or something like that. . . that's when I don't know what to do?
      can anyone help me please?
    1. daniel_emt's Avatar
      daniel_emt -
      How do i get the installer on 1.1.1 after I've done all this. I see a guide for windows but not OS X. Can someone point me in the right direction.
    1. xxjoebreadxx's Avatar
      xxjoebreadxx -
      Hey Guys, I'm stuck on step 6. Everything is working fine up to this point. When I try to run springpatch, I get an error, Permission denied. Like I didn't set the permissions properly, but they are correct. Any help? Thanks