• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Firmware 2.0 is out
    The file is called: iPhone1,2_2.0_5A347_Restore.ipsw and you can snag it from apple here http://appldnld.apple.com.edgesuite....7_Restore.ipsw

    keep in mind this is only for the iphone. Ipod touch users will have to wait a little bit longer today. Also when you go to put it on your phone, for windows users hold the shift key when you click restore so you can tell it to use the file downloaded.



    Use it at your own risk, and keep in mind if you have an unlocked phone, this will lock it, so dont install it. Your phone wont be jailbroken either.

    If you do update your phone, you can install apps now. Super monkey ball rocks, and the ebay app is very nice


    EDIT
    The 2.0 firmware erases every bit of data and info on your iPhone and completely installs the iPhone 2.0 firmware. So as long as you are on AT&T, you can officially use all features available on the phone.

    Your phone obviously WONT be unlocked, NOT would it be jailbroken.
    This article was originally published in forum thread: Firmware 2.0 is out started by .:MirrorminD:. View original post
    Comments 196 Comments
    1. coreym@cfl.rr.com's Avatar
      Quote Originally Posted by dbldare View Post
      I believe he's just talking about the logo itself, not the carrier. There is software that you can get from the installer app that let's you modify the lettering on the logo to say what you want it to. The one I use is MIM (Make It Mine).

      dbl
      Right that was what I was wondering if Make it Mine was used, I used customize because I have a styled text and a small graphic. I have used MiM before and did a restore and it left the carrier I was just curious.

      Quote Originally Posted by foureyez View Post
      i used MIM also. i was just wondering y it still shows the custom carrier logo when upgrading to 2.0 was suppose to wipe all the data on the phone.
      However MiM works unless you set your phone up as new it keeps the modified carrier.
    1. jfmsam's Avatar
      jfmsam -
      Quote Originally Posted by rick1123581322 View Post
      can anyone tell me what the baseband version that is running on 5a347?

      is it the same as 5a345 and 5a331?
      Same as before 04.05.04_G.
    1. BoostedEvoIX's Avatar
      BoostedEvoIX -
      This didnt work for me, i got an errror 20 when i tried to update to 2.0.. I am not jailbroken or unlocked
    1. eeBz's Avatar
      eeBz -
      Ok, im having Issues with the 2.0

      I am an ATT Customer
      I restored my phone to 1.1.4 (Non Jailbroken) before updating.
      Im using iTunes 7.7

      I shift+check for update, selecte the 2.0 ipsw - After it runs through about 3 bars of "Preparing iPhone for restore" it gives me the error "The iPod "iPod" could not be restored. An unknown error occurred (1611)"

      After that it appears my iPhone sits there locked up (i freaked out when it first happened) But I can just Power+Home to shut it off and with I turn it back on its in recovery mode, from here I can try again (and fail) to update to 2.0, or I can take it back to 1.1.4 no problem.

      I'd like to get 2.0 running now. Any idea's?
    1. eswanborg's Avatar
      eswanborg -
      Quote Originally Posted by .:MirrorminD:. View Post
      Ya thats what i was affraid of, you need the business plan through at&t to have two calendars from what i remember reading
      I guess the one thing to try, after MobileMe is actually working: perhaps if you choose to Push your MobileMe info AND push the Exchange info it will work. Maybe the catch is just that you can't Push one and Sync the other...???
    1. frogmella's Avatar
      frogmella -
      Just wanted to add my name to the list of those who've successfully installed this over a jailbroken unlocked 1.1.4 and now have a fully-functional iPhone 2, working on a non-iPhone O2 contract. Result!
    1. C1KK's Avatar
      C1KK -
      I "successfully" upgraded to 2.0, but now my wifi signal is constantly getting lost and saying incorrect passcode, maybe I'm just being paranoid but it was working great before I upgraded
    1. tijs's Avatar
      tijs -
      Quote Originally Posted by frogmella View Post
      Just wanted to add my name to the list of those who've successfully installed this over a jailbroken unlocked 1.1.4 and now have a fully-functional iPhone 2, working on a non-iPhone O2 contract. Result!
      frogmella

      what kind of unlock did you used on 1.1.4?
      thanks
    1. Kyduckman's Avatar
      Kyduckman -
      iphone could not be restored unknown error (5) I have jailbroken 1.1.4, not unlock. I used the link provided and hit shift and restore. Anyone have any suggestions. I went ahead and did a regular restore cause it would not read the phone.
    1. trevorrawson's Avatar
      trevorrawson -
      Has anybody had any problems with their email after they upgraded to 2.0? Everything else works fine and I've downloaded and purchased some great apps. But when I try to open mail on my iPhone it opens for about 5 seconds then closes again. If this has happened to someone else and they've figured out why, I'd love to know.
    1. BoostedEvoIX's Avatar
      BoostedEvoIX -
      Quote Originally Posted by Kyduckman View Post
      iphone could not be restored unknown error (5) I have jailbroken 1.1.4, not unlock. I used the link provided and hit shift and restore. Anyone have any suggestions. I went ahead and did a regular restore cause it would not read the phone.
      got the samething and had to restore back to 1.1.4
    1. Kyduckman's Avatar
      Kyduckman -
      Boosted let me know if you hear of something. I don't know what went wrong, but at least I am not alone.
    1. iPhoneRogue's Avatar
      iPhoneRogue -
      AT&T user. Well, I was 1.1.1 and I updated to 1.1.4 before trying to go to 2.0 and now all I am getting is the screen with the iTunes logo and the connecting cord. Not showing up in iTunes. Am I bricked? Can I get back or update to 2.0?
    1. mikenificent's Avatar
      mikenificent -
      Seems like quite a few people are having issues. Maybe due to not upgrading itunes first or whatever case is. For me though will just wait till tomorrow. Not that big of a deal to rush.
    1. iPhoneRogue's Avatar
      iPhoneRogue -
      I did update iTunes to 7.7???

      Can I manually update to 2.0 without iTunes?
    1. BoostedEvoIX's Avatar
      BoostedEvoIX -
      Quote Originally Posted by mikenificent View Post
      Seems like quite a few people are having issues. Maybe due to not upgrading itunes first or whatever case is. For me though will just wait till tomorrow. Not that big of a deal to rush.
      I updated to 7.7 first then i tried to restore to 2.0 and i got error 20
    1. CAPcadetJC's Avatar
      CAPcadetJC -
      Everyone, I just found out why so many people are having problems. Download the new firmware using Firefox. IE and Safari do not download it correctly.
    1. jrtek's Avatar
      jrtek -
      i cant get this stupid f'n $h!t to work... I have 7.7.... Im not nor ever been unlocked or jailbroken... i did shift+restore like instructed in the first post... WTF...
    1. redguy's Avatar
      redguy -
      MAC USERS - FOR THE RECORD: I just spent like 4-5 hours trying to downgrade to 1.1.4 after an unsuccessful attempt to upgrade to 2.0.
      After dozens of failed attempts and following a bunch of tutorials, I finally had the inspiration to try on windows. Itunes was already installed on (7.6) and right after I restored in DFU mode (and got some error), I could restore in normal recovery mode.

      ALL the mac attempts failed for some reason and I tested with both 7.5 and 7.6 downgraded Itunes.

      BTW - I recovered using a 1.1.4 firmware found in this forum's wiki (firmware download links).
    1. eswanborg's Avatar
      eswanborg -
      My install of 2.0 appeared to fail too - gave me the Connect to iTunes screen. I just forced it to restart, restarted iTunes and it was all fine - have 2.0 running - no problems.

      Have you tried just continuing without reverting to 1.1.4? You may have it working already and not know it...???