• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iLibertyX - Premier iPhone/iTouch Jailbreaking, Unlocking, Activation for OS X
    We are happy to introduce the newest and shiniest OSX software for releasing iPhone or iPod Touch into your control. What is is called? iLibertyX. It is the culmination of the great work put into iLiberty and iPlus to bring you the best in modding.



    Guide | Download | theiphoneproject | Download from theiphoneproject

    iLibertyX does it all, jailbreaks, activates and unlocks firmware up to 1.1.4 for all bootloader versions of the iPhone and easily jailbreaks your iPod Touch. Another cool feature available is the packages console. With this you can easily install pre made third party payloads onto your iPhone / iPod Touch like dropbear ssh and a payload to reflash the wifi / edge / bluetooth. iLibertyX will even upgrade the bootloader on 3.9 b/l phones if you so desire (note the bootloader upgrade does not work on ziphone unlocked phones). Oh and you can't help but love the great looking GUI .



    A full usage guide can be found here.

    Windows version here.

    Big credit goes out to francis, pepijn, George Zhu, AViegas, cmw, w__, Baalbeck, bgm, cRAKn, GeoHot, MuscleNerd, pumpkin, SoLoR, sunny, tjcarter, and the iPhoneDev Team.
    This article was originally published in forum thread: iLibertyX - Premier iPhone/iTouch Jailbreaking, Unlocking, Activation for OS X started by Cody Overcash View original post
    Comments 92 Comments
    1. jhamster67's Avatar
      jhamster67 -
      Does it fix the mail problem that many people experience after using ziphone? Since unlocking my phone with ziphone i get a message about imap.yahoo.account not responding. If I use libertyx will I experience the same???

      J
    1. iPhonedme's Avatar
      iPhonedme -
      I have sort of a silly inquiry...

      I have a 1.1.3 OTB Jailbroken/Unlocked/Activated with Ziphone (when it was on 1.1.3).

      I recently installed BBInfo to check what bootloader I am using and it is telling me that I am using 4.6 BL. Now, my understanding was that Ziphone permanently downgraded to 3.9. Why would it be showing that I am using 4.6 BL. I am just curious because I would like to upgrade to 1.1.4 and use LibertyX to Free the phone and install the 3.9 FB.

      Some help would be appreciated!
    1. cory's Avatar
      cory -
      Ok... no questions, (I've already read everything including the guide) I just thought someone might get some use out of my experience. I have an 8gb iPhone running 1.1.4 unlocked on t-mobile with the t-zones hack. everything was working perfectly until today. my email started saying it couldn't connect with yahoo unless I had full signal. Edge has had some issues connecting today. I saw this bright and shiny new program and thought what timing. so here is more info about my phone. started out as a 1.1.1 OTB updated along the way. I got to 1.1.4 using ZiPhone. I still have the 3.9bl. I'll be posting my results as an edit.

      EDIT:
      #1. restored to 1.1.4 with iTunes, did NOT back up my phone (had some issues with that and ZiPhoone just thought I would steer clear to start with) got an error message after first attempt. tried again and went through just fine.
      #2. Got the "need at&t sim card" I just ignored this for now.
      #3.opened iLibertyX (iTunes quit on it own) chose to do all three jailbreak, unlock, and activate. under the payloads i chose the wifi/edge/bluetooth, and the install BBinfo. all went through with no problem. I did find that the iLibertyX will quit on its own right after opening if iTunes is not open with your phone in the sidebar.
      #4. Set up the phone as a new phone. everything sync'd just fine.

      phone info: modem FW 04.04.05_G BL 3.9_M3S2 version 1.1.4
      Voicemail works, will have to post later when I get wifi access to re-install the t-zones hack about youtube, mail, safari, maps, and anything that needs an edge or wifi conection. the phone is working just fine. text is good. I'll post later about other programs. overall very nice program. very easy to use. Hats off to all involved in the making of this program.

      EDIT: after getting the t-zones hack installed all my programs worked just fine on wifi and edge. the only one that didn't is you tube (I believe that is because of the t-zones hack). even summerboard works just fine without installing any tweaks or fixes. this is a great program.
    1. drehleierguy's Avatar
      drehleierguy -
      Worked beautifully! (haven't checked mail etc, but wifi works fine etc). None of the 'payloads' could be downloaded, but no big deal since installer is there and ready to go. Thanks for your advice.

      Cheers!

      dg
    1. Roland7's Avatar
      Roland7 -
      using 8GB 1.1.4 worked a treat simple as can be thanks
    1. henry's Avatar
      henry -
      Ok, I'm probably one of a few that is still running 1.0.2.
      I was wondering for a long time to upgrade, but since I bought my iPhone unlocked and I don't know in which way was unlocked (I tried to know with sendmodem, but I always got an error message), I'm still stuck on 1.0.2
      In the past days I read tons of guides/tutorials/posts trying to understand: how to Virginize, which the best unlocking and so on, till yesterday when I found out this wonderful software and now, after reading a lot about it, I would like to upgrade to 1.1.4
      My question is, may I do it simply following the guide and not checking the box "unlock with 3.9FB" bcs I have a 03.14.08_G ?
      Perhaps is a stupid question, but I want to be sure do not brick my iPhone.

      Thanks!
    1. imode's Avatar
      imode -
      Quote Originally Posted by henry View Post
      My question is, may I do it simply following the guide and not checking the box "unlock with 3.9FB" bcs I have a 03.14.08_G ?
      Perhaps is a stupid question, but I want to be sure do not brick my iPhone.
      Download the 1.1.4 firmware, do an "option Restore" (since you are posting in this thread I assume you are on a Mac), select the 1.1.4 firmware you have just downloaded and run iLibertyX. You won't brick your phone.
    1. henry's Avatar
      henry -
      Quote Originally Posted by imode69 View Post
      Download the 1.1.4 firmware, do an "option Restore" (since you are posting in this thread I assume you are on a Mac), select the 1.1.4 firmware you have just downloaded and run iLibertyX. You won't brick your phone.
      This is what I was thinking to do, but I still have doubt about the necessity to Virginize first, bcs I read many times/posts here and in other forum, that is requested for 1.0.2.
      Are you sure I can proceed without Virginize first?
      Thanks in any case, I appreciate.
    1. mmartinez's Avatar
      mmartinez -
      Hi I am new to this newsgroup and new to iPhone, I used ziphone and had had problems using springboard and some audio annoyances, then I restore my phone and used independence and my phone died. I try the hard restore and researched all probable solutions to bring it to live, I failed, I took it to the apple store and the could not fix it either, they gave a new one. I have version 1.1.4
      I would like to stay in 1.1.4 and would like to have the installer and summerboard. I would like to be able to restore my phone to the original settings without going to much trouble.

      What would be a better choice for me?
      Jailbreak, Independence or liberty?
      Is it any better to use a MAC than Windows, what are the main differences.
      You guys seem to know all the minor deatil.
      I thank you for your advice
      Mario
    1. henry's Avatar
      henry -
      Finally I did it, but not without problems.

      1. I virginized with "The Virginizer" and all went well
      2. I connected the iPhone in DFU mode, to my MacBook Pro and tried to make a restore to 1.1.4 but iTunes (7.6) froze in "preparing iPhone to restore", then after 15 min. wait, I forced the exit to Itunes and I tried again, but with same result.
      3. I connected the iPhone to my old MacBook with OSX 10.5.2 but iTunes 7.4 and the restore went well.
      4. I connected the iPhone to my MacBook Pro, opened iTunes (7.6), opened iLiberty (iTunes quit autom.) and start the procedure, but it froze at the first step of restore, then I had to force the exit.
      5. I connected the iPhone again to the MacBook, made a new restore, opened iLiberty and all went well!

      I made the above recap just to let understand to the the guys who knows more than me where the problems come from.

      Thanks for the wonderful app and all the work you done!
    1. djtrip's Avatar
      djtrip -
      ..
    1. adit555's Avatar
      adit555 -
      Hello,
      I have unlocked my 16GB with ZiPhone. Would it work better if I upgrade the bootloader through iLiberty ?? and if yes then what would the advantage be to upgrade the bootloader to 4.6 ??
      Do I need to run any other process before upgrading the bootloader ??
      Please advise. Thanks.
    1. Cody Overcash's Avatar
      Cody Overcash -
      you can not upgrade your bootloader. It was downgraded by ziphone and you are now stuck like that.
    1. iPhonedme's Avatar
      iPhonedme -
      Hello... I used this program and now my Mail application crashes on loading...

      Anyone had problems with this? And if so how did you fix it?

      Thanks
    1. mdborn39's Avatar
      mdborn39 -
      Thanks for this i am new to this stuff i was looking for that new pwnage tool dose anyone know when that is coming out should i wait to jailbreak when it is released or what?????
    1. PSP2006's Avatar
      PSP2006 -
      Quote Originally Posted by mdborn39 View Post
      Thanks for this i am new to this stuff i was looking for that new pwnage tool dose anyone know when that is coming out should i wait to jailbreak when it is released or what?????
      There has been a fantastic piece of hardware developed for finding things like this out, it's been about for a while and has been named amongst other things "eye's" combined with a new technique called "reading" you can find out a lot of stuff !
    1. oldernu's Avatar
      oldernu -
      If I use iLiberty on my brand new iphone (arrives tomorrow from Apple), do i need to have a sim installed for the whole procedure to work? Also, do you recommend using "Unlock with 3.9FB" ?
    1. Bernie-Mac's Avatar
      Bernie-Mac -
      Does this free up space for apps? Cuz i just used this and then downloaded BossTool and when i clicked move apps i got the spinning wheel of death
    1. xxgoozxx's Avatar
      xxgoozxx -
      Worked on my 1.1.4 OTB that I purchased this morning! No problems to report. Checked all boxes including the fake 3.9 and it was good to go. Using T-Mobile with edge and wifi all good!
    1. punisher's Avatar
      punisher -
      I used this to upgrade to 1.1.4 over the weekend.

      In itunes, i selected the option to 'download only' firmware 1.1.4.

      Held option and clicked on restore... chose the 1.1.4 .ipsw file

      itunes did its thing, then i got the unsupported SIM card screen.

      Opening iLibertyx, it closed itunes

      Checked jailbreak, activate and unlock

      5 mins later, i'm all sorted on 1.1.4

      Easy!