• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iDemocracy 2.0 Officially Released - So many new features, it just might kill you!

    Friends:

    The day has come at last; iDemocracy 2.0 has just been released! (cue angelic choir singing)

    MMi Edit: to continued development

    What's new, do I hear you ask? Well...

    1. Slick new interface in Expression Blend
    2. Quick, WiFi-Less Jailbreak of 1.1.1
    3. 1.1.2 Jailbreak support.
    4. Built-in activation for all firmwares.
    5. Built-in virginizing for 1.0.2!
    6. Built-in baseband downgrading to 3.xx
    7. Ringtones for 1.1.1/1.1.2 (for free)!
    8. Applications for 1.1.1/1.1.2!
    9. Wallpapers for 1.1.1/1.1.2!
    10. Other media, SSH functions.
    11. iDemocracy File Browser.
    12. Revised, detailed steps.
    13. Installation of MobileStack.
    14. Manage, edit, add and remove from MobileStack.
    15. Included Installer.app Fix, DropbearSSH Removal, Unpatching Springboard.
    16. Included fixes for YouTube, some Putty errors.
    17. Projects embedded like CARNAVAL, Dev Team 1.1.2 Fix.
    18. Quick links for donations, Digg, etc.
    19. Lots and LOTS of bug fixes.
    20. Plenty more! It's a whole new experience!

    Here are some screenshots for your enjoyment:

    The iDemocracy 2 Jailbreak screen:

    The iDemocracy 2 Media Manager:

    The iDemocracy 2 File Browser:

    If that hasn't convinced you to hurry over and download it, I don't know what will!

    You can grab your own copy and test away from the Google Code Site. MMi Download Section. MediaFire Mirror.

    Be sure to send lots of feedback and leave in a good word

    Thank you all for your immense support, and keep it coming! Don't worry, iDemocracy 2.1 will release someday soon and add support for unlocking OTB UK iPhones (as long as it's humanly possible ).

    Also, please Digg it if you have an account!
    http://digg.com/apple/iDemocracy_2_0..._More_Features

    Sincerely,

    Drakenza

    http://idemocracy.googlecode.com
    This article was originally published in forum thread: iDemocracy 2.0 Officially Released - So many new features, it just might kill you! started by Drakenza View original post
    Comments 355 Comments
    1. slayorktc's Avatar
      slayorktc -
      Hey.. question... i have 1.1.1 and if i use that oktoprep along with iD2, is this a upgrade or will i end up having to restore and wipe clean again..
    1. dvd65's Avatar
      dvd65 -
      hi there,

      my iphone 1.1.2 with bootloader4.06 (suck!!)is jailroken and downgraded to 1.1.1 version with idemocracy2 is working fine with all app installed except for phone function still locked due to anySIM is not working with new bootloader version 4.06. my questions are:
      - do i need to upgrade back to 1.1.2 version? why?
      - do i need to remove anySIM software? how?

      thank you,
    1. oOXDreadXOo's Avatar
      oOXDreadXOo -
      Quote Originally Posted by ShadyBeagle View Post
      umi cant open the file it says .rar and not .zip how do i open .rar files
      For windows you can utilize WinRAR
    1. Kitsune's Avatar
      Kitsune -
      I changed my password when Jailbreaking 1.1.2 out of habit. I haven't forgotten it, but when trying to sync media it speaks about the SSH key or whatever and then a window comes up and says "Access Denied." How do I change the password Democracy uses?
    1. noob2profi's Avatar
      noob2profi -
      have a little question. Sorry^^

      i have a OTB iphone 1.1.2 with new bootloader. I downloaded iDemocracy 2 and i dont know really what to do know!

      Klick on "1.1.2"-->"1.1.2 JAILBREAK" ?

      or do i have to do something else before i can use iDemocracy ?!

      Please help
    1. Drakenza's Avatar
      Drakenza -
      @Kitsune: You can't change iD2's password quite yet, but soon enough you'll be able to.
      Until then you'll have to stick with alpine.
      Sorry...

      @noob2profi: I assume you're trying to jailbreak 1.1.2. In that case, click on "1.1.2 Jailbreak"

      @dvd65: You can pick whatever firmware you want. However, no matter what you do you cannot unlock it.

      @Everyone: iDemocracy 2.0.1 update is now available, so go download it.
    1. noob2profi's Avatar
      noob2profi -
      Quote Originally Posted by Drakenza View Post

      @noob2profi: I assume you're trying to jailbreak 1.1.2. In that case, click on "1.1.2 Jailbreak"

      [/COLOR]
      thank you very much ^^

      So just plug in the iPhone and than click on 1.1.2 jailbrack..nothing else right?
      Very nice Prog! maybe i will donate tomorrow
    1. A3 Australia's Avatar
      A3 Australia -
      Hi!

      I have an iPhone (shipped from Apple's China factory on Nov 9th so I guess 1.1.2) arriving next week. I have a blank TurboSIM from Bladox.

      Any news on iD 2.1 for Out of the Box 1.1.2 iPhones with 4.06 ?????

      And

      Has anyone successfully used iD 2.01 (patched) on an OOTB 1.1.2 with 4.06 to Activate and Jailbreak - then successfully used a TurboSIM and appelsaft ??? Can you make and receive calls?? Do all other functions work OK???

      What else (other than iD 2.01 and TurboSIM/appelsaft) do you have to use/do to get the iPhone working with any GSM SIM card???

      Thanks from Australia
    1. djafropiq's Avatar
      djafropiq -
      i downloaded the patch but it doesnt want to update. everytime i click on update the installation it says that there is an error and it cannot find a path to the files its looking for..HELP.. just virginze update to 1.11 and then unlock correct? i just need this patch to work.
    1. spurlock's Avatar
      spurlock -
      iDemocracy 2.0.1 update still did not go to 1.1.1 it did say it symlink fine though
    1. Drakenza's Avatar
      Drakenza -
      @djafropiq: Are you pointing it to the Debug folder? If you read the text in the "Browse" window it tells you to browse to the Debug folder.

      Quote Originally Posted by A3 Australia View Post
      Hi!

      I have an iPhone (shipped from Apple's China factory on Nov 9th so I guess 1.1.2) arriving next week. I have a blank TurboSIM from Bladox.

      Any news on iD 2.1 for Out of the Box 1.1.2 iPhones with 4.06 ?????

      And

      Has anyone successfully used iD 2.01 (patched) on an OOTB 1.1.2 with 4.06 to Activate and Jailbreak - then successfully used a TurboSIM and appelsaft ??? Can you make and receive calls?? Do all other functions work OK???

      What else (other than iD 2.01 and TurboSIM/appelsaft) do you have to use/do to get the iPhone working with any GSM SIM card???

      Thanks from Australia
      Can't be done, my friend.
      Not right now anyway. We're all working on it...
    1. nickh's Avatar
      nickh -
      Hi Drakenza, Firstly a huge thankyou for your work on this!! Need a little guidence please.

      Q. Am trying to virginize my wifes 1.0.2 with id2, every time i hit virginise button i get i get the please read popup, hit yes then get PuTTY Internal Error message- Invaild Port Number.

      What am i doing wrong??

      Using Vista, installed Framework 3.0

      Cheers, Nick
    1. Drakenza's Avatar
      Drakenza -
      @Nick: sounds like you forgot to put your iPhone's IP address in the text box
    1. noob2profi's Avatar
      noob2profi -
      sry that i ask again, but i read now in few threads that you need do DOWNGRADE your firmware first before you can jailbreak 1.1.2

      Is it with iDemocracy not so? Can i just plug in an 1.1.2 iPhone and thats it?

      i'm confused
    1. Drakenza's Avatar
      Drakenza -
      @noob2profi: Sorry, you have to downgrade with iD2 as well... but don't worry, it guides you through all that. It's necessary because you need to OktoPrep in 1.1.1 before you can jailbreak 1.1.2. We're all working on an easier method, but it's not getting anywhere...
    1. nickh's Avatar
      nickh -
      Ahhh, thats done the trick!!

      Just to clarify, once i have done this, i need to update to 1.1.1 via itunes, using restore to 1.1.1 which i have on the desk top, using shift wait till updates then go through steps on id2.

      PS. Am now at the warning of Power Source. Is it safe to continue?? How do i confirm?
    1. Reako's Avatar
      Reako -
      Am I lost or is drag/drop not implemented into this program?

      Reako
    1. noob2profi's Avatar
      noob2profi -
      After the restore comes and error, should you click on ok before you click on apptapp in iD2 ?

      after i downgraded i dont have to upgrade again?
    1. theKYKid's Avatar
      theKYKid -
      this looks like a great lil' package of goods....

      though everytime I try to virginize my 1.0.2 phone, I keep getting an error in the putty window saying

      Using username "root".
      Access denied

      ....BUT if I try to use Putty without the iDemocracy...I can log into my phone no prblem.

      Can you help?

      Thanks
    1. djafropiq's Avatar
      djafropiq -
      Quote Originally Posted by nickh View Post
      Ahhh, thats done the trick!!

      Just to clarify, once i have done this, i need to update to 1.1.1 via itunes, using restore to 1.1.1 which i have on the desk top, using shift wait till updates then go through steps on id2.

      PS. Am now at the warning of Power Source. Is it safe to continue?? How do i confirm?
      +1.. it wont let me press 1 to continue.. is it done? i dont think i have time to go thorugh with updated to 1.11 right now.. i should be able to just do anysim right?