• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iDemocracy 2.0 Officially Released - So many new features, it just might kill you!

    Friends:

    The day has come at last; iDemocracy 2.0 has just been released! (cue angelic choir singing)

    MMi Edit: to continued development

    What's new, do I hear you ask? Well...

    1. Slick new interface in Expression Blend
    2. Quick, WiFi-Less Jailbreak of 1.1.1
    3. 1.1.2 Jailbreak support.
    4. Built-in activation for all firmwares.
    5. Built-in virginizing for 1.0.2!
    6. Built-in baseband downgrading to 3.xx
    7. Ringtones for 1.1.1/1.1.2 (for free)!
    8. Applications for 1.1.1/1.1.2!
    9. Wallpapers for 1.1.1/1.1.2!
    10. Other media, SSH functions.
    11. iDemocracy File Browser.
    12. Revised, detailed steps.
    13. Installation of MobileStack.
    14. Manage, edit, add and remove from MobileStack.
    15. Included Installer.app Fix, DropbearSSH Removal, Unpatching Springboard.
    16. Included fixes for YouTube, some Putty errors.
    17. Projects embedded like CARNAVAL, Dev Team 1.1.2 Fix.
    18. Quick links for donations, Digg, etc.
    19. Lots and LOTS of bug fixes.
    20. Plenty more! It's a whole new experience!

    Here are some screenshots for your enjoyment:

    The iDemocracy 2 Jailbreak screen:

    The iDemocracy 2 Media Manager:

    The iDemocracy 2 File Browser:

    If that hasn't convinced you to hurry over and download it, I don't know what will!

    You can grab your own copy and test away from the Google Code Site. MMi Download Section. MediaFire Mirror.

    Be sure to send lots of feedback and leave in a good word

    Thank you all for your immense support, and keep it coming! Don't worry, iDemocracy 2.1 will release someday soon and add support for unlocking OTB UK iPhones (as long as it's humanly possible ).

    Also, please Digg it if you have an account!
    http://digg.com/apple/iDemocracy_2_0..._More_Features

    Sincerely,

    Drakenza

    http://idemocracy.googlecode.com
    This article was originally published in forum thread: iDemocracy 2.0 Officially Released - So many new features, it just might kill you! started by Drakenza View original post
    Comments 355 Comments
    1. diljosh's Avatar
      diljosh -
      when I was using the virginser in this , after some time it asked me if I want to proceed and gave me two options 1)yes or 2) No, how do I reply in the putty. I am not able to type anything on it
    1. iBwizzle's Avatar
      iBwizzle -
      iHave iDemocracy 2 and iJail Broken 1.1.2 usin' the steps from MMi. Everythin' seems to be workin' good; however, iCan't iNstall any ringtones usin' iDemocracy 2. Do you have to have Wi-Fi to upload ringtones to your phone? That and how do iCustomize the iCons. iKnow this iS a great program and all, but its very complicated. iCan't wait until they release another version. iF you know how to upload ringtones on a jail broken 1.1.2 iPhone can you please tell me how. Thanks...!

      -sent from my iPhone
    1. vvam123's Avatar
      vvam123 -
      I'm trying to download the application of idemocracy2.0, but when it downloads it only shows a text file not and executable. any help please?
    1. fekz's Avatar
      fekz -
      Just doesn't work for me period. I double click the exe and I get nothing. I'll have to check which framework I have, but I'm sure it's 3.0
    1. binoyin's Avatar
      binoyin -
      does jailbroken 1.1.2 work with all networks ??

      thanx
    1. Drakenza's Avatar
      Drakenza -
      Hey everyone,
      Sorry, I fell way behind on this thread because my Wi-Fi died on me and I went through all kinds of stuff to get it back up and running (which it is now)
      I'll try and read up but I can't answer all your questions.
    1. rawbdee's Avatar
      rawbdee -
      First of all thank you for your dedication

      Now a question, I have 1.1.2 installed I ran oktoprep can I use this to jailbreak even if ive been running on 1.1.2 for a few days now?
    1. kuhndsn's Avatar
      kuhndsn -
      Hello Geniuses (namely Drakenza...You Rock!),
      Ok am I reading this all correctly? I can verginize my phone and upgrade from my unlocked 1.0.2 to 1.1.2? I unlocked my phone (1.0.2) Oct 1st and have been wanting to upgrade since 1.1.1 came out and now even more so when I seen my buddies 1.1.2 and compaired the sound quality and speed. (it rocks!)
      Here is what I have... I have a 1.0.2 (1C28) with Modem firmware 03.14.08_G. running Vodafone.de sim card. Everything works on the phone with no issues...
      I would like to upgrade to 1.1.2. can I do this with iDemocracy 2.0? Has anyone done it? Is there a guided step instruction out? I know alot of questions..(Sharp but not the sharpest tool in the shed :-) )


      What I have---
      --I am running windows vista
      --Downloaded 1.1.1 and 1.1.2 from this site
      --Downloaded 1.0.2 from iUnlock.app that I bought (iPhone1,1_1.0.2_1C28_Restore) the file is what I used when I initially unlocked my phone.
      --I have WIFI access (slow speed)
      --iBrick v0.91
      --Basic knowledge and a bit slow on all the lingo...
      --iTunes version 7.3.0.54 (Yes thats correct I havent upgraded...was afraid to when everyone bricked their phone back in Oct)

      Thank's in advance for the help. There seems to be alot of Albert Einsteins on this site so I know someone has the answers...

      Dennis
    1. morphiusrt's Avatar
      morphiusrt -
      i have jailbroken 1.0.2 and thats it, what do i have to do to get 1.1.2. i do jailbroken. also when i go to install the idemocracy update from google it gives me an error
    1. Drakenza's Avatar
      Drakenza -

      Notice: Two more prominent bugs have been found in iDemocracy 2.0.1 which are the following:

      1. There's a little confirmation option at the beginning of virginator.sh which plink doesn't allow you to input to. Put simply, I have to hack out a line of code so that it doesn't hang up at the very beginning.
      2. anySIM 1.2 is not getting chmodded correctly somewhere which is causing some crashes while reading files and then screwing up iPhones. If you're running an updated, jailbroken 1.1.2 iPhone, DO NOT try to unlock it with anySIM until I release a fix.

      Also, I plan on adding an auto-updater feature if possible, or atleast update notifications, so that you guys don't have to keep watching for posts like these.

      So... looks like the time has come for iDemocracy 2.0.2. I appreciate your patience and cooperation




      @kuhndsn: My opinion is that 1.1.2 is a worthless waste of time... However, if you really want the sound upgrade, iD2 can jailbreak 1.1.2 for you. What you need to do is virginize your 1.0.2 iPhone, upgrade it to 1.1.1, run the Short Method and jailbreak it, and finally follow the 1.1.2 jailbreak in iD2. For virginizing, you'll have to use another fix out there until the update mentioned above is released.

      @morphiusrt: When you say "that's it" I'm assuming you mean it isn't unlocked. In that case, get into DFU mode and restore to 1.1.1, and then follow the Short Method in iD2. After that you can follow the 1.1.2 jailbreak instructions. Alternatively you can follow the long method, as you're on 1.0.2 already...
    1. mors's Avatar
      mors -
      this should be for mac!

      if youre going to use the Leopard look, why are you developing for Windows!?

      ugh... i just got rid of my Windows HP and got me a Macbook Pro!! dang it!!

      great app though... thanks for all the work!

      mac please!!!

      (ill donate when theres a mac version!
    1. kuhndsn's Avatar
      kuhndsn -
      Drakenza,
      Copy that I will take your advise and not upgrade to 1.1.2. However I will upgrade to 1.1.1. (video output is really all i want anyway). I I understand correctly once you fix the virginizer in iDependance I can use it to virginize my phone and jailbreak it to run my homebrew aps again and then use AnySim to unlock it to use my own sim/service provider correct. Also by using iDemocrace I will have Utube again as well correct. Thanks again for all the hard work you have provided. Wish I was a computer savi to lend a hand.

      Dennis
    1. theone77's Avatar
      theone77 -
      Hello Sir Drakenza,

      i just bought my phone in US, im here in UAE(middle east) using etisalat sim. UNLOCKED and JAilbreaked. I dunno what they use to unlocked and other things they done on my iphone

      This is my phone.

      8gb version 1.0.2
      4.01.13 G


      Now i want to upgrade for 1.1.1 yet im so scared that i can brick my iphone worth half of my monthly salary.

      Do u think its now time to update for 1.1.1? How about IbrickR? can i use without any hassle in 1.1.1?

      in upgrading, is this idemocracy is safe? can u teach me what to do or i'll just follow what post u have in the first page?
    1. viorelo's Avatar
      viorelo -
      Oh my God, I had an aweful night...here's my story
      I had an unlocked 1.02 iphone with the old bootloader.
      I virginized it with idemocracy2, it went all good.
      after that in itunes i hit restore press shift, chose a downloaded 1.1.1 firmware, waited and after
      tons of 1011 errors, countless restores, windows restarts etc, managed to restore to 1.0.2
      first time I got that @iphone needs repair@, couldn't even dial
      new restore to 102, this time I could dial, go to prefs, make my wifi work,
      got that imei 0049 incorrect sim error - activate to itunes
      used ibrckr to jaibrake, after that used ID2 to activate 102
      used ibrckr to install installer, after that anysim 1.02
      and voila thank God I have returned to my 102 unlocked iphoned, only this time is jailbraked
      I really don't want anymore to get to 1.1.1 because my heart really hurts, I felt tonight like doing stunts without a safety net..

      let this be a lesson for all you out there who have the guts to do it, but was not born a hacker
    1. jb504's Avatar
      jb504 -
      every time i start viginazer it says acces denied
    1. archie69's Avatar
      archie69 -
      Hi, i'm reading that in thess hours it seems someone dumped bootloader 4.6. I have an iphone (1.1.2 and 4.6) in my hands and no way to use it (can't unlock). What's about idemocracy 2.1? Is coming? How much does it takes?? I can't live with an iphone without using it
    1. morphiusrt's Avatar
      morphiusrt -
      i have a problem,

      none of my icons show up and it shows them all in my installs and i can't unistall some of them i get "error during unistall script execution!"

      when i try to install customize i get" this version of customize requires firmware 1.1.[12]." same as with summerboard and stackcontroller.
    1. sawrat's Avatar
      sawrat -
      I get an error when i click "1.1.2 jailbreak" button. the error is "this utility can only be used if you have run oktoprep before updating to 1.1.2". i have iTunes 7.4 and Java installed on this Vista machine.

      Here are the steps i took:
      1. started with a v1.1.2 (04.02.13_G) iphone
      2. downgraded the firware to v1.1.1 (although i noticed after downgrading that the firmware version was still 04.02.13_G when you check with *3001#12345#*)
      3. activated & jailbroke the v1.1.1 using CARNAVAL by Brasuco
      4. installed Installer.app, BSD, OpenSSH, and Oktoprep
      5. upgraded firmware back to 1.1.2
      6. this leaves me at step 3 in iD2 where i'm required to click "1.1.2 jailbreak", but i get the error mentioned above.

      i did install oktoprep and got the "ready to upgrade to 1.1.2" message in installer.app so i don't know why i'm getting this error
    1. morphiusrt's Avatar
      morphiusrt -
      please help

      see post above

      also when i try to install many of the apps i get similar error to the unistall error script execution

      My firmware on the phone says 1.1.1 (3A109a) but i keep getting firmware 1.1.1 required for this app

      it makes no sense

      i managed to download finder and went to var/root/media and smb and customize are still there but no icon is available and i can't uninstall.

      my phone was 1.0.2 jailbroken with apptapp just used idemocracy to upgrade 1.1.1

      i noticed the version of installer is the older one i had the new one on my 1.0.2

      questions: what is virginizing? was i supposed to do that? if so where can i find it?

      ps thank you for creating this great program, i will definitely be donating later this week.
    1. Kuffdam's Avatar
      Kuffdam -
      Guys I need some help please

      Go easy on me here I'm not the best at this kinda thing.

      I have an Iphone with 1.0.2 and I want to upgrade with IDemocracy. The program is running and I have keyed in the Ip address. The problem is it doesn't seem to work. I hit the virginise button but then it fails to connect or the network times out.

      I have installed Openssh but I don't see an icon on my Iphone, Should I? I have the Sub thing installed also...

      What am I doing wrong?

      My iphone was unlocked for me so not sure what method was used.
      Can anyone help please???

      Thanks in advance