• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Jailbreak 1.1.2 software released Win/OS X
    So many are confused about how exactly to jailbreak to 1.1.2

    If you are running a 1.1.2 phone you need to get back to 1.1.1. This method is documented countless times on this site and the rest of the web. If is also included in the readme file packaged in the zip file linked below.

    Now that you have a 1.1.1 phone you need to get installer working.

    Install OktoPrep via Installer

    upgrade to 1.1.2

    Conceited software has released software that will jailbreak 1.1.2, installs installer, and install ssh app. Both windows and mac versions are available and you can get them here:
    http://conceitedsoftware.com/iphone/site/112jb.html

    Run the conceited software 1.1.2 jailbreak software, it will take about 10 minutes to complete.

    Note: if you did not install OktoPrep before you upgraded to 1.1.2 none of this will work
    This article was originally published in forum thread: Jailbreak 1.1.2 software released Win/OS X started by Cody Overcash View original post
    Comments 215 Comments
    1. jacobzking's Avatar
      jacobzking -
      Quote Originally Posted by Drakenza View Post
      No, there's something definitely wrong...
      It's been more than 10 minutes and I see nothing but "Reading flash image..."
      The progress bar is empty except for a tiny little sliver.
      The output window shows "0/314572800"
      iPhone is running normally...

      I've done this on my Vista computer and my Leopard-running iMac so I'm concluding that I didn't update properly somehow... Going back to iTunes, downgrading to FW 1.1.1, and trying again.

      By the way, does anyone know if I need iTunes 7.5 in order to upgrade to 1.1.2? I did it with iTunes 7.4.x and it did everything just fine, but now I end up with this...

      Thanks,

      Drakenza
      you can use itunes 7.4.2 to install 1.1.2 on a Mac
    1. ben101's Avatar
      ben101 -
      great job was able to do it about 10 min, if any one needs help for doing it on windows will be happy to help
    1. CaryDude's Avatar
      CaryDude -


      Ok, there are several folks (including myself) who are claiming to have gone through the process as directed and are getting to 1.1.2, firing up the JailBreak Java app and getting
      Cannot connect to your device: Please plug your iPod/iPhone into your computer. If you're still having trouble, restart the computer, reconnect the device and try again.
      If we're going to get help, we need to pass along more details. Obviously, everybody thinks they did Oktoprep just fine. I know I did mine twice and rebooted the phone in between, then just before starting the upgrade to 1.1.2.

      When ./osx is telling me this, ./iphuc.ppc can get in just fine and is sitting there waiting for something to do. With an ls I can see the AppSnapp.log file sitting there, so I'm pretty confident I didn't get Restored, just Upgraded. Has anyone else used iphuc to see if they can truly get into the phone and exit cleanly? Perhaps some of the automation could be taken out of the process and we enter commands manually?

      I'm on a PowerPC Mac; who else having trouble is on a PowerPC Mac?

      Who's on an Intel Mac?

      Who's on Windows?
    1. teufel657's Avatar
      teufel657 -
      It says i didn't install the OkToPrep even though i did.......damn
    1. ~W~'s Avatar
      ~W~ -
      Wait.. this is what i've done--->

      downgraded to 1.1.1 jailbreak and used oktel thing.... upgrade to 1.1.2 and download that pkg, and in that file, open up "osx" or jailbreak.jar?
    1. mofolo's Avatar
      mofolo -
      hmm - cant they make this so OkToPrep works with appsnapp?

      I need a way to Hacktivate my iphone too
    1. thewhiterabbit9's Avatar
      thewhiterabbit9 -
      So I have been seeing some issues on here with jailbreaking and I did the appsnapp last week and my phone was kind of stuttering so i did a restore.

      So i would greatly appreciate some one to answer a couple questions for a fellow iphone owner...

      1. So today I took my phone back and got a new replacement because it was kind of stuttering between apps. Does anyone else have this sometimes? Is this normal?

      2. I have heard that there have been problems with appsnapp loading, so is this still happening?

      3. So if I jailbreak again and apple releases another firmware does anyone feel they will brick jailbroke phones or just those are unlocked not on at &t?

      As always everyone is a great help on the site...
    1. daniel_m352000's Avatar
      daniel_m352000 -
      Quote Originally Posted by Dman51 View Post
      guys 1.1.2 isnt worth it. Its for euros to change time n **** nothin new.
      Does anyone know if cyberduck works with iphone 1.1.1?
      works very well
    1. Murfunit's Avatar
      Murfunit -
      Quote Originally Posted by will042082 View Post
      so just to clarify, i don't really need to do this if i don't want 1.1.2, aint broke don't fix it, but if/when i plug into itunes, does it force me to update before syncing etc? or can i just opt NOT to update and continue using itunes as usual?
      It never forces you to update. You can sync without updating. All you need to do is be careful what you agree to
    1. mrl0n3ly714's Avatar
      mrl0n3ly714 -
      PLEASE CORRECT ME IF I WRONG ALL OF THIS MOTHOD for firmware 1.1.2 is just jailbreak right ? SO what is the point if just jailbreak ur fone and couldn't unlock the sim.....
    1. mofolo's Avatar
      mofolo -
      Quote Originally Posted by mrl0n3ly714 View Post
      PLEASE CORRECT ME IF I WRONG ALL OF THIS MOTHOD for firmware 1.1.2 is just jailbreak right ? SO what is the point if just jailbreak ur fone and couldn't unlock the sim.....
      because people on AT&T have the right to have 3rd party apps too.
    1. Affliction's Avatar
      Affliction -
      ok anyone having trouble with ssh? i keep getting this error "Error skipping startup message. Your shell is probably incompatible with the application (BASH is recommended)."

      at the top it says
      connection closed unexpectedly server sent command exit status 127

      nevermind i figured it out
    1. rfracing's Avatar
      rfracing -
      Quote Originally Posted by mrl0n3ly714 View Post
      PLEASE CORRECT ME IF I WRONG ALL OF THIS MOTHOD for firmware 1.1.2 is just jailbreak right ? SO what is the point if just jailbreak ur fone and couldn't unlock the sim.....
      Some of us actually pay AT&T for our service and like it, no probs here, just want 3rd party apps on the phone!! LOL!!

      Anyone having probs with really slow installer.app?
    1. pdconner's Avatar
      pdconner -
      I have a phone with 1.1.2 on it (becuase apple had me upgrade) I have came back to 1.1.1 8 times and nothing works (not even getting the patch or what ever from installer) it wont give you a chance to activate the phone and it shows no bars for at&t. I have had to downgrade to 1.0.2 and load everything from there.. IT doesnt work if you have had 1.1.2 on your phone to go to 1.1.1...

      Sorry

      Patrick
    1. yowiphone's Avatar
      yowiphone -
      thats good
    1. Affliction's Avatar
      Affliction -
      i think there is a certain way you have to downgrade i downgraded and used a walkthrough and mine worked fine the only prob i had was with openssh but i fixed that, now the only thing i can do is instal dock which is making me mad but maybe it will b fixed soon good luck to all im updated and good to go thanks for all the help from the forums
    1. Drakenza's Avatar
      Drakenza -
      Great news everyone,

      iDemocracy 2.0 now has the official Dev Team 1.1.2 jailbreak incorporated as an optional part of the process. It will guide you through the whole thing so don't worry. (Tested and confirmed working). It can unlock 1.1.2 as well using the Elite Team's method.
      Not only that, but it brings a number of features (most of which are yet undisclosed... believe me ) which I can confirm all work splendidly well on firmware 1.1.2.

      Also, a couple of answers:
      - About the slow Installer.app thing, it's been like that for me since 1.1.1 (actually since they came up with v3.0). Especially refreshing sources and all that. It seems to be getting worse now, but I think the AppTapp guys are working on it. I'm pretty sure there are no 1.1.2-specific problems.
      - People having trouble getting the 1.1.2 jailbreak to work: I had to use iTunes 7.4 to restore to 1.1.1 and then upgrade to iTunes 7.5 to do the update to 1.1.2 before the jailbreak would download from the iPhone properly. Dunno why, but that fixed it for me and might help you as well.
      - People who aren't getting how this process works: Go in this sequence--First, use Installer.app in 1.1.1 to install OktoPrep (in the Tweaks 1.1.1 Section). Then upgrade to 1.1.2 in iTunes. Then run the jailbreak by double clicking "windows.bat" on Windows or "osx" in OS X.
      - People who can't upgrade to 1.1.2 in iTunes: Not all iTunes are seeing 1.1.2 for some reason. To get around this, go the the Downloads section on this site, and then the Firmware folder. Download firmware 1.1.2 and save it somewhere. In iTunes, SHIFT+Click "Check for Updates" with your 1.1.1 iPhone plugged in, and choose the ipsw file. You do not need to be in recovery/DFU mode in order to do this.

      Hope that helps a few people.

      -- Drakenza
    1. easty111's Avatar
      easty111 -
      hi mate can you help me, i bought a iphone unlocked, when i got it worked fine then i went on i tunes and upgraded it, it now says insert sim, is it stuffed, can it be fixed if so were do i go , how do i do it, your help will be appreciated thanks kyle
    1. GalaxyNET's Avatar
      GalaxyNET -
      Quote Originally Posted by easty111 View Post
      hi mate can you help me, i bought a iphone unlocked, when i got it worked fine then i went on i tunes and upgraded it, it now says insert sim, is it stuffed, can it be fixed if so were do i go , how do i do it, your help will be appreciated thanks kyle
      http://modmyi.com/forums/showthread.php?p=89929
    1. samx's Avatar
      samx -
      can some help me too, (windows vista) went from

      1.1.1>oktoPrep>forceupdate1.1.2>error "need to run OktoPrep before updating>

      downgrade 1.02>upgrade to 1.1.1>OktoPrep(I damn made sure it was installed)>Force update to 1.1.2>same error again,

      wtf am I doing wrong.