• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Installer.app 3.0!
    Posted by Ste.
    “LG”, of Nullriver Software, just told me that he hopes to release Installer.app 3.0 shortly, perhaps as early as today. He just has one last piece to complete first. He says “The new installer is just so much better. [There’s] really no point keeping people on the old one anymore.”

    I have been testing the new version for a while now. New features include, but aren’t limited to:

    -Redesigned UI
    -Collapsed groups on the Install page
    -“Recents” category on the Install page, for “Today”, “Yesterday” and “Older”
    -Ability to easily add/remove Sources
    -Abilty to easily install all available updates
    -A “Featured” page that currently is used as an info page
    -“More Info” no longer opens Safari

    This is SO awesome!

    UPDATE: It's out!


    This article was originally published in forum thread: Installer.app 3.0! started by Dash-2 View original post
    Comments 143 Comments
    1. kenymc1's Avatar
      kenymc1 -
      don't up grade to 1.11 yet. there is nowhere on the web to re download the program only on your old firmware. Wait for support, I wish I had. I got happy and upgraded and lost my installer app.
    1. xplod4202's Avatar
      xplod4202 -
      Same here, i wish they didn't put that thing where they said it needs 1.1.1 to work properly. I hope they fix the installer app soon, i need my custom tones and all my apps back
    1. elr0y7's Avatar
      elr0y7 -
      Quote Originally Posted by kenymc1 View Post
      don't up grade to 1.11 yet. there is nowhere on the web to re download the program only on your old firmware. Wait for support, I wish I had. I got happy and upgraded and lost my installer app.
      Just download it from the downloads section under software. If you're using an iphone with firmware 1.0.2 then use a program like iBrickr to put it on your phone, if you're using a phone on firmware 1.1.1 then you will need to use a program that utilizes SSH like winSCP to move it onto your phone, there's plenty of guides to tell you how. If you can't find 3.0 just download one of the older versions of installer and upgrade it through itself, if you have the right sources it should pop right up.

      Not to sound like a douche but I really feel sorry for those of you who caught up in the confusion. I can see how you would be with some of the false information you are getting from other people on this forum, there's really a loss of accurate communication here, just use your best judgement.
    1. joedornan's Avatar
      joedornan -
      Quote Originally Posted by 02589 View Post
      To be honest, there are a ton of unknown variables, so I would hate to lead you down the wrong path. I find it hard to believe installer is not on your phone. Personally, I'd go to great lengths beyond the scope of this thread to find it. If that failed, I would probably try to reinstall Apptap as though it were an original installation. I don't know if this is right and I can't recommend it, but it's probably what I would do.


      And since you are on 1.0.2, you do have a ton of options to go back and start over. Sure, it takes some time and you might have to read up on old news. OTOH, it might refresh yourself and give you a better understanding of the whole thing.

      Keep us updated.
      thanks 02589. I am sure installer.app is there, it is just bumped off the springboard home screen. I'm going to do some more research to see if there is a way to launch installer.app some other way, and if there is a safe way of removing the apps that it installed (in the hopes of having it show up in the home screen).

      Also, I will probably start a new thread to deal with this problem since this thread is pretty noisy with other issues and comments right now.
    1. RareProjectz's Avatar
      RareProjectz -
      how can i add sources in the neww installer, and what additional sources do you recommend
    1. Dash-2's Avatar
      Dash-2 -
      Quote Originally Posted by RareProjectz View Post
      how can i add sources in the neww installer, and what additional sources do you recommend
      Here's how to install the 3 main "pirate" sources.
      The other two URLs are at the bottom.
      http://code.google.com/p/iswitcher/wiki/HowToAddSource
    1. iphoneroeth's Avatar
      iphoneroeth -
      Quote Originally Posted by xplod4202 View Post
      You can get 3.0 if you refresh your old instaler app directly from your phone.
      And as of now you can't put it directly on you 1.1.1 phone. The app is not ready yet. Its very strange, on the app its saying that it will work on 1.1.1 but there is not installer app with that on version number on the list.
      thanks. I upgraded to 1.1.1 the day it came out. I guess I'm stuck until AppTapp natively installs into 1.1.1
    1. Iphoneclueless's Avatar
      Iphoneclueless -
      Hi,
      I have Installer v2.63 on mi iphone, but when I go to update I get nothing... yes I press "refresh" and the program does "refreshing sources" and later "registering packages"... but no update shows up. How can I fix this???
      I already downloaded and reinstall v2.63.
    1. xplod4202's Avatar
      xplod4202 -
      Follow this link and add it manually.

      http://code.google.com/p/iswitcher/wiki/HowToAddSource
    1. atm_10142k's Avatar
      atm_10142k -
      I installed on two of my Iphones with 1.0.2 fireware and have not had any problems. at all. works like a charm.
    1. HITCH's Avatar
      HITCH -
      Runs smooth on 1.0.2...never downgraded..
    1. Dash-2's Avatar
      Dash-2 -
      Version 3.0b4 is out!
      It fixes some install/uninstall issues.
    1. CD65's Avatar
      CD65 -
      I have installer 2.63 installed yet in my uninstall list, it says that I am running 3.0b4. Trying to reinstall this (yes, from the Uninstall list) results in a "No location defined in package" error. The file has a size of 0 bytes. I do not have installer 3 on my iPhone but I did have it before virginizing and then upgrading to 1.1.1. I'm thinking that the iphone somehow is referring to my old installer 3 even though it no longer exists on my iphone.

      Wondering if there is someway to fix this....
    1. chazzzzy's Avatar
      chazzzzy -
      I have the same issue CD65. I would like to upgrade but am not getting that option on 1.1.1
    1. joedornan's Avatar
      joedornan -
      For those with 1.0.2 who updated to installer 3, and who found their installer icon disappeared from their springboard home screen, I can confirm that this solution worked for me:

      http://www.modmyi.com/forums/showthread.php?t=11584

      use:
      http://cre.ations.net/creation/ibrickr

      to install:
      http://iphone.exploit.org/pxl/SummerBoard-2.11.pxl

      to regain access to installer.app
    1. Jaysonic88's Avatar
      Jaysonic88 -
      Just as an fyi...found a bug on newest version of installer 3.

      Trying to install CIDE or Web1913 (both are Dictionary files) will cause a long hang followed by a hard reboot. Both were installable under 2.11
    1. bensmith91's Avatar
      bensmith91 -
      I'm having the same issue as CD65 and Chazzzzy as well. Anyone know why this is happening?
    1. chazzzzy's Avatar
      chazzzzy -
      Wow.. what a bummer! Am I going to have to go through the whole process of downgrading my phone again.. installing AppTap, then upgrading to 1.1.1? Or downgrading installing AppTap then upgrading apptap in 1.0.2 to vs. 3.. then Upgrading to 1.1.1?? I really wish the AppTap guy would update his website and say that Installer/AppTap works with 1.1.1. This is really frustrating.
    1. tekwiz's Avatar
      tekwiz -
      Quote Originally Posted by CD65 View Post
      I have installer 2.63 installed yet in my uninstall list, it says that I am running 3.0b4. Trying to reinstall this (yes, from the Uninstall list) results in a "No location defined in package" error. The file has a size of 0 bytes. I do not have installer 3 on my iPhone but I did have it before virginizing and then upgrading to 1.1.1. I'm thinking that the iphone somehow is referring to my old installer 3 even though it no longer exists on my iphone.

      Wondering if there is someway to fix this....

      Same issue here, on a maybe related note I have tried installing both the new summerboard via installer 2.63 as well as the 1.1.1 ipod tweaks and all say I must have firmware 1.1.1 but I do have it...even my SystemVersion.plist says it..
    1. mdbsat's Avatar
      mdbsat -
      EXACTLLY my problem! i have 1.1.1 and STILL cant download summerboard!! ugh....any help would be great