• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • New T-Zones Hack


    T-Mobile USA has changed the IP address in their system for the T-Zones service. For anyone on 1.1.4 and below you will have to SSH in and manually change your settings (see below) or upgrade to 2.0+ and install the NEW T-Zones Hack provided by Big Boss in Cydia. For anyone on 2.0+ who has the previous hack installed you will need to update to the new one.

    You must subscribe to the $5.99 T-Zones service for the T-Zones hack to work.

    "For 1.1.x users that really don’t want to upgrade, you can fix proxy.pac yourself but editing the file /var/preferences/proxy.pac and changing “10.0.0.0″ to “25.0.0.0."

    [sleepers.net]
    This article was originally published in forum thread: New T-Zones Hack started by Poseidon79 View original post
    Comments 73 Comments
    1. jjp72's Avatar
      jjp72 -
      Quote Originally Posted by freshster View Post
      After editing the proxy.pac file, I would suggest that you reboot the iphone and be patient.
      Also check and make sure your APN is set correctly to wap.voicestream.com
      Most of the time it takes a few attempts (initially) to get T-Zones working.
      Start by trying the Weather app, then try the Stocks app.
      THEN try Safari.

      Once you get data flowing, you should be set.
      Good luck!
      thanks for the continued help - much appreciated.

      ok, so i have a new, possibly bigger problem:

      tried to uninstall the old hack, reinstall it and then make sure proxy.pac was exactly was you had it. somehow during the process something must have happened, and now after uninstalling and reinstalling the hack, when i use cuteftp to ssh i can no longer see proxy.pac at all. in private/var/root (where i used to see proxy/pac) i have 'library', 'media' and 'smartrss.txt' and that is all. could it have gotten deleted somehow? if so, what do i do about that? can i get it back somehow?

      apologies for all the questions, but i'm trying to learn my way through this stuff. thanks.

      EDIT: ok, so i found proxy.pac on my hard drive from my earlier attempts at this (before i edited it), and so i dragged it back into private/var/root. that should do the trick for that problem, right? now to edit again and try to get the data flowing.
    1. VBP2004EP3's Avatar
      VBP2004EP3 -
      I couldn't get it to work on 1.1.4 so i just upgraded to 2.0.2 and everything's working fine
    1. Boxerman1's Avatar
      Boxerman1 -
      Okay well the T Zones hack didn't work for me so I just called T-mobile told them I had an iPhone(they didn't care) they set me up with the unlimited data plan(19.99) he even helped me setup my iPhone and told me to type internet2.voicestream.com into the APN field. T-mobile is awesome if you need help just call them they don't care if you have an unlocked iPhone they still have techs there that will help you out. I wouldn't mention the Tzones hack they might not care to help you too much with that

      also, the unlimited works with ALL apps including Youtube, maps, weather, and Pandora
    1. pacmac's Avatar
      pacmac -
      im on 1.1.4 i have 19.99 data plan..everything works fine but when i go to engadget sometimes it wont load up a complete page but sometimes it does..same for myspace and other sites i go to..how do i fix that?

      do i have to upgrade to 2.0 or that fix only works for 5.99 t-zone hack?

      thanks
    1. jordan19s's Avatar
      jordan19s -
      this is pissing me off!!!!! mine still dont work
    1. Boxerman1's Avatar
      Boxerman1 -
      the hack only works with tzones. You can try internet3.voicestream.com as your APN settings instead. That may help. If not just switch back.
    1. Ikemann888's Avatar
      Ikemann888 -
      T-Zones didn't work since yesterday. Just fixed it with SSH change "10.0.0.0" to "25.0.0.0", reboot. Now working okay again.

      Location: Newport Beach, CA

      Stock, Weather, Safari all work fine. Google map loaded but current location not working right, got a message "Your location could not be determined" any idea to fix this?
    1. ricanstructed311's Avatar
      ricanstructed311 -
      off topic question...can I upgrade to the 2.0 firmware and still use tmobile??
    1. kensleydusen's Avatar
      kensleydusen -
      ok well Iam on 2.0.2 still not working for me, I even restore my phone then applied the tzones hack. not working, says ''internal error you do not have access to the site in www.google.com" gives the samething for any site expect yahoo.com


      please help
    1. b4lyph's Avatar
      b4lyph -
      I am pretty sure I found out the answer to why it is not working even when you changed the proxy.pac file in /var/preferences/. The reason is the proxy.pac file needs to be in "TWO" places. The first one is in /var/preferences and the next one is in /private/var/root. If both of your proxy.pac files are setup like this:

      function FindProxyForURL(url, host)
      {
      if ((isInNet(myIpAddress(), "25.0.0.0", "255.0.0.0")) || (isInNet(myIpAddress(), "10.0.0.0", "255.0.0.0")))
      return "PROXY 216.155.165.50:8080";
      else
      return "DIRECT";
      }

      like the other user said, than you should be browsing the internet once again. Hit me up if you need any additional help.

      Quote Originally Posted by kensleydusen View Post
      ok well Iam on 2.0.2 still not working for me, I even restore my phone then applied the tzones hack. not working, says ''internal error you do not have access to the site in www.google.com" gives the samething for any site expect yahoo.com


      please help
      Just add the modified proxy.pac file that you edited to /private/var/root and restart and you'll be just fine. Post to this forum again if it works for you so others can know.

      I was lost trying to figure out what was going on for a few days now. I just saw the other proxy.pac file while trying to backup my iphone for the update since I thought that was my only chance of getting t-zones working again. I just did it a little while ago and it works now!! FINALLY!!
    1. jjp72's Avatar
      jjp72 -
      Quote Originally Posted by b4lyph View Post
      I am pretty sure I found out the answer to why it is not working even when you changed the proxy.pac file in /var/preferences/. The reason is the proxy.pac file needs to be in "TWO" places. The first one is in /var/preferences and the next one is in /private/var/root. If both of your proxy.pac files are setup like this:

      function FindProxyForURL(url, host)
      {
      if ((isInNet(myIpAddress(), "25.0.0.0", "255.0.0.0")) || (isInNet(myIpAddress(), "10.0.0.0", "255.0.0.0")))
      return "PROXY 216.155.165.50:8080";
      else
      return "DIRECT";
      }

      like the other user said, than you should be browsing the internet once again. Hit me up if you need any additional help.
      worked for me! i had the edited proxy.pac in /private/var/root already, but the one in /var/preferences hadn't been edited. once i did that i rebooted, checked the stocks app and got the data flowing, then checked safari, weather, maps and all are working.

      thanks so much for the help.
    1. beaner4sho's Avatar
      beaner4sho -
      I added another proxy pack on private>var>root and still nothing... Man this is pissing me off!!
    1. freshster's Avatar
      freshster -
      Quote Originally Posted by beaner4sho View Post
      I added another proxy pack on private>var>root and still nothing... Man this is pissing me off!!
      Please try my documented procedure for the T-Zones hack.
      It does not use a proxy.pac script, which makes it much more reliable for any IP subnet changes that T-Mobile may make.

      http://www.modmyi.com/forums/t-mobil...-pac-file.html
    1. Ikemann888's Avatar
      Ikemann888 -
      Prior to T-Mobile changed the IP address for T-Zones service, my 1.1.4 with T-Zones hacked worked fine with edge. All Stocks, Weather, Safari, iTunes, and Maps were working fine.

      After the change & fixed on proxy.pac, all work fine except Maps could not locate current location on Edge mode (on wifi mode still working fine), anyone know how to fix this problem? Thank you.

      Updated: Google Maps current location function works on other areas on Edge mode, in Los Angeles & Buena Park CA both work okay. I believe its depend on signal Tower.
    1. bobby_nguyen's Avatar
      bobby_nguyen -
      Wichita, KS - tmo must have changed their ip here, stopped working a few days ago.

      Putting the proxy.pac in the second place solved my issue with the 4 iphones i was working on. The stock and weather worked, but no safari. Phones are on 201/202. thanks
    1. dq13's Avatar
      dq13 -
      Like other users have said, this must be in some areas only. I am in Miami, running 2.0.1 and I haven't made any changes and everything still works. I installed the T-Zones Hack from Cydia when I updated the firmware, like 2 maybe 3 weeks ago and it's been working since w/o problems
    1. trilogy069's Avatar
      trilogy069 -
      Quote Originally Posted by ricanstructed311 View Post
      off topic question...can I upgrade to the 2.0 firmware and still use tmobile??
      I am on 2.0.2 and having no issues...u will be fine...just read the posts.
    1. 6309phone's Avatar
      6309phone -
      I removed my t-zones hack, used the link provided above that bypasses proxy.pac and it works FINE!!!!! 1.1.4 iphone - works perfectly.
    1. JackedTiTan's Avatar
      JackedTiTan -
      Thanks! Saved my life...
    1. miamib30514's Avatar
      miamib30514 -
      My edge has been down for about a week and i cant figure out how to get it back. i upgraded to the t zones hack 2.0 but i dont know what to do after that. i keep reading about changing a "proxy.pac..." where do you do this on the phone or on the computer? im completely lost and any help will be greatly appreciated THANKXXXX.....im on 2.0.1 by the way.