• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Pwnage 2.0 Full Guide w/Pics Up


    Hey guys, the full guide is up here:

    1st Gen iPhone Guide

    3G iPhone Guide

    Enjoy.

    edit: iPhone 3G is NOT unlocked yet. It will NOT yet work with T-Mobile - if you're unlocked, do NOT USE PWNAGE YET.
    This article was originally published in forum thread: Pwnage 2.0 Full Guide w/Pics Up started by Kyle Matthews View original post
    Comments 213 Comments
    1. latoya00's Avatar
      latoya00 -
      How can I unlock old iphone to 2.0 using a PC???
    1. Havokiphone's Avatar
      Havokiphone -
      any Windows version is this masterpiece?

      ahhh nvm i read above... tee hee hee... thanks
    1. cates044's Avatar
      cates044 -
      Quote Originally Posted by [email protected] View Post
      make sure the unlock is checked and i think there is one more the needs to be checked in that same screen maybe just try the unlock first
      Thanks for the help but I've tried that still with no luck. Last night I tried proceeding anyway without that step and I had temporarily bricked my phone, but I got it back to 2.0 non jailbroken.

      Does anybody know a fix for getting Pwnage to ask for the bootloader files?
    1. Wudstock's Avatar
      Wudstock -
      I thought I’d write and say THANKS to the Dev Team and Poetic Folly for the absolutely wonderful PWNAGE app and tutorial.

      I wasn’t going to upgrade until I heard about a few success stories first, but I got to the point where my phone was staring at me, taunting me ~Upgrade Me~… So I jumped in with both feet and took the plunge. No guts no glory eh?

      I was a little worried about PWNAGE working on a Hackintosh running Leoprad, but there were no problems as a result (PWNAGE opened fine). The only confussion was whether or not to keep iTunes open while opening PWNAGE (PF didn’t specify). The answer is yes, you want to have iTunes open while going through PWNAGE and building the firmware (please correct me if I’m wrong, this worked for me). There was one hick-up during installation but that was the crappy HD I was using, it errored out a couple of times, so I saved my new firmware directly onto a 2 gig Flash Drive instead. Everything else worked like a charm and I am now running 2.0 on my first Gen Phone.

      T-Mobile: Working

      Edge (T-Zones): Working (You have to load OpenSSH first, then the T-Zones Patch in ‘Tweaks’. (From Cydia of course.) Once loaded, power down the phone. Turn back on and type ‘wap.voicestream.com’ in the APN field (Settings>General>Network>Cellular Data Network>APN) No password needed. Keep in mind you have to pay $5.99 per month for T-Zones to work, otherwise you will not see the ‘Cellular Data Network’ field.)

      YouTube: Working

      Locate Me: Working (I was surprised about this one)

      App Store / Apps: Working (WiFi and Edge)

      SMS: Working


      After having gone through this, feel free to ask me any questions you have.

      Thanks again Dev Team and Poetic Folly for making my weekend.

      Sincerely
      Wudstock
    1. eyefone4949's Avatar
      eyefone4949 -
      Okay, first let me say I am not a complete noob. I do know how to search and usually find an answer. Until now.
      I waited until the dev team did their magic before I updated my iPhone to 2.0.

      I have a 1st Gen iPhone running 1.1.4 jailbroken (jailbreaked??) using Pwnage Tool 1.0.
      I updated to iTunes 7.7.
      Downloaded PwnageTool 2.0 and now 2.0.1.

      Now, I can read directions/guides fairly well and have checked to make sure I didn't miss anything.
      Here's my problem:
      I connected iPhone to iTunes to "Download Only" the 2.0 ipsw. (iPhone1,1_2.0_5A437_Restore.ipsw)
      When I run PwnageTool and search for the ipsw it says "Wrong Firmware Bundle Selected".
      I know people had this issue before and it was because they had the wrong bundle (for 3G) but I have the bundle that Apple said is for my iPhone. I also downloaded different ipsw's from various links and even tried the 3G bundle. Nothing works. Am I missing something?
      Any help would be greatly appreciated!!!
    1. kadinh's Avatar
      kadinh -
      Quote Originally Posted by Wudstock View Post
      I thought I’d write and say THANKS to the Dev Team and Poetic Folly for the absolutely wonderful PWNAGE app and tutorial.

      I wasn’t going to upgrade until I heard about a few success stories first, but I got to the point where my phone was staring at me, taunting me ~Upgrade Me~… So I jumped in with both feet and took the plunge. No guts no glory eh?

      I was a little worried about PWNAGE working on a Hackintosh running Leoprad, but there were no problems as a result (PWNAGE opened fine). The only confussion was whether or not to keep iTunes open while opening PWNAGE (PF didn’t specify). The answer is yes, you want to have iTunes open while going through PWNAGE and building the firmware (please correct me if I’m wrong, this worked for me). There was one hick-up during installation but that was the crappy HD I was using, it errored out a couple of times, so I saved my new firmware directly onto a 2 gig Flash Drive instead. Everything else worked like a charm and I am now running 2.0 on my first Gen Phone.

      T-Mobile: Working

      Edge (T-Zones): Working (You have to load OpenSSH first, then the T-Zones Patch in ‘Tweaks’. (From Cydia of course.) Once loaded, power down the phone. Turn back on and type ‘wap.voicestream.com’ in the APN field (Settings>General>Network>Cellular Data Network>APN) No password needed. Keep in mind you have to pay $5.99 per month for T-Zones to work, otherwise you will not see the ‘Cellular Data Network’ field.)

      YouTube: Working

      Locate Me: Working (I was surprised about this one)

      App Store / Apps: Working (WiFi and Edge)

      SMS: Working


      After having gone through this, feel free to ask me any questions you have.

      Thanks again Dev Team and Poetic Folly for making my weekend.

      Sincerely
      Wudstock
      that is awesome! makes me wish that we had t-mo in this area. i have at&t
    1. Wudstock's Avatar
      Wudstock -
      Quote Originally Posted by kadinh View Post
      that is awesome! makes me wish that we had t-mo in this area. i have at&t
      No problem Bro, AT&T will work too.

      Wudstock.

      Quote Originally Posted by eyefone4949 View Post
      Okay, first let me say I am not a complete noob. I do know how to search and usually find an answer. Until now.
      I waited until the dev team did their magic before I updated my iPhone to 2.0.

      I have a 1st Gen iPhone running 1.1.4 jailbroken (jailbreaked??) using Pwnage Tool 1.0.
      I updated to iTunes 7.7.
      Downloaded PwnageTool 2.0 and now 2.0.1.

      Now, I can read directions/guides fairly well and have checked to make sure I didn't miss anything.
      Here's my problem:
      I connected iPhone to iTunes to "Download Only" the 2.0 ipsw. (iPhone1,1_2.0_5A437_Restore.ipsw)
      When I run PwnageTool and search for the ipsw it says "Wrong Firmware Bundle Selected".
      I know people had this issue before and it was because they had the wrong bundle (for 3G) but I have the bundle that Apple said is for my iPhone. I also downloaded different ipsw's from various links and even tried the 3G bundle. Nothing works. Am I missing something?
      Any help would be greatly appreciated!!!
      Are you sure it's asking you for the IPSW and not the bootloader files? If so, make sure you put the IPSW in the folder specified in the instructions, or let iTunes download it to the default location. PWNAGE will only look for the IPSW in the default download location.


      Hope this helps
      Wudstock.
    1. kadinh's Avatar
      kadinh -
      Quote Originally Posted by Wudstock View Post
      No problem Bro, AT&T will work too.

      Wudstock.
      and i have XP

      but w/ t-mo it sounds a lot cheaper to have service instead of at&t's iphone plan.
    1. eyefone4949's Avatar
      eyefone4949 -
      Quote Originally Posted by Wudstock View Post
      No problem Bro, AT&T will work too.

      Wudstock.



      Are you sure it's asking you for the IPSW and not the bootloader files? If so, make sure you put the IPSW in the folder specified in the instructions, or let iTunes download it to the default location. PWNAGE will only look for the IPSW in the default download location.


      Hope this helps
      Wudstock.
      Oh, I can't even get to the bootloader part.
      Pwnage: "No IPSW found. Would you like to browse the web for this file?
      Me: "No"
      Me: clicks "Expert Mode"
      Pwnage: "Browse for IPSW"
      Pwnage: "Wrong Bundle blah blah blah"
      I've downloaded so many different iPhone1,1_2.0_5A437_Restore.ipsw files it's not even funny.

      I let iTunes DL it to the default
      i tried both:
      ~/Library/iTunes/iPhone Software Updates
      and
      ~Users/"me"/Library/iTunes/iPhone Software Updates

      Nothing...
    1. galaga_z's Avatar
      galaga_z -
      Quote Originally Posted by cates044 View Post
      I cannot for the life of me get Pwnage to ask me for the bootloader files. I have tried deleting and reinstalling the app numerous times from all 3 sources. Any ideas??
      I am having the same exact problem as, Cates. I've tried re-installing pwnage and bootloader files, but no luck. I cant seem to get pwnage to ask for the Bootloader v3.9 file, or the v4.6 bootloader file. Everything is checked in the Bootneuter settings just as the guide calls for.

      Any other suggestions would be greatly appreciated. Thanks to all the people who have been so helpful answering all the questions related to pwnage. And you too, Dev team
    1. LGgeek's Avatar
      LGgeek -
      My understanding ( ya limted) is 2.0 has completely new frameworks so the old installer apps ( smartrss , customize, agilemessenger, etc) will not run.
      correct or incorrect ?
    1. 808mp5's Avatar
      808mp5 -
      Too Easy... Thank you DevTeam
    1. galaga_z's Avatar
      galaga_z -
      Quote Originally Posted by cates044 View Post
      I cannot for the life of me get Pwnage to ask me for the bootloader files. I have tried deleting and reinstalling the app numerous times from all 3 sources. Any ideas??
      cates044, here is what I did to get pwnage to recognize the bootloader files:

      1) I deleted pwnage tool and the bootloader files I previously downloaded.
      2) The I re-downloaded the files from the following sites:

      Pwnage tool-- blog.iphone-dev.org (Scroll down the page and look for the link that says "_BigBoss_’s repository"). Click on this and it will download the pwnage tool for you

      bootloader files-- RapidShare: Easy Filehosting

      3) I unzipped and re-installed the above files
      4) I followed the guide for pwnage tool made by the modmyi staff, and this time pwnage tool recognized the bootloader files.
      5) Follow the rest of the guide from where you are stuck and you should be good to go

      GOOD LUCK!!

      Everything worked perfectly after I downloaded the above files. I'm jailbroken and unlocked. Nice work Dev team!!! And thanks to the modmyi team for putting up with many of the ridiculous questions. Everyone is fantastic within this site
    1. Xtremeiphone's Avatar
      Xtremeiphone -
      i want to thank the Dev team for releasing this ! you guys are truley amazing and talented. i would really like to make you guys a FREE custom shirt with your name on it as a thank you. here in NJ we have a sign shop and i do all kinds of vinyl signage, screen printing & embroidery, please get back to me i would like to throw your logo on a shirt ! thanks again !
    1. Osglith's Avatar
      Osglith -
      Come on T-Mobile support. I love you guys long time if I g3t t-mobile support!
    1. baskln's Avatar
      baskln -
      yes, it unlocks and jailbreaks. My phone is a 1.1.2 OTB unlocked and jailbroken with 1.1.4 using ILiberty.
    1. GreatOBI's Avatar
      GreatOBI -
      Is this program out for windows pc?
    1. dm_hawk's Avatar
      dm_hawk -
      just finished upgrading/jailbreaking my previously jailbroken 1.1.3 (not unlocked) 1st gen iphone to FW 2.0 using Pwnage Tool, then restored previous data via itunes.

      everything is as it should be (pineapple logo, cydia, wifi, etc.) EXCEPT that the phone doesn't seem to be connected to my cellular network or EDGE.

      -it says "No Service" where the signal bars and AT&T logo should be.
      -in Settings/General/About/Network, it says "Not Available"
      -any attempt to make a phone call results in a "Call Failed" screen.
      -incoming calls go directly to voice mail.
      -the iphone SIM card works fine in my Sony-Ericsson phone.
      -restarting the iphone didn't work.

      ANY suggestions would be appreciated... thanks in advance.

      UPDATE: i tried running Pwnage Tool 2.01 again, but in SIMPLE mode this time - my ATT network signal is back - it worked like a charm!
    1. ghallegher's Avatar
      ghallegher -
      damn!!! it can't get easier than this... thanks a lot guys...
    1. pnmd's Avatar
      pnmd -
      Quote Originally Posted by dm_hawk View Post
      just finished upgrading/jailbreaking my previously jailbroken 1.1.3 (not unlocked) 1st gen iphone to FW 2.0 using Pwnage Tool, then restored previous data via itunes.

      everything is as it should be (pineapple logo, cydia, wifi, etc.) EXCEPT that the phone doesn't seem to be connected to my cellular network or EDGE.

      -it says "No Service" where the signal bars and AT&T logo should be.
      -in Settings/General/About/Network, it says "Not Available"
      -any attempt to make a phone call results in a "Call Failed" screen.
      -incoming calls go directly to voice mail.
      -the iphone SIM card works fine in my Sony-Ericsson phone.
      -restarting the iphone didn't work.

      ANY suggestions would be appreciated... thanks in advance.

      UPDATE: i tried running Pwnage Tool 2.01 again, but in SIMPLE mode this time - my ATT network signal is back - it worked like a charm!
      ATT users: In pwnage tool Expert Mode, under the "General" tab you have to uncheck "activate." Your iphone will be activated by iTunes during the restore process.