• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Peer 2 Peer File Sharing Hits iPhone / iPod Touch with iSlsk
    We all knew it was coming but now it's here. Peer 2 Peer on the iPhone. The app is called iSlsk and is basically a nice port of Soulseek to the iPhone. With easy to use features you can search other users on their network and download some music.


    video courtesy of app developer errrick | his site

    Where do you get it? Just refresh Installer and look for iSlsk from the Big Boss source.
    edit: if the file stays at 0% in the app its probably because the user sharing the file isn't online

    Features:
    • File Search lets you easily search for files
    • Transfers shows you your que of downloads and download progress.
    • Downloads lets you view what you have downloaded
    • A nice import feature lets you import you files into your music database, allowing you to play them through the normal iPod controls - not working yet . . .

    To get the files you download one of the many apps that allow you to browse the iPhones file directory and browse to /var/mobile/Media/Downloads to play your files. Hopefully the import feature will be fixed soon.

    edit for the FirmwareGUID error first try setting the permissions for the app to 777
    alternatively try this.

    And of course some screenies



    This article was originally published in forum thread: Peer 2 Peer File Sharing Hits iPhone / iPod Touch with iSlsk started by Cody Overcash View original post
    Comments 268 Comments
    1. Rustynuts's Avatar
      Rustynuts -
      Quote Originally Posted by jgrewal87 View Post
      I had the same problem for a while.. i was going to the wrong downloads folder, i guess there is more than one...

      im on 1.1.4.. and my folder is /private/var/root/Media/Downloads.. And i changed the permission of the folder along with everything inside. i did the same with the App, both to 0777.

      i can now find the downloaded files thru SSH'ing, but they dont show up in the downloads screen of the App itself so i cant add to ipod etc.
      i dont have that folder i too am on 1.1.4... hmmm



      also when im trying to chmod or what ever its called, its telling me the file/folder doesnt exist...
    1. mofolo's Avatar
      mofolo -
      FIX:

      http://iphonefreakz.com/2008/05/14/i...or-ipod-touch/
      Scroll past the pictures for the fix.

      Best of luck.
    1. Rustynuts's Avatar
      Rustynuts -
      Quote Originally Posted by mofolo View Post
      FIX:

      iPhoneFreakz iSlsk P2P music sharing on your iPhone or iPod Touch | iPhoneFreakz
      Scroll past the pictures for the fix.

      Best of luck.
      that fix has already been posted twice and it dont work for some of us...
    1. FredieC's Avatar
      FredieC -
      i tired a combo of what everyone said to do on this thread, and nothing works for me
    1. Malik.1st's Avatar
      Malik.1st -
      Quote Originally Posted by egarc View Post
      I just set permissions to 0777 for the Application and Download folder and everything is working perfectly.
      worked for me toooooooooooooooooo
    1. Rustynuts's Avatar
      Rustynuts -
      Quote Originally Posted by Malik.1st View Post
      worked for me toooooooooooooooooo

      what firmware you guys using??
    1. erix920's Avatar
      erix920 -
      Mine works fine, all I did was follow that guide exactly and got the two files needed. After that I made a downloads folder at /Media/ set permissions to 0777 and ran my symlink (I posted the command a few pages back). Started up the app, downloaded the song I wanted, went back into Finder, browsed to /Media/Downloads and sure enough my songs were there to play with avplayer.
    1. Malik.1st's Avatar
      Malik.1st -
      after importing the songs to the library . why can't sync them back to itunes to add photos and lyrics ?
      after synching the songs disappear from the phone .
    1. neontronix's Avatar
      neontronix -
      Hi guys,

      I need help. I accidentally deleted MobileEnhancer folder with all its content, located in private/library. Now my phone wont start up. Just loops in apple logo. this happened just after i deleted it. I need the entire MobileEnhancer folder with its content for SSH. yes i can ssh but will only last for 10 seconds before the next restart. so PLEASE zip me the whole folder. Thanks.
    1. Malik.1st's Avatar
      Malik.1st -
      Quote Originally Posted by Rustynuts View Post
      what firmware you guys using??

      see the signature ......
    1. Rustynuts's Avatar
      Rustynuts -
      Quote Originally Posted by Malik.1st View Post
      see the signature ......
      lmao i dint see that...
    1. chancre_scolex's Avatar
      chancre_scolex -
      I tried using the import feature and for some reason I cant play music now. When I play a song through the ipod app it just sits there. Doesnt play, doesnt do anything.
    1. kyp421's Avatar
      kyp421 -
      the program works fine for me. i download the song, import and it goes to the IPOD. all this without any of the fixes.
    1. Rustynuts's Avatar
      Rustynuts -
      Iv done everything twice over and still the same, tunes are vanishing after download, my iphones memory aint even changing and iv downloaded about 10 songs, im giving up on this, fingers crossed they make a fix in the next update...
    1. timliora's Avatar
      timliora -
      Can't wait for installer update...I usually end up f-ing up my phone trying to fix this app.
    1. acmwallace5's Avatar
      acmwallace5 -
      Everything else works but doesnt play. Drops it in my ipod area on my iphone. Running 1.1.2. Hope update will allow it to play!! Awesome
    1. Valdis's Avatar
      Valdis -
      For some reason i am on a strong wifi connection but the app keeps saying connecting and disconnecting but never connected, what seems to be the problem. I am on a universitys network.
    1. cheezbergher's Avatar
      cheezbergher -
      Quote Originally Posted by acmwallace5 View Post
      Everything else works but doesnt play. Drops it in my ipod area on my iphone. Running 1.1.2. Hope update will allow it to play!! Awesome
      craap. It looks like this app was developed for 1.1.2.
    1. jaredb03's Avatar
      jaredb03 -
      iphonefreakz added a step and suggested to use putty. i don't know which fixed it for me but i couldn't get it to work using terminal so i suggest using putty and doing the extra step.

      Also is finder the best to use? and is there a way to get it to startup in the download folder instead of the application folder? and get it to save starting in that folder?
    1. acmwallace5's Avatar
      acmwallace5 -
      Tried a couple more songs!!! It Plays now!! 1.1.2