• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • ZiPhone - Unlock, Jailbreak, Activate, REPAIR your iPhone - NO DOWNGRADING REQUIRED!
    Zibri has released ZiPhone - an incredible tool for activating, jailbreaking, repairing, and unlocking all versions of iPhones (unlock only works on 1.1.2 and 1.1.3 OTB).

    Its incredibly easy to use, and both OS X and Windows versions are included in the download. Instructions from the readme:

    Connect a brand new phone to the dock.
    Run the program

    Well, you can also use a restored phone...
    Or a normal in use phone...
    Well... whatever !
    Windows download the app from the MMi downloads section (this version is packaged with the .exe gui), or if you're not an MMi member you can download it here or from MediaFire. Windows users you can get a gui here Copy to Ziphone folder and run. requirements : .Net framework 2.0 or above

    OS X download the app here, or if you're not an MMi member you can download it here.


    If you would like to compile the latest version the SVN is located: http://iphone-elite.googlecode.com/svn/trunk/ZiPhone/

    Here's how to use the app:

    Tutorial for noobs:

    1. Put iPhone in Dock

    2. Copy all files under C:

    3. Start/Run --> write cmd --> Hit Enter

    4. Drag ziphone.exe into the cmd window and you will see this:

    C:ziphone.exe"

    5. type -j -a

    and it need to look like this:

    C:ziphone.exe" -j -a

    6. hit enter and follow directions! Directions looking like this:

    ZiPhone v1.0 by Zibri. http://zibree.blogspot.com
    Source code available at: http://www.iphone-elite.org

    Loading zibri.dat.
    Searching for iPhone...
    Please power off the iPhone, then hold the home button
    and connect to dock to enter recovery mode.
    Working...
    Please wait 45".
    Done!


    ( To put your iPhone in recovery mode, hold down sleep/wake + Home Button until you see the iTunes logo on your iPhone)

    7. Do the same thing with dragging ziphone.exe to cmd and write -u

    This looks like this:

    C:ziphone.exe" -u

    ZiPhone v1.0 by Zibri. http://zibree.blogspot.com
    Source code available at: http://www.iphone-elite.org

    Loading zibri.dat.
    Searching for iPhone...
    Working...
    Please wait 2'30".
    Done!
    I will have a better guide up soon in the Wiki, this is just a basic rewrite of a guide a user tossed up.

    Mad props to Zibri and the elite dev team for their incredible work on this!

    http://zibree.blogspot.com/

    ******cash edit******

    This tool also can repair a phone with a "dead" baseband. To quote Zibri's blog

    To REPAIR a *DEAD* baseband, do THIS:

    Put the iphone in recovery mode (NOT DFU..normal recovery mode)

    Then run: ziphone -u

    And you will have back IMEI and WIFI.

    This procedure already worked on 3 phones.
    This article was originally published in forum thread: ZiPhone - Unlock, Jailbreak, Activate, REPAIR your iPhone - NO DOWNGRADING REQUIRED! started by Kyle Matthews View original post
    Comments 568 Comments
    1. geovass's Avatar
      geovass -
      dont think that will upgrade to BL 4.6.
    1. s3rvan7's Avatar
      s3rvan7 -
      Im a little confused... does this unlock your iPhone even if you don't want it to? or can I Jailbreak my 1.1.3 AT&T iPhone w/ out the unlocking part of it?
    1. Cody Overcash's Avatar
      Cody Overcash -
      Quote Originally Posted by s3rvan7 View Post
      Im a little confused... does this unlock your iPhone even if you don't want it to? or can I Jailbreak my 1.1.3 AT&T iPhone w/ out the unlocking part of it?
      all I know is what has been said

      run:
      ziphone [-u] [-a] [-j] [-i imei]
      -u: Unlock (Only for 4.6 BL, it can also fix many dead basebands)
      -a: Activate
      -j: Jailbreak (not a soft update, true jailbreak)
      -v: Verbose boot (debug)
      seems to me if you run ziphone -j -a it would jailbreak/activate and not unlock
    1. rjlamb11's Avatar
      rjlamb11 -


      since 1.1.1 i have not jailbroken my iPhone so im a bit rusty. so i think i did this correctly - the .exe said Done! - if this is now jailbroken how do I put installer.app on my iPhone. I tryed to go to the website for installer.app and it wouldnt work. Any suggestion???
    1. ericidle's Avatar
      ericidle -
      There is a warning out regarding use of -a -j only on 3.9, seems its not working all the time. A new option to ierase 3.9 has been added but I've no idea what the steps are and how it works

      however -a -j -u is reported to work perfectly on 4.6

      http://www.iclarified.com/entry/index.php?enid=656
    1. ballaholyk84's Avatar
      ballaholyk84 -
      Everytime I go to run the program everything is good until the program ends then an error pops up saying "ZiPhone v1.0 has stopped working" and asks to check online for a solution and close the program or just close the program. Am I doing something wrong?
    1. SvB's Avatar
      SvB -
      When I type ziphone -j in Terminal I get:
      dyld: Library not loaded: ./MobileDevice.framework/Versions/A/MobileDevice
      Referenced from: /Users/SvB/Desktop/ZiPhone/ziphone
      Reason: image not found
      Trace/BPT trap

      What's wrong? =(

      UPDATE: Actually, I moved ZiPhone folder to my HOME folder, and typed in Terminal:
      ./ziphone -j

      Works fine!
    1. steve_k's Avatar
      steve_k -
      Quote Originally Posted by Sirhc35 View Post
      So I have a question. I have the 3.9 bootloader. Could I restore my iPhone to 1.1.3 with an unaltered baseband, then use this method to jailbreak and activate, and then use anySIM 1.1.3 to unlock the phone, seeing how that is specifically for iphones with the 3.9 bootloader. Then the phone would be completely unlocked jailbroken, and activated. Just wondering if something like that would work.
      i would love to know too!!!
    1. andrex04's Avatar
      andrex04 -
      UUUGHHH

      I keep getting the message "zibri.dat could not be opened for reading"

      From searching (all results have been in french....and i dont speak french)

      I have found that i need to change permissions to 777, is that right?

      should typing (without <>) into terminal work?, because it doesnt.

      Im hitting my head on the desk and it gets sore....
      please help
    1. mikefrombg's Avatar
      mikefrombg -
      Hi All,

      I just unlocked a 16gb 1.1.3OOTB )

      I have one complaint though.. That was tooo easy ... no errors - no fun , just kiddin'. Awesome guys, who should I donate to?
    1. Cody Overcash's Avatar
      Cody Overcash -
      Quote Originally Posted by mikefrombg View Post
      Hi All,

      I just unlocked a 16gb 1.1.3OOTB )

      I have one complaint though.. That was tooo easy ... no errors - no fun , just kiddin'. Awesome guys, who should I donate to?
      Zibri
    1. grantmaier687's Avatar
      grantmaier687 -
      Quote Originally Posted by Sirhc35 View Post
      So I have a question. I have the 3.9 bootloader. Could I restore my iPhone to 1.1.3 with an unaltered baseband, then use this method to jailbreak and activate, and then use anySIM 1.1.3 to unlock the phone, seeing how that is specifically for iphones with the 3.9 bootloader. Then the phone would be completely unlocked jailbroken, and activated. Just wondering if something like that would work.
      Quote Originally Posted by steve_k View Post
      i would love to know too!!!
      Absolutely. zibri has mentioned this in the comments on his blog, and is currently working on adding 3.9 unlock support as well.

      just jailbreak and activate, and run anysim 1.3 (in airplane mode of course )
    1. andrex04's Avatar
      andrex04 -
      Quote Originally Posted by andrex04 View Post
      UUUGHHH

      I keep getting the message "zibri.dat could not be opened for reading"

      From searching (all results have been in french....and i dont speak french)

      I have found that i need to change permissions to 777, is that right?

      should typing (without <>) into terminal work?, because it doesnt.

      Im hitting my head on the desk and it gets sore....
      please help
      Ok if anyone else gets this message I fixed it by moving the Ziphone folder to my home folder, pulling zibri.dat out of the (ziphone) folder and placing it into my home folder as well, then running chmod 777 zibri.dat in terminal

      Now i am also at the same problem as gramirez
      bus error

      Oh how I envy those of you who had it work
    1. odiyan's Avatar
      odiyan -
      unlock.no released a GUI for Ziphone
      download here

      Copy to Ziphone folder and run
      requirements : .Net framework 2.0 or above
    1. chasev2's Avatar
      chasev2 -
      Is there currently a simple method of upgrading to 1.1.3 for unlocked phones with (non-OTB) 1.1.2 that also upgrades the baseband? Or is the only method currently available the one that involves downgrading to 1.1.1, then upgrading, etc. etc.?
    1. sziklassy's Avatar
      sziklassy -
      I get the error "zibri.dat could not be opened for reading" on both vista and XP Iobviously using the windows folder). Any suggestions?
    1. steve_k's Avatar
      steve_k -
      Quote Originally Posted by grantmaier687 View Post
      Absolutely. zibri has mentioned this in the comments on his blog, and is currently working on adding 3.9 unlock support as well.

      just jailbreak and activate, and run anysim 1.3 (in airplane mode of course )

      i'm currently trying it wish me luck!
    1. sogo's Avatar
      sogo -
      Sweet, but I might still wait.
    1. ballaholyk84's Avatar
      ballaholyk84 -
      Anyone know why as soon as I start the program and it gets to "Searching for iPhone..." It pops up "ZiPhone v1.0 Has Stopped Working" and needs to shutdown?

      iPhone is in recovery mode and ready to go but wont get past this part.

      BTW: Only closes like that when I connect the iPhone
    1. zzclown's Avatar
      zzclown -
      Quote Originally Posted by steve_k View Post
      i'm currently trying it wish me luck!

      LET US KNOW WHAT HAPPENS STEVE!! ASAP!!

      Did your bootloader get updated as well? (3.9 to 4.6)