• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Use Installer to Jailbreak 1.1.3 - MMi Installer Repo
    1/29/08 pf update: This method uses the Dev Team's jailbreak method. They have now released their own Installer version of it on the ConceitedSoftware Community Source, so we will be removing ours.

    1/31/08 update: Regardless of whether you have ATT or not, say YES to hacktivation using this method - if you do not, iTunes will throw an error and not let you use your iPhone until you restore to 1.1.1.

    Digg It!

    Hey! So we've made it even easier to Jailbreak 1.1.3 using the Dev Teams jailbreak method. You will now find 1.1.3 Dev Team Jailbreak in installer, provided to you by the ModMyI repository.

    Poetic_Folly and I have written up a package and tested it thoroughly and it appears that there are no issues running this Jailbreak from Installer

    Requirements
    • Jailbroken 1.1.2 phone
    • Newest version of BSD Subsystem -- version 2.0
    • Latestest Update of Installer.app -- version 3.0b10 (If you are not using the newest version installer will not work on 1.1.3)
    • Phone connected via wifi (its a large download)
    • Settings->General->Autolock SET TO NEVER

    All you need to do is find the 1.1.3 Dev Team Jailbreak package in Installer and run it. The rest will be done for you. Once done (about 20 mins - some reports have been as long as 50 minutes) your phone will restart and you will be updated and jailbroken to 1.1.3!

    Refresh Your Installer Sources to See It

    F.A.Q.
    • I'm on 1.1.1, can't I just install this from there? No. If you're on 1.1.1, follow the guides to update to 1.1.2 jailbroken (and unlocked if you need it), THEN run this from Installer.
    • I already did NateTrue's jailbreak method. Is there a difference? Should I do this one? You don't have to. Supposedly NateTrue's method will break functionality needed to support official 3rd party apps when they come out in February, so it is a good idea to use this method instead.
    • Ok, but how do I erase Nate's method and use this one? You'll have to use iTunes to downgrade all the way to 1.1.1, then follow guides to get back to a jailbroken 1.1.2, and then run this script.
    • What about Google Maps' new features? Do they work any better with this method? Just like NateTrue's method, this does not update your baseband, just your firmware. So yes, you'll still have the same issues with Google Maps not wanting to locate. The going method to fix this is install Navizon, open it and have it find you, then go back to Google Maps and it should work.
    • Will my ringtones/sound/SSH/EDGE/mouthwash still work after I do this? Sure.
    • What about my applications? Do I need to delete them? Will they still be there in 1.1.3? You don't need to delete them, but you will need to reinstall them when you get to 1.1.3. NOTE: SummerBoard and Customize don't work with 1.1.3 yet.
    • Does this method clean out that 185 MB restore file it downloads? No. You'll need to delete it still once you get to 1.1.3.
    if you don't want to use installer but would still like to update via the dev teams method we have MANUAL INSTRUCTIONS

    THIS IS THE DEV TEAMS METHOD so the normal issues are there, some ppl it hangs at the end. IF you want to watch a log of whats going in while you are on 1.1.2 ssh in and run /Applications/Installer.app/Installer then use installer on your iphone to run the jailbreak. You will see a log of whats going on in the ssh window.

    When completed and on 1.1.3 only if you having a problem syncing use scp to copy over syncfix.sh file from this archive to / directory of your iphone. The ssh in and run syncfix.sh. Your syncing problem will be fixed.
    This article was originally published in forum thread: Use Installer to Jailbreak 1.1.3 - MMi Installer Repo started by Cody Overcash View original post
    Comments 967 Comments
    1. ehcropydoc's Avatar
      ehcropydoc -
      Will this work if we have MOVED our APPS with the BOSSTOOL? And also....WHICH ONE DO WE INSTALL? MMI? DEV TEAM? Skylar?
    1. DirtyDan's Avatar
      DirtyDan -
      If anyone is having problems with this feel free to IM me via AIM and I will help you through it or answer any questions you have.

      I've done this successfully everything is working perfectly!
    1. gabesir's Avatar
      gabesir -
      Quote Originally Posted by duss31 View Post
      hey everybody,
      so ive just upgraded via ibrick to 1.1.3 and everything looks great apart from edge that seems not to work.i type all the needed things like apn, username and password, but at some point screen goes black and that's it. iphone doesnt remember the edge settings.
      anybody has a similar problem or know how to fix it?
      thanks
      dude many posts about this

      just reset your setting reboot and try it again


      Search is your best friend
    1. Nefarious's Avatar
      Nefarious -
      Just finished this. Ringtones dont work. I tried to install the patch, but got an execution failure. Still looking over everything else.
    1. den.brandon's Avatar
      den.brandon -
      bear with me because i am trying to do this at work (AT&T) but where is the 1.1.3.app in the installer? i cant seem to find it?
    1. rickenbacher's Avatar
      rickenbacher -
      I updated and things seem to work very well, except that I lost all the icons of my installed apps despite the fact that they still showed up in installer as installed. I tried to uninstall and reinstall them. This worked except for the following apps: "Devicescape Connect", "Categories", "OpenSSH", "SummerBoard" where I received the following error: "Main script execution failed!". I don't know whether this problem is a result of my moving the applications under 1.1.2 with the BossTool or whether this is simply a result of the upgrade. Fact is I cannot access the SummerBoard preferences anymore and of course reinstall the these apps.
      Furthermore, I unlocked the phone under 1.1.2 with anySIM1.2 and my SIM card worked like a charme. While I still have access to the phone after the upgrade I can no longer set the EDGE settings under "Settings - General - Network - EDGE". As soon as I enter the APN and try to proceed to the username and/or password the application crashes and I am back on the main screen without EDGE access. Does anybody have an idea what the reason could be? Should I downgrade again to 1.1.2 and us the new upgrade version of the Dev Team? Thanks.
    1. teriyakiboy13's Avatar
      teriyakiboy13 -
      To do this do we need to have gone from 1.1.3 to jailbroken 1.1.2?
      Or can we just do it w/ a 1.1.2 jailbroken phone that has never been to 1.1.3?
    1. akosko01's Avatar
      akosko01 -
      I have 1.1.3. No jailbreak because the original instruction froze my phone. i power cycled the phone and the apple was showing and wouldnt go to main screen. now i cant get back to 1.1.1. PLEASE HELP!!
    1. rickenbacher's Avatar
      rickenbacher -
      Sorry, should have read some of the responses. I reset the network settings and was afterwards able to enter all the necessary info for EDGE. Am back in business. Only thing that doesn't work is the de- and reinstall of the mentionned apps.
    1. gabesir's Avatar
      gabesir -
      Quote Originally Posted by duss31 View Post
      hey everybody,
      so ive just upgraded via ibrick to 1.1.3 and everything looks great apart from edge that seems not to work.i type all the needed things like apn, username and password, but at some point screen goes black and that's it. iphone doesnt remember the edge settings.
      anybody has a similar problem or know how to fix it?
      thanks
      dude many posts about this

      just reset your setting reboot and try it again


      Search is your best friend
    1. ehcropydoc's Avatar
      ehcropydoc -
      Will this work if we have MOVED our APPS with the BOSSTOOL? And also....WHICH ONE DO WE INSTALL? MMI? DEV TEAM? Skylar?
    1. thenaronsaid's Avatar
      thenaronsaid -
      ive got a 1.1.2 att activated jailbroken phone that im attempting to upgrade using this installer app method. every time i start it the bottom says running install script- have a sandwich and sits at 3/4 of the way done for about 30 minutes before my phone receives a call and is kicked out of installer app and i have to start all over again! is this normal? do i need to just keep trying and hope that i dont get a call? is the screen supposed to sit at this stage for so long?
    1. Kyle Matthews's Avatar
      Kyle Matthews -
      Quote Originally Posted by MacManPro View Post
      ok so i found this and installed it. however the download is not stalled about 3/4 of the way through at running instal script have a sandwhich. its been sitting there for well over 20 mins... help?
      Some reports have said up to 50 minutes. Apple's servers are slammed for requests for the file, so it may be slow. Your WiFi speed also affects it.

      Quote Originally Posted by woox View Post
      Does this work with a jailbroken 1.1.1 phone? Does it still remove all the apps?
      Still removes, and no, you have to be on 1.1.2 jailbroken.

      Quote Originally Posted by ehcropydoc View Post
      Will this work if we have MOVED our APPS with the BOSSTOOL? And also....WHICH ONE DO WE INSTALL? MMI? DEV TEAM? Skylar?
      Works, yes. The MMi versions is the Dev Team version, we just packaged it for Installer to make it easier for ya'll to use.

      Quote Originally Posted by DirtyDan View Post
      If anyone is having problems with this feel free to IM me via AIM and I will help you through it or answer any questions you have.

      I've done this successfully everything is working perfectly!
      thanks, glad it worked for ya!

      Quote Originally Posted by Unky View Post
      I apologize for the stupid question, but running installer 3.0b10 and BSD subsystem 2.0 the only 1.1.3 upgrade I see is the one posted by natetrue. Where is the development team's 1.1.3 upgrade located and what is it called?
      Refresh your sources. It should be under Recent Packages, but if not, its also under Utilities.

      Quote Originally Posted by Nefarious View Post
      Just finished this. Ringtones dont work. I tried to install the patch, but got an execution failure. Still looking over everything else.
      This method or NAteTrue's? Ringtones should be unaffected with this method.

      Quote Originally Posted by rickenbacher View Post
      I updated and things seem to work very well, except that I lost all the icons of my installed apps despite the fact that they still showed up in installer as installed. I tried to uninstall and reinstall them. This worked except for the following apps: "Devicescape Connect", "Categories", "OpenSSH", "SummerBoard" where I received the following error: "Main script execution failed!". I don't know whether this problem is a result of my moving the applications under 1.1.2 with the BossTool or whether this is simply a result of the upgrade. Fact is I cannot access the SummerBoard preferences anymore and of course reinstall the these apps.
      Furthermore, I unlocked the phone under 1.1.2 with anySIM1.2 and my SIM card worked like a charme. While I still have access to the phone after the upgrade I can no longer set the EDGE settings under "Settings - General - Network - EDGE". As soon as I enter the APN and try to proceed to the username and/or password the application crashes and I am back on the main screen without EDGE access. Does anybody have an idea what the reason could be? Should I downgrade again to 1.1.2 and us the new upgrade version of the Dev Team? Thanks.
      Those apps don't work with 1.1.3 yet. As to the EDGE, add the BigBoss source (see our wiki for the url) and install the EDGE fix.

      Quote Originally Posted by thenaronsaid View Post
      ive got a 1.1.2 att activated jailbroken phone that im attempting to upgrade using this installer app method. every time i start it the bottom says running install script- have a sandwich and sits at 3/4 of the way done for about 30 minutes before my phone receives a call and is kicked out of installer app and i have to start all over again! is this normal? do i need to just keep trying and hope that i dont get a call? is the screen supposed to sit at this stage for so long?
      Tell people to stop calling you.
    1. elle49's Avatar
      elle49 -
      I've read entire thread and can't find an answer to this question... I know with NateTrue's method, if you have a 1.1.1 or 1.1.2 jailbroken phone, you have to upgrade to 1.1.3 and then downgrade so that the baseband is upgraded. However with the new dev team method I have the same question that someone else has asked "do we need to have gone from 1.1.3 and dowgraded to jailbroken 1.1.2?
      Or can we just do it w/ a 1.1.2 jailbroken phone that has never been to 1.1.3?"

      I've been waiting to upgrade and still have a 1.1.2 jailbroken that has never been upgraded to 1.1.3
    1. Nefarious's Avatar
      Nefarious -
      Successful. Everything from Apple is working now. Can not uninstall or install anything though through installer. Get an execution failed message.
    1. Kyle Matthews's Avatar
      Kyle Matthews -
      Quote Originally Posted by Unky View Post
      I apologize for the stupid question, but running installer 3.0b10 and BSD subsystem 2.0 the only 1.1.3 upgrade I see is the one posted by natetrue. Where is the development team's 1.1.3 upgrade located and what is it called?
      You've asked this a dozen times, and its been answered. Stop.

      Quote Originally Posted by Nefarious View Post
      Successful. Everything from Apple is working now. Can not uninstall or install anything though through installer. Get an execution failed message.
      Did you make sure to update Installer to the latest version before running this script?
    1. Nefarious's Avatar
      Nefarious -
      Did you make sure to update Installer to the latest version before running this script?
      v3.0b10 is on the phone. Updated before I ran the script. I can reload sources, and it attempts to download. Install, reinstall, or uninstall net the failure notice.
    1. den.brandon's Avatar
      den.brandon -
      so i have refreshed my sources 6 times i have the dev team source and mod my iphone and still nothing in recent or utitiles can some one give me the exact address for the source so i can check please?
    1. viP4x's Avatar
      viP4x -
      MMi Repo is not working or what??? I tried several times to add it to the sources but nothing happened; then its under uncategorized repository :S
    1. dnoc's Avatar
      dnoc -
      iphone 1.1.3 jailbroke but no phone features, att carrier can any body help