• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iPhone 3.0 Jailbroken Already


    iPhone 3.0 is coming summer.

    And while the baseband IS updated in this firmware (so if you're yellowsn0w unlocked, DON'T upgrade til a proper PwnageTool version is out), 3.0 is already jailbroken, so say the Dev Team on a recent blog post.

    And for those wondering, yes the 3.0 OS is jailbreakable on all devices. It’s just those using 3G yellowsn0w that have to show some restraint and wait for PwnageTool to create a custom IPSW that avoids the baseband update.
    We'll let you know ASAP when a version of PwnageTool which works with 3.0 is out, but rest easy knowing the devices are already ready for WinterBoard and all your favorite jailbreak apps right next to Apple's 100 new 3.0 features.
    This article was originally published in forum thread: iPhone 3.0 Jailbroken Already started by Kyle Matthews View original post
    Comments 227 Comments
    1. Channan's Avatar
      Channan -
      Quote Originally Posted by Poseidon79 View Post
      The new iPhone will have to have a faster processor and more RAM to keep up with all the intense graphical games these Devs keep putting out. The fact that you have TO REBOOT before some of these games so they don't crash is ridiculous. I'm happy the new OS is jailbreakable though. The only think left to install is irealsms and winterboard b/c the rest is taken care of.
      The full version of iReal won't be needed any more. The only thing that will be useful still is quick reply and quickSMS. Pretty much everything else that iReal offers is going to be in the new Messages app.

      But I still don't think Apple is even close to keeping us from jailbreaking. There's still so much more we can't do without it. And if AT&T charge an additional monthly fee for tethering (on top of the $30/month data plan) then PDANet is more than enough to jailbreak.
    1. darkrom's Avatar
      darkrom -
      Well I'm a registered DEV as of like 10 minutes ago...

      What about a jailbreak solution for us who are in no way hurting apple and are actually supporting them by paying $100 a year for basically nothing but to make them more money if we actually make any apps that sell?

      I wish the dev team would address the issue for us, since we will be legally having the firmware from now until summer and it sure would be nice to test it out once jailbroken. Besides...I'm a PC user :P
    1. dr.stevil's Avatar
      dr.stevil -
      amazing news. way to go dev team
    1. hurstolds83's Avatar
      hurstolds83 -
      ok I am not a dev and have to wait for summer I am already syched but anyone care to share sims info about the os lime can u use the mms yet as att has a block last I knew can't wait to send my first mms it's going straight to AT&T with a big ha ha ha. tell me the iPhone is not capable LOL
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by €hR!$ View Post
      OHHHHH! I was wondering how that works. I though apps would have to be ported each year, from 2.0 to 3.0, 3.0 to 4.0, etc. So basically, this means all apps from 2.0 on will work on every firmware as soon as that FW can be jailbroken? That's great news. :]
      I think you've misunderstood.

      All App store apps should work fine because they use APIs and things that Apple guarantee and will, in all likelihood, not change.

      One of the main reason apps are not approved and hence are only available from cydia is because they use non-approved APIs and calls - lots of which are likely to have changed in 3.0

      I would not be surprised if most cydia apps (the ones that are not made redundant by FW 3.0) have to be ported.
    1. burdell1's Avatar
      burdell1 -
      post censored
    1. Happy Noodle Boy's Avatar
      Happy Noodle Boy -
      Quote Originally Posted by boe_dye View Post
      wait... wha??

      So if I was a Dev I could discuss where I could get it illegally?
      LOL, no. Here's the thing. The 3.0 Firmware given to devs is a nice beta at best and a firmware with disabled features at worst. I'm not a dev so I don't know. The firmware is out for one simple reason, for developers to have a chance to test their applications so that when 3.0 is released, they can be ready on day 1.

      The firmware is not out to be tested by the mass public. I don't think they even meant for it to be tested on a day to day use. Developers pay $99 for the right to use this beta software for the next couple of months.

      Now seeing as this is the internet, the firmware was leaked exactly 0.0000001 seconds after being released. However, you need a developers account among other things to get some functionality out of it.

      Whether the Dev Team chooses to jailbreak and support a beta firmware at this time is still up in the air, but since right now the beta is labeled for devs only, this forum will keep that stand here.

      Once again, you can discuss anything about 3.0 here. Just don't come straight out and say "AFTER I ILLEGALLY OBTAINED 3.0 I DID X AND Y" because it's just letting us know that well... you shouldn't have it and any issues/complaints you have with the FW could be BECAUSE ITS A BETA SOFTWARE.

      So in summary:

      GOOD:
      - Talking about what 3.0 is going to do
      - Devs can tell their stories of how awesome/crappy the new changes are

      BAD:
      - Asking how to get 3.0
      - Asking how to jailbreak 3.0
      - Complaint about a broken/disabled feature in a BETA OS.
      - You get the idea.

      Quote Originally Posted by burdell1 View Post
      Which version of Pwnge Tool would I use to jailbreak my iPhone 2G to the 3.0 software?
      Posts like THIS is what I'm trying to avoid. I will start throwing infractions if you can't play by the rules.
    1. burdell1's Avatar
      burdell1 -
      sorry about my post...i didn't mean anything bad by it....i guess I (and most people) don't realize the difference between talking about 3.0 and modding the iphone.) I thought that Apple thought even less of people who modded the iphone (since they want to make it illegal)
    1. laz305's Avatar
      laz305 -
      well being on a 2G I know I have to get rid of it but don't know to wait for new one or just get a 3G?
    1. czarnachmura28's Avatar
      czarnachmura28 -
      so , please , how did You jailbreak the version 3.0 ? , please , i have 3.0 but its not jailbreak (( its bad . why did i Didit ! ;P
      can someone help and just direct me to the right source ?

      please , please
    1. confucious's Avatar
      confucious -
      Assuming a new one comes out in June/July you will be kicking yourself if you get a 3G now if you have no need too.
    1. nycdiplomat's Avatar
      nycdiplomat -
      i read on another forum that the baseband is 4.20 (dont know how accurate that is) can a dev confirm or am i not allowed to ask that?
    1. Dryice's Avatar
      Dryice -
      Quote Originally Posted by czarnachmura28 View Post
      so , please , how did You jailbreak the version 3.0 ? , please , i have 3.0 but its not jailbreak (( its bad . why did i Didit ! ;P
      can someone help and just direct me to the right source ?

      please , please
      wow.....
      2 posts above you....
    1. czarnachmura28's Avatar
      czarnachmura28 -
      Quote Originally Posted by boe_dye View Post
      wait... wha??

      So if I was a Dev I could discuss where I could get it illegally?

      Either way, actually having watched the video with the original link, I gotta be honest but all things being equal after 3.0 many of the jailbroken apps will be made somewhat obsolete...

      They actually talked about backgrounding and why they don't do it, but did take the time to test it just to see what would happen.

      As it is now, generally speaking, I have a winterboard theme, vWallpaper, and status notifier running, with my own custom sounds.

      I have backgrounder but only on two apps that with vWallpaper get rendered useless anyhow.

      3.0 looks to be a pretty cool thing!
      How did You did it ? please ....

      Quote Originally Posted by Dryice View Post
      wow.....
      2 posts above you....
      Yes ? :P
    1. illuminatty's Avatar
      illuminatty -
      Is it possible to Jailbreak 3.0 yet? If I am a dev and have the 3.0 software how can I jailbreak? Theoretically speaking of course...
    1. nycdiplomat's Avatar
      nycdiplomat -
      Quote Originally Posted by czarnachmura28 View Post
      How did You did it ? please ....



      Yes ? :P
      no one will give you what you are asking for until 3.0 is actually out, you are probably not even supposed to have it, even if you were able to restore your phone with the beta, it will not work on your phone because you are not a registered dev. quit asking.......
    1. brotherbond007's Avatar
      brotherbond007 -
      I watched the video on Apple's website. The phone is almost complete..They should have placed the Camera in the front, like iSight. So you could have live video conversations with others (iMac/iPhone). The ability to shoot short video, 30 sec even would complete this phone for me. All the new stuff is great esp. the MMS! Hopefully AT&T will keep that monthly price down to a minimum $2.99 per month for limited MMS, $5.99 unlimited. Can you imagine how much money they would make monthly just on MMS? There over 30 million Touch/iPhone users. Even if 8 million subscribers sign up thats $23 million a month, $287 million a year. At that rate, The US Government would ask AT&T for a bailout. LOL.
    1. tha5150's Avatar
      tha5150 -
      i have been watching this thread and decided to jump in. first off, i am not a dev, i am just like most of you who watch, read and learn.. some people need to read...

      if you ask about how to JB 3.0, nobody will help. STOP ASKING
      if you ask where to download 3.0, nobody will help. STOP ASKING
      if you ask about the 2.0 vs 3.0 compatibility, if you were a dev and had the FW, you would know. if you dont, dont worry about it. this will all be resolved by the time it is released to the public.

      im saying this with a helping tone. not trying to be a dic*....

      i want 3.0 too. i want to use it and enjoy all the new features, just like everyone else... if someone were to shoot me an email and say, here is the FW link to download, everything works, have fun.... yes, i would do it. but i am not going to sit here and ask how to find it, JB it, etc WHEN THE DAMN MODERATOR TELLS YOU NOT TO!!

      come on guys... think for a sec...
    1. nycdiplomat's Avatar
      nycdiplomat -
      Quote Originally Posted by tha5150 View Post
      i have been watching this thread and decided to jump in. first off, i am not a dev, i am just like most of you who watch, read and learn.. some people need to read...

      if you ask about how to JB 3.0, nobody will help. STOP ASKING
      if you ask where to download 3.0, nobody will help. STOP ASKING
      if you ask about the 2.0 vs 3.0 compatibility, if you were a dev and had the FW, you would know. if you dont, dont worry about it. this will all be resolved by the time it is released to the public.

      i say this will a helping tone. not trying to be a dic*....

      i want 3.0 too. i want to use it and enjoy all the new features, just like everyone else... if someone were to shoot me an email and say, here is the FW link to download, everything works, have fun.... yes, i would do it. but i am not going to sit here and ask how to find it, JB it, etc WHEN THE DAMN MODERATOR TELLS YOU NOT TO!!

      come on guys... think for a sec...

      +1 i dont understand how many times people need to read that from several different people before they understand that they cannot ask for it....hopefully after reading your post they will finally get the hint.... ...its in beta for a reason everyone and its not meant for everyone to have yet..
    1. tha5150's Avatar
      tha5150 -
      whats killing me the most is that the Moderator tells you to stop, 2 post after that someone says

      """hey, where can i illegally download this beta FW? will pwnage 2.0 work? someone please help me!"""


      wooooowwwwwww... mooorrrroooooonnnnnnnssssssss

      i do have a question though, how is the FW locked to devs? do you need a password to use it or restore or something? i haven't heard of that before if this is the case. just wondering obviously.

      and for the devs, i read a few posts back that this FW will use more resources. is this true? will the phone act sluggish? i am not that knowledgeable with the specs of the iPhone but this struck my curiosity.