• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • PwnageTool & QuickPwn 2.1 Released - iTunes 8 Compatible
    The dev team has done it again and this time in only one day. You can now grab your copy of QuickPwn or PwnageTool for Mac OS X that will allow you to pwn your iPhone that is already at firmware version 2.1 or load on a custom 2.1 .ispw.



    Here's the OS X PwnageTool guide.

    Need Firmware?

    3g iPhone 2.1
    2g iPhone 2.1

    Yes there are no issues with iTunes 8 when you use these. No patching required at all Windows users will need to wait a bit for Windows programs to catch up. These are not for the new iPod Touch since the devs don't have one yet.

    Just like last time, they've initially released the tools via bit torrent only. MMi has provided mirrors as well. Here's the download info:

    Pwnage Tool 2.1 (OS X)

    QuickPwn Tool 1.1 (OS X)

    [via iphone-dev]
    This article was originally published in forum thread: PwnageTool & QuickPwn 2.1 Released - iTunes 8 Compatible started by Cody Overcash View original post
    Comments 608 Comments
    1. boneheadxan's Avatar
      boneheadxan -
      Can I go from 2.0 to 2.1 without going through 2.0.2?

      What about Bootloader?
    1. WillyDavidK's Avatar
      WillyDavidK -
      Good morning everyone! Hope things are still going well for some of you Just checking in to let everyone know I'm still here

      It looks like we might have a solution to the error 6 issue thanks to vxprettyboy!! I would suggest everyone try his solution if you are having this problem.

      I'll be back later to address some of the other concerns.
    1. zap1027's Avatar
      zap1027 -
      I finally was able to restore to the 2.1 cfw by WillyDavid, I was getting the error 6 message and was unable to restore to any other cfw, and stuck in restore mode. I used WinPwn 2.5 to re-pwn iphone, also helped to make sure I was in DFU mode. Once I went thru the pwning process, I went to iTunes 8.0, shift+restore, and selected the 2.1 cfw from WillyDavid and voila!! I am now syncing all my music and apps back on my phone, which is on 2.1, jb'd and unlocked on T-mo, both Cydia and Installer are installed. Hopefully, everything else will go smoothly from now on...

      Thanks again WillyDavid!!
    1. EmDoubleU's Avatar
      EmDoubleU -
      just got my iphone back and working thanks for the post. I had numerous error problems when trying to ALT restore in itunes.
      If your having the same problems do the following:
      1. use quickpwn 2.1
      This will get your phone back working, almost. I had no signal because i didnt have a compatible sim card. this is ok though
      2.Use pwnage 2.1
      -follow the steps exactly for the 3g unlock guide
      -it says that they are the same and wait till the 2g is posted later
      -It works for the 2g as well because that is what i have

      Hope this works if you need further information let me know.

      Thanks guys for the info to solve my problem.
    1. CyberGreg's Avatar
      CyberGreg -
      Quote Originally Posted by CaptainChaos View Post
      Should I rename the file after the download to get rid of the (ATT_ONLY) in the file name?
      Only if it doesn't have an ipsw file extension as mentioned a few times in this thread. The actual file name is irrelevant, you can name it Windows_Vista and as long as it has the .ipsw extension, iTunes will know what to do with it.


      Quote Originally Posted by arekisu View Post
      I can't ssh my touch now, fugu says 'remote host identification has changed'. Anyone know what to do about this?
      already been posted; you know the "Search this Thread" function works quite well

      Quote Originally Posted by CyberGreg View Post
      Open terminal, type
      cd .ssh
      rm known_hosts

      This wil remove the known_hosts file that stores the ssh key.
      Quote Originally Posted by boneheadxan View Post
      Can I go from 2.0 to 2.1 without going through 2.0.2?

      What about Bootloader?
      You know, posting a bit more information might help get an answer. Such as:
      What version iPhone, 2g or 3g?
      Do you need it unlocked?
    1. boneheadxan's Avatar
      boneheadxan -
      Hey,
      Its an iPhone 2G unlocked, running 2.0.
      I want to upgrade to 2.1, so I was wondering if i need to go through 2.0.2 or if I could directly just pwn it from 2.0 to 2.1.

      Also I downloaded the custom firmware and PwnageTool 2.1 ain't finding it I put it into Expert Mode and and located it and it gives an error saying, 'Wrong Firmware' something...

      Any solutions?
    1. Pcpro745's Avatar
      Pcpro745 -
      I used the Quickpwn for PC last night on Quickpwn.com and it worked just fine on my iphone 2g, Anyone tried this yet?
    1. CaptainChaos's Avatar
      CaptainChaos -
      Quote Originally Posted by CyberGreg View Post
      Only if it doesn't have an ipsw file extension as mentioned a few times in this thread. The actual file name is irrelevant, you can name it Windows_Vista and as long as it has the .ipsw extension, iTunes will know what to do with it.




      already been posted; you know the "Search this Thread" function works quite well





      You know, posting a bit more information might help get an answer. Such as:
      What version iPhone, 2g or 3g?
      Do you need it unlocked?
      Thank you for the reply! The search function doesn't work half of the time for me

      I appreciate what you and others are doing by contributing to the community.
    1. EmDoubleU's Avatar
      EmDoubleU -
      Quote Originally Posted by boneheadxan View Post
      Hey,
      Its an iPhone 2G unlocked, running 2.0.
      I want to upgrade to 2.1, so I was wondering if i need to go through 2.0.2 or if I could directly just pwn it from 2.0 to 2.1.

      Also I downloaded the custom firmware and PwnageTool 2.1 ain't finding it I put it into Expert Mode and and located it and it gives an error saying, 'Wrong Firmware' something...

      Any solutions?
      You can upgrade from 2.0=>2.1 by pwning your phone from before.
      download the restore firmware 2.1 and create your ow custom firmware in expert mode. use the Alt restore like usual and follow the steps for the 3g 2.1 firmware guide in the forum.

      Let me know if everything works or need more detail
    1. richiemana's Avatar
      richiemana -
      Quote Originally Posted by kuhndsn View Post
      You are on a windows machine correct? Did you upgrade your itunes to 8.0 first?

      Where did you get the custom .ipsw?

      thx

      D
      Yes i'm on windows and I got the ipsw from the link in willydavidk's sig. Downloaded the ipsw, Upgraded itunes, connected iphone and left it on homescreen, shift restore with the ipsw off willydavidk and then its all done.
    1. Manca's Avatar
      Manca -
      Just restored and used quick pwn! Works perfect! I even managed to make a workaround for AppSupport stuff Even tho the original files that were on 2.0.2 changed. It's soo fast so far! Contacts are at least 100% loaded faster!
    1. boneheadxan's Avatar
      boneheadxan -
      I got the Custom Firmware...but in PwnageTool when I browse for the CF it says "Wrong Firmware Bundle" :S
    1. tellytel's Avatar
      tellytel -
      are Any word on an official release of quickpwn for windows users?? Sounds hella hard to do it right now.
    1. georgc's Avatar
      georgc -
      I can successfully get 2.1 on my phone, but it always fails on the restore. What can i do soo i dont have to put in all my info again?
    1. trte-mrte's Avatar
      trte-mrte -
      For all windows users with 2G NON AT&T phones.

      Just use the Grip`s custom IPSW for 2G Non AT&T and shift+restore option in iTunes 8
      Yesterday I did this on my 2G phone and its OK (till now )
      Grip`s custom IPSW has : custom logos (pineapple-quickpwn logo), cydia,installer.
      Works EXCELLENT on my phone. I also have my old applications working (from 2.0.2)
      For 5-7 minutes u will have 2.1 jailbroken,activated and unlocked phone.



      GOOD LUCK to everyone
    1. Dark Angel's Avatar
      Dark Angel -
      Quote Originally Posted by bbdc View Post
      For people with issues having pwnage find the bootloader files, there is an update to the dev's blog which state that pwnage must be run from the applications folder. If not, users will experience some unintended issues.
      Thanks, this did resolve the previously unaccepted BL files.
      Since I'm at work, I don't have my sync cable, I have to wait till I get home tonight and try to update with the new custom ispw.
      Cheers!
    1. SilhouetteNinja's Avatar
      SilhouetteNinja -
      I got my iPhone in September '07 and have always used this site to mod it (unlocked and jailbroken for use with T-Mobile).

      Can I upgrade to 2.1 with PwnageTool or QuickPwn right now? Am I considered a "2G"? My baseband is 04.05.04_G.

      Thanks.
    1. superscreen's Avatar
      superscreen -
      For those who get the error that bootloaders are not correct, I was getting the same error also. The error happens when I run pwnagetool directly from the .dmg on the desktop. I then drag the pwnage tool (pineapple logo) out of the .dmg onto download folder (i imagine any folder or desktop would work) and amazingly it works, no more bootloader error and start creating my .ipsw. Hope that works for you guys.
    1. arekisu's Avatar
      arekisu -
      After CyberGreg's advise i was able to ssh my touch but after re-placing the mobileinstallation file my touch got stuck on the pineapple logo and wouldn't boot.

      I restored to 2.1 but then i got the error 6 message when trying to do a custom restore, so i've have to restore to 2.0. I'll have to try a custom restore from there.

      edit: Didn't work, updated to 2.1 then used quickpwn.
    1. Dark Angel's Avatar
      Dark Angel -
      Quote Originally Posted by superscreen View Post
      For those who get the error that bootloaders are not correct, I was getting the same error also. The error happens when I run pwnagetool directly from the .dmg on the desktop. I then drag the pwnage tool (pineapple logo) out of the .dmg onto download folder (i imagine any folder or desktop would work) and amazingly it works, no more bootloader error and start creating my .ipsw. Hope that works for you guys.
      Yes. this method does in fact work without the previous error. Custom ispw is just a few steps away...