• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • MMS on the iPhone


    Wednesday ModMyI member Suavphisticated has released MMS, a native iPhone app which can send MMS directly from your iPhone. MMS receiving is NOT yet implemented, but is in the development process.

    Great job Suavphisticated - this has been MUCH needed by the iPhone community! It will be interesting to see how MMS receiving is implemented here.

    MMS is available via the Community Source maintained by Ste.

    NOTE: this is still an early beta release. It is slightly buggy, but is working. You will need to set it up with your carrier MMSC info. Please add your carriers MMSC info to the Carrier APN Wiki so we can get a nice complete listing. There's a good list here too (thanks, mjaydb) You will also need MMS enabled on your account.

    Digg it.
    This article was originally published in forum thread: MMS on the iPhone started by Kyle Matthews View original post
    Comments 278 Comments
    1. wcb4's Avatar
      wcb4 -
      ok, so I sent one and it got received, but there is an issue with the picture selector, at least for me. It is not using the thumbnail view. My pix are full screen as if superimposed over top of the thumbnail scren because when I try to select one, I see a small blue mark on the left side, approximately the size of what would be the thumbnail. I tried to figure out which image was selected but I sent the wrong one anyway. Any clue?
    1. mjmills's Avatar
      mjmills -
      Hi, I think the problem with my one is that it is on 1.1.2 on Orange in the UK, as such it does that thing when edge is available but not being used with the blue box on the screen with no E. For that reason I get the standard:

      Send Failed!
      Could not connect!

      any thoughts??
    1. Jabez's Avatar
      Jabez -
      Quote Originally Posted by akimbo View Post
      i'm on optus and used the following settings and it works:

      MMS settings
      MMSC: mmsc.optus.com.au:8002/
      Proxy: 61.88.190.10:8070/

      Edge APN: MMS

      turn off wifi first. you might have to enable internet on your account if you haven't already...
      OK. Looks like I had the port wrong on the proxy. I was using a different port that I got from some other details on the web.

      Changed the port number to 8070, and it worked!

      Thanks akimbo!
    1. dicksharard's Avatar
      dicksharard -
      I can't select any pictures. Nothing comes up in the selector except a blank screen. What gives?
    1. r1tricky's Avatar
      r1tricky -
      Has any one got it working with Vodafone UK only the settings i have fail every time?
      Any help much appreciated.
    1. bbplayer5's Avatar
      bbplayer5 -
      take a picture with your camera, it can only send pics in that folder...

      Mine says it sent a picture, but the person never got it.. oh well..
    1. dallasnights's Avatar
      dallasnights -

      Not working said message failed

      Hope it does soon great worktho
    1. mr_greedy's Avatar
      mr_greedy -
      Works for me.

      On a US bought 1.0.2, unlocked and updated to 1.1.1 on O2 payasyougo SIM in the UK.

      Amazing work. Get receiving MMS sorted out and improve the interface a little and expect a bit donation off me
    1. wcb4's Avatar
      wcb4 -
      Quote Originally Posted by wcb4 View Post
      ok, so I sent one and it got received, but there is an issue with the picture selector, at least for me. It is not using the thumbnail view. My pix are full screen as if superimposed over top of the thumbnail scren because when I try to select one, I see a small blue mark on the left side, approximately the size of what would be the thumbnail. I tried to figure out which image was selected but I sent the wrong one anyway. Any clue?
      ok, answered my own question and figured I share for anyone else who might see this. I have the i-App-a-day "wallpaper" application installed. I used it to view and DL several wallpaper images to my camera roll.... apparently when you use this app to add to the camera roll, these images show up full screen, not as thumbnails and mess up the user experience. If I could make a suggestions, use the "photo library" approach , with ALL images available (unless you can not figure out the image DB format) and allow the user to just flip through them full screen. A little extra coding, but would definitely enhance the program. Great app though.... Now I have MMS, voice notes, to do lists, internet radio... All the things APPLE should have put on the phone, but Steve didn't think we needed.

      Great work guys, and great site
    1. mr_greedy's Avatar
      mr_greedy -
      Works for me.

      On a US bought 1.0.2, unlocked and updated to 1.1.1 on O2 payasyougo SIM in the UK.

      Amazing work. Get receiving MMS sorted out and improve the interface a little and expect a donation off me

      ---

      oops double post. dunno why
    1. anthoneous's Avatar
      anthoneous -
      has anyone got it to work with tmobile usa???
    1. Eurisko's Avatar
      Eurisko -
      For you Rogers people, the APN settings for EDGE won't work. You need to change your EDGE settings from:

      APN: internet.com User: wapuser1 Pass: wap

      to:

      APN: media.com User: media Pass: mda01
    1. msriotdoll's Avatar
      msriotdoll -
      i tried using all the apn setting with and without the http:// and it did not work for me.
      if anyone has figured out how to do it on tmo usa please let me know

      thanks!
    1. eastpointvet's Avatar
      eastpointvet -
      i got all the cingular settings correct. i have a locked 1.1.2 phone on att. i can send the msgs and get a successful but none of my recipients have actually recieved them. do they have any att specific settings that doesnt use cingulars gateway even though i know they all one company. i have the unlimited text plan so it shouldnt be any problem. any ideas?
    1. auser1's Avatar
      auser1 -
      anyone get it to work with tmobile usa?
    1. Eurisko's Avatar
      Eurisko -
      Quote Originally Posted by dicksharard View Post
      I can't select any pictures. Nothing comes up in the selector except a blank screen. What gives?
      It currently only takes pictures from your camera roll.
    1. akelley's Avatar
      akelley -
      When I go into settings, general, network, I do not see EDGE as an option. Can anyone help me please?

      1.1.1 jailbroke, on ATT, prepaid.

      TIA!
    1. Brookied's Avatar
      Brookied -
      ok for me the error is "Can not Resize image"?? any ideas
    1. meagain's Avatar
      meagain -
      So far, for AT&T, I've found THREE different setting recommendations for the MMSC.

      Can anyone confirm which of the setting scenarios thrown out there - actually work?

      And, am I to understand all one has to do is punch in the recipients phone number (including 1 before the area code) - to make this work? Thanks.
    1. Alperovich's Avatar
      Alperovich -
      holy crap this is awesome. now if someone would come up with a 1 touch, downgradeless jailbreak method. this woudl be awesome