• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • First official photos of a jailbroken 3G[s] released. Tool not too far away!


    Earlier this morning geohot posted the first official photos of a jailbroken iPhone 3G[s]. geohot uses an iboot patch to upload a LLB to the phone which utilizes the 24kpwn patch in the bootrom. He mentions on twitter that a simple change in the current redsn0w would allow the 3G[s] jailbreak:


    geohot:


    There is still lot of questions on whether geohot plans on releasing a jailbreak tool of his own or releasing his exploit to the other dev teams working on the project. Seeing as it would only take updating a few lines in redsn0w, I would hope he allows the dev team to update it and get the tool to the public as soon as possible. We almost haz jailbreak.




    Enjoy!
    This article was originally published in forum thread: First official photos of a jailbroken 3G[s] released. Tool not too far away! started by StealthBravo View original post
    Comments 2113 Comments
    1. Get_Zwole's Avatar
      Get_Zwole -
      Quote Originally Posted by cpjr View Post
      Try doing it with Itunes open and running.
      tried that before and just tryed it again same thing done wait for reboot and nothing ever happens. Seems like everyone is finding a way but me lol this sucks.
    1. Ath_x64's Avatar
      Ath_x64 -
      Quote Originally Posted by Get_Zwole View Post
      tried that before and just tryed it again same thing done wait for reboot and nothing ever happens. Seems like everyone is finding a way but me lol this sucks.
      Ok when you get to that stage close iTunes, then close purplera1n.

      Leave the phone plugged in and restart Purplera1n.
      From there see if it run the install.
    1. nickswagger's Avatar
      nickswagger -
      question, since winterboard doesnt yet work on this JB, do you think when they iron it out it will be just a simple patch administered thru cydia, or will i have to rejailbreak using the newer method?
    1. Get_Zwole's Avatar
      Get_Zwole -
      Quote Originally Posted by Ath_x64 View Post
      Ok when you get to that stage close iTunes, then close purplera1n.

      Leave the phone plugged in and restart Purplera1n.
      From there see if it run the install.
      just did it exactly like that to a T and same thing stuck in restore and it just says done wait to reboot.
    1. Ath_x64's Avatar
      Ath_x64 -
      Quote Originally Posted by Get_Zwole View Post
      just did it exactly like that to a T and same thing stuck in restore and it just says done wait to reboot.
      are you using a USB hub at all?
      When it goes into restore mode does your system install a driver for it?

      Try this, when it pauses like that unplug the phone and plug it right back in. You should see the driver change.

      close purplera1n and then restart it.
    1. Get_Zwole's Avatar
      Get_Zwole -
      ok ill try this
    1. iPhoneMuscle's Avatar
      iPhoneMuscle -
      Where in cydia do i get *******....what source. Thanks ahead time.
    1. Get_Zwole's Avatar
      Get_Zwole -
      Quote Originally Posted by Ath_x64 View Post
      are you using a USB hub at all?
      When it goes into restore mode does your system install a driver for it?

      Try this, when it pauses like that unplug the phone and plug it right back in. You should see the driver change.

      close purplera1n and then restart it.
      ok i tried this and same thing happened. what is a usb hub? no it doesnt say install driver or anything just a window pops up on itunes that says a restore is needed etc. Man this is frustrating thanks for the help man.
    1. dchandler's Avatar
      dchandler -
      Dude at least you get that far, All mine says is error then shuts down
      Quote Originally Posted by Get_Zwole View Post
      ok i tried this and same thing happened. what is a usb hub? no it doesnt say install driver or anything just a window pops up on itunes that says a restore is needed etc. Man this is frustrating thanks for the help man.
    1. Get_Zwole's Avatar
      Get_Zwole -
      ^^^ that sucks man sorry to hear hopefully we can get it figured out. OK via SB's tutorial i set up purplera1n a compatable to windows xp service pack 2 is this right? Then i tried it again now it goes to entering recovery and just stays there its been about 8 minutes since it started saying that. Should i give it more time or try something else? thanks again in advance.

      heres my log before i made it compatible
      INFO: welcome to purplera1n for windows
      INFO: button clicked
      INFO: internal recovery callback called
      INFO: unregistered normal mode callback
      INFO: go go gadget ra1n
      INFO: said hi
      INFO: sent exp1
      INFO: uploading payload
      ERROR: usb send file failed
      ERROR: payload upload failed
      WARN: wtf who called this?
      INFO: global callback finished
      INFO: callbacks registered

      here it is after
      INFO: welcome to purplera1n for windows
      INFO: button clicked
      INFO: internal device callback called
      INFO: callbacks registered
      INFO: sent enter recovery command
      ***
    1. Ath_x64's Avatar
      Ath_x64 -
      Quote Originally Posted by Get_Zwole View Post
      ^^^ that sucks man sorry to hear hopefully we can get it figured out. OK via SB's tutorial i set up purplera1n a compatable to windows xp service pack 2 is this right? Then i tried it again now it goes to entering recovery and just stays there its been about 8 minutes since it started saying that. Should i give it more time or try something else? thanks again in advance.

      heres my log before i made it compatible
      INFO: welcome to purplera1n for windows
      INFO: button clicked
      INFO: internal recovery callback called
      INFO: unregistered normal mode callback
      INFO: go go gadget ra1n
      INFO: said hi
      INFO: sent exp1
      INFO: uploading payload
      ERROR: usb send file failed
      ERROR: payload upload failed
      WARN: wtf who called this?
      INFO: global callback finished
      INFO: callbacks registered

      here it is after
      INFO: welcome to purplera1n for windows
      INFO: button clicked
      INFO: internal device callback called
      INFO: callbacks registered
      INFO: sent enter recovery command
      ***
      Ok it is not able to talk to your phone,
      check device manager and see if there is an entry in USB devices called something like Apple USB restore... or DFU
    1. Get_Zwole's Avatar
      Get_Zwole -
      Quote Originally Posted by Ath_x64 View Post
      Ok it is not able to talk to your phone,
      check device manager and see if there is an entry in USB devices called something like Apple USB restore... or DFU
      the only one in there with apple it just says apple iphone...
    1. Ath_x64's Avatar
      Ath_x64 -
      Hmm I am pretty sure if you are in DFU mode i should say Apple Recovery iBoot USB Driver.


      SO we need to get the proper driver installed on your system.
      I think you need to do the following and perform a complete restore on the iPhone 3G S

      Turn off the phone (hold down home and power until it shuts off)
      Unplug the USB cable from the PC (or from the Phone)

      Open iTunes, (if it is already open close it and open it again)

      Hold down the home button and while keeping it presses plug the phone in
      Keep the home button pressed until you see a message saying you have to restore the phone to use it with iTunes.

      From there, preform a restore with a good copy of OS 3.0 for the 3G S.

      If you made a back up you can restore that after the regular restore is done.

      After that is done try Purplera1n.

      Also do not use compatibility mode with this, just run it as Administrator...
    1. gatheredbob's Avatar
      gatheredbob -
      anyone get the emulators working like gpsphone or nes i cant get them to work
    1. Get_Zwole's Avatar
      Get_Zwole -
      so im gonna wanna restore in dfu mode? going by what you said it wont really turn it off it comes back on after i release the two buttons?

      Quote Originally Posted by Ath_x64 View Post
      Hmm I am pretty sure if you are in DFU mode i should say Apple Recovery iBoot USB Driver.


      SO we need to get the proper driver installed on your system.
      I think you need to do the following and perform a complete restore on the iPhone 3G S

      Turn off the phone (hold down home and power until it shuts off)
      Unplug the USB cable from the PC (or from the Phone)

      Open iTunes, (if it is already open close it and open it again)

      Hold down the home button and while keeping it presses plug the phone in
      Keep the home button pressed until you see a message saying you have to restore the phone to use it with iTunes.

      From there, preform a restore with a good copy of OS 3.0 for the 3G S.

      If you made a back up you can restore that after the regular restore is done.

      After that is done try Purplera1n.

      Also do not use compatibility mode with this, just run it as Administrator...
    1. Ath_x64's Avatar
      Ath_x64 -
      Quote Originally Posted by Get_Zwole View Post
      so im gonna wanna restore in dfu mode? going by what you said it wont really turn it off it comes back on after i release the two buttons?
      What happens when you open iTunes?
      Does it tell you that you need to restore?
    1. Get_Zwole's Avatar
      Get_Zwole -
      no it just comes up normal and starts charging etc. I just held the home and sleep awake until it went off but when i released the phone just came back on now itunes didnt say anything about a restore.
    1. Ath_x64's Avatar
      Ath_x64 -
      Ok that is odd turn the phone off the normal way (hold down the sleep button)

      then follow the rest of the instructions I posted above.
    1. Get_Zwole's Avatar
      Get_Zwole -
      Quote Originally Posted by Ath_x64 View Post
      Ok that is odd turn the phone off the normal way (hold down the sleep button)

      then follow the rest of the instructions I posted above.
      Ok i held down the home sleep awake until it was in recovery was that right? did the rest now im about to restore it wanted to make sure that was right?
      went ahead and started the restore will take a bit.
    1. wig's Avatar
      wig -
      Everything seems AOK except the few unsigned files (patch coming?) and app store works, but update keeps coming up with a "1" red star on the icon and going into it and viewing updates available just sits there with a gray screen.

      Way to go GEO!