• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • [ RELEASE ] 3G iPhone Unlocked - Eat the yellowsn0w


    You've waited. You've watched. You've waited more. Now... its here!

    The Dev Team has released yellowsn0w, the 3G iPhone unlock. Its available NOW via Cydia, you'll need to add their source (check the release post for the URL - they'd prefer sites didn't link the repo url) then check your Changes tab - yellowsn0w should be right on top. If you don't know how, here's how to add a source in Cydia. Refresh if you don't see it. If you're reading this later, just search for yellowsn0w in Cydia (making sure of course you've added their source). As guessed (and confirmed a bit later) from their post earlier today, IT WORKS WITH THE 02.28.00 BASEBAND version - in fact, ONLY for that baseband version. Meaning yes, you will need to update in iTunes and then use PwnageTool on a freshly updated 2.2 iPhone if you DON'T have 02.28.00 right now. Running the unlock on older basebands will simply cause it to exit, and do nothing. "No harm, no foul."

    All you do is go to the package in Cydia and install just like you'd install any other package. Boom - restart the iPhone, and...

    ...wait for the slide to unlock screen, then wait 10 or 15 secs more. If you don’t see your carrier name pop up, then remove your SIM, reinsert it, and wait 10 secs more. This is the step we’ll be working on eliminating next.
    Then you're unlocked. A quick note for users whose SIM cards come preinstalled with menus or apps on them, you'll

    ...need to pull and reinsert the SIM once after rebooting the phone to engage the unlock. Even though it’s needed only once per boot, it’s still a nuisance and we’ll be fixing that ASAP... You’ll know if you fall into that “extra step” category if your carrier doesn’t show up within about 10 seconds of the slide to unlock screen.

    There is a known issue with SIM cards that have STK (SIM Toolkit) application menus, these menus are usually items such as “top up” “get credit” etc. These menu items confuse the application sometimes, removing and reinserting the SIM fixes this issue.
    Answers to some potential questions:

    My modem software says I have {less than 02.28.00} - can I still unlock?
    Yes, but you have to upgrade your baseband to 02.28.00 before you do anything. First restore completely to 2.2 in iTunes (just connect the iPhone to the computer, go to the iPhone tab in iTunes, and press Restore in the version area).You can follow this guide to jailbreak after, then install the unlock from Cydia.

    Is this permanent? In other words, will I be able to upgrade my firmware when the next one comes out and keep my unlock?
    No. This is a soft[ware] unlock, not a hardware unlock, so you'll need to do as we've mostly been doing - wait to upgrade on new firmwares (all current firmwares are unlockable as of now) until the Dev Team releases a patch. Of course we'll have details for you every time Apple comes out with a firmware update.

    What if I WANT to remove the unlock?
    yellowsn0w is completely removable through Cydia, the command line, and iTunes.

    I'm still on [2.1 / 2.0.2 / 2.0.1 / 2.0] firmware on my iPhone 3G, but would like to upgrade... what should I do?
    Back up your iPhone. Restore in iTunes. Follow this guide to upgrade to 2.2 jailbroken, then simply install yellowsn0w from Cydia when you're finished - unlocked, jailbroken, enjoy.

    I have T-Mobile, and they've recently upgraded their network to include 3G. Can I use the T-Mobile 3G data network with my unlocked iPhone 3G?
    No - T-Mobile and AT&T use different 3G frequencies, so your iPhone 3G won't pick up T-Mobiles 3G network. You CAN however still use T-Mobile EDGE and GPRS just fine with the iPhone 3G - as well as all T-Mobile's voice features, and WiFi of course.

    I have AT&T. I don't plan on selling my iPhone anytime soon, and I'm staying with AT&T. Is there any benefit for me to unlock my iPhone?
    Nope. Aside from the ability to use the iPhone 3G on other networks than it comes locked to (T-mobile in the States, various carriers elsewhere), and the higher potential asking price if you sell your iPhone unlocked, there are no benefits to unlocking your iPhone.

    OMG WTF BBQ!!!! This is awesome and I want to donate. Who do I send money to?
    Don't. They like uh... post cards. Scanned. And emailed.

    I think you're wrong about the basebands it will work with. I have an older baseband, and I'm going to run the unlock anyway. I think it will magically work in my case.
    I'm going to have a sandwich. After we each do these things, lets reconvene and see who's happier.


    [B]Edit: T-Mobile USA Users must turn off the 3G toggle in settings.

    Everyone: You MUST have your SIM card in (without the proxy chip) throughout the entire process. With your SIM card installed... Install yellowsn0w 0.9, then reboot and wait up to 2 minutes for the phone to get service. If it doesn't work then uninstall 0.9 and try version 0.91. Keep reporting

    If you have a SIM PIN you will need to REMOVE this first before running yellowsn0w... it is not compatible (yet)[/B


    Update: Version 0.9.5 should fix T-Mobile USA outgoing call SIM issues.

    EDIT: In case there is still any confusion about how to unlock your 3G iPhone, a tutorial has been created. Be sure to read the instructions very carefully so that you are on the right firmware or you maybe never be able to unlock your 3G.
    IPhone 3G Unlock Guide - ModMyi - Wiki
    This article was originally published in forum thread: [ RELEASE ] 3G iPhone Unlocked - Eat the yellowsn0w started by Kyle Matthews View original post
    Comments 1325 Comments
    1. franijose's Avatar
      franijose -
      Everything is working on my except edge. Can someone help have no idea how to get it to work. It used to work fine with gevey sim
    1. amirica's Avatar
      amirica -
      T-Mobile here in AZ. Newest SIM card. .9.5 wasn't working for me. I wasn't able to get anything at all, just 5 dots. Restoring phone, then will QuickPWN, and try again. Will keep you posted.

      Keeping my fingers crossed!!

      Quote Originally Posted by amirica View Post
      T-Mobile here in AZ. Newest SIM card. .9.5 wasn't working for me. I wasn't able to get anything at all, just 5 dots. Restoring phone, then will QuickPWN, and try again. Will keep you posted.

      Keeping my fingers crossed!!

      So yeah... same results... nothing but 5 dots. But I have faith! Keep up the research and great work Dev Team, and I look forward to the next release (hopefully tomorrow, LOL).

    1. imagineThiss's Avatar
      imagineThiss -
      okay so after seraching all over the internet... i found a solution to my once working phone...

      install mobile terminal from cydia

      this is only for ppl on 0.9.5

      type yellowsn0w -c
      type yellowsn0w -r
      type yellowsn0w -q

      restart it.. then you should get no service ..... this is key then toggle airplace mode on and off.. and vwallah back online...

      if you don't get the "no service" and keep getting the "....." then repeat the commands till it works... this is what i did and im back.. i don't know for how long though lol.. also plz try this on your own risk just as i did.. i dont know what this exactly does..
    1. tattoojack's Avatar
      tattoojack -
      for edge,
      Turn on data roaming
      NOT 3G
      And set ur cellular data network APN to
      epc.tmobile.com
      No need to reboot

      And i know someone will ask, so
      YES
      YOU MUST HAVE EITHER
      tzones $5.99
      Web2go $9.99
      Or
      Mobile web $19.99
      They are all the sane speed and reliabilty
    1. ellicit's Avatar
      ellicit -
      Mine never says "No Service" I get those ....
      and I get a red dot next to the VoiceMail icon...

      VERY UPSET, Ihave been trying for 2 days
    1. itsjdmyo's Avatar
      itsjdmyo -
      idk if that has been asked and answered yet. there are just too many pages to go through. but will this program work on my 1st gen. iphone running on 2.2FW? or only for 3g phones?
    1. woostar88's Avatar
      woostar88 -
      Quote Originally Posted by ellicit View Post
      Mine never says "No Service" I get those ....
      and I get a red dot next to the VoiceMail icon...

      VERY UPSET, Ihave been trying for 2 days

      first, uninstall yellowsn0w
      try to reset the network settings.
      and install the latest yellowsn0w.
      reset the network settings.

      reboot.

      if the network doesn't show, turn on the airplane mode ON. and wait about 10sec.(this is important)

      and THEN turn off the airplane. BOOM!

      have fun

      Quote Originally Posted by itsjdmyo View Post
      idk if that has been asked and answered yet. there are just too many pages to go through. but will this program work on my 1st gen. iphone running on 2.2FW? or only for 3g phones?

      yellowsn0w is ONLY for 3g's.

      and for 2g iphones it's already been unlocked/jailbroken.

      go to dev team website, and you'll be able to find it. if not it's here on the forums.

      cheers!

      Quote Originally Posted by amirica View Post
      T-Mobile here in AZ. Newest SIM card. .9.5 wasn't working for me. I wasn't able to get anything at all, just 5 dots. Restoring phone, then will QuickPWN, and try again. Will keep you posted.

      Keeping my fingers crossed!!




      So yeah... same results... nothing but 5 dots. But I have faith! Keep up the research and great work Dev Team, and I look forward to the next release (hopefully tomorrow, LOL).


      have you tried to reinstalling the yellowsn0w? and resetting the network?

      and after reinstall yellowsn0w and then try to perform airplane on/off trick.
    1. liton's Avatar
      liton -
      I try here with my 3G but seems the problem is same as like other persons, Just 5 dots and no signal. I try several time install and uninstall YellowsnOw and 3g off, Airplane mode on-off but all the same.

      Don't know what to do now,
    1. Rajputro's Avatar
      Rajputro -
      Quote Originally Posted by woostar88 View Post
      first, uninstall yellowsn0w
      try to reset the network settings.
      and install the latest yellowsn0w.
      reset the network settings.

      reboot.

      if the network doesn't show, turn on the airplane mode ON. and wait about 10sec.(this is important)

      and THEN turn off the airplane. BOOM!

      have fun
      You are the man! I have tried for 3 hours, followed everyone's suggesstions, no luck. Your instruction got it working on firt try, thanks so much.
    1. ellicit's Avatar
      ellicit -
      As I said before I have tired alot of things, it didnt work.
      like some, I kept getting the " ..... " dots on status

      Here is my solution:

      once you have yellowsn0w 0.9.5 install

      make sure you have mobile terminal installed too, with edge off, 3G off,

      open terminal type:

      " yellowsn0w -c " press return
      " yellowsn0w -q " press return
      " yellowsn0w -r " press return

      go back to home, then Setting > General > Reset > Reset Network Settings

      this will reboot your phone, now once its turned back on, you should still see the evil "....." , thats fine, now goto Setting and turn Airplane Mode ON wait 10 sec, turn it back off, now you should see "Searching" on the signal bar area, and after 1 sec or so, BOOOM full bar.


      what works
      - EGDE
      - INCOMING CALLS/ OUT GOING CALLS
      - TEXT (SEND/RECIEVE)
      - WIFI


      everytime you boot, you must do this on terminal...

      until 0.9.6
      Dev team rulez

      BTW, I've tired this 3 times, and it worked all the time.


      Oh!
      worked on : Tmobile
      Location: New York, NY, USA
    1. AndrewIbk's Avatar
      AndrewIbk -
      ok updated to 9.5 and did the mobile terminal thing, and now i can make calls in out. text in and out..

      BUT NO EDGE!!!!!!!!! =/

      never ending cycle man... No edge Icon.. nothing..

      tmobile, USA southern california. Help pleaseeee
    1. i pimping's Avatar
      i pimping -
      Quote Originally Posted by ellicit View Post
      As I said before I have tired alot of things, it didnt work.
      like some, I kept getting the " ..... " dots on status

      Here is my solution:

      once you have yellowsn0w 0.9.5 install

      make sure you have mobile terminal installed too, with edge off, 3G off,

      open terminal type:

      " yellowsn0w -c " press return
      " yellowsn0w -q " press return
      " yellowsn0w -r " press return

      go back to home, then Setting > General > Reset > Reset Network Settings

      this will reboot your phone, now once its turned back on, you should still see the evil "....." , thats fine, now goto Setting and turn Airplane Mode ON wait 10 sec, turn it back off, now you should see "Searching" on the signal bar area, and after 1 sec or so, BOOOM full bar.


      what works
      - EGDE
      - INCOMING CALLS/ OUT GOING CALLS
      - TEXT (SEND/RECIEVE)
      - WIFI


      everytime you boot, you must do this on terminal...

      until 0.9.6
      Dev team rulez

      BTW, I've tired this 3 times, and it worked all the time.


      Oh!
      worked on : Tmobile
      Location: New York, NY, USA
      you dont need to do any of this just do wot was said in the first post
    1. imilad's Avatar
      imilad -
      I am a tmobile user in southern cali. .. I did not have outgoing call until this morning when i got 0.9.5.. at first i updated through cydia and I had no luck.. I completely restored through itunes, then pwnage tool. installed a fresh copy of 0.9.5 restarted my phone.. still no service...
      ran mobile terminal with command line yellowsn0w -r then yellowsn0w -c put my phone in airplane mode and BAAAAAM tmobile full bars with outgoing calls... DEV TEAM FINALLY CAME THROUGH!!!


      So

      1,if you already have yellowsn0w on your phone i suggest you restore to a fresh copy 2.2 (through itunes)
      2, jailbreak
      3, install yellowsn0w 0.9.5
      4, install mobile terminal
      5, reboot
      6, open mobile terminal
      7, type yellowsn0w -r
      8, type yellowsn0w -c
      9, airplane mode ON
      10, airplane mode Off
      you will see the carrier menu pop up and your bars showing up couple seconds after.


      if you are in USA and have t-zone on your phone type epc.tmobile.com in APN settings to make it work

    1. ellicit's Avatar
      ellicit -
      What worked for me was my last post, I have edge, wifi, calls in/out text in and out. I have tired all the other method and nothing else worked for me.
    1. zani1972's Avatar
      zani1972 -
      hi downloaded the yellowsn0n 9.5 works great everything works. downloaded it and reboot it and waited like 30 sec. and bars all 5 thanks DEV
    1. newyork0900's Avatar
      newyork0900 -
      I have 3 network sim 3g iphone 2.2fw 02.28 bb. I followed turntablists guide and it worked, I upgraded from 9.4 to 9.5 and it still worked. I turned it off last night and back on the this morning, I have dotted lines and then no signal, airplane mode hasn't worked, network reste hasn't worked. I have had to uninstall 9.5 and reinstall and then follow the process I did last time. I now have my signal back.

      1. Has anyone else had this problem?

      2. Is there a solution?

      3. Can I get the 9.4 from somewhere?

      Thanks

      I forgot to ask. How do I reboot using bossprefs, as I carn't find an option.
    1. Mes's Avatar
      Mes -
      After getting this to work .... twice (Ugg), and the last time without hiccups --- let me make a suggestion.

      Time is your key

      The Dev-Team yellowsn0w is a software unlock --- a daemon process. Daemons run in the background and here's the key -- need time to work--. The amount of time needed depends upon what else is running.

      So..... Everytime you reboot, or turn airplane on -- or off. Wait a while --- at least 10 seconds. (The very 1st reboot after installing yellowsn0w, or resetting network setting - 1 min or more).

      For me, this was the key to make it work relialbly.
    1. mlopato's Avatar
      mlopato -
      HI guys , I tried every option to unlock 3g i on yellowsn0w 9.1 through 9.5 played with airplane mode was rebooting phone dozen times nothing worked, than last night i Just hit RESET ALL SETTINGS instead just network setting and it worked since . tried on Italian TIM , polish Orange , US T-Mobile SIM cards
    1. johnnys's Avatar
      johnnys -
      Im in the US and tried using my t-mobile sim after installing yellowsn0w. It doesn't work.
    1. ajl917's Avatar
      ajl917 -
      Quote Originally Posted by johnnys View Post
      Im in the US and tried using my t-mobile sim after installing yellowsn0w. It doesn't work.
      Try looking through the last few pages of the thread, and you will probably find an answer...