• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Tethering on 3.1 - MyWi 3.1.8


    Folks have been waiting for tethering on 3.1.x, and it's available now with the 3.1.8 release of MyWi.app. MyWi is a Rock.app application we've mentioned before, which runs $9.99 to purchase. It comes with a free trial. The nice thing about the tethering? Not only does it work on 3.1 firmware, it runs on the iPhone 2G just as smoothly as the iPhone 3G/3G[S] (of course at a slower speed, since the 2G obviously only runs EDGE).

    Version 3.1.8 is now available from the Rock App.. All trials which have occurred before are being reset as well, so folks are getting a full trial regardless as of this release.



    Features are the same as before, but now with 3.1.x and iPhone 2G covered as well:
    • Create WiFi Hotspot to connect mutiple laptops or mobile devices to share your iPhone''s internet connection
    • 40 bit and 104 bit WEP Security to prevent others from accessing your WiFi HotSpot
    • Ability to enable USB and Bluetooth Tethering on your iPhone as well
    • Uses less battery and much faster then PdaNet due to native routing
    • Broadcasts the Network Name (SSID) - no need to fuss with creating an adhoc network on your laptop
    • Shows up and down bandwith usage

    RockYourPhone
    This article was originally published in forum thread: Tethering on 3.1 - MyWi 3.1.8 started by Kyle Matthews View original post
    Comments 176 Comments
    1. genuino's Avatar
      genuino -
      Sorry for not reading the whole thread, I was just thrilled to have it working again, my bad. By the way, I didn't loose my voicemail, tested it.
    1. Daps's Avatar
      Daps -
      It's cool and you're a lucky *bleep* *bleep* I got it to work with tethering and my MMS worked but it killed my vmail I spent a few hours yesterday trying to get it to work with my voicemail, after getting stuck at the apple logo and having to full restore, I decided that was enough, the $10 for MyWi was worth it & not worry about it anymore and besides I could wifi tether if I needed although I don't see any need to at this point
    1. genuino's Avatar
      genuino -
      Perhaps I didn't loose VM because I used the iPhone Configuration Utility to install it. I was ready to try MyWI when I saw this on another forums.
    1. Daps's Avatar
      Daps -
      Hmmm could be. I just installed my profile using benm site with safari on my iphone..didn't try the iphone config utility

      hmmmmmm dare I try again...hmmmmm
    1. metaserph's Avatar
      metaserph -
      Once again, if you just want to tether using your usb/bluetooth connection then the hack works just fine. If you'd like the option of creating a wifi hotspot that can be shared, over wifi, with others then MyWi does the trick. Apples to apples...

      Keep an eye on what happens to the "tethering hack" after the trial period for MyWi expores.
    1. TooSlo's Avatar
      TooSlo -
      Well, I've offically had my last bad experience with any Rock related apps.

      After installing MyWi from the Rock repo, my Exchange connection no longer works. I've verified my OWA credentials are correct and that there have been no changes made to either our OWA or Exchange servers.

      Looks like I get to restore my phone, the most frustrating part is that I don't have a 3.0 ECID since this was a replacement phone when my screen died and I have to go up to 3.1 or 3.1.2 now.

      Sign me up as someone completely unimpressed with anything Rock related. I'll burn in hell before I suggest to anyone that they should use another Rock only app.
    1. Daps's Avatar
      Daps -
      My exchange connection seems to still be working
    1. TooSlo's Avatar
      TooSlo -
      Quote Originally Posted by Daps View Post
      My exchange connection seems to still be working
      That's quite strange. The only thing that changed on my phone last night was installing Rock App and MyWi.

      I've confirmed that my OWA server is online and my officemate, who hasn't made any changes to his phone, is still able to properly connect, as well as I can use my credentials on his phone to properly connect to Exchange.

      Something hosed the Exchange capabilities on my iphone and the only suspect apps that were installed recently have been Rock App and MyWi.

      I'm fairly confident that anyone trying to troubleshoot an issue such as this would start at the recent change level.

      WTB: Rollback functionality/saved state w/ the iphone.... I can do it w/ my Android and WinMo phones w/o too much hassle.
    1. Daps's Avatar
      Daps -
      I sent myself an email to myself from my desktop and my phone binged me after I read your post, but I thought it had been working with MyWi installed.

      Do you get any type of error? Try deleting the exchange acct and put it back. Have you tried a network reset on your iphone? Probably won't help but who knows with these things.

      I tried the tether hack yesterday and it didn't work for me and had wound up getting stuck at the apple logo. I just did a factory restore through itunes and then restored a backup from that morning. If you're unlocked that may not be an option.

      Email just came in on my phone as I was typing this..

      Don't know what to tell you, maybe turn it all the way and back on, reset network, delete exchange acct on the phone and put back...I'd be interested in hearing what you wind up doing and g/l
    1. twitchthecat's Avatar
      twitchthecat -
      I bought MyWi. It works.
    1. TooSlo's Avatar
      TooSlo -
      Quote Originally Posted by Daps View Post
      Don't know what to tell you, maybe turn it all the way and back on, reset network, delete exchange acct on the phone and put back...I'd be interested in hearing what you wind up doing and g/l
      I can officially say that today has been an absolutely frustrating day on my part.

      I've verified that my Exchange account works on two other 3GS iphones, my G1, as well as through my company's OWA page.

      Removed the Exchange account, rebooted phone, attempted to set up again. Still get the error. Attempted to set up officemate's account, still no love.

      Completely removed everything related to Rock and MyWi and reset my network settings. Rebooted phone, no dice.

      Reloaded the 5.0 carrier bundle and synced to itunes to get the most recent bundle, still nothing.

      Attempted to set my phone up as a new device, still nothing.

      Had to restore my phone, losing 3.0.1 and having to futz around for several hours to make sure that my baseband wasn't upgraded during the process, which was a huge pain in the *** since I only own PCs because of my business.

      That being said, I've made it a point to make sure I will never install another Rock app on my phone, and will steer anyone who asks as far away from them as possible. It's the second time that having anything to do with the Rock apps has forced me to restore, and I've wasted 4-5 hours today just getting my phone back to it's former self, aside having to upgrade the FW.

      I can't support any company that has the terrible track record of not even responding when you try to get customer support from their site and forums.

      Personally I'm appalled that a company could validly attempt to charge $10 for a tethering application. I can load up a home cooked ROM on any HTC device and have it as a free option, and honestly it's getting me closer and closer to buying an unlocked HTC Hero, and just use my iphone to play UniWars on my free tethering application that I built into a ROM that I can install any time that I'd like to in the near future.

      Call me a grumpy bear, but I'm getting VERY tired of both Apple and the greedy app developers that won't back up their products.
    1. Daps's Avatar
      Daps -
      Sorry to hear about your problems but I'm not having any issues with MyWi. MMS,VM and my exchange mail works.

      It you had 3.0.1 why would you use MyWi when if memory serves you could already use the native tether ability...

      I hate to see what you think about PDANet who charges $30 and you have to load a client on your machine.
    1. TooSlo's Avatar
      TooSlo -
      Quote Originally Posted by Daps View Post
      Sorry to hear about your problems but I'm not having any issues with MyWi. MMS,VM and my exchange mail works.

      It you had 3.0.1 why would you use MyWi when if memory serves you could already use the native tether ability...

      I hate to see what you think about PDANet who charges $30 and you have to load a client on your machine.
      I prefer using something along the lines of MyWi since it allows me a bit more freedom with my netbook, as well as allowing my wife to have our itouch connected to the network and have internet access as well.

      I think yesterday was the final tipping point for me, I'm on the prowl for an HTC Hero.
    1. Daps's Avatar
      Daps -
      Ok got ya....you needed the sharing capabilities...
      Does PDANet offer that? It's way more though...
    1. ty22's Avatar
      ty22 -
      Quote Originally Posted by ekull25 View Post
      I was about to uninstall the trial of MyWi, when I noticed that the iPhone's native tethering option was back in my settings/general/network screen! Hmmm. I flipped the switch to ON, and my laptop instantly saw the connection!!

      So I couldn't get the MyWi app to work, but got native tethering to work. So, who needs MyWi, right? I uninstalled it, but now my native tethering option was GONE! WTF!?!?
      Same here except I uninstalled mywi and the native tab was there still.....Yay
    1. niketheory's Avatar
      niketheory -
      I've been looking up how to do this forever, lol!
      This is a relief.