• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iPhone 3GS OS 3.1 Pwned? Sorta...
    Well, there's a good news for some but bad for others..



    First of all, the good news is that according to CPICH - an iPhone DevTeam member - DevTeam has successfully upgraded an iPhone 3GS on OS 3.0, pwned previously, to OS 3.1 without loosing the jailbreak! That's a great news for those who have been desperately waiting to upgrade their 3GS but don't want to sacrifice the jailbreak for it.



    However, the solution works ONLY for previously Pwned iPhone 3GS and NOT for the OOTB (out of the box) 3.1 or non-downgradeable ones (in case you didn't capture the iBSS and iBEC files)... This means that if you just bought the device, you're completely out of luck for some more weeks!



    This new exploit will definitely be merged into the PwnageTool, which means no luck for Windows peeps as well.

    P.S. There is no solution for unlocking the new baseband found in OS 3.1 but you can preserve the unlock while updating the iPhone to OS 3.1, once the jailbreak tools are available publicly.

    [Twitter]
    This article was originally published in forum thread: iPhone 3GS OS 3.1 Pwned? Sorta... started by sayam View original post
    Comments 50 Comments
    1. dmerrill's Avatar
      dmerrill -
      Ok, I'll throw my hat into the ring with questions too. We have 2 32GB 3GSs on 3.0 jailbroken with purplera1n. We have 8.2 iTunes on hubbys machine, 9.0.1 on mine. NO version of iTunes will talk to my phone (I had to use the SSH method to upgrade my carrier as a result), but can talk to hubby's just fine (used iTunes to do his carrier). iTunes tells me I must restore, figured I would use Suarik's method to restore back to 3.0 eventually. I have all of the files IBEC, IBSS, etc for MINE locally, not hubby's, but have the saved files for both on Saurik's server. All of this is in Windows. SO, will the new tool work with Windows (seems to be confusion about that), AND do I have everything I need on Suarik's server? I really want to be able to get Snapture back on the phones (an app requiring 3.1). If not for devs that leave 3.0 behind, I wouldn't care, restoring is a pain in the butt for people like me with hundreds of apps.

      Ok, well, Windows users, we are out of luck, Dev-Team just updated. Ahh well, I can live without Snapture for a while longer. I'll just keep my 3.0 JB and be happy. I got MMS so not like I'm deprived (hat tip to Stealth Bravo for the SSH instructions on that!!!)
    1. twitchthecat's Avatar
      twitchthecat -
      Quote Originally Posted by DarkoNova View Post
      Does anyone even care anymore? You can essentially do everything with 3.0 and the .ipcc hack that you can do with 3.1.

      Matt
      I do care and for the same reasons as santaf. If we follow the directions in the first thread, will the phone end up being on 3.1, 3.0.1, 3.0 or what?
    1. emile17's Avatar
      emile17 -
      How do you go about saving the signature files on cydia for the iphone3gs 3.0 so i can do future jailbreaks(not 3.1), and can i capture it with 3.01 or am i limited to just 3.0. I'm planning to get a iphone 3gs (3.0) and want to make sure I'm able to do future jailbreaks. example if i get a new 3gs outta the box and it has 3.0 will i still be able to do future jailbreaks
    1. vjnk's Avatar
      vjnk -
      I currently have an iphone 3gS that is running 3.0.1. It has never been jailbroken. Forget for a second about 3.1. Is there any way right now that i can jailbreak my phone running 3.0.1. Whether its creating a custom IPSW i am not sure. I dont have anything on file with saurik. I just have an iphone 3GS running 3.0.1 that has never been modded.

      thanks
    1. dmerrill's Avatar
      dmerrill -
      If you are on 3.0.1 you should be able to use redsn0w to jailbreak.
    1. k4nt0r's Avatar
      k4nt0r -
      Quote Originally Posted by vjnk View Post
      I currently have an iphone 3gS that is running 3.0.1. It has never been jailbroken. Forget for a second about 3.1. Is there any way right now that i can jailbreak my phone running 3.0.1. Whether its creating a custom IPSW i am not sure. I dont have anything on file with saurik. I just have an iphone 3GS running 3.0.1 that has never been modded.

      thanks
      Yes. I just recently jailbroken my 3GS like last week.
      For Mac: iClarified - iPhone - How to Jailbreak Your iPhone 3GS on OS 3.0.x Using RedSn0w (Mac)
      For Windows: iClarified - iPhone - How to Jailbreak Your iPhone 3GS on OS 3.0.x Using RedSn0w (Windows)

      Note that instead of 3.0.1 .ipsw, use 3.0.
    1. mdc929's Avatar
      mdc929 -
      cheesin
    1. Azn_Sapper's Avatar
      Azn_Sapper -
      You can use the Dev team's PwnageTool 3.1.3 to JB your jailbroken 3.0/3.0.1 iphones.

      The iPhone 3GS is now supported in PwnageTool 3.1.3, assuming the phone was pwned at 3.0 or 3.0.1 - PwnageTool does not support the 3GS out of the box. If your iPhone 3GS has 3.1 preinstalled and is not Pwned then there is no tested jailbreak solution at the moment.

      The iPod 2G is now supported in PwnageTool 3.1.3, assuming the iPod 2G was pwned at 3.0 or 3.0.1 - PwnageTool does not support the iPod 2G with 3.1 software out of the box.

      DETAILS:

      1. GOLDEN RULE: If you are using a iPhone 3G or iPhone 3G(S) with ultrasn0w and rely on ultrasn0w to obtain cellular service then you should only update your device with an .ipsw that is made with the new PwnageTool. There are no second chances with this. You need to remember that PwnageTool will provide an upgrade path to newer versions of the iPhone software in the future.
      2. Please read all parts of this post before downloading and using these tools.
      3. Read items 1, 2 and 3 again and again.
      4. At the bottom of this post are the bittorrent files for the 3.1 capable version of PwnageTool.
      5. PwnageTool will work for the iPhone 3GS assuming you have already Pwned it at 3.0 or 3.0.1
      6. PwnageTool will work for the iPod touch 2G assuming you have already Pwned it at 3.0 or 3.0.1
      7. PwnageTool WILL work for Original iPhone (1st Generation), the iPhone 3G and iPhone 3G(S) and the iPod touch (1st Generation and 2nd Generation) but NOT the iPod touch 3rd generation.
      8. For 3G and 3G(S) users who are Pwned, PwnageTool is your key to updating in the future, just remember to never install an update directly from Apple, always use an .ipsw that has been created with PwnageTool.
      9. There is no Windows version of PwnageTool it is a Mac OS X tool only, we are not developing a Windows version of PwnageTool.
      Yu can find everything you need to know here: Dev-Team Blog - All aboard the update train!

      Unfortunately, those of us who used redsn0w are SOL until they release an update.
    1. omie1023's Avatar
      omie1023 -
      I've tried downgrading to 3.0 from 3.1 and itunes tells me that my iphone cannot restore to the 3.0 firmware ! That sucks!
    1. z28kid's Avatar
      z28kid -
      humm.. wrong place.. my bad