• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Get MMS on your iPhone TODAY

    image source: Fire Wire

    Cult of Mac has a simple straightforward hack to enable MMS messaging on your iPhone 3G or 3GS if you just can't wait... or if, like me, you have fun playing around in your phone's guts a little.

    It takes about three minutes, and Leander Kahney warns that some users have said it doesn't work. Your mileage, as always, may vary.
    This article was originally published in forum thread: Get MMS on your iPhone TODAY started by Paul Daniel Ash View original post
    Comments 286 Comments
    1. hollow0's Avatar
      hollow0 -
      Quote Originally Posted by ifonemaniac View Post
      BEST POST I'VE SEEN ON MMI... thats awesome rescuer

      You could fiddle with all that MMS crap...or you can be awesome and have mms for the past year on the 2G without having a single problem /@$ mode
      That weak 2g iphone on that weak T-mobile network? Yeah i had that...can you send videos via mms too? If you can't then i guess you're not that awesome..
    1. z4kMKv's Avatar
      z4kMKv -
      Works!
    1. bish's Avatar
      bish -
      worked for me! thanks for the post
    1. one1's Avatar
      one1 -
      This is where the send bar hangs for people that are having it hang @ 90% (like me on my 3gs)

    1. netsliderx2's Avatar
      netsliderx2 -
      Mine was hanging at the 95% mark (estimated) and I suddenly realized that I imputed the settings into the cellular data part and not the mms part (duh right) i made the correction and it works just fine now!!

      I must admit that it still hangs but only for about 20 seconds or so and then .. tada it sends and I have been able to receive as well. Hope this helps someone
    1. one1's Avatar
      one1 -
      Mine has always been in the right spot, but I did notice that I have a "max message size" limit like the screen shot in the OP so maybe we are hitting that size limit somehow.

    1. StealthBravo's Avatar
      StealthBravo -
      I am so sick of these MMS threads. I can't wait for the 25th so everyone can STFU.
    1. mrguy's Avatar
      mrguy -
      For everyone who's mms is stoping at 90%
      try putting the username and password in again then reboot ur phone, after reboot make sure u put in the username and password one more time.
    1. one1's Avatar
      one1 -
      Quote Originally Posted by StealthBravo View Post
      I am so sick of these MMS threads. I can't wait for the 25th so everyone can STFU.
      Me too, that's why I am actually trying it for once. I figure there's gotta be something amazing I don't know about, but it isn't working out so screw it!
    1. tudtran's Avatar
      tudtran -
      It's doesn't work for me. The picture doesn't send.
    1. TheOrioles33's Avatar
      TheOrioles33 -
      Quote Originally Posted by danw217 View Post
      i've been trying to get this to work with no success... I am able to update my IPCC file and the phone shows Carrier: AT&T 5.0 in the About page... and i've entered all the Cellular Data connection info (user name, password, proxy, etc...) but there is still no camera icon! And no option to enable MMS under my message settings..

      I am running 3.0.1 on my 32GB 3GS... anybody else have a clue?
      Hey man! I was in the same boat until a few minutes ago. I went into settings and messages and there is an MMS Messaging ON/OFF switch. Turn it on and the camera icon will magically appear. Working great! I do have unlimited family messaging plan. That may have something to do why some peoples are working and some are not.

      EDIT: Ok, I'm a dumb *****! Just saw you tried that! Duh!
    1. lupyman's Avatar
      lupyman -
      Do you have to be using a certain firmware and carrier file version? I'm on 3.01 and used the carrier file in the link which is AT&T 5.1

      Still no MMS...
    1. imirish02's Avatar
      imirish02 -
      So I did this, and I just checked my account features on the att wireless app and there is a no longer an iphone messaging plan, just "messaging". Still, no dice on it working
    1. hollow0's Avatar
      hollow0 -
      Quote Originally Posted by StealthBravo View Post
      I am so sick of these MMS threads. I can't wait for the 25th so everyone can STFU.
      whoooosaaaahhhhhhhh....
    1. bruinsrme's Avatar
      bruinsrme -
      Quote Originally Posted by DarkoNova View Post
      Windows 2000/XP/Vista (32-bit):

      1. Go to Start -> Run
      2. Type in "command" and hit enter
      3. Type/copy+paste this into the command console that comes up: "C: Program FilesiTunesiTunes.exe" /setPrefInt carrier-testing 1
      4. Hit enter

      Windows XP/Vista (64-bit):
      1. Go to Start -> Run
      2. Type in "command" and hit enter
      3. Type/copy+paste this into the command console that comes up: "C: Program Files (x86)iTunesiTunes.exe" /setPrefInt carrier-testing 1
      4. Hit enter

      Then follow the rest of the original tutorial.

      EDIT: I put a space between ": " because if you don't, the forum turns it into a smiley, lol. -> :

      Matt

      If you cut and paste the command line you may get an error. if that is the case manually type it in.
      took me an hour to figure that out. dont know what the difference is but I am happy with MMS and tethering

      also, I ahve not seen this work with phones with just the iphone text plan. I have family messaging and it works.
      it works on 3Gs jailbreak 3.0 with family messaging
      it works on 3G non-jailbreak 3.1 with family messaging
      couldnot get it to work with a 3Gs or 3G jailbroken or not that just has the iphone texting plan. It does enable the function to be displayed but it doesn't send or recieve
    1. BlackedOutMugen's Avatar
      BlackedOutMugen -
      Doesnt work. poop

      EDIT, it does! It takes forever to send the pic though!

      SWEET
    1. jrod_15's Avatar
      jrod_15 -
      wow really works just did it on my 3gs & wifes 3g....thanxz
    1. NSXrebel's Avatar
      NSXrebel -
      I think it's only working for people on a family plan.
    1. FURBY8704's Avatar
      FURBY8704 -
      mine been working for a few months now >;P
    1. apwtwenty's Avatar
      apwtwenty -
      Quote Originally Posted by BlackedOutMugen View Post
      Doesnt work. poop

      EDIT, it does! It takes forever to send the pic though!

      SWEET
      do you have the family plan?

      i dont have the family plan, and ive tried just about everything/combination. im beginning to think ppl are right bout it only working on family plan phones. i dont have another att phone 2 do sb's method so i cant go that route. i have my husbands, but its his work phone.