• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • [ HOW TO ] Jailbreak Using Pwnage Tool on 3.1 for Mac
    PLEASE TAKE HEED OF THIS INFO FROM THE DEV TEAM:

    This release starts with PwnageTool 3.1 for Mac OS X - this application supports the iPhone 1st Generation (2G), the iPhone 3G and the iPod touch 1G. NB: THIS DOES NOT SUPPORT THE 3GS OR 2G/3G IPOD TOUCH. redsn0w for Mac OS X and Windows will follow sometime in the near future, please don’t bug us about it - we’ll release when we have something ready.
    • GOLDEN RULE: If you are using a 3G iPhone with ultrasn0w and rely on ultrasn0w to obtain cellular service, then you should only upgrade to 3.1 with a PwnageTool created .ipsw. - Stay away from Apple’s direct updates as described here and here please get up to speed on the whole subject by reading the information contained in these posts.
    • If you have an original iPhone (1st generation) then 3.1 unlock works with this PwnageTool release. iPhone 3G users upgrading to 3.1 will need to continue using ultrasn0w with a PwnageTool created 3.1 .ipsw
    • Please read all parts of this post before downloading and using these tools.
    • Read items 1, 2 and 3 again and again.
    • This app is suitable for the recent 3.1 release.
    • This version of PwnageTool will NOT work for the iPhone 3GS.
    • PwnageTool WILL work for Original iPhone (1st Generation), Original iPod touch (1st Generation) and the iPhone 3G.
    1. Download PWNage tool
    2. Download the original 3.1 ipsw
    3. Open PWNage tool
    4. Select your model of phone

    5. Click Next
    6. PWNage will search for the 3.1 ipsw

    7. Select the firmware and Click Next

    8. Click Yes to creat the firmware

    9. It will ask you if your phone activates through itunes. If you are hacktivating your phone select No. If you have an authorized carrier select yes.

    10. It will now begin to build the custom ipsw

    11. You will be prompted to enter your password. Enter it to continue building the ipsw.


    12. You will then be asked if you iPhone has been Pwwned before...Select No


    13. You will then be prompted to plug in your phone.

    Follow the on screen instructions....









    14. Open iTunes

    15. iTunes will detect your phone in recovery mode. Click OK.

    16. Hold the Option button on your keyboard and click Restore in iTunes

    17. Then browse to the custom ipsw you just made.

    18. Select it and press Choose.
    19. iTunes will begin to restor your iPhone with the custom ipsw


    20. When it is finished you will see this message


    From The Dev-Team:
    Update : Unlocked users on the 3G will probably notice that the name and/or logo of their carrier is missing, but they still have full bars and a signal. So far this seems to be purely a cosmetic issue and it doesn’t impact your signal or coverage. We hope to have this issue “fixed” when we release the 3GS compatible version of PwnageTool. This is very likely tied to Update #3…

    Update : As of 3.1, the *.ipcc carrier bundles are signed, and you can no longer force tethering capability simply by crafting your own bundle. The good news is this obstacle can probably be overcome by virtue of the jailbreak. But so far that extra hack is not part of the PwnageTool custom IPSW creation.
    This article was originally published in forum thread: [ HOW TO ] Jailbreak Using Pwnage Tool on 3.1 for Mac started by Melech518 View original post
    Comments 458 Comments
    1. shabz_de_don's Avatar
      shabz_de_don -
      nicely done.. i didnt even need to put my phone in dfu or recovery mode.. i done it like a normal restore lol...

      quiestion guys anyone ind out how to get the carrier part sorted?
    1. karlreed2's Avatar
      karlreed2 -
      Got it baby!!! iPhone 3G 3.1 Jailbroken. Thank you Thank you Dev Team. Very nice work!!! I love my jailbreak and this time around I used Rockapp to restore all my JB apps which made it a cinch.
    1. mombopete's Avatar
      mombopete -
      I have it working with the only problem being that there's no weather icon. Actually running better than 3.0. Thanks Dev Team.
    1. GrandMstrBud's Avatar
      GrandMstrBud -
      Does anyone have issues with Sling Player? I got an error after the restore.
    1. trellaine's Avatar
      trellaine -
      UGh! I followed the directions from iclarified to jailbreak my iPhone3G and it seemed to have worked BUT I have lost my network? UGH! I also had itunes latest update and running 3.1,

      Is there anyway to get my network back?

      Thanks in advance.
    1. ninthchamber99's Avatar
      ninthchamber99 -
      Here is a question I have not seen the answer to. Ok, in reference to Cydia (I saw several posts/threads and a screen shot of Cydia displaying that your personal iBSS and iBEC and ECID was saved on the server). Once 3.1 is jailbroken (i know pwnage is available but I have a 3GS and I am waiting for redsnow), will Cydia give us the option of saving this info since most people did not do this. I have my files saved on my PC, using the iClarifi method a while ago, but I would also like Cydia to keep a copy also (in case something happens to my home computer).
    1. galaxygrrl's Avatar
      galaxygrrl -
      My phone is working perfectly now since I manually installed everything. No issues like other people are having. Just stay away from Aptbackup.

      Thanks Jay and iphone dev team
    1. Melech518's Avatar
      Melech518 -
      Quote Originally Posted by ninthchamber99 View Post
      Here is a question I have not seen the answer to. Ok, in reference to Cydia (I saw several posts/threads and a screen shot of Cydia displaying that your personal iBSS and iBEC and ECID was saved on the server). Once 3.1 is jailbroken (i know pwnage is available but I have a 3GS and I am waiting for redsnow), will Cydia give us the option of saving this info since most people did not do this. I have my files saved on my PC, using the iClarifi method a while ago, but I would also like Cydia to keep a copy also (in case something happens to my home computer).
      Cydia will keep your 3.1 signatures on file eventually yes, but your 3.0 and 3.0.1 files are lost forever if you didnt get them on file previously
    1. gggguest's Avatar
      gggguest -
      So umm... Pwnage Tool doesn't work on my MBP with 10.6.1. Just sits at this screen forever:


      I can't click on anything; nothing happens when I click on a button. Just sits here. I left it for 10 minutes and it just does nothing. I put the IPSW in ~/Library/iTunes/iPhone Software Updates to maybe have Pwnage Tool find it quickly, but it does nothing.

      I was hesitant to jailbreak 3.1 because I just didn't want to go through updating all my jailbroken mods and stuff, but now I really want to, but when I try to do that, it just sits there. LAME!
    1. Pekkle's Avatar
      Pekkle -
      Quote Originally Posted by confucious View Post
      It's strange what some people post.
      I haven't had a problem accessing the network and my tab is still there.
      Can you please post how you upgraded to 3.1? such as what custom settings you have used and what network you are on and operating system version and itunes version number? Because I and majority of the other people are having the network issues, including the carrier logo disappeared.

      Thanks!
    1. confucious's Avatar
      confucious -
      Quote Originally Posted by BeSweeet View Post
      So umm... Pwnage Tool doesn't work on my MBP with 10.6.1. Just sits at this screen forever:


      I can't click on anything; nothing happens when I click on a button. Just sits here. I left it for 10 minutes and it just does nothing. I put the IPSW in ~/Library/iTunes/iPhone Software Updates to maybe have Pwnage Tool find it quickly, but it does nothing.

      I was hesitant to jailbreak 3.1 because I just didn't want to go through updating all my jailbroken mods and stuff, but now I really want to, but when I try to do that, it just sits there. LAME!
      Turn on spotlight

      Quote Originally Posted by Pekkle View Post
      Can you please post how you upgraded to 3.1? such as what custom settings you have used and what network you are on and operating system version and itunes version number? Because I and majority of the other people are having the network issues, including the carrier logo disappeared.

      Thanks!
      The vast majority of people have absolutely no problem whatsoever apart from the carrier logo disappearing - if you have bars, you have service. The logo is a total irrelevance.
    1. angiepangie's Avatar
      angiepangie -
      Carrier logo doesn't show up on 3.1 JB and UL unless you use makeitmine or something similar.
      Confucious is T-mobile UK but his logo is AT&T (lol)
    1. 360psp's Avatar
      360psp -
      Can anyone tell me, with a straight answer......which custom ipsw to use if i want to continue to have ultrasnow/tmobile on my phone.........the activated ipsw or the unactivated one, because iam just very confused?
    1. angiepangie's Avatar
      angiepangie -
      activated.
    1. confucious's Avatar
      confucious -
      Here's mine - doesn't need APN to work
    1. angiepangie's Avatar
      angiepangie -
      And your data's working?
    1. confucious's Avatar
      confucious -
      Of course
    1. angiepangie's Avatar
      angiepangie -
      Gosh, you're even more special than me.
    1. confucious's Avatar
      confucious -
      But I don't even get 5Mb on WiFi
    1. phoeny's Avatar
      phoeny -
      hey there,

      so i thought i just throw this in here cause i don't feel like getting another account to comment on dev-team's blog.
      anyways, i successfully jailbreaked 3.1 on my factory unlocked 3G.

      but, instead of everybody else it seems, i don't have any problems with my carrier text/logo showing. it's there just fine.
      once again i'm on a factory unlocked 3G, restored to official 3.1 first, and then used a custom .ipsw to jailbreak.
      no carrier text/logo issues! it's shows up as it did before on 3.0.

      my thoughts on this:
      #1 maybe my carrier still shows up cause i'm using a non-official carrier, e.g. the generic carrier bundle (which contains NO logo files, but get's the actual text to show from the carrier)
      #2 before using a custom .ipsw i restored to the official 3.1, which means i'm on bb 05.11.07 (which is of course the luxury of a factory unlocked phone) - so maybe this is an issue due to pwnagetool preserving the old bb

      nevertheless, it's a minor issue, but i'm glad my carrier text still shows up :-)