• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iPhone OS 3.1 - All you need to know
    <iframe src="http://www.zumodrive.com/photo/embed/Yk2OTQ3Mz" width="450" height="300" frameborder="0"></iframe>

    It's been quite a while since Apple released the OS 3.1 for iPhone and there's been a lot of confusion regarding it's Jailbreak Status etc. Therefore, here's a summary of do's and dont's

    • According to ChronicDev, the 3.1 GM seed is still vulnerable.
    • It has been confirmed by MuscleNerd from DevTeam that iTunes 9 doesn't interfere with jailbreaking so you can update iTunes <s>but make sure that you do not update your device firmware to 3.1 yet if you want to jailbreak</s>. UPDATE: Jailbreak for OS 3.1 has been released but for the iPhone 2G, iPhone 3G and iPod Touch 1G ONLY and NOT iPhone 3GS, iPod Touch 2G and iPod Touch 3G! Therefore, update only if you have older hardware
    • Saurik confirms once you update to 3.1, there's <s>no way to downgrade</s> to an earlier version as iTunes no longer signs the older firmware. Therefore, if you do not have your ECID information saved, <s>you're completely stuck</s>! For those who have the information saved, there should be a solution out soon. UPDATE: 3.1 can now be downgraded to 3.0 but remember, the baseband is not downgraded along with the firmware, so you might still be permanently locked even though you can now jailbreak 3.1 in future.
    • The new firmware also includes a new baseband which means none of the current unlocking tools will work. Therefore, if you upgrade an iPhone 3G with bootloader newer than 5.8 or an iPhone 3GS, there are chances that your device might get permanently locked.


    Verdict: If you EVER want to jailbreak and unlock your iPhone 3G / iPhone 3GS again, DO NOT UPDATE YET!
    This article was originally published in forum thread: iPhone OS 3.1 - All you need to know started by sayam View original post