• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • AT&T MMS Already Working for Some Folks?


    Looks like some users are already receiving and sending MMS just fine on the AT&T US network. ModMyi.com member yotelefonotresg sent us some legit-looking screenshots of MMS coming through just fine on AT&T (yes, I'm fully aware you can do that easily on T-Mobile by changing the carrier name, but we've received decent enough proof to ask if anyone else is seeing this).

    How bout you guys - any AT&T users able to send out MMS or receive them yet? EDIT: reports keep pouring in, looks like its true. AT&T is gradually turning on MMS throughout the US!

    AT&T yesterday announced they'd have MMS ready by September, through a YouTube video (see below) you've probably already seen, by the new[er] AT&T talking head, Seth. I like Seth. He's a person, and he talks about AT&T crap that's been going on - straight up, and up front. Of course, he doesn't fix it... but he's a nice guy, right? I mean, that counts for something? Anything?

    This article was originally published in forum thread: AT&T MMS Already Working for Some Folks? started by Kyle Matthews View original post
    Comments 592 Comments
    1. Rescuer's Avatar
      Rescuer -
      Quote Originally Posted by StealthBravo View Post
      Sim swapping works 90% of the time. But the longevity is questionable
      that's what she said?
    1. thu6's Avatar
      thu6 -
      seems to come down to texting plan in my case.

      i have 2 iphones on my contract, mine, and wife's. i dont have a text plan on my line. i dont text much. she however does, so she has the 200msg plan.

      mms works fine for her. not for me. text plan is the only diff between phones.
    1. mobileSTU's Avatar
      mobileSTU -
      Thanks to the initial write up by StealthBravo (also for supplying the 5.0 carrier file) and the instructions/help from Rescuer and ugshotgun I can confirm that it works!!!!

      It seems (at least for me) that the key is to log in to your account online while your iPhone sim is in the other phone and change your "iPhone" messaging plan to a "standard" messaging plan. Send a mms from the other phone and if it goes through you are in business and can put your iPhone sim back in your iPhone and the MMS on the iphone will go through!

      Thanks guys!
    1. corradoking's Avatar
      corradoking -
      O no! Its not working on my phone now.. BUt the wifes phone is running still
      UPDATE


      Working again I did another SIM swap..I also went to media net and signed up for that..we will see.
    1. A Retired Mod's Avatar
      A Retired Mod -
      Quote Originally Posted by StealthBravo View Post
      It has nothing to do with 3.1. You must update your carrier settings and use another phone to activate it on the network
      I didn't do any of that....
    1. thu6's Avatar
      thu6 -
      nm
    1. madLyfe's Avatar
      madLyfe -
      even with updating the carrier settings, sometimes i lose the camera icon, and options to enable mss... but it still says carrier att: 5.0... wtf....
    1. StealthBravo's Avatar
      StealthBravo -
      If you have trouble updating via ipcc, then ssh the ATT_US.bundle into your phone
    1. madLyfe's Avatar
      madLyfe -
      Quote Originally Posted by StealthBravo View Post
      If you have trouble updating via ipcc, then ssh the ATT_US.bundle into your phone
      SB you have a step by step on this one?
    1. Late421's Avatar
      Late421 -
      I did the whole SIM swap thing for the last couple months but whenever I shut off the iphone completely it would always stop my MMS from working when it was turned back on, thus requiring to do the SIM swap again...well I went into court on Thursday and had turned my phone off, when I came out and turned my phone back on I was surprised to see that my MMS was still functioning fine, and still is now, no SIM swap required this time either....might be one of the lucky ones here
    1. sucram6791's Avatar
      sucram6791 -
      i get about 80% on the send bar when sending an mms and then it just stops
    1. StealthBravo's Avatar
      StealthBravo -
      Quote Originally Posted by madLyfe View Post
      SB you have a step by step on this one?
      Unzip this bundle. It should read ATT_US.bundle when done.

      ATT_US.bundle

      SSH into your phone and navigate to /var/mobile/Library/Carrier Bundles

      There you will see a bundle called ATT_US, delete it and replace with the one downloaded.

      now navigate to /System/Library/Carrier Bundles

      There you will see a bundle called ATT_US, delete it and replace with the one downloaded.

      Now restart your phone and you should have the camera icon in the messages app.


      *Side Note. If in the future you get errors trying to update ipcc's via iTunes like this:

      “iTunes could not update the carrier settings on your iPhone. An unknown error occured (0xE800003D)”

      Then SSH to your iPhone and change permissions in the /private/var/mobile/Library/Carrier Bundles/ folder.

      Type this in terminal:

      chmod a+rw -R /private/var/mobile/Library/Carrier Bundles/


      Enjoy!
    1. coppernights's Avatar
      coppernights -
      i got it all working!! updated the ipcc and set up everything but mms gets about 95% sent then i just get the red explanation marks and it doesn't go through.
    1. sucram6791's Avatar
      sucram6791 -
      Quote Originally Posted by coppernights View Post
      i got it all working!! updated the ipcc and set up everything but mms gets about 95% sent then i just get the red explanation marks and it doesn't go through.
      i tried the guide and that happens to me too
    1. madLyfe's Avatar
      madLyfe -
      Quote Originally Posted by StealthBravo View Post
      Unzip this bundle. It should read ATT_US.bundle when done.

      ATT_US.bundle

      SSH into your phone and navigate to /var/mobile/Library/Carrier Bundles

      There you will see a bundle called ATT_US, delete it and replace with the one downloaded.

      now navigate to /System/Library/Carrier Bundles

      There you will see a bundle called ATT_US, delete it and replace with the one downloaded.

      Now restart your phone and you should have the camera icon in the messages app.


      *Side Note. If in the future you get errors trying to update ipcc's via iTunes like this:

      “iTunes could not update the carrier settings on your iPhone. An unknown error occured (0xE800003D)”

      Then SSH to your iPhone and change permissions in the /private/var/mobile/Library/Carrier Bundles/ folder.

      Type this in terminal:

      chmod a+rw -R /private/var/mobile/Library/Carrier Bundles/


      Enjoy!
      hey thanks dood, i saw "__MACOSX" dir in that zip.. dunno if i needed that or not.. i just used the "ATT_US.bundle" dir that was also in the zip.. what are your cell data network settings..? i am gunna try the sim in another phone then change the msg plan then put it back into my iphone..
    1. StealthBravo's Avatar
      StealthBravo -
      Follow my guide, it has most of the methods of achieving working MMS on AT&T.

      Guide: MMS and Tethering working with AT&T on 3.0 iphone
    1. Rescuer's Avatar
      Rescuer -
      i got my mms working a few hours ago............... and now its' not sending any longer

      i didn't change anything and kept the phone on
    1. madLyfe's Avatar
      madLyfe -
      This is how its done... i have tried everything you can imagine... i feel the pain.. but i got it working.. ok this is very easy.. screw the itunes crap.. what i did was totally reset the network settings and rebooted my phone(clean start) then i this this below, provided by SB.. read on below..
      Quote Originally Posted by StealthBravo View Post
      Unzip this bundle. It should read ATT_US.bundle when done.

      ATT_US.bundle

      SSH into your phone and navigate to /var/mobile/Library/Carrier Bundles

      There you will see a bundle called ATT_US, delete it and replace with the one downloaded.

      now navigate to /System/Library/Carrier Bundles

      There you will see a bundle called ATT_US, delete it and replace with the one downloaded.

      Now restart your phone and you should have the camera icon in the messages app.
      then i took my sim out and put it into another att phone, my dads razor.. made a few calls, messed around on it for a bit.. then i logged into att website for my account info, if it doesnt recognize your phone as the updated substition phone and still says iphone, then log out and wait awhile longer, and keep checking back to make sure it shows the updated phone when you log in.. once it finally recognizes the phone it will show your txting plan still on the iphone plan.. well pick a corresponding txt plan that is non iphone(there wont be any other iphone choices btw..) then i made a few more phone calls on that phone just to make sure it took(dunno if that matters) then put your sim back into your iphone and reboot.. then mms works.. and when you log back into your att account it will still show the "Messaging Unlimited AT&T Recommends" and not the "iPhone Text Messaging Unlimited"
      FINALLY!
      FU ATT!!!!!!!!!
      BTW I JUST DID IT AND DONT KNOW HOW LONG IT WILL LAST.....
      ********** edit
      i dunno about mms video tho.. i only have a 3g.. my bro tried to send a video but said he couldnt send it.. he could be retarded but i dunno if its a 3g thing...
    1. chadgraves7814's Avatar
      chadgraves7814 -
      I read this thread this morning and just thought i'd give it a try. Well my wifes phone and mine both can send and recieve MMS now. Both are on firmware 3.0.1 with new carrier settings. Takes a little bit for it to send and to show up on the phone you sent it to but it is working.
    1. jonban's Avatar
      jonban -
      heres a new one i think, why is it that these settings are set in my phone, grant it ive still never to send MMS, but this is first time, since i been tinkering with this that i seen these settings, and they came up after i pressed "reset settings" option, if you see at bottom says, [url]www.apple......