• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • WinterBoard Released for iPhone 3GS


    You may have noticed - WinterBoard wasn't working on the iPhone 3GS.

    Well guess what? It is now.

    Open up Cydia, and download away... everything is working spot on.

    Thanks, Saurik.
    This article was originally published in forum thread: WinterBoard Released for iPhone 3GS started by Kyle Matthews View original post
    Comments 198 Comments
    1. 7lowe's Avatar
      7lowe -
      I was having battery life issues along with the problem of going into safe mode if I tried to hit the sleep button while it was charging. I decided to restore to stock 3.0 and then try jailbreaking with redsn0w this time. It went a lot smoother as it worked perfect both times using purplera1n (beta & RC) it took at least 2 tries.

      Afterward, I noticed my screen was a lot dimmer. Before it seemed super bright all the time and I thought that might have something to do with the battery life issues I was having. Reinstalled SBSettings and went in and picked my toggles and it suddenly got super bright again. Went into settings to play around with the brightness and turn Auto off and then on again and it seemed more reasonably bright. Then I was reading an e-mail and I double tapped to zoom in, but it tried to select instead and when it did the screen went super bright again.

      The brightness thing is weird, but so far I haven't had the safe mode crash when sleeping anymore, so that's good.

      7
    1. xpc21's Avatar
      xpc21 -
      Well,what hell the problem with this people?Now everyone wanna be "The first to create or realease something to iPhone 3GS". Damn, seems that they wanna loose respect from 2G and 3G users. Damn, nerds.
    1. bschucher's Avatar
      bschucher -
      Quote Originally Posted by xpc21 View Post
      Well,what hell the problem with this people?Now everyone wanna be "The first to create or realease something to iPhone 3GS". Damn, seems that they wanna loose respect from 2G and 3G users. Damn, nerds.

      Ummmm huh?????
    1. babyblue_pimp's Avatar
      babyblue_pimp -
      Quote Originally Posted by xpc21 View Post
      Well,what hell the problem with this people?Now everyone wanna be "The first to create or realease something to iPhone 3GS". Damn, seems that they wanna loose respect from 2G and 3G users. Damn, nerds.
      lol, the day we pay 2.99 for winterboard is the day they will "focus" on everyone.

      For the meanwhile these developers are just having fun, breaking and modifying the latest and greatest from apple... Until they get it perfect i really don't see them focusing to much on other phones...

      It'll only be a few weeks though, then they will get their old 3g's working, then their old 2g's etc.
    1. Amadomon's Avatar
      Amadomon -
      Quote Originally Posted by name00 View Post
      this is awesome

      now i'll be waiting for mobilefinder
      i couldnt get it to work,it crashes every now and then
      I too was waiting for mobilefinder. However, someone pointed out that iFile does everything mobilefinder did and more. Check it out (Cydia).
    1. Aste88's Avatar
      Aste88 -
      I have a redsn0w jailbroken 3gs unlocked with ultrasn0w 0.9
      Icy doesn't find the new winterboard version so I installed it trough ssh dpkg as I did for mobilesubstrate.
      I had to use the dpkg ignore dependency option bc I couldn't find killall package (I alredy have killall command) anyway it installed fine and doesn't send my iphone into safe mode anymore.

      Now when I select a theme winterboard respring but nothing changes.
      Anyone has the same issue?

      ps: I'm using icy bc cydia has too many ads!!
    1. bluebadge's Avatar
      bluebadge -
      Ok, running a 3GS fw 3.0 used redn0w 0.8 to jailbreak, installed most recent mobilesubstrate and re-booted... entered Cydia installed Winterboard, downloaded a couple of themes and ringtones, and now when i try and open an app, it pops opens and closes instantly. I thought the Mobilesubstrate upgrade fixed this... I guess not. Anyone still having this issue? or anyone know a way to fix it! so I dont have to keep re-flashing my 3GS.

      Cheers
    1. Stylinjatt's Avatar
      Stylinjatt -
      Great Job Guys . Thnks
    1. Meth Taylor's Avatar
      Meth Taylor -
      my winterboard was working on my 3gs. but now it keeps crashing my phone every time i install it or when i respring my phone. im running on the firmwire 3.0.1. can someone please help.
    1. ronblade's Avatar
      ronblade -
      I knew it. WinterBoard before did not work on 3G. But now it has been a great help for the new release. I am very happy to see this post. Thanks for sharing.
    1. MrSpiffdifilous's Avatar
      MrSpiffdifilous -
      Any word on when keyboards will start working again? I'm loving Winterboard right now, I cant decide whether I like iNinja(customized) or ANM Rebuild more. either one would be so much better with keyboard support though!
    1. kwickone's Avatar
      kwickone -
      Quote Originally Posted by MrSpiffdifilous View Post
      Any word on when keyboards will start working again? I'm loving Winterboard right now, I cant decide whether I like iNinja(customized) or ANM Rebuild more. either one would be so much better with keyboard support though!
      Per Saurik's Twitter:

      "I just spent way too many hours pulling apart the 3.x keyboard code. There isn't enough legacy support to theme keyboards anymore. Sorry. "

      Not good news for keyboards.
    1. kiwi_chic's Avatar
      kiwi_chic -
      i have a 3gs iphone and would like to download winterboard but am wondering do i need anything else to make it work as ive heard from other people their fone crashes etc plz help and tell me how to install thanx in advance
    1. tsatryan's Avatar
      tsatryan -
      Winterboard works fine.
    1. bbillh77's Avatar
      bbillh77 -
      been there done that
    1. firearbete's Avatar
      firearbete -
      First post ever. Join today. I'm a total newbs. Sorry about that. Installed winterboard on my 3gs latest firmware (3.1.2?) jailbroke with black rain downloaded with rock your phone. Works freaking great though it crased the wireless connection. My phone doesn't detect any wireless network. The status bar is set on solid but either on solid or on normal its sometimes disappear.

      Also I'm trying to get more involved in this community but I don't know were to start who to talk to. Thanks for leaving me a note.
    1. Melech518's Avatar
      Melech518 -
      Welcome to MMi!

      To fix your wifi simply install PushFix from Cydia by following this guide, or go into Settings->General->Reset->Reset Network Settings. This is a known issue with blackra1n.

      As far as your solid status bar is concerned, check to see if you have that feature enabled in Winterboard.

      To find answers to most of your questions you can use the Search Bar in the upper right hand corner of every page. Most topics and issues have already been discussed and solutions have been posted. If you cannot find the answer to a question after searching, you can search the Forums section of this site and narrow down the proper section to post your question. The General iPhone Chat section is also a great place to post any questions or problems. You can also check the Chit-Chat Section to just chat with other users.
    1. firearbete's Avatar
      firearbete -
      Wow ! Thanks soo much for this intro. I really feel welcomed

      I've uninstalled winterboard to check if the status bar would come back to normal and it did. Oh well, it's not that much of a problem anyway.