• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • WinterBoard Released for iPhone 3GS


    You may have noticed - WinterBoard wasn't working on the iPhone 3GS.

    Well guess what? It is now.

    Open up Cydia, and download away... everything is working spot on.

    Thanks, Saurik.
    This article was originally published in forum thread: WinterBoard Released for iPhone 3GS started by Kyle Matthews View original post
    Comments 198 Comments
    1. HOPPERSAN's Avatar
      HOPPERSAN -
      [QUOTE=CoPa708;4759831]This is exciting! So is there still a lot of bugs that need to be fixed or is jb for the 3gs set for now (except on 3.1)? I see a lot of people are still having problems installing it and such... is it that common or are they just messing up,




      I dont know how we could mess it up its just an upgrade unless im missing something restarted cydia still will not open
    1. eballesq's Avatar
      eballesq -
      Quote Originally Posted by jabij1 View Post
      how do i get that mail icon on the top right of the phone next to the battery percentage...is that for mail or sms? is it only for 3gs or is there a work around to get it on the 3g as well (like the battery percentage hack)
      That's the Notifier app in Cydia. You'll get icons in the status bar for mail, SMS, MMS, missed calls, and voicemails.

      It's working on the 3GS JB.
    1. djpeetur's Avatar
      djpeetur -
      ok this what i did. after i restored. i installed mobilesubstrate and then winterboard. and evyerthing worked fine.
    1. HOPPERSAN's Avatar
      HOPPERSAN -
      tried removing cydia with icy and reinstalling still wont open
    1. jabij1's Avatar
      jabij1 -
      Quote Originally Posted by eballesq View Post
      That's the Notifier app in Cydia. You'll get icons in the status bar for mail, SMS, MMS, missed calls, and voicemails.

      It's working on the 3GS JB.
      awesome thanks
    1. metalmaster420's Avatar
      metalmaster420 -
      I was one of the people having trouble getting this to work. Install winterboard kept having to restore, and try again. The suggestion to install mobile substrate first, then reboot, then install winterboard worked like a charm! Anyone having trouble should try this method. Btw, used redsn0w 0.8 on an XP machine (blech) to JB.
    1. MetallicaFan1991's Avatar
      MetallicaFan1991 -
      Installed fine first time round on my 3GS, installed MS and WB at the same time, I have only a couple of App Store apps so I don't know what the issue is then.
    1. kminatta's Avatar
      kminatta -
      installed first geohot jb and then second. updated mobile substrate and installed winterboard. now i can't download any apps from Appstore. i have two gray icons on my springboard that say "Waiting". any ideas? if not, i'll have to restore and jb again when i get off work... =(

      after reboot, i receive a message that says "Unable to Purchase".
    1. angrylilasiangirl's Avatar
      angrylilasiangirl -
      My phone froze after installing cydia. Hold down pwr button and home button. Runs fine now.
    1. Melech518's Avatar
      Melech518 -
      Quote Originally Posted by timbo View Post
      WHY ID I HAVE TO UPGRADE TO 3.1. I'm missing out on all the fun. DEV TEAM PLEASE JB 3.1!!

      I miss winterboard themes. STICKERS Rocks!!

      I am hoping to trick Apple to help me restore to 3.0 at the store.
      I am sorry but this is YOUR OWN FAULT!! Everyone warned about not updating when the beta was released. I remember sitting on the thread and you even asking if you would be able to revert back to 3.0 and be able to jailbreak, and we all told you not to update yet. You then did it and posted everywhere that YOU had 3.1 wooohooo. Now you need to sit down and wait and see what happens.

      Now, if you want to "trick apple" then remove your digitizer/lcd and unplug the cable to the digitizer so it will not respond, then pop the screen back in places and replace the 2 screws on the bottom. Go to apple and tell them it wont work, they will replace it. Be sure not to chip the glass and only attempt this if you know what you are doing.
    1. JAG2621's Avatar
      JAG2621 -
      Well i must be one of the lucky ones. I jailbroke with purplera1n RC1 without a problem first time and then after RC2 came out i did a jailbreak over the RC1 with purplera1n RC2 first time no problem. Now that the fix for winterboard came out i updated mobilesubstrate first then installed the updated winterboard and have not had the first problem.
    1. Brandon's Avatar
      Brandon -
      Quote Originally Posted by kminatta View Post
      installed first geohot jb and then second. updated mobile substrate and installed winterboard. now i can't download any apps from Appstore. i have two gray icons on my springboard that say "Waiting". any ideas? if not, i'll have to restore and jb again when i get off work... =(

      after reboot, i receive a message that says "Unable to Purchase".
      I have the same issue, app's don't download. They stay on waiting.

      FOUND A SOLUTION. Plug your iPhone into iTunes
    1. Mista Brothason's Avatar
      Mista Brothason -
      I have a question

      If I downgrade from 3.1 to 3.0 will the unlock work or not?



      EDIT

      Nvm

      I found the answer, no thanks to anybody

      Found it here:
      http://www.redsn0w.eu/how-to-downgra...3-1-to-3-0-os/
    1. arfreitas12's Avatar
      arfreitas12 -
      WOOT! finally i used to have this on my 3g but it lagged it so bad and now that i have it on my 3gs i hope it runs smooth. i will upload a screen shot of my 3gs when i am done setting everything up.

      oh and i jb with ra1n and my iphone is running beautifully
    1. kminatta's Avatar
      kminatta -
      Quote Originally Posted by Brandon View Post
      I have the same issue, app's don't download. They stay on waiting.

      FOUND A SOLUTION. Plug your iPhone into iTunes
      lol...i figured that, but does it allow me to download apps over 3G again or am i stuck syncing through iTunes?
    1. Brandon's Avatar
      Brandon -
      Quote Originally Posted by kminatta View Post
      lol...i figured that, but does it allow me to download apps over 3G again or am i stuck syncing through iTunes?
      Just download apps through iTunes until Saurek released a new version to fix this issue. Everybody most likely has this problem. When you plug your phone into iTunes, those grey icons will disapeer into the full downloaded version.

      Also, does restoring your iPhone remove contacts and SMS and apps?
    1. thuwun's Avatar
      thuwun -
      Quote Originally Posted by iN2K View Post
      Anyone using vista 32bit home having trouble? I restored the other day before rc2 and now I can't install freeze. It does the whole process like before but after the reboot freeze is not installed. Has the steps to install changed?
      I'm on home. I had a slight problem as well with my main vista profile. so I created a second profile, logged in and bam! worked like a charm purplera1n on iphone 3GS 3.0 (purchased release date)
    1. arfreitas12's Avatar
      arfreitas12 -
      Here are some screen shots of my phone

    1. Brandon's Avatar
      Brandon -
      Quote Originally Posted by arfreitas12 View Post
      Here are some screen shots of my phone

      Does downloading apps from the app store work for you
    1. arfreitas12's Avatar
      arfreitas12 -
      im checking for u right now it says its "loading" so it is downloading it but its taking a bit so ill let you know how it goes. the bar is filling green so im sure its going to work


      edit: downloaded really slow but installed fine and app worked