• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • WinterBoard Gets An Long Awaited Update


    I for one have been looking forward to an update to WinterBoard since I first got my iPhone. Being a theme designer as well, this makes me super excited, and it should for all you theme lovers as well!

    For those of you who might not know, WinterBoard is an App developed by @Saurik that allows Jailbroken users to completely change the look and feel of their iDevice. Through Icons, Sounds and User Interface redesigns.

    WinterBoard has now been updated to 0.9.3154-1 and is now located in Settings. This update also fixes a few 3.1+ specific issues, and can "iPhone-optimize" PNG's using pincrush (from @dhowett).

    Inside settings we now have a few new features for WinterBoard as well. There is also a Summerboard Mode, that makes older themes more compatible with Winterboard, and the current iPhone Jalbreak.

    As mentioned, @dhowett's PinCrush has been implemented into this update to increase the speed of loading PNGs. However, for those designers out there, be careful, as this will replace your current PNG files, making them un-viewable on your computer (you'll have to use a PNG converter again). Or you could always just reinstall your theme if you still have the deb, but personally I like to work with live files when I design themes.

    There is also a debugging mode and a "summerboard" mode, which will help add support for older themes that might not load properly. You can also hide the winterboard icon if you choose to.

    I for one am stoked and can't wait to see what else will be brought to WinterBoard in the future.
    This article was originally published in forum thread: WinterBoard Gets An Long Awaited Update started by nickhesson View original post
    Comments 108 Comments
    1. indyracer05's Avatar
      indyracer05 -
      Hey, cpjr, looks like I'm right, THERE is a problem with this update, I've tried everything, it is DEFINITLY
      winterboards problem
    1. Jahooba's Avatar
      Jahooba -
      Guys, there's so many things that could possibly be wrong with your device and Winterboard. In my year of modding I've found that the problem is usually something stupid or simple. There could be problems with a (poorly made) mod that is interfering with something, there could be a file that was renamed that was important, or any number of things. My Winterboard works perfectly, so I know it's not a problem with that program in particular, so you should probably start uninstalling/ reinstalling your other mods until you fix it.

      If you all want help I suggest you start listing the mods you have installed, your OS version #, what you've tried so far, and the themes you're having trouble with. Maybe put just a little effort into helping others understand THEIR problem by being more specific about YOURS. And who knows, perhaps you will come to a collective eureka and identify the problem.

      It may also help to start a topic in the forums dedicated to your problem. This thread was for the announcement of an update, and not really dedicated to problems arising from the update. Not that you shouldn't be posting here, it's just that you may find more help if you create a thread that deals specifically with your problem.
    1. unoimkll's Avatar
      unoimkll -
      100% fix to all jailbroken issues (though at times tedious)

      Step One:
      Download SBSettings if you have not already.

      Step Two:
      Slide finger across status bar then hit the "more" button in SBSsettings window.

      Step Three:
      Then near the bottom hit "mobile substrate addons" tab.

      Step Four:
      Uncheck EVERYTHING YOU REMEMBER INSTALLING!

      Step Five:
      Hit the home button and wait for message "Reseting language" (or something).

      Step Six:
      Your iPhone/iPod will respring and your problem WILL be resolved (but all the cool stuff isn't there =[... NOT A PROBLEM!)
      (NOTE: if for some reason your problem still occurs then something is flawed with the jailbreak itself. What you have essentially troubleshot is that nothing your installed after jailbreaking caused the problem)

      Step Seven:
      (Now the fun starts... Consider this a game =)
      Go back to the mobile substrate addons section and RESELECT 5 or less addons. (must be small number and keep track, write them down if you have to).

      Step Eight:
      After hitting home and letting your device respring, see if the problem still occurs.

      NOW you have two options:

      ONE:
      If the problem did NOT occur then repeat Step Eight until it does (making note of the specific addons you enabled)then proceed to TWO.

      TWO:
      If the problem DID occur. Go back and see which 5 addons you enabled and deslect all of them EXCEPT ONE. Respring and see if the problem is still there. Repeat this until you have successfully identified the problematic addon. Then proceed to Step Nine.

      Step Nine:
      Go to Cydia and reinstall said addon (sometimes try a uninstall then REBOOT then install as this eliminates what i like to call "RESIDUE PROBLEMS" , like little stupid errors that are left when something hasn't fully been cleaned)

      SOLVED, 100% guarantied!!!


      (Oh and note: If after reinstalling their is a problem and you tried the reboot method, something is conflicting and you should contact the maker of the app and notify them of this conflict, ie nothing you can do =S)

      If this helped you at all please hit the thanks button. In the past i had a serious crashing problem and resorted to this nine step process (and frankly it was fun seeing whether or not i could find the little f*** that screwed my iPhone)

      HOPE THIS HELPS!!!

      Troy
    1. PhanaticD's Avatar
      PhanaticD -
      with my gameloft icon issue i think its winterboard, because it didnt work before the update either unless i put it in bundles. like if i put it in icons then it didnt work. now after update it doesnt work either way and just looks weird
    1. indyracer05's Avatar
      indyracer05 -
      Thnks, unoimkll.
    1. unoimkll's Avatar
      unoimkll -
      You're very welcome indyracer05 =]
    1. mazda3issexy's Avatar
      mazda3issexy -
      Quote Originally Posted by unoimkll View Post
      100% fix to all jailbroken issues (though at times tedious)

      Step One:
      Download SBSettings if you have not already.

      Step Two:
      Slide finger across status bar then hit the "more" button in SBSsettings window.

      Step Three:
      Then near the bottom hit "mobile substrate addons" tab.

      Step Four:
      Uncheck EVERYTHING YOU REMEMBER INSTALLING!

      Step Five:
      Hit the home button and wait for message "Reseting language" (or something).

      Step Six:
      Your iPhone/iPod will respring and your problem WILL be resolved (but all the cool stuff isn't there =[... NOT A PROBLEM!)
      (NOTE: if for some reason your problem still occurs then something is flawed with the jailbreak itself. What you have essentially troubleshot is that nothing your installed after jailbreaking caused the problem)

      Step Seven:
      (Now the fun starts... Consider this a game =)
      Go back to the mobile substrate addons section and RESELECT 5 or less addons. (must be small number and keep track, write them down if you have to).

      Step Eight:
      After hitting home and letting your device respring, see if the problem still occurs.

      NOW you have two options:

      ONE:
      If the problem did NOT occur then repeat Step Eight until it does (making note of the specific addons you enabled)then proceed to TWO.

      TWO:
      If the problem DID occur. Go back and see which 5 addons you enabled and deslect all of them EXCEPT ONE. Respring and see if the problem is still there. Repeat this until you have successfully identified the problematic addon. Then proceed to Step Nine.

      Step Nine:
      Go to Cydia and reinstall said addon (sometimes try a uninstall then REBOOT then install as this eliminates what i like to call "RESIDUE PROBLEMS" , like little stupid errors that are left when something hasn't fully been cleaned)

      SOLVED, 100% guarantied!!!


      (Oh and note: If after reinstalling their is a problem and you tried the reboot method, something is conflicting and you should contact the maker of the app and notify them of this conflict, ie nothing you can do =S)

      If this helped you at all please hit the thanks button. In the past i had a serious crashing problem and resorted to this nine step process (and frankly it was fun seeing whether or not i could find the little f*** that screwed my iPhone)

      HOPE THIS HELPS!!!

      Troy
      Will this help with the icons problem?


      When you said uncheck everything you installed does that include ALL of the themes???/

      Quote Originally Posted by indyracer05 View Post
      Hey, cpjr, looks like I'm right, THERE is a problem with this update, I've tried everything, it is DEFINITLY
      winterboards problem
      @ indyracer05 what do we do?
    1. nicholasa's Avatar
      nicholasa -
      I've been having major problems with winterboard making my device crash to safe mode. And worse yet when I turn all the themes off or turn winterboard off in sbsettings and even uninstall winterboard my device still crashes to safe mode. The only way for my device not to crash into safe mode is I reinstalled winterboard in safe mode (still after reboot crashed to safe mode), then opened winterboard up and enabled debug logging and summerboard mode, and a theme (only certain themes), will my device not crash to safe mode. That's f'ed up right. So my device which is an iphone 3gs will not start in normal operation unless I have a theme and those settings mentioned above turned on, now I've tried all kinds of things to just have my device start not in safe mode just without winterboard but to no avail, and I don't really want to restore cause that just sucks. Wellp that's it.