• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Blacksn0w for 3.1.3 3G/3GS with 05.11.07


    Well folks, the news has begun to spread about a new package for Blacksn0w and 3.1.3 on the 3G/3GS with baseband 05.11.07. This supposed new Blacksn0w package is put together by a user going by msft.guy.

    Here is a link to msft.guy's blog where he discusses the current issues as to why Blacksn0w wont work with 3.1.3.

    This tip comes in from a good friend (PushFix.info) who has gone ahead and packaged it together and gave it a shot on his iPhone 3GS. Here's what he had to say:

    Basically I have made two packages, both require 05.11.07 baseband:

    #1 Blacksn0w RC2 for 3.1.3 (Pwnagetool upgraded)

    msft.guy found the string that needed changing that makes blacksn0w work under 3.1.3. This is impressive in it's own right, but he also fixed a bug in Geohot's code that he identified. Although he didn't seem to know it, that bug was the cause of all the WiFi problems with blacksn0w (almost exclusively with the 3GS). By that I mean the issue where your phone works on one boot, but the next boot, your WiFi doesn't work and you have to reset network settings to get it to work. This is a great find and I don't even think he recognized what he fixed.

    #2 Blacksn0w RC2 for 3.1.2

    So, I applied that fix to regular old blacksn0w RC1 for 3.1.2 and again, it keeps the WiFi from getting broken. I have called it blacksn0w RC2. I have a 3GS that had constant WiFi problems with blacksn0w under 3.1.2. With this patched version of Geohot's unlock, WiFi works perfectly. I have powered off and rebooted more than 10 times and it has worked every single time now.
    It appears that msfit.guy has no intention of publicly releasing the fix and GeoHot is nowhere to be found to comment on the issue.

    The packages put together by PushFix.info have been tested by a handful of people and both appear to work flawlessly at this point.

    There are some issues with making this public as of right now, for example, if you are faking your OS version to be 3.1.3 and you install the 3.1.3 version of blacksn0w RC2 with 3.1.2 CommCenter, you will cause problems! Your cell and WiFi could be unresponsive until you either uninstalled the package again via Cydia or restored the phone.

    Besides the technical issues of current app compatibility, we feel it is appropriate to wait for GeoHot and msft.guy to respond and let us know their intentions.

    Once this package is made available, we will let you know.

    THIS IS NOT A NEW EXPLOIT! IT IS ESSENTIALLY AN PACKAGE PUT TOGETHER THAT UPDATES BLACKSN0W TO WORK WITH 3.1.3 on 05.11.07

    *Note: What we are referring to is a package put together by PushFix.info that contains msft.guy's work and geohot's blacksn0w.
    This article was originally published in forum thread: Blacksn0w for 3.1.3 3G/3GS with 05.11.07 started by nickhesson View original post
    Comments 133 Comments
    1. Pushfix's Avatar
      Pushfix -
      Everyone just needs to wait a little longer (less than 12 hours). This message that I sent Nick was not intended to be made public until the Cydia package was released. A unified (unofficial) blacksn0w RC2 Cydia package will be out shortly. It checks to make sure you have 05.11.07 baseband and are running 3.1.2 or 3.1.3. It will unlock your 3G or 3GS if you meet those conditions and will abort install when it detects it wouldn't be able to unlock. In current testing, it also appears to greatly reduce the chance of your WiFi not working and requiring "reset network settings".

      On my 3GS old bootrom under 3.1.2, out of approximately 30 power cycles, only one time resulted in non-working WiFi and it was fixed with a reboot (no reset network settings). Before this patch, my WiFi was dead every other power cycle and required "reset network settings" to fix it. Your experience may vary, but it certainly should not be *worse* than the original RC1 blacksn0w.

      My other 3GS with old bootrom running 3.1.3 (05.11.07 of course) has not experienced dead WiFi yet, although I haven't power cycled or rebooted it nearly as much. Yesterday it wasn't even usable as a phone because it is locked to a South American cell provider. Now it is fully usable on T-Mobile.

      To summarize, please wait until the official announcement comes on modmyi.com.
    1. F1refly's Avatar
      F1refly -
      ok here's my situation.. i have a 3gs with the new bootrom with 3.1.2, bb 5.07.11. i was wondering if i could update to 3.1.3 without updating the bb. i know you can use sn0wbreeze for this purpose but i was wondering if it works with the 3gs with the new bootrom? im asking since i fiddle with my phone a lot and was hoping to have a safety net so to speak...
    1. GellBrake'rrrr's Avatar
      GellBrake'rrrr -
      This is insane!!! Why us everyone asking how to/ is it safe to/ what do I need to do to update to 3.1.3!!!! What benefits are you trying to achieve? PLEASE.... Let me know.
    1. H3x.'s Avatar
      H3x. -
      complete waste of time?
      like... all of the 3.1.3 users have 5.12.01 so it wont work..
    1. EddieLeonard's Avatar
      EddieLeonard -
      so is this a jailbreak...
      i have baseband 05.12.01...
      im confused
    1. knexlegend's Avatar
      knexlegend -
      I can confirm that this unlock worked on my iPhone 3G (5.11.07) Firmware 3.1.3
    1. replay187's Avatar
      replay187 -
      yooo do youtube Vid. that will be great
    1. punjabi212's Avatar
      punjabi212 -
      My iphone 3G is jailbroken at 3.1.3 but the unlock doesn't work. Do I re-jailbreak it with this to get my unlock??
    1. Pushfix's Avatar
      Pushfix -
      Quote Originally Posted by punjabi212 View Post
      My iphone 3G is jailbroken at 3.1.3 but the unlock doesn't work. Do I re-jailbreak it with this to get my unlock??
      This is not a jailbreak, only an unlock. It only unlocks baseband 05.11.07. If you upgraded using official 3.1.3, then your baseband was upgraded and you are out of luck until OS 4.0 probably. No one is going to release an unlock for 05.12.01 until OS 4.0 is out.

      If you are running 3.1.3 with 05.11.07 baseband, please wait for the Cydia package and it will be easy.
    1. punjabi212's Avatar
      punjabi212 -
      Quote Originally Posted by Pushfix View Post
      This is not a jailbreak, only an unlock. It only unlocks baseband 05.11.07. If you upgraded using official 3.1.3, then your baseband was upgraded and you are out of luck until OS 4.0 probably. No one is going to release an unlock for 05.12.01 until OS 4.0 is out.

      If you are running 3.1.3 with 05.11.07 baseband, please wait for the Cydia package and it will be easy.
      Yea i'm on 3.1.3 but my baseband is still 5.11.07. So I guess I gotta wait for the cydia package. Thanks for the help!
    1. adarsh's Avatar
      adarsh -
      What the hell, everyone who updated their iphones are on 5.12.1, so there is no use of this one for them. Still waiting for the unlock or jaibreak for 5.12.1 on 3.1.3.
    1. hollow0's Avatar
      hollow0 -
      Quote Originally Posted by Poseidon79 View Post
      I don't get the relevance. For anyone that is on 3.1.3 with baseband 5.11.07 you are by default unlocked ad jailbroken b/c you can only achieve this with a custom firmware. How does this find benefit anyone?
      This find helps because the wifi issue is fixed. There are those such as myself that are still having wireless issues and this guy seems to have found a fix for it. Also, this is with blackra1n and not pwnagetool. Some people prefer using blackra1n and not pwnagetool and if you remember blackra1n and blacksn0w do not work on 3.1.3 with 5.11 baseband. Once you've upgraded to 3.1.3 you're done. This find allows you to continue using blackra1n and blacksn0w while using 3.1.3 fw and still on 5.11. For those that upgraded correctly.

      Quote Originally Posted by adarsh View Post
      What the hell, everyone who updated their iphones are on 5.12.1, so there is no use of this one for them. Still waiting for the unlock or jaibreak for 5.12.1 on 3.1.3.
      Not everyone who updated are on 5.12. Only fools or the very unlucky ones updated their bb. But this has use and relevance for anyone who is on 3.1.3 and is still on 5.11 because they updated correctly and they will still have use of blacksnow for unlock.
    1. after_burners's Avatar
      after_burners -
      I'll want is to b able to install my apps again
    1. iMalinko's Avatar
      iMalinko -
      I can't even jailbreak my new 3GS. Tethered or not, my spring board loves to constantly crash. I wish I didn't have to get a new 3GS; stupid speaker blew up.
    1. Imsorussian's Avatar
      Imsorussian -
      If upgrading to 3.1.3 updates baseband to 05.12.01 then therr is a definate way to jb this i would do it but my brain capacity doesnt enable to think in a way that some of these j breakers do ( hope that statement made scense). well we waiting. My jb phone got broken (kids) so i got the new one with 3.1.3 and it done cant do anything. So im inpatiently waiting
    1. odisho's Avatar
      odisho -
      thankssssssssssss
    1. RelleR's Avatar
      RelleR -
      Wow this headline got me stoked until I read the actual details. Got me excited for whats to come though...
    1. mavrik101's Avatar
      mavrik101 -
      Pushfix,
      Thanks for the work you put in. Some of us do realize what you really did and the benefit.
    1. corkey20000's Avatar
      corkey20000 -
      Nice update...but everyone is stuck on 05.12.01. I don't see why they would even bother with 05.11.07 in the first place.
    1. hollow0's Avatar
      hollow0 -
      Quote Originally Posted by corkey20000 View Post
      Nice update...but everyone is stuck on 05.12.01. I don't see why they would even bother with 05.11.07 in the first place.
      WRONG not everyone is stuck on 5.12. Those that had no choice but to upgrade and those who were foolish enough to upgrade without custom fw are the only ones stuck on 5.12. There are still so many people who did it the right way and are waiting for unlock with 5.l1. And this find is for them.