• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • Dec. 28 Cydia Crashing Problem. DO NOT Restore Your Device FIX Inside!
    Today around 12:05 EST there was a Packages file distributed via macciti/zodttd's source that causes cydia to not launch properly. The issue is well known and a solution is being worked out. Please do not panic/overreact and restore. Again, DO NOT restore your device.

    More Information:
    The issue was caused by a unicode character used in zodttd's packages file. This character brought out a bug in cydia which caused it to not launch. (a similar problem was created in the past when another community source missed a line break between entries.) This is not the fault of anyone at macciti or zodttd this is simply a bug in cydia.
    Fix:
    This is a simple fix really.
    • Connect to your iphone/ipod via either ssh, mobile terminal, ifile, diskaid or some other type of usb file system browser. Browse to /var/lib/apt/lists/
    • Delete cydia.zodttd-1.com_repo_cydia_dists_stable_main_binary-iphoneos-arm_Packages.
    • Install the new update to cydia to fix this.

    IF you have apt7 installed you should be able to just run the following:
    Code:
    apt-get update
    You can also follow the direction in this .pdf to fix using diskaid for mac or windows
    https://files.getdropbox.com/u/15373...Cydia18Jul.pdf
    This article was originally published in forum thread: Dec. 28 Cydia Crashing Problem. DO NOT Restore Your Device FIX Inside! started by JStraitiff View original post
    Comments 129 Comments
    1. Melech518's Avatar
      Melech518 -
      Quote Originally Posted by INDEPENDENT View Post
      so wait no one is going to answer me? well **** you guys to... im sure im not the only one with this problem!
      Whoa whoa whoa....relax buddy! Just try JBing again...if that doesnt work restore.
    1. StealthBravo's Avatar
      StealthBravo -
      haha. Take it easy
    1. dman918's Avatar
      dman918 -
      When I try JBing again, I don't get any new icons. Am I doing something wrong? The blackra1n splashscreen comes up when rebooting and then it just goes to my lockscreen. Again, I then go through my apps and no new icon.
    1. Melech518's Avatar
      Melech518 -
      No, youre not doing anything wrong. The blackra1n app will not appear again after it has been deleted. You'll have to restore if you cannot ssh
    1. generalsnake's Avatar
      generalsnake -
      Quote Originally Posted by dman918 View Post
      When I try JBing again, I don't get any new icons. Am I doing something wrong? The blackra1n splashscreen comes up when rebooting and then it just goes to my lockscreen. Again, I then go through my apps and no new icon.
      I have the EXACT same problem....... don't wanna restore though.....................
    1. MagicMacMan's Avatar
      MagicMacMan -
      I still don't know what to do. I've hacked my Apple tv and much other stuff but I'm new to it with my iPod touch. I used Blackra1n RC3 to jb my iPod. I have a 3rd gen 64 gb. I can open the black rain app and i was able to install rock, and cydia. But cydia will not open. I have done everything suggested so far. I have used rock to reinstall cydia, I have used disk aid to delete the files and no luck. I tried using rock and went to manage and deleted the files there, then searched cydia and reinstalled. Still, it just goes back to the springboard. This is frustrating.. I also restored once already with no luck! What do i do...
    1. 99allturbo's Avatar
      99allturbo -
      I used diskaid to delete all files except the partial folder per OP's instructions, Cydia still crashes. I never had Rock so without Cydia working, I'm stuck.

      I appreciate all the help here, but nothing worked until I deleted all the files in /var/lib/dpkg/updates. I did this using DiskAid. Got this info form this link iPhone 3G- Cydia stop Working + Weird things happening! - Mac Forums
    1. katastrophic's Avatar
      katastrophic -
      Help! Cydia isn't working for me. It just keeps loading on forever. I tried deleting files except Partial and deleting all repos. Rebooted and It still doesn't work. Any suggestions on what to do besides doing the dreadful RESTORE ?
    1. Jahooba's Avatar
      Jahooba -
      Good thing I deleted that horrible repo a long time ago. There's nothing but a bunch of crap on there. Modmyi is the way to go, or BigBoss.