• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iPhone 3G[S] 3.1 Jailbroken - PwnageTool 3.1.3 Released
    PwnageTool 3.1.3 is out now - and jailbreaks the 3G[S] (with a caveat) as well as all other iPhone models, and the iPod Touch 1G and 2G.

    The iPod Touch 3G is NOT supported, and the iPhone 3G and 3G[S] are only supported if they were jailbroken by PwnageTool at 3.0 or 3.0.1.

    EDIT: To clarify, whether you jailbroke with redsn0w or PwnageTool, you're still Pwn'd.

    PwnageTool 3.1.3 Download Links
    MMi Member Mirror
    Rapidshare
    MegaUpload

    EDIT 2: Here's the links to the various 3.1 firmware files (which you'll need to run PwnageTool):
    iPhone 2G
    iPhone 3G
    iPhone 3G[S]


    I recommend you read through their blog (link below) to check specifics for your device. Here's their brief details (more at their page):

    1. GOLDEN RULE: If you are using a iPhone 3G or iPhone 3G(S) with ultrasn0w and rely on ultrasn0w to obtain cellular service then you should only update your device with an .ipsw that is made with the new PwnageTool. There are no second chances with this. You need to remember that PwnageTool will provide an upgrade path to newer versions of the iPhone software in the future.
    2. Please read all parts of this post before downloading and using these tools.
    3. Read items 1, 2 and 3 again and again.
    4. At the bottom of this post are the bittorrent files for the 3.1 capable version of PwnageTool.
    5. PwnageTool will work for the iPhone 3GS assuming you have already Pwned it at 3.0 or 3.0.1
    6. PwnageTool will work for the iPod touch 2G assuming you have already Pwned it at 3.0 or 3.0.1
    7. PwnageTool WILL work for Original iPhone (1st Generation), the iPhone 3G and iPhone 3G(S) and the iPod touch (1st Generation and 2nd Generation) but NOT the iPod touch 3rd generation.
    8. For 3G and 3G(S) users who are Pwned, PwnageTool is your key to updating in the future, just remember to never install an update directly from Apple, always use an .ipsw that has been created with PwnageTool.
    The official torrent link is at ThePirateBay, we will have links up for you ASAP to download direct. Links Above

    dev team blog
    This article was originally published in forum thread: iPhone 3G[S] 3.1 Jailbroken - PwnageTool 3.1.3 Released started by Kyle Matthews View original post
    Comments 383 Comments
    1. rumcajs's Avatar
      rumcajs -
      biteSMS is working without problems
    1. santaf's Avatar
      santaf -
      thanks
    1. reddawg's Avatar
      reddawg -
      Quote Originally Posted by johnboy797 View Post
      I am getting a 1600 error message. anyone know what this is from?

      3G(s)
      3.0 jailbroken
      new firmware built w/ 3.1.3
      General causes for 1600 errors
      • You might be using the wrong firmware.
      • You're either not on firmware 3.0 or 3.0.1 and not jailbroken.
      • You're not in restore mode properly.
      How to put iPhone into Recovery Mode
      1. First disconnect your iPhone from USB cable and power off your iPhone.
      2. Then hold the “Home” button and connect USB cable again.
      3. Keep holding the “Home” button until you see a dock cable pointing to the iTunes icon. Now you are in recovery mode.
      Restore your custom firmware
      1. Click Shift+Restore (Windows) or Option+Restore (Mac) and select your custom firmware IPSW.
      2. Wait for iTunes to restore your custom firmware. If you have any problems, downgrade your iTunes from 9.x to 8.2.0.23 or 8.2.1. I have never encountered any problems using iTunes 8.2.0.23. Very important, backup your iTunes Library.itl file.
      FYI: Anyone who generates custom firmwares with PwnageTool will remember the question "Has your iPhone been Pwned before (Does it have the pineapple logo)? If you are unsure click No".

      YES, puts your iPhone into Recovery Mode.
      NO, puts your iPhone into DFU Mode.

      The requirements for going to firmware 3.1 are:
      1. Your iPhone must be on firmware 3.0 or 3.01, no higher.
      2. Your iPhone must be jailbroken (Pwned)

      This means you should be in Recovery mode, not DFU. If you are successful in restoring your custom firmware, do NOT "Restore from backup". Set your phone up as new and then sync to get your contacts, apps, music, ringtones, calendars, etc.
    1. pacmac's Avatar
      pacmac -
      great news...not updating to it just yet..im happy with 3.0.1 for now..till most all apps work then ill update they prob already do but i dont want to redo all my stuff i have so many stuff installed/too lazy..great job devteam
    1. santaf's Avatar
      santaf -
      i've heard different things hear one guy is saying to just leave the phone as is and option click and put to new ipsw another is saying put in recovery and then option click and put to new ipsw what one should i do?
    1. coolmacguy's Avatar
      coolmacguy -
      Quote Originally Posted by santaf View Post
      i've heard different things hear one guy is saying to just leave the phone as is and option click and put to new ipsw another is saying put in recovery and then option click and put to new ipsw what one should i do?
      recovery and then option click is correct

      itunes will give you a message that it is in recovery and needs to be restored.
    1. santaf's Avatar
      santaf -
      alright thanks
    1. terrorgen's Avatar
      terrorgen -
      for those not getting phone service, go to Cydia and install ultrasn0w (I know, I know, you are faithful AT&T customers and actually don't need it), reboot and you will get the signal.
    1. johnrs's Avatar
      johnrs -
      Could someone please clarify this statement

      "If you have a 3G[S], you will need to have ALREADY jailbroken the device at a previous 3.xfirmware (3.0 or 3.0.1) in order for this to work. If you have a 3G[S] which came at or has already been upgraded to 3.1 through Apple, this release of PwnageTool (3.1.3) WILL NOT WORK."

      So I have a 3G S iPhone. It WAS previously JB at both 3.0 & 3.0.1 but NOW is on 3.1 via apple official update.

      My question is: Can I use this method to JB my 3.1 iPhone 3G S as I have previously JB my device on a previous 3.xfirmware

      I also have my IBEC & iBSS info stored - any good to me or pointless?

      I am not complaining as I know people are working dam hard to get this sorted for people and I know that I should have waited before I upgraded to 3.1. Lesson learned

      Thanks for any help and comments.

      Cheers
    1. coolmacguy's Avatar
      coolmacguy -
      If you have your 3.0 ECID on file with Cydia you can downgrade to 3.0 then use this. Otherwise you are SOL until a new exploit for 3.1 official is released.
    1. johnrs's Avatar
      johnrs -
      Quote Originally Posted by coolmacguy View Post
      If you have your 3.0 ECID on file with Cydia you can downgrade to 3.0 then use this. Otherwise you are SOL until a new exploit for 3.1 official is released.

      Is that info stored in the iBEC or IBSS info ??

      thanks
    1. coolmacguy's Avatar
      coolmacguy -
      Quote Originally Posted by johnrs View Post
      Is that info stored in the iBEC or IBSS info ??

      thanks
      Yes but just having those files doesn't really help you because no one has made a tool to downgrade using them.

      Currently the only way to downgrade is to redirect the itunes signature process through saurik's server instead of Apple's, and for that you needed to have the info stored at Cydia during the period that was available for 3.0 (which was short).
    1. johnrs's Avatar
      johnrs -
      Thanks for your reply on that.. waited this long a few more weeks or so wont hurt.

      Sure the iPhone dev team will come good in time

      Note to self: wait before you upgrade in the future
    1. confucious's Avatar
      confucious -
      For anyone unsure what to do There is a guide here -> [GUIDE] Jailbreak 3.1 with PwnageTool 3.1.3
    1. kambozza's Avatar
      kambozza -
      i activated my 3gs when i got it through itunes using an AT&T sim card (eventhough I don't live in the US).

      should i get the hacktivated ipsw or the non-activated one and activate using an AT&T sim card again? if i get the hacktivated version will i lose my signal?

      also is it important to use the same at&t sim or any at&t sim will do?
    1. confucious's Avatar
      confucious -
      Your phone is activated so you don't need it to be hactivated.
    1. kambozza's Avatar
      kambozza -
      Quote Originally Posted by confucious View Post
      Your phone is activated so you don't need it to be hactivated.
      it is activated now, but when if i restore from a non-activated ipsw i will have to re-activate it again using the at&t sim, right?

      can i just install the hacktivated ipsw since i don't even live in the US?
    1. confucious's Avatar
      confucious -
      You won't have to re-activate. It is already activated.
    1. SiFli's Avatar
      SiFli -
      I have 3Gs 3.0 jb with Purplera1n. I held off too long before doing anything. Am I now an endangered species just waiting for my time to become extinct as PR users dissapear? I got it signed to restore to 3.1 but missed the 3.0. Is there anyway out of Purplera1n or do I have to wait and hope for clean jb oneday? I'm holding 3.0 trying to figure out best course of action.
    1. confucious's Avatar
      confucious -
      Pwnage will work fine on a Pooplera1ned device.