• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • [Windows] How to Jailbreak and Unlock iPhone 2G Firmware 3.0 with RedSn0w
    This guide will teach you how to jailbreak AND unlock your iPhone 2G running 3.0 firmware using RedSn0w on Windows.

    I strongly recommend you backup and restore your iPhone 2G to 3.0 firmware via iTunes BEFORE you begin this guide. By strongly recommend I mean restore to 3.0 firmware.

    You will need RedSn0w 0.7.2 which you can download here along with the iPhone 2G 3.0 firmware file available for download here. You also need the 3.9 and 4.6 bootloader files. Download 3.9 here and 4.6 here.

    Once you have downloaded everything, extract redsn0w-win_0.7.2.zip to a location on your computer. You should see redsn0w.exe. Run it.

    Click Browse.



    Find your iPhone 2G 3.0 firmware file you downloaded earlier. Select it and click Open.



    RedSn0w tells you that the ISPW is successfully identified. Click Next.



    There will be a quick pop up.



    Select your options to Install Cydia and Unlock. If you don't need to unlock your iPhone 2G you can de-secelct Unlock



    If you are unlocking you need to located the 3.9 and 4.6 bootloader .bin files you downloaded earlier.









    Now that you have told RedSn0w where the bootloader files are click Next.



    At this point you should make sure your iPhone 2G is plugged into your computer AND turned off. Click Next.



    RedSn0w gives you instructions. We are entering DFU mode now. First hold the power button for 3 seconds.



    Keep holding the power button and start holding the home button for 10 seconds.



    Release the power button but continue holding the home button for 30 seconds.



    RedSn0w does its thing. Let it.













    Finally RedSn0w has finished loading everything onto your phone. You will see a pretty screen on your phone as it is being Jailbroken and Unlcoked. Don't mess with your phone while all this is going on. After your phone restarts you are done!

    This article was originally published in forum thread: [Windows] How to Jailbreak and Unlock iPhone 2G Firmware 3.0 with RedSn0w started by Cody Overcash View original post
    Comments 845 Comments
    1. redzombi2k's Avatar
      redzombi2k -
      Quote Originally Posted by falconeyez View Post
      change the ".zip" to a "ipsw" and you should be okay
      Are you talking to me?
    1. falconeyez's Avatar
      falconeyez -
      Quote Originally Posted by Loyalty View Post
      I am 100% convinced that this doesn't work and you all are crazy that said it does

      Here's the deal.....I'm running IE (which I've used a ton of times during the jailbreaking process on other FW's). When I download Redsn0w it seems fine....the file comes up that allows me to run the program. HOWEVER when I download the FW file from the first post in this thread this is what the file saves as: iPhone1,1_3.0_7A341_Restore

      There is no .zip extension to change to .ipsw?? I'm also using Vista is that helps anyone find out WTF is going on. If someone could PM me I'd appreciate it. Thanks everyone!!!!
      In the options menu in your file folder window (Tools>Folder Options>View) make sure "hideextensions for know file types" in unmarked. Then you can change the file extension.

      Quote Originally Posted by redzombi2k View Post
      Are you talking to me?
      LOl, no sorry, but I'm having the smae problems you are. Let me look at it and I'll get back to you. What are yor using (XP, Vista, RC1 for 7) and what version of itunes?
    1. redzombi2k's Avatar
      redzombi2k -
      Well Damn it!
      I think I just royally F'ed up. I held down shift and hit restore and chose the 3.o firmware i downloaded from the above link. so im guessing once this finishes I will have the new unjailbroken, unlocked 3.0 firmware....
      Please tell me Im wrong..
    1. falconeyez's Avatar
      falconeyez -
      Quote Originally Posted by Radfone View Post
      Hey guys need help......I have an Iphone 1G windows on tmobile. was running 2.2 with no problems.........upgraded yesterday to 3.0 using redsnow, just jail break no unlock....seemed like everything was working fine but could not use edge. no internet no email. wifi working fine. so I reran redsnow, this time wiped everything clean on Itunes (restore to original settings) and then JB and unlocked again (lost all my programs this time)and exactly the same thing...edge not working error says"could not activate cellular data network: yo are not suscribed to a cellular data service"
      What data plan on T-Mobile are you using, because some people who had the $9.99 T-Zones plan are reprting that they are getting messages saying that the plan doesnt support that phone, or something like that.
    1. jnandez's Avatar
      jnandez -
      Out of couriosity. i have had my iphone for 2-3 months now and the first thing i did was jailbreak it so i know no difference. everthing was great except my reception. it was horrible and very spotty. i just upgraded to OS 3.0 and i do notice a slight differnce in the bars i get. i did a test call and it did not drop. i want to jailbreak my phone again but reluctant to do so at the loss of reception. is anyone else having this issue and is jailbreaking the issue?
    1. falconeyez's Avatar
      falconeyez -
      Okay just to help those who may be joining the thread here are some answers to the most commonly asked questions:

      Do I need iTunes 8.2?: YES

      Do I need 3.0 on my iPhone before I use Redsn0w?: YES

      Can I update instead of restore? Yes, this option seems to work for most people.

      Is runing redsn0w on Windows 7 RC1 going to give me problems? Probably, use an XP machine if you have one.

      I downloaded 3.0 firmware but when I unzipeed it there was no .ipsw file: If you download the file do not unzip it, just change the ".zip" to a ".ipsw"
    1. blkcadi's Avatar
      blkcadi -
      Quote Originally Posted by LadyTech View Post
      Someone please send a private PM on how to downgrade from 3.0 to 2.2.1. I keep trying. Putting my iphone in DFU mode and then shift+restore. But it gives me error 1600. Any help will be greatly appreciated

      Can someone send a PM** Sry i corrected myself
      Your giving up huh, that's to bad. If you want to downgrade you'll have to downgrade iTunes first to at least 8.1.
      Here are a new tutorial that might help you get the 3.0 J/B done. Maybe try this first.
      Tutorial it's a tree menu, follow it then clicck on what apply s to you.
      Or here. this one is best for you I think.
    1. inco9nito99's Avatar
      inco9nito99 -
      can anybody help me? i cannot find cydia or winterboard.
    1. Beva922's Avatar
      Beva922 -
      as of now, i have not dropped a call due to loss of reception.... and im on FW 3.0, JAILBROKE'd
    1. SkyGuy5's Avatar
      SkyGuy5 -
      Worked great on my 2G
    1. redzombi2k's Avatar
      redzombi2k -
      pewh! It looks as though I panicked a little to soon as I didnt know that you needed the offical 3.0 on your phone before you do this.
      Anyway ran the redsnow again and all is well.
    1. DamianMavis's Avatar
      DamianMavis -
      I upgraded using this method perfectly, everything was fine.... however when I installed these from cydia: cydia upgrade, bossprefs THEN Winterboard which makes you reboot it will not reboot. It crashes 7 seconds after it tries to turn on again (silver apple screen). Every time I try to turn it back on it only stays on for 7 seconds then turns itself off. This means I CANNOT RESTORE, Itunes does not see the phone at all.

      How could this happen? Is my phone completely destroyed? It simply cant stay on long enough to do anything to fix it. Everything was fine until cydia broke my phone (or a combination of 3.0 and cydia) I'm in shock.
    1. m600i's Avatar
      m600i -
      Is everyone's locate me feature working on their 2G iPhones?
    1. blkcadi's Avatar
      blkcadi -
      Quote Originally Posted by DamianMavis View Post
      I upgraded using this method perfectly, everything was fine.... however when I installed these from cydia: cydia upgrade, bossprefs THEN Winterboard which makes you reboot it will not reboot. It crashes 7 seconds after it tries to turn on again (silver apple screen). Every time I try to turn it back on it only stays on for 7 seconds then turns itself off. This means I CANNOT RESTORE, Itunes does not see the phone at all.

      How could this happen? Is my phone completely destroyed? It simply cant stay on long enough to do anything to fix it. Everything was fine until cydia broke my phone (or a combination of 3.0 and cydia) I'm in shock.
      put your phone in DFU mode, restore to 3.0 and start over.
      DFU instructions in case you need them.
    1. DamianMavis's Avatar
      DamianMavis -
      Thanks anyways, just before reading your reply that is exactly what I was able to do, I tried several times and it didnt work but finally I got it into DFU mode so alls good.

      But I am terrified of cydia now, how on earth did it screw up my iphone so bad? I only installed those 3 things!
    1. Radfone's Avatar
      Radfone -
      No Im not using T Zone. Im using the $30 one!!
    1. blkcadi's Avatar
      blkcadi -
      Quote Originally Posted by DamianMavis View Post
      Thanks anyways, just before reading your reply that is exactly what I was able to do, I tried several times and it didnt work but finally I got it into DFU mode so alls good.

      But I am terrified of cydia now, how on earth did it screw up my iphone so bad? I only installed those 3 things!
      Awesome,


      Guys, forum etiquette, someone helps, hit the thanks button, cool
    1. PlatoTheForms's Avatar
      PlatoTheForms -
      After entering DFU mode and REDSN0W is doing its thing, the process quickly finishes and says done!, but my phone just shows a black empty screen and stays there.

      I never had a problem with quickpwn and im on windows vista, yes im administrator and run as administrator (right-clicked), the problem is not starting redsn0w, the problem is that the phone freezes on a empty black screen after redsn0w quickly finishes and says done!

      if there is anyone who can help me, please do so.
    1. blkcadi's Avatar
      blkcadi -
      Quote Originally Posted by Emelin27 View Post
      After entering DFU mode and REDSN0W is doing its thing, the process quickly finishes and says done!, but my phone just shows a black empty screen and stays there.

      I never had a problem with quickpwn and im on windows vista, yes im administrator and run as administrator (right-clicked), the problem is not starting redsn0w, the problem is that the phone freezes on a empty black screen after redsn0w quickly finishes and says done!

      if there is anyone who can help me, please do so.
      some people have had luck with holing the home button a little longer.
    1. dzcobwebs's Avatar
      dzcobwebs -
      Work perfectly