• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iPhone OS 4.0 Beta Unlock : BlackSn0w Ported by msft.guy
    [ame=http://www.youtube.com/watch?v=ZlewvG56t3I]YouTube - Blacksn0w ported to 4.0 in action on a 3GS 4.0 beta 4[/ame]


    It's impressive the amount of work that is being done with iPhone OS 4.0 Beta inside the Jailbreaking community. Not only do we have jailbreak tools for iPhone OS 4.0 Beta, but now we have the ability to unlock 4.0 on the iPhone 3GS. While these tools and the beta are not practical at this moment, it's great news for developers that are stuck with the beta and need to be unlocked.

    Msft.guy has released a video demonstrating the unlock and how he has managed to port Blacksn0w to be compatible with the new beta operating system. He also provide instructions on how to do this yourself. The video itself is only a proof of concept, and here's why. There are still some bugs involved so it will be a pain in the *** to stay unlocked. Each time you reboot your device, you will need to re-apply the patched files.

    A word of caution as usual; if you are not a developer, you shouldn't be playing with iPhone OS 4.0. IF you have a good reason to be using this, you will need to be on baseband 05.11.07 in order for this to work. If you don't know what your doing, stay away from this.

    We strongly suggest you stay away from playing with any unlocking tools until the iPhone Dev-Team released their unlock for 3.1.3, which isn't far away, as the new 4.0 should be available shortly after WWDC.
    This article was originally published in forum thread: iPhone OS 4.0 Beta Unlock : BlackSn0w Ported by msft.guy started by nickhesson View original post
    Comments 48 Comments
    1. ro0oney's Avatar
      ro0oney -
      Epic win!
    1. battlecrushr's Avatar
      battlecrushr -
      Lol ninthchamber
    1. Nikhilnagaraj24's Avatar
      Nikhilnagaraj24 -
      @ nycdiplomat and UKfitch21

      Ignorance is not always bliss. Especially when ignorance is evident in such stupid, arrogant, ruthless remarks.

      There are people who bought the iPhone with the 3.1.3 firmware and 5.12 baseband and they had nothing to do with updating anything. Ever thought of that?
    1. riku98523's Avatar
      riku98523 -
      Quote Originally Posted by ninthchamber99 View Post
      Just curious, how do the members of the Dev-Team, geohot, and the latest person to post the video in this thread know all this stuff about the FW/unlocking/jailbreaking? Did they go to college and learn this stuff or did the learn on their own?? I would like to learn how to do this stuff.

      Amazing what people know and can do with what they know!!

      Most Universities offer classes called "Iphone Hacking 101"
    1. Nikhilnagaraj24's Avatar
      Nikhilnagaraj24 -
      Quote Originally Posted by riku98523 View Post
      Most Universities offer classes called "Iphone Hacking 101"
      Lol........
      My professor gave me a 'F' grade coz I started talking about legalities..
    1. mikerlx's Avatar
      mikerlx -
      I purchased mine 3.1.3 and 5.12 and 5.09 via fuzzyband said no downgrade
    1. clarky8's Avatar
      clarky8 -
      Jailbreak for iPhone 4G will be days after the release
    1. mikerlx's Avatar
      mikerlx -
      Ques- will the unlock be via going into cydia and installing the package and reboot?
    1. madon's Avatar
      madon -
      Quote Originally Posted by -=viper=- View Post
      UKFitch21 and nycdiplomat
      thats not necessary true
      My iPhone got into recovery mode and I had to restore
      I have an MC model so I couldn't use custom firmware (it would have cause an infinite loop so i was told) and not update the modem...
      My only chance to even use the phone was simply to update to 3.1.3
      To my knowledge both old and new bootrom 3GS devices are MC models (I know for a fact that there's an old bootrom 3GS about a metre from me which is the MC133B model)

      The issue is date of manufacture with the 3GS, it's only the iPods where the MC is significant in determining bootrom types, and I'm guessing if it was on 3.1.2 since you've had it before the recovery mode, there was still time to have obtained the SHSH hashes when you first got the unit (Was it jailbroken previously?)

      Ultimately though, for people for whom an unlock is really required that urgently, there's always the option of selling off your device and purchasing one that is factory unlocked, or doing it through your provider if they provide it as an option in your region, it may cost you extra yes, but even people who bought a device with the intention of unlocking it via jailbreak based tools and got a 3.1.3 device had the opportunity to do pre-purchase research and make an informed decision about buying new or on a contract, or seeking out a second hand old-bootrom device.

      The only ones I have genuine sympathy for in this scenario are those who got a 3GS with no intention or plans to jailbreak/unlock and then discovered it further down the road, however in that case they're not losing out that badly since they still have all the functionality they had when they bought the device, and have no dependance on pre-existing jailbreak apps in their day-to-day usage so the advice to them would simply be patience and to read up as much as they can so as not to become the next generation of people who get stuck on a bad firmware release because they didn't do their research and preparations.
    1. wolverinemarky's Avatar
      wolverinemarky -
      keep up the good work dev team
    1. imilad's Avatar
      imilad -
      We need 5.12 unlock!!!!!!
    1. ten_piseth's Avatar
      ten_piseth -
      Maybe good for 3.1.3 user
    1. dhamien's Avatar
      dhamien -
      I think this is a problematic way of writing a news story. Sure, there's news in it, but it's not what the writer claims it is. You can't say that OS 4 has been unlocked for the same reason that you wouldn't claim that 3.1.3 has been unlocked.

      And to some random folks:
      No new exploit was released so nothing has been wasted.
      This isn't the work of the Dev Team.
      Geohot is not the one with an unlock ready for OS 4.x, Dev Team is (correct me if I'm wrong).
      If you bought your phone with 3.1.3 on it, you're just as much as fault as the ones who 'accidentally' upgraded to 3.1.3. Sure, you didn't actually upgrade yourself, but you were well aware that no unlock was available when you bought your phone.
    1. Zuaro's Avatar
      Zuaro -
      Dutch power for the win!
      Good job!
    1. sziklassy's Avatar
      sziklassy -
      Not practical? You must not have been around during the original iPhone JB and unlocking days LOL.
    1. dq13's Avatar
      dq13 -
      no one (Dev Team or Geohot or anyone else) have an unlock for the official 4.0 to be released, because they have no clue what the baseband version will be, so they can't work on something they don't have. They might have an unlock for 5.12, but they're not releasing it, in case the patch works on the official 4.0 baseband, so if they do release it, Apple will patch it.
    1. dhamien's Avatar
      dhamien -
      Quote Originally Posted by dq13 View Post
      no one (Dev Team or Geohot or anyone else) have an unlock for the official 4.0 to be released, because they have no clue what the baseband version will be, so they can't work on something they don't have. They might have an unlock for 5.12, but they're not releasing it, in case the patch works on the official 4.0 baseband, so if they do release it, Apple will patch it.
      Bugs carry over from version to version if they're not fixed. This means that the exploit they have ready will work fine on 4.0
    1. 01grander's Avatar
      01grander -
      I just wish there was something for 5.12.01
    1. elly2k2's Avatar
      elly2k2 -
      Quote Originally Posted by 01grander View Post
      I just wish there was something for 5.12.01
      yea me tooo bro wish there's an unlock for 3.1.3 3gs
    1. madon's Avatar
      madon -
      Pretty sure the reasons for notcrrleasing have Bern stated many times, constantly posting wishes for it won't do a thing to make it cone quicker