• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iPhone 4.0 Beta FAQ


    Some popular questions are:

    1. How do I get Beta 4.0!? How much should I PAY for a Dev spot?

    You must first download 4.0 Beta via a torrent file or from the Apple Dev portal. (Search on google)
    You must have access to a dev account. (This forum has Users selling Dev spots. Also see Ebay)
    Anyone can buy a Dev account for $99.00 and they can then add 100 devices
    Prices for Dev spots seem to be a reasonable $5 to $10 donation.

    2. What is a UDID and How do I find it?

    A UDID is each iPhone's Unique Device ID (40 hex characters)
    To find it:
    You connect your iPhone to itunes

    Click on the actual serial numbers for your iPhone in iTunes summary page:
    Serial Number:*9xxxxxxxxxx (11 digits)

    When you click the serial numbers it will change to identifier:
    Identifier (UDID):*xxxxxxxxxxxxxxxxxx.... (40 digits)

    2. Is 4.0 Beta or a real release and when is it being released to the public?

    4.0 is a Beta release for developers to incorporate support for the new capabilities of 4.0 into their software

    The legitimacy of using 4.0 is kind of shady. While apple does allow developers to seed their apps to "testers" who don't have to be developers, apple agreed to allow developers too add up to 100 devices to their lists as to collect crash log info and make debugging much easier.

    Apple do not support or recommend updating at this time (If you are not a developer or tester for a developer). It will not void your warranty but will leave you with a unjailbreakable OS. If you try to update without being on a dev list you may not be able to activate your phone, but some people have managed to circumvent this.

    3. If I upgrade my 3G/3GS phone to 4.0 will it still be unlocked?

    No, and there will not be official Dev Team support for 4.0 jailbreak/unlock until the official 4.0 release.

    4. I upgraded my phone to 4.0 and can't make calls how do I install ultrasn0w or blackrain?

    Due to there not being support for Jailbreaking/Unlocking Installing ultrasn0w or blackra1n is NOT possible.

    5. How do I downgrade the baseband?

    Downgrading the Baseband is NOT Possible.
    Users must wait for the Dev Team to release an Unlock to use other GSM carriers on 4.0.

    6. How do I Unlock/Jailbreak Beta 4.0?

    You cannot Unlock/Jailbreak until the official release for 4.0 comes out and the Dev Team post their update. Beta jailbreaks may come out but will not have official support.

    7. I installed 4.0 Beta on my phone and iTunes won't activate my phone... Help!

    You must have access to a dev account. (This forum has Users selling Dev spots. Also see Ebay)
    Anyone can buy a Dev account for $99.00 and they can then add 100 devices

    8. How do I downgrade from Beta 4.0 to 3.X.X?

    From member rishidhar: I can confirm that I was able to downgrade my Iphone 3GS from 4.0 beta to 3.1.3 (since I did not save my SHSH files) by going to DFU mode and restoring the old firmware using the new ITunes 9.2, The restore fails half way when it tries to downgrade the baseband (which we know does not work). After the restore fails, it puts your phone on the recovery mode loop, to get out of this, I just ran blackra1n when it was on the recovery mode screen, this led to the screen going blank. Keep the sleep/wake and home button pressed until apple logo shows up and it should take you to your home screen eventually. I am currently on 3.1.3 with the new base-band 5.13.03. Hope this helps all the user's on modmyi.com.

    Apple is still signing 3.1.3 so you do not need any special shsh on file to get back to this firmware on a 3GS. Regular 3G users should be able to go back to 3.1.2 as needed.

    9. Does 4.0 Beta upgrade the baseband?

    Yes. There are reports of 5.13.01 out in the wild. It's possible future betas will further upgrade the baseband so no one will be working on an unlock until the final/official release.

    10. Will this Beta version expire?

    Yes. Apple traditionally releases several beta versions before the final public release. Older Beta versions will expire very soon after the replacement is released and you will be forced to upgrade to the most current beta.

    11. Why do I get an error when I install 4.0 beta on windows?

    As of today, April 9, only Mac users can install this onto their iPhone. Windows users will have to wait until Apple fixes the issue.
    This article was originally published in forum thread: iPhone 4.0 Beta FAQ started by Poseidon79 View original post
    Comments 231 Comments
    1. Simtech's Avatar
      Simtech -
      Stealth has the file for download on his site...
    1. velle's Avatar
      velle -
      Plz add if you have windows, you're fudged, and can't update to the 4.0 beta yet!!!
    1. santaf's Avatar
      santaf -
      Quote Originally Posted by jdyates View Post
      @Santaf: i know, thats what i said, but i still want the 4.0 beta . Anyone want to sign my UDID? :P
      Oh I thought you were saying you want 4.0 to get multitasking again because you don't have a jailbreak hah my bad
    1. jdyates's Avatar
      jdyates -
      Its cool, and yes, i'm currently JB on 3.1.3 with Backgrounder and Multifl0w
    1. 2Jaze's Avatar
      2Jaze -
      Quote Originally Posted by velle View Post
      Plz add if you have windows, you're fudged, and can't update to the 4.0 beta yet!!!


      SAY IT AINT SO!!!
    1. jdyates's Avatar
      jdyates -
      If my UDID gets signed, ill install hackintosh just for this
    1. Late421's Avatar
      Late421 -
      would it be safe to say if you get your hands on the 4.0 beta firmware for the ipod touch you'd be fine in the fact you wouldnt have to have a dev account or be added to one cuz you have no need to activate anything and you'd be able to install the 4.0 beta and use it, even as buggy as it may be, until the next beta or the official release? or is the 4.0 beta release only for iphones?
    1. iPhone3G[S]'s Avatar
      iPhone3G[S] -
      You can restore to 3.1.2 in DFU mode...

      You will get an error msg after you restore, simply jailbreak with your favorite tool and move on.

      Tested, working on my wifes 3G.
    1. Cid K's Avatar
      Cid K -
      I would like to become a tester for 4.0 beta. Please pm me if you have an open spot on your account that I can pay for.


      Cheers
    1. mamirza's Avatar
      mamirza -
      Quote Originally Posted by iPhone3G[S] View Post
      You can restore to 3.1.2 in DFU mode and then use fuzzyband to downgrade the modem firmware... if your 3G has the old bootloader that is.

      You will get an error msg after you restore, simply jailbreak with your favorite tool and move on.

      Tested, working on my wifes 3G.
      what favorite tool...

      blackra1n or pwnage tool
    1. garytaylor's Avatar
      garytaylor -
      i would like a copy please i can donate $10 by paypal please pm me if you can help
    1. Cid K's Avatar
      Cid K -
      I would like to become a tester for 4.0 beta. Please pm me if you have an open spot on your account that I can pay for.


      Cheers
    1. FeartheSpear's Avatar
      FeartheSpear -
      college student looking to test 4.0. if you have a spot i can toss you $5 but i am on a budget and its food or iphone fun.
    1. ginobili's Avatar
      ginobili -
      anyone with windows get around error 13 yet?
    1. goodluck4287's Avatar
      goodluck4287 -
      I'm a dev...

      I'm thinking of a whole number between 9-11. I just started the dev program yesterday, so I'll keep you on for a year.
    1. jwlionking's Avatar
      jwlionking -
      I am dev - PM me if you wish to be a tester.
    1. moneybanks14's Avatar
      moneybanks14 -
      how long does it take before i can get access to the "iphone sdk 4.0 beta section after you have signed up for a dev account im just waiting now so should have 100 slots available.
    1. Ray661's Avatar
      Ray661 -
      Reposting

      A couple questions, first,

      "10. Will this Beta version expire?

      Yes. Apple traditionally releases several beta versions before the final public release. Older Beta versions will expire very soon after the replacement is released and you will be forced to upgrade to the most current beta."

      Will i have to use a mac machine to do this, or will apple let me use a windows machine after my beta expires?

      Also, will devs update their app early to allow 4.0 beta users to run their apps with backgrounding, or am I not gonna be able to try out stuff like pandora with music backgrounding and so on?
    1. J273's Avatar
      J273 -
      Id love to test this...Did the same with the 3 beta on my 3g but my 3gs isn't registered


      If anyone's willing to add my udid to their account that would be much appreciated.


      Id pay for this also.

      If so please PM me.


      Thanks
    1. iPhone3G[S]'s Avatar
      iPhone3G[S] -
      warning!!

      if you have a downgradable 3g with the older bootloader, fuzzyband will not downgrade from 5.13.03 that comes with 4.0!!