• Your favorite

    Apple

    ,

    iPhone

    ,

    iPad

    ,

    iOS

    ,
    Jailbreak
    , and
    Cydia
    site.
  • iPhone 4.0 Beta FAQ


    Some popular questions are:

    1. How do I get Beta 4.0!? How much should I PAY for a Dev spot?

    You must first download 4.0 Beta via a torrent file or from the Apple Dev portal. (Search on google)
    You must have access to a dev account. (This forum has Users selling Dev spots. Also see Ebay)
    Anyone can buy a Dev account for $99.00 and they can then add 100 devices
    Prices for Dev spots seem to be a reasonable $5 to $10 donation.

    2. What is a UDID and How do I find it?

    A UDID is each iPhone's Unique Device ID (40 hex characters)
    To find it:
    You connect your iPhone to itunes

    Click on the actual serial numbers for your iPhone in iTunes summary page:
    Serial Number:*9xxxxxxxxxx (11 digits)

    When you click the serial numbers it will change to identifier:
    Identifier (UDID):*xxxxxxxxxxxxxxxxxx.... (40 digits)

    2. Is 4.0 Beta or a real release and when is it being released to the public?

    4.0 is a Beta release for developers to incorporate support for the new capabilities of 4.0 into their software

    The legitimacy of using 4.0 is kind of shady. While apple does allow developers to seed their apps to "testers" who don't have to be developers, apple agreed to allow developers too add up to 100 devices to their lists as to collect crash log info and make debugging much easier.

    Apple do not support or recommend updating at this time (If you are not a developer or tester for a developer). It will not void your warranty but will leave you with a unjailbreakable OS. If you try to update without being on a dev list you may not be able to activate your phone, but some people have managed to circumvent this.

    3. If I upgrade my 3G/3GS phone to 4.0 will it still be unlocked?

    No, and there will not be official Dev Team support for 4.0 jailbreak/unlock until the official 4.0 release.

    4. I upgraded my phone to 4.0 and can't make calls how do I install ultrasn0w or blackrain?

    Due to there not being support for Jailbreaking/Unlocking Installing ultrasn0w or blackra1n is NOT possible.

    5. How do I downgrade the baseband?

    Downgrading the Baseband is NOT Possible.
    Users must wait for the Dev Team to release an Unlock to use other GSM carriers on 4.0.

    6. How do I Unlock/Jailbreak Beta 4.0?

    You cannot Unlock/Jailbreak until the official release for 4.0 comes out and the Dev Team post their update. Beta jailbreaks may come out but will not have official support.

    7. I installed 4.0 Beta on my phone and iTunes won't activate my phone... Help!

    You must have access to a dev account. (This forum has Users selling Dev spots. Also see Ebay)
    Anyone can buy a Dev account for $99.00 and they can then add 100 devices

    8. How do I downgrade from Beta 4.0 to 3.X.X?

    From member rishidhar: I can confirm that I was able to downgrade my Iphone 3GS from 4.0 beta to 3.1.3 (since I did not save my SHSH files) by going to DFU mode and restoring the old firmware using the new ITunes 9.2, The restore fails half way when it tries to downgrade the baseband (which we know does not work). After the restore fails, it puts your phone on the recovery mode loop, to get out of this, I just ran blackra1n when it was on the recovery mode screen, this led to the screen going blank. Keep the sleep/wake and home button pressed until apple logo shows up and it should take you to your home screen eventually. I am currently on 3.1.3 with the new base-band 5.13.03. Hope this helps all the user's on modmyi.com.

    Apple is still signing 3.1.3 so you do not need any special shsh on file to get back to this firmware on a 3GS. Regular 3G users should be able to go back to 3.1.2 as needed.

    9. Does 4.0 Beta upgrade the baseband?

    Yes. There are reports of 5.13.01 out in the wild. It's possible future betas will further upgrade the baseband so no one will be working on an unlock until the final/official release.

    10. Will this Beta version expire?

    Yes. Apple traditionally releases several beta versions before the final public release. Older Beta versions will expire very soon after the replacement is released and you will be forced to upgrade to the most current beta.

    11. Why do I get an error when I install 4.0 beta on windows?

    As of today, April 9, only Mac users can install this onto their iPhone. Windows users will have to wait until Apple fixes the issue.
    This article was originally published in forum thread: iPhone 4.0 Beta FAQ started by Poseidon79 View original post
    Comments 231 Comments
    1. blkcadi's Avatar
      blkcadi -
      Nice, this should help a lot of people out.
    1. RonHC's Avatar
      RonHC -
      i am hyped about the new iPhone
    1. jdyates's Avatar
      jdyates -
      I wanna be a tester . I have an iTouch 2G (no multitasking while unjailbroken).
    1. DanJan's Avatar
      DanJan -
      Im curious why when I attempt to update to 4.0 Beta iTunes Crashes when it says verifying with apple




      WTFFFFF
    1. Poseidon79's Avatar
      Poseidon79 -
      Is your iTunes IP pointed at Apple? Some people have changed it to point to saurik's server which won't verify 4.0 at the moment.
    1. xwinger's Avatar
      xwinger -
      Hmmm I've always considered becoming a registered dev.. I dono though...
    1. DanJan's Avatar
      DanJan -
      Quote Originally Posted by Poseidon79 View Post
      Is your iTunes IP pointed at Apple? Some people have changed it to point to saurik's server which won't verify 4.0 at the moment.
      Hmm im not quite a "pro" at this, but I am on a Dev account...what is pointing? and is there anyway i can get this to work without ******* up my phone :/
    1. Poseidon79's Avatar
      Poseidon79 -
      If you don't know what pointing your IP address is then I guarantee that you haven't changed it. Try reinstalling iTunes perhaps. Try getting on the Apple support pages and see if others are having a similar issue.
    1. ltjbigshot's Avatar
      ltjbigshot -
      Have you used iTunes to downgrade your iPhone recently?
    1. thechronic's Avatar
      thechronic -
      I would like to become a tester for 4.0 beta. Please pm me if you have an open spot on your account that I can pay for. Thank you.
    1. santaf's Avatar
      santaf -
      Quote Originally Posted by jdyates View Post
      I wanna be a tester . I have an iTouch 2G (no multitasking while unjailbroken).
      I don't believe the iPod touch 2G supports multitasking in 4.0
    1. tha5150's Avatar
      tha5150 -
      error 13 seems to be happening to alot of people. would someone confirm this will ONLY install usuing a Mac and 10.6.3, and the newest iTunes of course.

      question is, if Leopard is installed on an older machine; PPC, would itunes allow you to install?

      some only have windows machines and can not install this. personally, i am in that boat. updated to 3.1.3 to get 4.0 to install and error 13 keeps happening.. now i am stuck on 3.1.3. i have my UDID stored and everything is fine with that...
    1. jdyates's Avatar
      jdyates -
      @Santaf: i know, thats what i said, but i still want the 4.0 beta . Anyone want to sign my UDID? :P
    1. mastaryan's Avatar
      mastaryan -
      I still have an original iPhone so no need for me! Interesting info and you guys are awesome at helping others out. I'm still waiting for a release date of the new iPhone before I upgrade. Any day now! At least that's what I keep telling myself.
    1. Ray661's Avatar
      Ray661 -
      A couple questions, first,

      "10. Will this Beta version expire?

      Yes. Apple traditionally releases several beta versions before the final public release. Older Beta versions will expire very soon after the replacement is released and you will be forced to upgrade to the most current beta."

      Will i have to use a mac machine to do this, or will apple let me use a windows machine after my beta expires?

      Also, will devs update their app early to allow 4.0 beta users to run their apps with backgrounding, or am I not gonna be able to try out stuff like pandora with music backgrounding and so on?
    1. steve-z17's Avatar
      steve-z17 -
      Great info, thanks!
    1. 2Jaze's Avatar
      2Jaze -
      I've got a spot from Stealth, but I'm not sure how to proceed. I can't find a working torrent anywhere for the 3Gs......assistance anyone?

      I'm also interested in the Windows 7 issue as well.
    1. ForumSnoBorderRK's Avatar
      ForumSnoBorderRK -
      yes, i had several problems installing but i came to figure a few things out.

      - my iTunes was not completely updated. once it was, the update went through fine.
      before that though, it gave a 2005 ERROR. I probably restored my phone 10 times yesterday, all because my iTunes wasnt updated. (i totally had forgot until the last time -- because modmyi said dont update iTunes, you may be unable to sync your jailbroken phone again)

      - i read somewhere that switching the USB ports to the next one over and trying again has ACTUALLY solved many peoples problems. Not sure which mac theyre talking about, but I would give it a shot just for the heck of it since at this point you have nothing to lose but time.

      - downgrading is most likely the same as any other firmware, except that you probably must put your phone into DFU mode before restoring. its going to be a pain in the a if you want to downgrade from 3.1.3 to 3.1.2 (if thats what you were jailbroken at before all of this) because THATS where the rerouting business goes on, and THATS also where the problems with syncing come into play.

      - also, if your install isnt going through correctly, make sure that the NAME of the FILE of the firmware is EXACTLY as provided from the Apple Dev Center. Some have renamed it, and (i believe) this is not making it work. The only filename I have is the 3GS' because thats the only firmware I need anyway. Heres the exact file name for that file:

      3GS: iPhone2,1_4.0_8A230m_Restore.ipsw
      3G:
      iPodT3g:

      good FAQ poseidon! if i were you, id probably add on your list of questions that iPhone 3G, 2G and iPod Touches 2nd gen and below will not have multitasking but will still have OS 4.0 and other features.


      Guys, 4.0 is very buggy right now. when I say "very", i truly mean VERY. If I were you guys, I would hold off until beta 2, because that is where a lot of the crashing problems go away (of course there are still other bugs, not as bad as the beta 1 ones). Ive had to hard-reset my phone 10 times yesterday. oddly enough, battery drainage is a little awkward as well-- its draining more than usual.
    1. lswpb's Avatar
      lswpb -
      For downgrading you just need to go in dfu and click restore + alt (mac) or shift (windows) and select your previous firmware
      Then it will give you error 1015
      Once then you close iTunes and run blackra1n untill it either shows just a black screen or geohot's face and then you reboot (don't let Blackra1n complete because you won't be able to receive phone calls anymore then)
      Done!
    1. 2Jaze's Avatar
      2Jaze -
      I just want the file!